ig ntp4
> merge. Until that point I was using the stock ntp4 from udel with no
> problems. But I tried the one shipping with 4.0 and it locks up completely
> (looks like a hardware lockup). The ntp4 from udel works completely
> though. Odd :)
Try disabling where it uses rtprio t
obability is very small).
There's no difference between rtprio and P1003.1B scheduling other than
the name. rtprio is the same as P1003.1B "SCHED_RR".
I'd like to remove the rtprio call from ntpd. I think we ought to do
it now before 4.0 ships.
Peter
--
Peter Dufaul
tprio != curproc->p_rtprio.prio?
That was my fault, it's out now. Any SMP kernel from
earlier today should re-sup.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Fail-Safe systems, Agency approval
To Unsubscribe
anything else, but be sure
you're paged in, don't handle signals that way, etc...
My "solution" would be to make rtprio lower priority
than regular time sharing and if it needs to use any time sharing
resources fault it or temporarily boost it up to time sharing.
Peter
--
Peter Du
> On 2000-Mar-09 10:05:21 +1100, Peter Dufault <[EMAIL PROTECTED]> wrote:
> >There's no difference between rtprio and P1003.1B scheduling other than
> >the name. rtprio is the same as P1003.1B "SCHED_RR".
>
> I wasn't aware of that.
>
> &g
on't run on but the headers might
be useful for.
I can imagine non-byte addressable floating point DSPs with
sizeof(char) == sizeof(double).
I won't complain about the headers in a machine subdirectory.
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machin
through the system
>
> syscall_Secs_to_hz(ulong *ticks, boolean Allow_zero SYSCTL_HANDLER_ARGS)
> syscall_mSecs_to_hz(ulong *ticks, boolean Allow_zero, SYSCTL_HANDLER_ARGS)
> syscall_uSecs_to_hz(ulong *ticks, boolean Allow_zero, SYSCTL_HANDLER_ARGS)
How about struct timeval instead?
Peter
--
P
e inconvenient
> (sysctl -w kern.quantum=0.00100 vs sysctl -w kern.quantum=1). We
> already use microseconds instead of nanoseconds for kern.quantum because
> nanoseconds resolution is unwieldy and not needed.
# sysctl -w kern.quantum=1000us
# kern.quantum: 1000us -> 1000us
is an
e array and the size of the int determine the value of NSIG or
vice-verse.
I would take an approach that will detect many broken programs, probably
the array of three native ints.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc.
in the low order 16 bits you'll be limitted to 2,097,152+1 signals with this
approach, but that won't be a restriction for a while.
Now you can detect in the kernel calls likely to be from the final
class of broken programs.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime deve
> Peter Dufault wrote:
>
> > Firstly, you should get rid of any explicit 32, 31, etc and anything
> > else tied to the assumed number of bits in an int.
>
> You first need to get rid of any code that assumes that siget_t is an
> (unsigned) integer. Use macros to abs
> Peter Dufault wrote:
>
> > 1. Immediately do roughly what you displayed only without increasing
> > the number of signals but instead using two sixteen bit ints, and
> > commit after testing.
> [snip]
> > 2. Switch to the higher number of signals using the ap
Not
> #ifdef _SIGNAL_HEADER
But
> #if _SIGNAL_HEADER == 1
of course.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Safety critical systems, Agency approval
To Unsubscribe: send mail to [EMAIL PROTECTED
s
> anyway, so this is no great loss.)
OK, given this my attempt to force everyone to the POSIX style
is misguided.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Safety critical systems, Agency approval
To Unsubsc
out of 6 times.
Without this it fails 1 out of 3 times. If it logically makes sense
that a delay is needed here (I don't have any docs) someone might add it.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Safety criti
ck.
See Ross's work, my "update_estcpu" is the equivalent of his
"sched_clock". If we keep this work I'll match his nomenclature.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Safety critical s
s?
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Fail-Safe systems, Agency approval
To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message
> In message <[EMAIL PROTECTED]> Peter Dufault writes:
> : > The reason why ntp is interesting is that we compare the received data
> : > with our unpredictable local clock. It is the result of this comparison
> : > which is good entropy bits.
> :
> : Is the
reeBSD-stable/% cvs checkout -r HEAD src
> stable:/FreeBSD/FreeBSD-stable/% cd src
> stable:/FreeBSD/FreeBSD-stable/src/% make buildworld >& buildworld.out
(The -current world builds)
Build the -current kernel, again as yourself:
> stable:/FreeBSD/FreeBSD-stable/src/% make buildkernel >& kernel.out
Now do all installs on the crash box.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Fail-Safe systems, Agency approval
To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message
gets the second.
5. Those items from the draft Posix 1003.1-G are bracketed by
_P1003_1G_VISIBLE optionally or'd with _BSD_TRADITIONAL, as needed.
--
It is useful to specify the Posix version, but right now the
lack of networking support makes it only marginally useful.
Peter
--
Peter Dufault ([
> < said:
>
> > Critique, please.
>
> I have almost completely finished this work. Please join the
> [EMAIL PROTECTED] mailing-list, where the patches were
> posted several months ago, and where hopefully more discussion can
> still take place.
Good, I shall do
ed to
a ZFOD type of operation for anyone expecting zeroed memory.
I guess I'm suggesting a clarification on when you want to set this flag.
If I want to be sure I get my zeroed out stuff real soon should I use
still use bzero?
Peter (couldn't afford BSDcon this year, looking forward to the r
ng a batch of those cards obviously
isn't staying up to date on the OS. Anyone who upgrades a working
system will be just as upset if it doesn't work as if it is gone
so I defer on the axe discussion.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Fail-Safe systems, Agency approval
To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message
e do during release is to make sure every feature is
specified and has a test, and I happily go through and rip out
those features without that. That's why it is hard for me to argue
with Poul.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Assoc
ketch out a road map of what I should do I'll do the
dirty work. I don't know about ACPI etc and so would appreciate a
kick start. I've picked up the spec but haven't printed it out yet.
Peter
PS minimal Sony Vaio LX700/LX800 technical info is available on
the Italian Son
'll open it up and put dynamat on the inside of the
plastic - I assume most heat loss is by convection and this won't
make much difference. Once I do get the fan throttling working
I'll have a real quiet system.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine
> It's possible that the EC is solely responsible for the fan, or that
> Sony decided in their infinite wisdom to do it all in a driver somewhere.
"acpiconf -s 1" switches the fan to its low setting, so we do know
how to do it.
Peter
--
Peter Dufault ([EMAIL PROTECTED])
to halt" options:
http://www-student.informatik.uni-bonn.de:8001/~petera/lpp/
Do we enable these? I don't see any CPU_SUSP_HLT options
in initcpu.c for Intel chips.
Chip is
> CPU: Pentium III/Pentium III Xeon/Celeron (801.82-MHz 686-class CPU)
> Origin = "GenuineIntel&
order number 245472, page B-25)
Peter
(The system is reasonably quiet now with my additional sound
proofing, but I'm afraid it isn't designed to continously run what was
originally an unacceptably noisy fan).
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD
akes it as quiet as
a "normal" computer plus gives it a real solid feel.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Fail-Safe systems, Agency approval
To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message
ion without running out of swap because objects
representing the system memory map were being accidentally created but
not referenced. C is much more forgiving of ignorance.
Peter
--
Peter Dufault ([EMAIL PROTECTED]) Realtime development, Machine control,
HD Associates, Inc. Fail-Saf
damental change should be enabled by a new flag and then added
when handled.
Changing things to return NULL pointers in the kernel where they
never were before is equally lame. Without the appropriate work
you're just pushing the panic off to a hard to find location.
Peter
--
Peter Dufault
warnings
that can mask problems can not be used.
Peter
--
Peter Dufault (dufa...@hda.com) Realtime development, Machine control,
HD Associates, Inc. Safety critical systems, Agency approval
To Unsubscribe: send mail to majord...@freebsd.org
with "unsubscribe freebsd-current" in the body of the message
o keep all the posixy stuff in one place with
calls out into the regular BSD kernel. Since the name is wrong,
I think right thing to do now is make this directory something that
means "posix_subsystem" and put similar chunks that follow similar
rules there. That keeps the code associated
on SMP
unless one turns it on with RTPRIO_AND_SMP_ANYWAY. SMP and RTPRIO
function but not correctly. Programs that assume that the presence
of the header means the subsystem is present will fail on SMP the
way they fail now.
When my build world completes I'm planning on applying essentially
th
convince myself.
Prior to this that system has been running a week with a patched world.
Peter
--
Peter Dufault (dufa...@hda.com) Realtime development, Machine control,
HD Associates, Inc. Safety critical systems, Agency approval
To Unsubscribe: send mail to majord...@freebsd.org
ontinue to function for us if
it worked the same as sched_yield()?
Peter
--
Peter Dufault (dufa...@hda.com) Realtime development, Machine control,
HD Associates, Inc. Safety critical systems, Agency approval
To Unsubscribe: send mail to majord...@freebsd.org
with "unsubscrib
rity than curproc.
*
* We shouldn't preempt the current process because of the
* priority of a sleeping or stopped process.
*
*/
else if ((chk->p_flag & P_INMEM) &&
chk->p_stat == SRUN &&
priority_type and int.
Or you might gently suggest improvements.
Peter
--
Peter Dufault (dufa...@hda.com) Realtime development, Machine control,
HD Associates, Inc. Safety critical systems, Agency approval
To Unsubscribe: send mail to majord...@freebsd.org
with "unsub
hard on a proposal that will let me spend some quality time
on this - wish me luck.
Meanwhile, I'm off all the lists. I'll check e-mail sent to either
dufa...@hda.com or dufa...@freebsd.org intermittently.
Peter
--
Peter Dufault (dufa...@hda.com) Realtime development, Machine c
GUSLY_CAST_AWAY_VOLATILITY(int *, &conspeed);
to surpress the warnings. You can easily redefine the macro to get
them back so together with the discouraging name you're not sweeping
things under the rug.
I don't think there is a GCC attribute to get around this differently.
Peter
PS
41 matches
Mail list logo