[FFmpeg-devel] PATCH: Fallback to NV12 format in VAAPI drivers

2024-08-10 Thread Lluís Batlle i Rossell
On Fri, Aug 09, 2024 at 09:43:53AM +0200, Lluís Batlle i Rossell wrote: > On Fri, Aug 09, 2024 at 11:49:54AM +0800, Zhao Zhili wrote: > > > vaapi drivers often lack proper image converesions and not all > > > situations allow vagetimage or vaputimage with the image formats > > > reported by the api

Re: [FFmpeg-devel] [PATCH] avformat/vpk: fix divide by zero

2024-08-10 Thread Andreas Rheinhardt
Kacper Michajlow: > On Fri, 9 Aug 2024 at 22:51, Michael Niedermayer > wrote: >> >> On Wed, Aug 07, 2024 at 03:42:46PM +0200, Kacper Michajłow wrote: >>> Can happen after calling avformat_find_stream_info() when the codec >>> fails to open, but return value is 0 and subsequent uses of this contex

Re: [FFmpeg-devel] [PATCH] avutil/hwcontext_videotoolbox: silence warning for RGB

2024-08-10 Thread epirat07
On 10 Aug 2024, at 8:13, gnattu via ffmpeg-devel wrote: > Hardware frames with RGB colorspace will not have a YCbCrMatrixKey. > Currently, it will spam the console with warning if rgb frame is > uploaded. Thanks, LGTM > > Signed-off-by: Gnattu OC > --- > libavutil/hwcontext_videotoolbox.c | 2

Re: [FFmpeg-devel] [PATCH 5/6] tools/target_dec_fuzzer: Use av_buffer_allocz() to avoid missing slices to have unpredictable content

2024-08-10 Thread James Almer
On 8/9/2024 5:09 PM, Michael Niedermayer wrote: Hi On Fri, Aug 09, 2024 at 03:56:42AM +0200, Kacper Michajlow wrote: On Fri, 9 Aug 2024 at 00:06, Michael Niedermayer wrote: On Thu, Aug 08, 2024 at 02:13:12PM -0300, James Almer wrote: [...] If decoders are fed with uninitialized buffers tha

[FFmpeg-devel] [PATCH] libavutil: deprecate the old Vulkan queue API, bump minor and add APIchanges

2024-08-10 Thread Lynne via ffmpeg-devel
--- doc/APIchanges | 9 + libavutil/hwcontext_vulkan.c | 8 libavutil/hwcontext_vulkan.h | 12 libavutil/version.h | 3 ++- 4 files changed, 31 insertions(+), 1 deletion(-) diff --git a/doc/APIchanges b/doc/APIchanges index 046828ded1..173f3

Re: [FFmpeg-devel] [PATCH] avformat/vpk: fix divide by zero

2024-08-10 Thread Kacper Michajlow
On Sat, 10 Aug 2024 at 11:25, Andreas Rheinhardt wrote: > > Kacper Michajlow: > > On Fri, 9 Aug 2024 at 22:51, Michael Niedermayer > > wrote: > >> > >> On Wed, Aug 07, 2024 at 03:42:46PM +0200, Kacper Michajłow wrote: > >>> Can happen after calling avformat_find_stream_info() when the codec > >>

[FFmpeg-devel] [PATCH 4/6] fftools/cmdutils: split stream specifier parsing and matching

2024-08-10 Thread Anton Khirnov
This approach has the major advantage that only parsing can fail (due to a malformed specifier or memory allocation failure). Since parsing is done generically, while matching is per-option, this will allow to remove substantial amounts of error checking code in following commits. The new code als

[FFmpeg-devel] [PATCH 2/6] fftools/ffmpeg: replace remaining uses of MATCH_PER_STREAM_OPT()

2024-08-10 Thread Anton Khirnov
--- fftools/ffmpeg.h | 49 --- fftools/ffmpeg_demux.c| 39 - fftools/ffmpeg_mux_init.c | 71 --- fftools/ffmpeg_opt.c | 5 ++- 4 files changed, 91 insertions(+), 73 deletions(-) diff --git a/fftools

[FFmpeg-devel] [PATCH 6/6] fftools/ffmpeg: switch -map parsing to new stream specifier API

2024-08-10 Thread Anton Khirnov
Makes optional map handling less hacky, fixes combining optional maps with metadata matching on tags/values containing the '?' character/ Forward errors from stream specifier parsing, previously the code would ignore them. --- fftools/ffmpeg_opt.c | 54 ++--

[FFmpeg-devel] [PATCH 3/6] fftools/cmdutils: put stream specifier handling back into cmdutils

2024-08-10 Thread Anton Khirnov
Stream specifiers were originally designed exclusively for CLI use and were not intended to be public API. Handling them in avformat places major restrictions on how they are used. E.g. if ffmpeg CLI wishes to override some stream parameters, it has to change the demuxer fields (since avformat_matc

[FFmpeg-devel] [PATCH 5/6] fftools/ffmpeg: use new stream specifier API in opt_match_per_stream*()

2024-08-10 Thread Anton Khirnov
Removes a lot of error checking code, as matching cannot fail. --- fftools/cmdutils.c| 8 ++ fftools/cmdutils.h| 6 +- fftools/ffmpeg.h | 16 +-- fftools/ffmpeg_demux.c| 87 - fftools/ffmpeg_mux_init.c | 198 ++

[FFmpeg-devel] [PATCH 1/6] fftools/ffmpeg: replace MATCH_PER_STREAM_OPT(.., str, ..) with a function

2024-08-10 Thread Anton Khirnov
This has multiple advantages: * The macro has multiple parameters that often have similar or identical values, yet very different meanings (one is the name of the OptionsContext member where the parsed options are stored, the other the name of the variable into which the result is written); t

[FFmpeg-devel] 回复: [PATCH v2 2/3] avcodec/vvc/cabac: remove vvc_refill2

2024-08-10 Thread Wu Jianhua
From Andreas Rheinhardt: > 发件人: ffmpeg-devel 代表 Andreas Rheinhardt > > 发送时间: 2024年8月8日 13:19 > 收件人: ffmpeg-devel@ffmpeg.org > 主题: Re: [FFmpeg-devel] [PATCH v2 2/3] avcodec/vvc/cabac: remove vvc_refill2 > > toq...@outlook.com: >> From: Wu Jianhua >> >> See https://github.com/ffvvc/FFmpeg/issues

[FFmpeg-devel] [PATCH v3 1/3] avcodec/vvc_parser: move avctx->has_b_frames initialization to dec

2024-08-10 Thread toqsxw
From: Wu Jianhua >From Jun Zhao : > Should we relocate this to the decoder? Other codecs typically set this > parameter in the decoder. Signed-off-by: Wu Jianhua --- libavcodec/vvc/dec.c| 1 + libavcodec/vvc_parser.c | 3 --- 2 files changed, 1 insertion(+), 3 deletions(-) diff --git a/li

[FFmpeg-devel] [PATCH v3 2/3] avcodec/vvc/cabac: remove vvc_refill2

2024-08-10 Thread toqsxw
From: Wu Jianhua The vvc_refill2 is the same as the refill2 in cabac_functions. Remove it to reduce duplicated codes. Signed-off-by: Wu Jianhua --- libavcodec/cabac_functions.h | 2 +- libavcodec/vvc/cabac.c | 28 +--- 2 files changed, 2 insertions(+), 28 deletio

[FFmpeg-devel] [PATCH v3 3/3] avcodec/vvc/dsp: prefix TxType and TxSize with VVC

2024-08-10 Thread toqsxw
From: Wu Jianhua See https://patchwork.ffmpeg.org/project/ffmpeg/patch/tyspr06mb64337c4a9adf5312e6648543aa...@tyspr06mb6433.apcprd06.prod.outlook.com/#81892 Signed-off-by: Wu Jianhua --- libavcodec/vvc/dsp.h | 28 ++-- libavcodec/vvc/dsp_template.c | 2 +- li

[FFmpeg-devel] [PATCH] tests/iamf: match stream group by id in some tests

2024-08-10 Thread James Almer
Increases specifier parsing code coverage a little bit. Signed-off-by: James Almer --- tests/fate/iamf.mak | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/tests/fate/iamf.mak b/tests/fate/iamf.mak index 164fd78bf6..bbf465bec6 100644 --- a/tests/fate/iamf.mak +++ b/tests/f

[FFmpeg-devel] [PATCH] avfilter/video: don't zero allocated buffers if memory poisoning is used

2024-08-10 Thread James Almer
Same as in avcodec/get_buffer.c Should help in debugging use of uninitialized memory. Signed-off-by: James Almer --- libavfilter/video.c | 12 1 file changed, 8 insertions(+), 4 deletions(-) diff --git a/libavfilter/video.c b/libavfilter/video.c index 89d0797ab5..afd3dc3dc3 100644