Re: [FFmpeg-devel] lavfi: add perlin noise generator

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 10:17:26 +0200, Paul B Mahol wrote: > No need for query function. > This implementation is so blatantly slow and inefficient that is not useful. > Source filters should use .activate instead. > Many more other issues... It was pending reviews for more than two weeks. Ab

Re: [FFmpeg-devel] lavfi: add perlin noise generator

2024-07-06 Thread Stefano Sabatini
On date Thursday 2024-07-04 17:29:16 +0200, Michael Koch wrote: > Tested and working fine. It would be nice if you could add the default > values to the documentation. Will do, thanks. ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.

Re: [FFmpeg-devel] [PATCH] lavfi/perlin: Fix out of bounds stack buffer write

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 20:38:00 +0200, Marvin Scholz wrote: > An incorrect calculation in ff_perlin_init causes a write to the > stack array at index 256, which is out of bounds. > > Fixes: CID1608711 > --- > libavfilter/perlin.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > di

Re: [FFmpeg-devel] [PATCH v4 0/3] s/RUNTIME/POST_INIT_SETTABLE/

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 10:08:37 +0100, Andrew Sayers wrote: > Some notes about this version: > > As previously mentioned, I think this is better with all three patches, > but can live without #2. > > I think I've followed the deprecation instructions, but editing APIchanges > seems to imply

Re: [FFmpeg-devel] [PATCH v3 1/3] lavu/opt: Rename AV_OPT_FLAG_RUNTIME_PARAM to ...POST_INIT_SETTABLE_PARAM

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 11:58:09 +0800, Zhao Zhili wrote: > > > 在 2024年7月2日,上午6:33,Stefano Sabatini 写道: > > > > On date Sunday 2024-06-16 18:08:29 +0100, Andrew Sayers wrote: > >> The old name could be misread as the opposite of "AV_OPT_FLAG_READONLY" - > >> some things can be set at runtime

Re: [FFmpeg-devel] [PATCH v4 1/3] lavu/opt: Rename AV_OPT_FLAG_RUNTIME_PARAM to ...POST_INIT_SETTABLE_PARAM

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 10:08:38 +0100, Andrew Sayers wrote: > The old name could be misread as the opposite of "AV_OPT_FLAG_READONLY" - > some things can be set at runtime, others are read-only. Clarify that > this refers to options that can be set after the struct is initialized. > --- > doc

Re: [FFmpeg-devel] [PATCH v4 0/3] s/RUNTIME/POST_INIT_SETTABLE/

2024-07-06 Thread Paul B Mahol
On Sat, Jul 6, 2024 at 11:44 AM Stefano Sabatini wrote: > On date Tuesday 2024-07-02 10:08:37 +0100, Andrew Sayers wrote: > > Some notes about this version: > > > > As previously mentioned, I think this is better with all three patches, > > but can live without #2. > > > > I think I've followed t

Re: [FFmpeg-devel] [PATCH v4 0/3] s/RUNTIME/POST_INIT_SETTABLE/

2024-07-06 Thread Andrew Sayers
On Sat, Jul 06, 2024 at 11:37:19AM +0200, Stefano Sabatini wrote: > On date Tuesday 2024-07-02 10:08:37 +0100, Andrew Sayers wrote: [...] > While I agree with Anton that we should avoid duplication, for the > usual arguments that a reference should avoid duplication of content > as much as possible

Re: [FFmpeg-devel] lavfi: add perlin noise generator

2024-07-06 Thread Paul B Mahol
On Sat, Jul 6, 2024 at 11:19 AM Stefano Sabatini wrote: > On date Tuesday 2024-07-02 10:17:26 +0200, Paul B Mahol wrote: > > No need for query function. > > This implementation is so blatantly slow and inefficient that is not > useful. > > Source filters should use .activate instead. > > Many mor

[FFmpeg-devel] [PATCHv2 1/2] lavc/h264dsp: R-V V 8-bit h264_weight_pixels

2024-07-06 Thread Rémi Denis-Courmont
There are two implementations here: - a generic scalable one processing two columns at a time, - a specialised processing one (fixed-size) row at a time. Unsurprisingly, the generic one works out better with smaller widths. With larger widths, the gains from filling vectors are outweighed by the e

[FFmpeg-devel] [PATCH 2/2] lavc/h264dsp: R-V V 8-bit h264_biweight_pixels

2024-07-06 Thread Rémi Denis-Courmont
T-Head C908: h264_biweight2_8_c:58.0 h264_biweight2_8_rvv_i32: 11.2 h264_biweight4_8_c: 106.0 h264_biweight4_8_rvv_i32: 22.7 h264_biweight8_8_c: 205.7 h264_biweight8_8_rvv_i32: 50.0 h264_biweight16_8_c: 403.5 h264_biweight16_8_rvv_i32: 83.2 SpacemiT X60: h264_weight2_8_

Re: [FFmpeg-devel] [PATCH] lavc/h264dsp: R-V V 8-bit h264_weight_pixels

2024-07-06 Thread Rémi Denis-Courmont
Superseded. -- レミ・デニ-クールモン http://www.remlab.net/ ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscrib

Re: [FFmpeg-devel] [PATCH 1/4] lavc/h263dsp: add DCT dequantisation functions

2024-07-06 Thread Rémi Denis-Courmont
Will merge soonish except for feedback. -- Rémi Denis-Courmont http://www.remlab.net/ ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-requ

Re: [FFmpeg-devel] lavfi: add perlin noise generator

2024-07-06 Thread Stefano Sabatini
On date Saturday 2024-07-06 12:40:55 +0200, Paul B Mahol wrote: > On Sat, Jul 6, 2024 at 11:19 AM Stefano Sabatini wrote: [...] > Not interested in your marginal toys or project. Good, so the next time avoid the rant and save even more time. ___ ffmpeg-

Re: [FFmpeg-devel] [PATCH] avformat/dvdvideodec: Don't add chapter markers for empty/dummy PTTs

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 00:41:39 -0500, Marth64 wrote: > Some discs (usually same ones with padding cells), also have empty > padding PTTs / chapters to accompany them. This results, for example, > in an extra chapter marker that starts and ends at 0 (no duration). > > Don't add these empty cha

Re: [FFmpeg-devel] [PATCH] avformat/dvdvideodec: Remove redundant ret initializations

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 01:03:29 -0500, Marth64 wrote: > Remove initializing ret = 0, in areas where ret is > only used to hold an error value, immediately returned, > and the function would otherwise return a literal 0. > > Signed-off-by: Marth64 > --- > libavformat/dvdvideodec.c | 12 ++

Re: [FFmpeg-devel] [PATCH v4] avformat/dvdvideodec: Fix incorrect padding cell trim logic

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 01:41:31 -0500, Marth64 wrote: > When -trim option is used (by default), padding cells > at the beginning of the title are supposed to be ignored. > The current implementation does the ignoring after we > have locked on to the PGC navigation event stream, > but does not s

Re: [FFmpeg-devel] Development process for explaining contexts (was Re: [PATCH v6 1/4] doc: Explain what "context" means)

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 10:56:34 +0100, Andrew Sayers wrote: > On Tue, Jul 02, 2024 at 12:16:21AM +0200, Stefano Sabatini wrote: > > On date Sunday 2024-06-16 19:02:51 +0100, Andrew Sayers wrote: > [...] > > > > Andrew, sorry again for the slow reply. Thinking about the whole > > discussion, I

Re: [FFmpeg-devel] [RFC]] swscale modernization proposal

2024-07-06 Thread Andrew Sayers
On Fri, Jul 05, 2024 at 11:34:06PM +0200, Michael Niedermayer wrote: > On Fri, Jul 05, 2024 at 08:31:17PM +0200, Niklas Haas wrote: [...] > > > Attached is my revised working draft of . > > I dont agree to the renaming of swscale, that is heading toward Would you mind talking a bit more about th

Re: [FFmpeg-devel] [PATCH 8/8] fftools/ffprobe: only print AVStereo3D.view when it's defined

2024-07-06 Thread Stefano Sabatini
On date Saturday 2024-06-22 00:37:01 -0300, James Almer wrote: > Signed-off-by: James Almer > --- > fftools/ffprobe.c | 3 ++- > tests/ref/fate/matroska-spherical-mono | 1 - > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/fftools/ffprobe.c b/fftools/ffpr

Re: [FFmpeg-devel] RISC-V vector DSP functions: Motivation for commit 446b009

2024-07-06 Thread Rémi Denis-Courmont
(Updating an old thread) Le perjantaina 19. tammikuuta 2024, 19.14.02 EEST Rémi Denis-Courmont a écrit : > Hi, > > Le perjantaina 19. tammikuuta 2024, 17.30.00 EET Michael Platzer via ffmpeg- > devel a écrit : > > Commit 446b0090cbb66ee614dcf6ca79c78dc8eb7f0e37 by Remi Denis-Courmont has > > rep

Re: [FFmpeg-devel] [RFC]] swscale modernization proposal

2024-07-06 Thread Niklas Haas
On Fri, 05 Jul 2024 23:34:06 +0200 Michael Niedermayer wrote: > On Fri, Jul 05, 2024 at 08:31:17PM +0200, Niklas Haas wrote: > > On Wed, 03 Jul 2024 15:25:58 +0200 Niklas Haas wrote: > > > On Tue, 02 Jul 2024 15:27:00 +0200 Niklas Haas wrote: > > > > > > > 1. Is this a good idea, or too confu

Re: [FFmpeg-devel] [RFC]] swscale modernization proposal

2024-07-06 Thread Niklas Haas
On Sat, 06 Jul 2024 02:11:30 +0200 Hendrik Leppkes wrote: > On Fri, Jul 5, 2024 at 11:34 PM Michael Niedermayer > wrote: > > > /** > > > * The exact interpretation of these quality presets depends on the > > > backend > > > * used, but the backend-invariant common settings are derived as follo

Re: [FFmpeg-devel] lavfi: add perlin noise generator

2024-07-06 Thread Stefano Sabatini
On date Tuesday 2024-07-02 10:17:26 +0200, Paul B Mahol wrote: [...] > Source filters should use .activate instead. Can someone elaborate about why .activate is favoured in this case (sorry I missed the activate discussion altogether and I cannot graps it from the docs)? Also, is the direct AVFil

Re: [FFmpeg-devel] [PATCH 1/2] avfilter/vf_tiltandshift: fix buffer offset for yuv422p input

2024-07-06 Thread James Almer
On 7/4/2024 2:58 PM, James Almer wrote: Fixes ticket #10950. Signed-off-by: James Almer --- libavfilter/vf_tiltandshift.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/libavfilter/vf_tiltandshift.c b/libavfilter/vf_tiltandshift.c index 85cce84fc3..b49a713339 100

Re: [FFmpeg-devel] [PATCH 1/4] lavc/h263dsp: add DCT dequantisation functions

2024-07-06 Thread Andreas Rheinhardt
Rémi Denis-Courmont: > Note that optimised implementations of these functions will be taken > into actual use only if MpegEncContext.dct_unquantize_h263_{inter,intra} > are *not* overloaded by existing optimisations. > --- > libavcodec/h263dsp.c | 25 + > libavcodec/h263dsp

Re: [FFmpeg-devel] [PATCH 2/4] lavc/mpegvideo: use H263DSP dequant function

2024-07-06 Thread Andreas Rheinhardt
Rémi Denis-Courmont: > --- > configure | 4 ++-- > libavcodec/mpegvideo.c | 40 +--- > 2 files changed, 11 insertions(+), 33 deletions(-) > > diff --git a/configure b/configure > index fed4c44cd1..42b9a72d5a 100755 > --- a/configure > +++ b/config

Re: [FFmpeg-devel] [PATCH 1/4] lavc/h263dsp: add DCT dequantisation functions

2024-07-06 Thread Rémi Denis-Courmont
Le lauantaina 6. heinäkuuta 2024, 18.17.37 EEST Andreas Rheinhardt a écrit : > Rémi Denis-Courmont: > > Note that optimised implementations of these functions will be taken > > into actual use only if MpegEncContext.dct_unquantize_h263_{inter,intra} > > are *not* overloaded by existing optimisation

Re: [FFmpeg-devel] [PATCH 2/4] lavc/mpegvideo: use H263DSP dequant function

2024-07-06 Thread Rémi Denis-Courmont
Le lauantaina 6. heinäkuuta 2024, 18.23.00 EEST Andreas Rheinhardt a écrit : > > static void dct_unquantize_h263_inter_c(MpegEncContext *s, > > > >int16_t *block, int n, int qscale) > > > > { > > > > -int i, level, qmul, qadd; > > +int qmul = qscal

Re: [FFmpeg-devel] [PATCH 2/4] lavc/mpegvideo: use H263DSP dequant function

2024-07-06 Thread Andreas Rheinhardt
Rémi Denis-Courmont: > Le lauantaina 6. heinäkuuta 2024, 18.23.00 EEST Andreas Rheinhardt a écrit : >>> static void dct_unquantize_h263_inter_c(MpegEncContext *s, >>> >>>int16_t *block, int n, int qscale) >>> >>> { >>> >>> -int i, level, qmul, qadd; >>>

Re: [FFmpeg-devel] [PATCH 1/4] lavc/h263dsp: add DCT dequantisation functions

2024-07-06 Thread Andreas Rheinhardt
Rémi Denis-Courmont: > Le lauantaina 6. heinäkuuta 2024, 18.17.37 EEST Andreas Rheinhardt a écrit : >> Rémi Denis-Courmont: >>> Note that optimised implementations of these functions will be taken >>> into actual use only if MpegEncContext.dct_unquantize_h263_{inter,intra} >>> are *not* overloaded

Re: [FFmpeg-devel] [PATCH] avcodec/h264_mp4toannexb: Prepend SPS/PPS to buffering period SEI

2024-07-06 Thread Michael Niedermayer
On Wed, Jul 03, 2024 at 02:05:06PM -0700, Josh Allmann wrote: > Encoders may emit a buffering period SEI without a corresponding > SPS/PPS if the SPS/PPS is carried out-of-band, eg with avcc. > > During Annex B conversion, this may result in the SPS/PPS being > inserted *after* the buffering perio

Re: [FFmpeg-devel] [RFC]] swscale modernization proposal

2024-07-06 Thread Michael Niedermayer
On Sat, Jul 06, 2024 at 02:11:30AM +0200, Hendrik Leppkes wrote: > On Fri, Jul 5, 2024 at 11:34 PM Michael Niedermayer > wrote: > > > /** > > > * The exact interpretation of these quality presets depends on the > > > backend > > > * used, but the backend-invariant common settings are derived as

Re: [FFmpeg-devel] [PATCH 2/4] lavc/mpegvideo: use H263DSP dequant function

2024-07-06 Thread Rémi Denis-Courmont
Le lauantaina 6. heinäkuuta 2024, 19.20.33 EEST Andreas Rheinhardt a écrit : > Rémi Denis-Courmont: > > Le lauantaina 6. heinäkuuta 2024, 18.23.00 EEST Andreas Rheinhardt a écrit : > >>> static void dct_unquantize_h263_inter_c(MpegEncContext *s, > >>> > >>>in

Re: [FFmpeg-devel] [PATCH v4 0/3] s/RUNTIME/POST_INIT_SETTABLE/

2024-07-06 Thread Michael Niedermayer
On Sat, Jul 06, 2024 at 12:40:07PM +0200, Paul B Mahol wrote: [...] > its much more text to type too. shorter options: AV_OPT_FLAG_ALTERABLE_PARAM AV_OPT_FLAG_MUTABLE_PARAM (just in case consensus ends on a rename, i am not sure a rename is a good idea here) thx [...] -- Michael GnuPG

Re: [FFmpeg-devel] [PATCH 1/4] lavc/h263dsp: add DCT dequantisation functions

2024-07-06 Thread Rémi Denis-Courmont
Le lauantaina 6. heinäkuuta 2024, 19.19.35 EEST Andreas Rheinhardt a écrit : > Rémi Denis-Courmont: > > Le lauantaina 6. heinäkuuta 2024, 18.17.37 EEST Andreas Rheinhardt a écrit : > >> Rémi Denis-Courmont: > >>> Note that optimised implementations of these functions will be taken > >>> into actua

Re: [FFmpeg-devel] [RFC]] swscale modernization proposal

2024-07-06 Thread Hendrik Leppkes
On Sat, Jul 6, 2024 at 6:42 PM Michael Niedermayer wrote: > > On Sat, Jul 06, 2024 at 02:11:30AM +0200, Hendrik Leppkes wrote: > > On Fri, Jul 5, 2024 at 11:34 PM Michael Niedermayer > > wrote: > > > > /** > > > > * The exact interpretation of these quality presets depends on the > > > > backen

Re: [FFmpeg-devel] [PATCH v4] avformat/dvdvideodec: Fix incorrect padding cell trim logic

2024-07-06 Thread Marth64
>t++: possibly add some more information to aid debugging, such as "Trimming enabled, skipping padding cell for non promising cell ..." Thanks Stefano for the review. A further cleanup patch set is coming shortly with a patch specifically on language in log messages, will include this. Cheers, __

Re: [FFmpeg-devel] [PATCH v4 0/3] s/RUNTIME/POST_INIT_SETTABLE/

2024-07-06 Thread Andrew Sayers
On Sat, Jul 06, 2024 at 06:49:51PM +0200, Michael Niedermayer wrote: > On Sat, Jul 06, 2024 at 12:40:07PM +0200, Paul B Mahol wrote: > [...] > > > its much more text to type too. > > shorter options: > > AV_OPT_FLAG_ALTERABLE_PARAM > > AV_OPT_FLAG_MUTABLE_PARAM > > (just in case consensus ends

Re: [FFmpeg-devel] [PATCH 1/4] lavc/h263dsp: add DCT dequantisation functions

2024-07-06 Thread Andreas Rheinhardt
Rémi Denis-Courmont: > Le lauantaina 6. heinäkuuta 2024, 19.19.35 EEST Andreas Rheinhardt a écrit : >> Rémi Denis-Courmont: >>> Le lauantaina 6. heinäkuuta 2024, 18.17.37 EEST Andreas Rheinhardt a écrit > : Rémi Denis-Courmont: > Note that optimised implementations of these functions will

Re: [FFmpeg-devel] [PATCH 2/4] lavc/mpegvideo: use H263DSP dequant function

2024-07-06 Thread Andreas Rheinhardt
Rémi Denis-Courmont: > Le lauantaina 6. heinäkuuta 2024, 19.20.33 EEST Andreas Rheinhardt a écrit : >> Rémi Denis-Courmont: >>> Le lauantaina 6. heinäkuuta 2024, 18.23.00 EEST Andreas Rheinhardt a écrit > : > static void dct_unquantize_h263_inter_c(MpegEncContext *s, > >

Re: [FFmpeg-devel] [PATCH 3/4] checkasm/h263dsp: test dct_unquantize_{intra, inter}

2024-07-06 Thread Andreas Rheinhardt
Rémi Denis-Courmont: > --- > tests/checkasm/h263dsp.c | 57 +++- > 1 file changed, 56 insertions(+), 1 deletion(-) > > diff --git a/tests/checkasm/h263dsp.c b/tests/checkasm/h263dsp.c > index 2d0957a90b..26020211dc 100644 > --- a/tests/checkasm/h263dsp.c > +++

Re: [FFmpeg-devel] [PATCH 1/2] configure: permit POWER9 cpu flags

2024-07-06 Thread Sean McGovern
Hi, On Wed, Jul 3, 2024, 21:24 Sean McGovern wrote: > --- > configure | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/configure b/configure > index b28221f258..bbda7a02cb 100755 > --- a/configure > +++ b/configure > @@ -5493,7 +5493,7 @@ elif enabled ppc; then >

Re: [FFmpeg-devel] [PATCH 2/2] lavc/flacdsp: implement wasted32 DSP function for VSX on POWER

2024-07-06 Thread Sean McGovern
Hi, On Thu, Jul 4, 2024, 13:54 Rémi Denis-Courmont wrote: > Le torstaina 4. heinäkuuta 2024, 19.26.19 EEST Sean McGovern a écrit : > > Is that correlated with the comment above re: len? Or is it more general > > that I should unroll until I've exhausted the available vector registers? > > You s

Re: [FFmpeg-devel] [PATCH 2/2] lavc/flacdsp: implement wasted32 DSP function for VSX on POWER

2024-07-06 Thread Rémi Denis-Courmont
Le lauantaina 6. heinäkuuta 2024, 23.00.47 EEST Sean McGovern a écrit : > Does wasted32 (and I guess wasted33 by proxy) not have to worry about loops > tails? I noticed the other vectorized versions don't do anything special in > that regard. Frankly, RISC-V vectors (like Arm SVE's) are scalable s

[FFmpeg-devel] [PATCH v2] libavformat/vapoursynth: Update to API version 4, load library at runtime

2024-07-06 Thread Stefan Oltmanns via ffmpeg-devel
Hello, this is revised patch, to sum up the changes: The current VapourSynth implementation is rarely used, as it links the VapourSynth library at build time, making the resulting build unable to run when VapourSynth is not installed. Therefore barely anyone compiles with VapourSynth activated.

Re: [FFmpeg-devel] [PATCH] tests/fate/mov: add a test for VFR muxing

2024-07-06 Thread Michael Niedermayer
On Tue, Jul 02, 2024 at 11:36:43AM +0200, Anton Khirnov wrote: > --- > tests/fate/mov.mak | 5 + > 1 file changed, 5 insertions(+) > > diff --git a/tests/fate/mov.mak b/tests/fate/mov.mak > index b54fe19620..d12980815f 100644 > --- a/tests/fate/mov.mak > +++ b/tests/fate/mov.mak > @@ -218,6 +

Re: [FFmpeg-devel] [PATCH] tests/fate/mov: add a test for VFR muxing

2024-07-06 Thread Michael Niedermayer
On Sun, Jul 07, 2024 at 01:57:56AM +0200, Michael Niedermayer wrote: > On Tue, Jul 02, 2024 at 11:36:43AM +0200, Anton Khirnov wrote: > > --- > > tests/fate/mov.mak | 5 + > > 1 file changed, 5 insertions(+) > > > > diff --git a/tests/fate/mov.mak b/tests/fate/mov.mak > > index b54fe19620..d1

[FFmpeg-devel] [PATCH] avformat/avisynth: remove atexit() handler

2024-07-06 Thread Stephen Hutchinson
The atexit() handler in the avisynth demuxer was added because there was a conflict in AvxSynth that arose due to their use of C++ global objects, particularly in relation to having added a logging function relying on log4cpp. This conflict was responsible for causing a segfault on exit. It did no