Signed-off-by: Marton Balint
---
libavutil/random_seed.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/libavutil/random_seed.c b/libavutil/random_seed.c
index f167b172f2..6d399cee49 100644
--- a/libavutil/random_seed.c
+++ b/libavutil/random_seed.c
@@ -59,6 +59,7 @@ static int read_random(u
On Tue, 4 Jul 2023, Marton Balint wrote:
Also fix a couple of possible overflows while at it.
Fixes the negative initial timestamps in ticket #10358.
Will apply.
Regards,
Marton
Signed-off-by: Marton Balint
---
fftools/ffmpeg.c | 26 +-
1 file changed, 13 insert
That feature is overkill for a constant pointer to AVFilterLink which
can be stored in AVCodecContext.opaque (indirectly, because the link is
not allocated yet at the time the codec is opened).
This also avoid leaking non-NULL AVFrame.opaque to callers.
---
libavfilter/src_movie.c | 10 ++
Quoting James Almer (2023-07-08 21:00:36)
> -/*
> - * The core of the receive_frame_wrapper for the decoders implementing
> - * the simple API. Certain decoders might consume partial packets without
> - * returning any output, so this function needs to be called in a loop until
> it
> - * returns
Quoting James Almer (2023-07-08 21:00:38)
> And not just those with the old decode() API.
>
> Signed-off-by: James Almer
> ---
> libavcodec/decode.c | 52 +++--
> 1 file changed, 27 insertions(+), 25 deletions(-)
Is there a functional reason for this patc
Quoting Marton Balint (2023-07-07 22:02:26)
>
>
> On Fri, 7 Jul 2023, Anton Khirnov wrote:
>
> > It is a better interface for /dev/u?random on Linux, which avoids the
> > issues associated with opening files.
>
>
> getrandom() actually have the same problem as read(). It can read less
> than
It is a better interface for /dev/u?random on Linux, which avoids the
issues associated with opening files.
---
configure | 2 ++
libavutil/random_seed.c | 16
2 files changed, 18 insertions(+)
diff --git a/configure b/configure
index 0ab0761011..f8c809e491 100755
Quoting Lynne (2023-07-06 18:04:41)
> It's been a while since we've had a release, and we've had
> a lot of new features in.
> We did say we would make releases more often, and I think
> it's about time we have a new release.
>
> Anything anyone wants to have merged or should we branch
> off 6.1 i
Quoting Michael Niedermayer (2023-07-07 17:06:54)
> Hi
>
> On Thu, Jul 06, 2023 at 06:04:41PM +0200, Lynne wrote:
> > It's been a while since we've had a release, and we've had
> > a lot of new features in.
> > We did say we would make releases more often, and I think
> > it's about time we have a
From: Elias Carotti
Add side data type to provide hint to the video encoders about unchanged
portions of each frame.
Signed-off-by: Anton Khirnov
---
I've made couple small changes:
* rebased against current master
* consistently refer to rectangles or AVVideoRect, not blocks
* use size_t inste
Quoting Carotti, Elias (2023-07-03 17:55:40)
> On Wed, 2023-06-21 at 15:57 +, Carotti, Elias wrote:
> > Hi all,
> > please find the second part of the patch set.
> > Best,
> > Elias
>
> Hi all,
> please find the second part of the patch, updating libavcodec/libx264.c
> to use the AVVideoHint s
On 7/9/2023 6:49 AM, Anton Khirnov wrote:
Quoting James Almer (2023-07-08 21:00:38)
And not just those with the old decode() API.
Signed-off-by: James Almer
---
libavcodec/decode.c | 52 +++--
1 file changed, 27 insertions(+), 25 deletions(-)
Is the
On 7/9/2023 6:48 AM, Anton Khirnov wrote:
Quoting James Almer (2023-07-08 21:00:36)
-/*
- * The core of the receive_frame_wrapper for the decoders implementing
- * the simple API. Certain decoders might consume partial packets without
- * returning any output, so this function needs to be called
Quoting James Almer (2023-07-09 14:11:14)
>
> I could call it discard_samples_or_frame(), or discard_frame().
> If i process the video in the caller, it will end up being duplicated in
> patch 2, which goes against the point of factoring this out.
The duplicated code would be 2 very simple lines
Attached.
From acdb135770da2c52f3f4f9416b231b1b573cb0ae Mon Sep 17 00:00:00 2001
From: Paul B Mahol
Date: Sun, 1 Aug 2021 20:06:24 +0200
Subject: [PATCH 1/3] avformat: add hvqm4 demuxer
Signed-off-by: Paul B Mahol
---
libavformat/Makefile | 1 +
libavformat/allformats.c | 1 +
libavform
This decoding flag makes decoders drop all frames after a parameter
change, but what exactly constitutes a parameter change is not well
defined and will typically depend on the exact use case.
This functionality then does not belong in libavcodec, but rather in
user code
---
doc/APIchanges
Quoting James Almer (2023-07-09 14:05:45)
> On 7/9/2023 6:49 AM, Anton Khirnov wrote:
> > Quoting James Almer (2023-07-08 21:00:38)
> >> And not just those with the old decode() API.
> >>
> >> Signed-off-by: James Almer
> >> ---
> >> libavcodec/decode.c | 52 +++--
Jul 9, 2023, 13:05 by an...@khirnov.net:
> From: Elias Carotti
>
> Add side data type to provide hint to the video encoders about unchanged
> portions of each frame.
>
> Signed-off-by: Anton Khirnov
> ---
> I've made couple small changes:
> * rebased against current master
> * consistently refer
As an intended side effect, avci->skip_samples is no longer being set when no
frame is output.
Signed-off-by: James Almer
---
libavcodec/decode.c | 269 +++-
1 file changed, 138 insertions(+), 131 deletions(-)
diff --git a/libavcodec/decode.c b/libavcodec
And not just those with the old decode() API.
Signed-off-by: James Almer
---
libavcodec/decode.c | 8
1 file changed, 8 insertions(+)
diff --git a/libavcodec/decode.c b/libavcodec/decode.c
index a39af2d014..b3e4b066e5 100644
--- a/libavcodec/decode.c
+++ b/libavcodec/decode.c
@@ -597,6
And not just those with the old decode() API.
Signed-off-by: James Almer
---
libavcodec/decode.c | 64 +++--
1 file changed, 33 insertions(+), 31 deletions(-)
diff --git a/libavcodec/decode.c b/libavcodec/decode.c
index b3e4b066e5..080edb5996 100644
--- a
ffmpeg | branch: master | Paul B Mahol https://ffmpeg.org/mailman/listinfo/ffmpeg-cvslog>> | Thu Jul 6 16:47:02 2023
+0200| [889c2529cc6ef65bb4c4f10aa79ca7ca0070a1aa] | committer: Paul B Mahol
avfilter/af_adynamicequalizer: simplify calculations
>/http://git.videolan.org/gitweb.cgi/ffmpeg.git/
On Sun, Jul 9, 2023 at 5:24 PM James Almer wrote:
> > ffmpeg | branch: master | Paul B Mahol https://ffmpeg.org/mailman/listinfo/ffmpeg-cvslog>> | Thu Jul 6 16:47:02
> 2023 +0200| [889c2529cc6ef65bb4c4f10aa79ca7ca0070a1aa] | committer: Paul B
> Mahol
> >
> > avfilter/af_adynamicequalizer: simpl
On Sun, 9 Jul 2023, Anton Khirnov wrote:
Quoting Marton Balint (2023-07-07 22:02:26)
On Fri, 7 Jul 2023, Anton Khirnov wrote:
It is a better interface for /dev/u?random on Linux, which avoids the
issues associated with opening files.
getrandom() actually have the same problem as read(
On 7/9/2023 1:23 PM, Marton Balint wrote:
On Sun, 9 Jul 2023, Anton Khirnov wrote:
Quoting Marton Balint (2023-07-07 22:02:26)
On Fri, 7 Jul 2023, Anton Khirnov wrote:
It is a better interface for /dev/u?random on Linux, which avoids the
issues associated with opening files.
getrandom
On Sun, 9 Jul 2023, James Almer wrote:
On 7/9/2023 1:23 PM, Marton Balint wrote:
On Sun, 9 Jul 2023, Anton Khirnov wrote:
Quoting Marton Balint (2023-07-07 22:02:26)
On Fri, 7 Jul 2023, Anton Khirnov wrote:
It is a better interface for /dev/u?random on Linux, which avoids the
i
On Sun, 2 Jul 2023, Marton Balint wrote:
BMDTimeValue is defined as LONGLONG on Windows, but int64_t on Linux/Mac.
Fixes format string warnings:
libavdevice/decklink_enc.cpp: In function ‘void construct_cc(AVFormatContext*,
decklink_ctx*, AVPacket*, klvanc_line_set_s*)’:
libavdevice/decklin
It has no effect on receive_frame() decoders.
Signed-off-by: James Almer
---
libavcodec/av1dec.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/libavcodec/av1dec.c b/libavcodec/av1dec.c
index e7f98a6c81..cc178464b9 100644
--- a/libavcodec/av1dec.c
+++ b/libavcodec/av1dec.c
It has no effect on receive_frame() decoders.
Signed-off-by: James Almer
---
libavcodec/libdav1d.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/libdav1d.c b/libavcodec/libdav1d.c
index c263157a2a..11cdbca274 100644
--- a/libavcodec/libdav1d.c
+++ b/libavcodec/li
It has no effect on receive_frame() decoders.
Signed-off-by: James Almer
---
libavcodec/mediacodecdec.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/libavcodec/mediacodecdec.c b/libavcodec/mediacodecdec.c
index 21464900d1..44f55947be 100644
--- a/libavcodec/mediacodecdec
It has no effect on receive_frame() decoders.
Signed-off-by: James Almer
---
libavcodec/mjpegdec.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/mjpegdec.c b/libavcodec/mjpegdec.c
index ab7fa73819..b42e75bcdd 100644
--- a/libavcodec/mjpegdec.c
+++ b/libavcodec/mj
It has no effect on receive_frame() decoders.
Signed-off-by: James Almer
---
libavcodec/mmaldec.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/libavcodec/mmaldec.c b/libavcodec/mmaldec.c
index 9bfb6778b6..8d67d10cd9 100644
--- a/libavcodec/mmaldec.c
+++ b/libavcodec/mmal
It has no effect on receive_frame() decoders.
Signed-off-by: James Almer
---
libavcodec/v4l2_m2m_dec.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/v4l2_m2m_dec.c b/libavcodec/v4l2_m2m_dec.c
index 4944d08511..aa2d759e1e 100644
--- a/libavcodec/v4l2_m2m_dec.c
+++
Ensure that only decode() callback ones set it.
Signed-off-by: James Almer
---
libavcodec/tests/avcodec.c | 4
1 file changed, 4 insertions(+)
diff --git a/libavcodec/tests/avcodec.c b/libavcodec/tests/avcodec.c
index bbf5289af2..08ca507bf0 100644
--- a/libavcodec/tests/avcodec.c
+++ b/lib
On 7/9/2023 10:39 AM, James Almer wrote:
And not just those with the old decode() API.
Signed-off-by: James Almer
---
libavcodec/decode.c | 8
1 file changed, 8 insertions(+)
diff --git a/libavcodec/decode.c b/libavcodec/decode.c
index a39af2d014..b3e4b066e5 100644
--- a/libavcodec
Hi,
On Thu, Jul 6, 2023 at 9:10 PM Dai, Jianhui J <
jianhui.j.dai-at-intel@ffmpeg.org> wrote:
> > -Original Message-
> > From: ffmpeg-devel On Behalf Of Dai,
> > Jianhui J
> > Sent: Monday, July 3, 2023 12:26 PM
> > To: ffmpeg-devel@ffmpeg.org
> > Subject: [FFmpeg-devel] [PATCH v5] a
As can be seen in man console_codes this parameter sets the default
background color
Signed-off-by: Jonas Lindner
---
libavcodec/ansi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/ansi.c b/libavcodec/ansi.c
index 49c3770c4c..d8d32bafbd 100644
--- a/libavcodec/
Should fix #10457, a regression caused by
69516ab3e917a6e91d26e38d04183c60fd71cbab.
Signed-off-by: Andreas Rheinhardt
---
I am not sure about this one. The problem is that avcodec_send_packet()
and avcodec_receive_frame() must not return EAGAIN at the same time.
If buffer_frame contains a frame w
On Sat, Jul 08, 2023 at 11:25:13PM +0200, Michael Niedermayer wrote:
> Signed-off-by: Michael Niedermayer
> ---
> libavradio/sdrdemux.c | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
will apply patchset
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FA
Signed-off-by: Michael Niedermayer
---
libavradio/sdrdemux.c | 56 ---
1 file changed, 26 insertions(+), 30 deletions(-)
diff --git a/libavradio/sdrdemux.c b/libavradio/sdrdemux.c
index 7cc71b2cfb..92b218d899 100644
--- a/libavradio/sdrdemux.c
+++ b/libavr
This simplifies the following commits
Signed-off-by: Michael Niedermayer
---
libavradio/sdrdemux.c | 12 +++-
1 file changed, 7 insertions(+), 5 deletions(-)
diff --git a/libavradio/sdrdemux.c b/libavradio/sdrdemux.c
index 92b218d899..ef8a8a91d3 100644
--- a/libavradio/sdrdemux.c
+++ b/
Signed-off-by: Michael Niedermayer
---
libavradio/sdrdemux.c | 17 ++---
1 file changed, 10 insertions(+), 7 deletions(-)
diff --git a/libavradio/sdrdemux.c b/libavradio/sdrdemux.c
index ef8a8a91d3..36b8aac2fb 100644
--- a/libavradio/sdrdemux.c
+++ b/libavradio/sdrdemux.c
@@ -1136,16
Signed-off-by: Michael Niedermayer
---
libavradio/sdrdemux.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/libavradio/sdrdemux.c b/libavradio/sdrdemux.c
index 36b8aac2fb..0cad9a2d3a 100644
--- a/libavradio/sdrdemux.c
+++ b/libavradio/sdrdemux.c
@@ -1099,6 +1099,7 @@ sta
Signed-off-by: Michael Niedermayer
---
libavradio/Makefile | 4 +-
libavradio/rds.c| 203
libavradio/sdr.h| 13 ++-
libavradio/sdrdemux.c | 18 +++-
libavradio/vissualize.c | 13 ++-
5 files changed, 240 insertions(+), 11 deletio
>From the spec: "It is a requirement of bitstream conformance that
the value of luma_bit_depth_entry_minus8 shall be equal to
the value of bit_depth_luma_minus8"; similarly for chroma.
Should fix Coverity ticket #1529226.
Signed-off-by: Andreas Rheinhardt
---
libavcodec/hevc_ps.c | 10 ++---
On 7/9/2023 9:19 PM, Andreas Rheinhardt wrote:
From the spec: "It is a requirement of bitstream conformance that
the value of luma_bit_depth_entry_minus8 shall be equal to
the value of bit_depth_luma_minus8"; similarly for chroma.
Should fix Coverity ticket #1529226.
Signed-off-by: Andreas Rhe
James Almer:
> On 7/9/2023 9:19 PM, Andreas Rheinhardt wrote:
>> From the spec: "It is a requirement of bitstream conformance that
>> the value of luma_bit_depth_entry_minus8 shall be equal to
>> the value of bit_depth_luma_minus8"; similarly for chroma.
>>
>> Should fix Coverity ticket #1529226.
Jul 3, 2023, 00:46 by mich...@niedermayer.cc:
> On Mon, Jul 03, 2023 at 12:03:10AM +0200, Lynne wrote:
>
>> Jul 2, 2023, 23:15 by mich...@niedermayer.cc:
>>
>> > On Sun, Jul 02, 2023 at 08:55:40PM +0200, Lynne wrote:
>> >
>> >> Jul 2, 2023, 13:01 by mich...@niedermayer.cc:
>> >>
>> >> > On Fri, Ju
48 matches
Mail list logo