Re: [FFmpeg-devel] [PATCH v4] avformat/mxfdec: Read video range from PictureDescriptor

2020-08-16 Thread Harry Mallon
> On 14 Aug 2020, at 22:33, Harry Mallon wrote: > > > > >> On 14 Aug 2020, at 11:53, Tomas Härdin wrote: >> >> tor 2020-08-13 klockan 22:21 +0200 skrev Marton Balint: >>> >>> On Thu, 13 Aug 2020, Tomas Härdin wrote: >>> tor 2020-08-13 klockan 11:04 +0100 skrev Harry Mallon: > H

[FFmpeg-devel] [PATCH] avcodec/cfhd: add x86 SIMD

2020-08-16 Thread Paul B Mahol
Hi, patch attached. Please help porting this to linux and 64bit calling convention. 0001-avcodec-cfhd-add-x86-SIMD.patch Description: Binary data ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel T

[FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Nicolas George
Signed-off-by: Nicolas George --- doc/ffmpeg.texi | 8 fftools/ffmpeg.h| 1 + fftools/ffmpeg_filter.c | 2 ++ fftools/ffmpeg_opt.c| 3 +++ 4 files changed, 14 insertions(+) diff --git a/doc/ffmpeg.texi b/doc/ffmpeg.texi index 267ddfe8b5..e38e55573e 100644 --- a/doc/f

Re: [FFmpeg-devel] [PATCH] avcodec/cfhd: add x86 SIMD

2020-08-16 Thread Paul B Mahol
On 8/16/20, Paul B Mahol wrote: > Hi, > > patch attached. > > Please help porting this to linux and 64bit calling convention. > New patch attached, could build on x64, please report any build failure. 0001-avcodec-cfhd-add-x86-SIMD.patch Description: Binary data

Re: [FFmpeg-devel] [PATCH] avcodec/cfhd: add x86 SIMD

2020-08-16 Thread James Almer
On 8/16/2020 11:09 AM, Paul B Mahol wrote: > On 8/16/20, Paul B Mahol wrote: >> Hi, >> >> patch attached. >> >> Please help porting this to linux and 64bit calling convention. >> > > New patch attached, could build on x64, please report any build failure. [...] > diff --git a/libavcodec/x86/cfh

[FFmpeg-devel] [PATCH] avfilter/yadif: simplify the code for better readability

2020-08-16 Thread lance . lmwang
From: Limin Wang Signed-off-by: Limin Wang --- libavfilter/vf_bwdif.c | 13 ++--- libavfilter/vf_yadif.c | 16 ++-- libavfilter/x86/vf_bwdif_init.c | 2 +- libavfilter/x86/vf_yadif_init.c | 3 +-- libavfilter/yadif.h | 5 - libavfilter/ya

Re: [FFmpeg-devel] [PATCH] avcodec/cfhd: add x86 SIMD

2020-08-16 Thread Paul B Mahol
On 8/16/20, James Almer wrote: > On 8/16/2020 11:09 AM, Paul B Mahol wrote: >> On 8/16/20, Paul B Mahol wrote: >>> Hi, >>> >>> patch attached. >>> >>> Please help porting this to linux and 64bit calling convention. >>> >> >> New patch attached, could build on x64, please report any build failure.

Re: [FFmpeg-devel] [PATCH] avcodec/cfhd: add x86 SIMD

2020-08-16 Thread James Almer
On 8/16/2020 12:01 PM, Paul B Mahol wrote: > On 8/16/20, James Almer wrote: >> On 8/16/2020 11:09 AM, Paul B Mahol wrote: >>> On 8/16/20, Paul B Mahol wrote: Hi, patch attached. Please help porting this to linux and 64bit calling convention. >>> >>> New patch attache

Re: [FFmpeg-devel] [PATCH] avcodec/cfhd: add x86 SIMD

2020-08-16 Thread Michael Niedermayer
On Sun, Aug 16, 2020 at 08:32:20AM +0200, Paul B Mahol wrote: > On 8/16/20, Michael Niedermayer wrote: > > On Sat, Aug 15, 2020 at 07:29:40PM +0200, Paul B Mahol wrote: > >> On 8/15/20, Michael Niedermayer wrote: > >> > On Fri, Aug 14, 2020 at 02:24:25PM +0200, Paul B Mahol wrote: > >> >> On 8/14

Re: [FFmpeg-devel] [PATCH] avcodec/cfhd: add x86 SIMD

2020-08-16 Thread Paul B Mahol
On 8/16/20, Michael Niedermayer wrote: > On Sun, Aug 16, 2020 at 08:32:20AM +0200, Paul B Mahol wrote: >> On 8/16/20, Michael Niedermayer wrote: >> > On Sat, Aug 15, 2020 at 07:29:40PM +0200, Paul B Mahol wrote: >> >> On 8/15/20, Michael Niedermayer wrote: >> >> > On Fri, Aug 14, 2020 at 02:24:2

[FFmpeg-devel] [PATCH] avcodec/decode: move the ff_decode_frame_props() prototype to the proper header

2020-08-16 Thread James Almer
Signed-off-by: James Almer --- libavcodec/decode.h| 5 + libavcodec/internal.h | 5 - libavcodec/libvpxdec.c | 1 + libavcodec/mmaldec.c | 1 + libavcodec/qtrle.c | 1 + libavcodec/rawdec.c| 1 + 6 files changed, 9 insertions(+), 5 deletions(-) diff --git a/libavcodec/deco

[FFmpeg-devel] [PATCH] avformat/utils: check for integer overflow in av_get_frame_filename2()

2020-08-16 Thread Michael Niedermayer
Fixes: signed integer overflow: 317316873 * 10 cannot be represented in type 'int' Fixes: 24708/clusterfuzz-testcase-minimized-ffmpeg_DEMUXER_fuzzer-5731180885049344 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Michael Nieder

Re: [FFmpeg-devel] [PATCH] avformat/utils: check for integer overflow in av_get_frame_filename2()

2020-08-16 Thread Paul B Mahol
On 8/16/20, Michael Niedermayer wrote: > Fixes: signed integer overflow: 317316873 * 10 cannot be represented in type > 'int' > Fixes: > 24708/clusterfuzz-testcase-minimized-ffmpeg_DEMUXER_fuzzer-5731180885049344 > > Found-by: continuous fuzzing process > https://github.com/google/oss-fuzz/tree/ma

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Marton Balint
On Sun, 16 Aug 2020, Nicolas George wrote: Signed-off-by: Nicolas George --- doc/ffmpeg.texi | 8 fftools/ffmpeg.h| 1 + fftools/ffmpeg_filter.c | 2 ++ fftools/ffmpeg_opt.c| 3 +++ 4 files changed, 14 insertions(+) diff --git a/doc/ffmpeg.texi b/doc/ffmpeg.texi inde

Re: [FFmpeg-devel] [PATCH] avformat/utils: check for integer overflow in av_get_frame_filename2()

2020-08-16 Thread Michael Niedermayer
On Sun, Aug 16, 2020 at 05:38:29PM +0200, Paul B Mahol wrote: > On 8/16/20, Michael Niedermayer wrote: > > Fixes: signed integer overflow: 317316873 * 10 cannot be represented in type > > 'int' > > Fixes: > > 24708/clusterfuzz-testcase-minimized-ffmpeg_DEMUXER_fuzzer-5731180885049344 > > > > Found

Re: [FFmpeg-devel] [PATCH] avformat/utils: check for integer overflow in av_get_frame_filename2()

2020-08-16 Thread Paul B Mahol
On 8/16/20, Michael Niedermayer wrote: > On Sun, Aug 16, 2020 at 05:38:29PM +0200, Paul B Mahol wrote: >> On 8/16/20, Michael Niedermayer wrote: >> > Fixes: signed integer overflow: 317316873 * 10 cannot be represented in >> > type >> > 'int' >> > Fixes: >> > 24708/clusterfuzz-testcase-minimized-

Re: [FFmpeg-devel] [PATCH] avcodec/cfhd: add x86 SIMD

2020-08-16 Thread Paul B Mahol
On 8/16/20, Paul B Mahol wrote: > Hi, > > patch attached. > > Please help porting this to linux and 64bit calling convention. > New patch attached. This one does not allocate stack on x32. 0001-avcodec-cfhd-add-x86-SIMD.patch Description: Binary data ___

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Nicolas George
Marton Balint (12020-08-16): > Can we find a shorter name for the option? E.g. simply call the option > auto_conversion_filters and the user can use -noauto_conversion_filters to > disable it... In the next patch with the current name you have > -nodisable_auto_coversion_filters which is really ugl

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Paul B Mahol
On 8/16/20, Nicolas George wrote: > Marton Balint (12020-08-16): >> Can we find a shorter name for the option? E.g. simply call the option >> auto_conversion_filters and the user can use -noauto_conversion_filters >> to >> disable it... In the next patch with the current name you have >> -nodisabl

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Nicolas George
Paul B Mahol (12020-08-16): > I do not like long name either. And do you have a better reason than the fact that it comes from me? -- Nicolas George signature.asc Description: PGP signature ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Gyan Doshi
On 16-08-2020 09:57 pm, Nicolas George wrote: Marton Balint (12020-08-16): Can we find a shorter name for the option? E.g. simply call the option auto_conversion_filters and the user can use -noauto_conversion_filters to disable it... In the next patch with the current name you have -nodisable

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Nicolas George
Gyan Doshi (12020-08-16): > Then make it a bit cryptic rather than verbose. e.g. an abbreviation. Urgh, no. Making it cryptic would be hostile to people who read the tests that use it. Cryptic is a very bad idea for almost everything. Regards, -- Nicolas George signature.asc Description: PG

[FFmpeg-devel] [PATCH 2/2] avformat/rmdec: sanity check coded_framesize

2020-08-16 Thread Michael Niedermayer
Fixes: signed integer overflow: -14671840 * 8224 cannot be represented in type 'int' Fixes: 24793/clusterfuzz-testcase-minimized-ffmpeg_DEMUXER_fuzzer-5101884323659776 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Michael Nied

[FFmpeg-devel] [PATCH 1/2] tools/target_dec_fuzzer: Adjust threshold for DST

2020-08-16 Thread Michael Niedermayer
Fixes: Timeout (too long -> 3sec) Fixes: 24239/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_DST_fuzzer-5189061015502848 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Michael Niedermayer --- tools/target_dec_fuzzer.c | 2

Re: [FFmpeg-devel] [PATCH] avformat/mpeg: Check avio_read() return value in get_pts()

2020-08-16 Thread Michael Niedermayer
On Fri, Aug 14, 2020 at 04:50:02PM -0700, Thierry Foucu wrote: > On Fri, Aug 14, 2020, 4:08 PM Michael Niedermayer > wrote: > > > Found-by: Thierry Foucu > > Fixes: Use-of-uninitialized-value > > Signed-off-by: Michael Niedermayer > > --- > > libavformat/mpeg.c | 5 - > > 1 file changed, 4

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Alexander Strasser
On 2020-08-16 18:39 +0200, Nicolas George wrote: > Paul B Mahol (12020-08-16): > > I do not like long name either. > > And do you have a better reason than the fact that it comes from me? This was uncalled for and not nice at all! It's neither good for you nor the community. There is nothing wro

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Alexander Strasser
On 2020-08-16 18:27 +0200, Nicolas George wrote: > Marton Balint (12020-08-16): > > Can we find a shorter name for the option? E.g. simply call the option > > auto_conversion_filters and the user can use -noauto_conversion_filters to > > disable it... In the next patch with the current name you hav

Re: [FFmpeg-devel] [PATCH 2/2] lavc/ratecontrol: Fix error logging for parsing and evaluation of rc_eq

2020-08-16 Thread Alexander Strasser
On 2020-08-13 22:32 +0200, Michael Niedermayer wrote: > On Wed, Aug 12, 2020 at 08:58:30PM +0200, Alexander Strasser wrote: > > On 2020-08-09 14:56 +0200, Michael Niedermayer wrote: [...] > > > > > > lib user > > > > > > > If I'm not mistaken, a library user should not set it to NULL. Is it > > >

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Nicolas George
Alexander Strasser (12020-08-16): > This was uncalled for and not nice at all! I will be correct, but I'm done being nice with him. > It's neither good for you nor the community. Do you honestly consider wrongs are balanced in this whole mess? Because if wrongs are not balanced, there is only on

Re: [FFmpeg-devel] [PATCH 1/2] ffmpeg: add disable_all_auto_conversion_filters option.

2020-08-16 Thread Nicolas George
Alexander Strasser (12020-08-16): > I dislike the negative name too, because like mentioned by Marton it > doesn't work well with overriding the option to turn it off. > > On one hand for this option in particular it wouldn't be that important, > on the other hand it will be something (new) develo

Re: [FFmpeg-devel] [PATCH 1/2] tools/target_dec_fuzzer: Adjust threshold for DST

2020-08-16 Thread Peter Ross
On Sun, Aug 16, 2020 at 08:04:08PM +0200, Michael Niedermayer wrote: > Fixes: Timeout (too long -> 3sec) > Fixes: > 24239/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_DST_fuzzer-5189061015502848 > > Found-by: continuous fuzzing process > https://github.com/google/oss-fuzz/tree/master/projec

Re: [FFmpeg-devel] [PATCH 1/3] avcodec/v4l2_context: return EAGAIN to signal full buffers

2020-08-16 Thread Andriy Gelman
On Sat, 15. Aug 22:34, Mark Thompson wrote: > On 17/07/2020 03:09, Andriy Gelman wrote: > > From: Andriy Gelman > > > > Return proper error when a frame buffers are full. This path is > > triggered on the DragonBoard 410c since the encoding API change in > > commit 827d6fe73d2f5472c1c2. > > > >

Re: [FFmpeg-devel] [PATCH 2/3] avformat/hls: Remove redundant resetting of AVPacket

2020-08-16 Thread Steven Liu
Andreas Rheinhardt 于2020年8月15日周六 上午5:20写道: > > av_read_frame() already returns blank packets on error. > > Signed-off-by: Andreas Rheinhardt > --- > libavformat/hls.c | 1 - > 1 file changed, 1 deletion(-) > > diff --git a/libavformat/hls.c b/libavformat/hls.c > index 4a3e0d6842..8217c5ede4 1006

[FFmpeg-devel] [PATCH] avformat/hlsenc: check the segment duration valid

2020-08-16 Thread Steven Liu
output a warning message if the target duration of the segment. and modify the target duration to one packet duration, because there maybe have bframe and then split not by keyframe, and the segment is very very small. Signed-off-by: Steven Liu --- libavformat/hlsenc.c | 5 + 1 file changed,

Re: [FFmpeg-devel] [PATCH] avformat/hls: Fix memleak when url is empty

2020-08-16 Thread Steven Liu
Andreas Rheinhardt 于2020年8月15日周六 上午4:35写道: > > Fixes Coverity ID 1465888. > > Signed-off-by: Andreas Rheinhardt > --- > Why does this code actually not check the return value of > ff_make_absolute_url()? > > libavformat/hls.c | 4 +++- > 1 file changed, 3 insertions(+), 1 deletion(-) > > diff --

Re: [FFmpeg-devel] [PATCH 3/3] avformat/hls: Use av_init_pkt() directly

2020-08-16 Thread Steven Liu
Andreas Rheinhardt 于2020年8月15日周六 上午5:21写道: > > and remove reset_packet(). The packet's data pointer is already zeroed, > so the only thing that reset_packet() does that av_init_pkt() doesn't is > redundant. > > Signed-off-by: Andreas Rheinhardt > --- > libavformat/hls.c | 12 +--- > 1 fi

Re: [FFmpeg-devel] [PATCH] avformat/hlsenc: check the segment duration valid

2020-08-16 Thread zhilizhao
Hi Steven, > On Aug 17, 2020, at 8:49 AM, Steven Liu wrote: > > output a warning message if the target duration of the segment. The sentence is incomplete. > and modify the target duration to one packet duration, > because there maybe have bframe and then split not by keyframe, > and the segme

Re: [FFmpeg-devel] [PATCH] avformat/hlsenc: check the segment duration valid

2020-08-16 Thread Steven Liu
zhilizhao 于2020年8月17日周一 上午10:54写道: > > Hi Steven, > > > On Aug 17, 2020, at 8:49 AM, Steven Liu wrote: > > > > output a warning message if the target duration of the segment. > > The sentence is incomplete. Ah ,yes, should "Output a warning message if the target duration of the segment is negativ

Re: [FFmpeg-devel] [PATCH] avformat/hlsenc: check the segment duration valid

2020-08-16 Thread zhilizhao
> On Aug 17, 2020, at 11:02 AM, Steven Liu wrote: > > zhilizhao mailto:quinkbl...@foxmail.com>> > 于2020年8月17日周一 上午10:54写道: >> >> Hi Steven, >> >>> On Aug 17, 2020, at 8:49 AM, Steven Liu >> > wrote: >>> >>> output a warning message if the target duration of the

Re: [FFmpeg-devel] [PATCH] avformat/hlsenc: check the segment duration valid

2020-08-16 Thread Steven Liu
zhilizhao 于2020年8月17日周一 上午11:15写道: > > > > > On Aug 17, 2020, at 11:02 AM, Steven Liu wrote: > > > > zhilizhao mailto:quinkbl...@foxmail.com>> > > 于2020年8月17日周一 上午10:54写道: > >> > >> Hi Steven, > >> > >>> On Aug 17, 2020, at 8:49 AM, Steven Liu >>> > wrote: > >>> > >

Re: [FFmpeg-devel] [PATCH] avformat/hlsenc: check the segment duration valid

2020-08-16 Thread zhilizhao
> On Aug 17, 2020, at 11:18 AM, Steven Liu wrote: > > zhilizhao mailto:quinkbl...@foxmail.com>> > 于2020年8月17日周一 上午11:15写道: >> >> >> >>> On Aug 17, 2020, at 11:02 AM, Steven Liu >> > wrote: >>> >>> zhilizhao mailto:quinkbl...@foxmail.com> >>>

[FFmpeg-devel] [PATCH V2] dnn/native: add log error message

2020-08-16 Thread Ting Fu
Signed-off-by: Ting Fu --- V2: Fix the issue in V1: make fate failed libavfilter/dnn/dnn_backend_native.c | 74 +++ libavfilter/dnn/dnn_backend_native.h | 5 ++ .../dnn/dnn_backend_native_layer_avgpool.c| 2 +- .../dnn/dnn_backend_native_layer_avgpool.

Re: [FFmpeg-devel] [PATCH] fix memory leak in qsvenc.c

2020-08-16 Thread Alex Pokotilo
> Seems reasonable, any special reason to reorder av_freep(&sync)? I want to combine "bs" and it's children structures disposal in the same order as in ff_qsv_encode where we have #if QSV_VERSION_ATLEAST(1, 26) if (avctx->codec_id == AV_CODEC_ID_H264) { enc_buf = bs->ExtParam