Re: [FFmpeg-devel] [PATCH 02/14] avformat/matroska: clean the structure formatting

2020-03-24 Thread Moritz Barsnick
On Sun, Mar 22, 2020 at 09:59:21 +0100, Steve Lhomme wrote: > Always use a comma at the end, order elements by value. IIUC, this is strictly a C99(+) "feature", so should probably be mentioned here: https://ffmpeg.org/developer.html#C-language-features in case "all compilers we care about" support

Re: [FFmpeg-devel] [PATCH 2/2] avcodec/wavpack: Prevent frame format from being wrong

2020-03-24 Thread Anton Khirnov
Quoting Michael Niedermayer (2020-03-24 01:41:24) > On Mon, Mar 23, 2020 at 05:49:06PM +0100, Anton Khirnov wrote: > > Quoting Michael Niedermayer (2020-03-20 21:50:18) > > > On Fri, Mar 20, 2020 at 10:18:49AM +0100, Anton Khirnov wrote: > > > > Quoting Michael Niedermayer (2020-03-20 01:03:36) > >

Re: [FFmpeg-devel] [PATCH 13/18] h264_sei: parse the picture timing SEIs correctly

2020-03-24 Thread Anton Khirnov
Quoting Kieran Kunhya (2020-03-23 22:34:59) > > > > I don't think you read that section carefully enough. What it says (in > > my interpretation) is that an SPS can be activated only by: > > - buffering period SEI > > - a PPS (which is itself activated by picture data) > > Picture timing SEI is nei

Re: [FFmpeg-devel] [PATCH 14/18] h264_ps: make the PPS hold a reference to its SPS

2020-03-24 Thread Anton Khirnov
Quoting Andreas Rheinhardt (2020-03-23 23:08:14) > Anton Khirnov: > > Quoting James Almer (2020-03-18 17:05:38) > >> On 3/13/2020 7:28 AM, Anton Khirnov wrote: > >>> It represents the relationship between them more naturally and will be > >>> useful in the following commits. > >>> > >>> Allows sign

Re: [FFmpeg-devel] [PATCH] avcodec/decode: Clear format on ff_get_buffer() failure

2020-03-24 Thread Anton Khirnov
Quoting Michael Niedermayer (2020-03-24 01:41:43) > Fixes: out of array access > Fixes: > 21193/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_WAVPACK_fuzzer-5125168956702720 > > Found-by: continuous fuzzing process > https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg > Signed-off

[FFmpeg-devel] [PATCH v1 2/4] avcodec/pgssubdec: replace data_size with got_sub_ptr for better readability

2020-03-24 Thread lance . lmwang
From: Limin Wang Signed-off-by: Limin Wang --- libavcodec/pgssubdec.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/libavcodec/pgssubdec.c b/libavcodec/pgssubdec.c index 7fadcb8b4b..9c59a2297f 100644 --- a/libavcodec/pgssubdec.c +++ b/libavcodec/pgssubdec.c @@ -

[FFmpeg-devel] [PATCH v1 3/4] avcodec/libzvbi-teletextdec: replace data_size with got_sub_ptr for better readability

2020-03-24 Thread lance . lmwang
From: Limin Wang Signed-off-by: Limin Wang --- libavcodec/libzvbi-teletextdec.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/libavcodec/libzvbi-teletextdec.c b/libavcodec/libzvbi-teletextdec.c index fe6504ff8a..8031b02286 100644 --- a/libavcodec/libzvbi-teletextdec.

[FFmpeg-devel] [PATCH v1 4/4] avcodec/dvbsubdec: replace data_size with got_sub_ptr for better readability

2020-03-24 Thread lance . lmwang
From: Limin Wang Signed-off-by: Limin Wang --- libavcodec/dvbsubdec.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/libavcodec/dvbsubdec.c b/libavcodec/dvbsubdec.c index 6e7e13b6eb..f63a1f3bf6 100644 --- a/libavcodec/dvbsubdec.c +++ b/libavcodec/dvbsubdec.c @@ -

[FFmpeg-devel] [PATCH v1 1/4] avcodec/xsubdec: replace data_size with got_sub_ptr for better readability

2020-03-24 Thread lance . lmwang
From: Limin Wang Signed-off-by: Limin Wang --- libavcodec/xsubdec.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavcodec/xsubdec.c b/libavcodec/xsubdec.c index 05c4a64ee5..c1c6e11dc3 100644 --- a/libavcodec/xsubdec.c +++ b/libavcodec/xsubdec.c @@ -46,7 +46,7 @@ sta

Re: [FFmpeg-devel] [PATCH v3 1/2] avcodec: add support for Cunning Developments' ADPCM

2020-03-24 Thread Zane van Iperen
On Mon, 23 Mar 2020 19:24:27 +0100 "Michael Niedermayer" wrote: > > + > > +const int16_t ff_adpcm_ima_cunning_index_table[8] = { > > +-1, -1, -1, -1, 1, 2, 3, 4, > > +}; > > this could be int8_t > Thanks, fixed. Will send a follow-up patch shortly. > https://ffmpeg.org/mailman/listinfo

[FFmpeg-devel] [PATCH v4 2/2] avformat: add demuxer for Pro Pinball Series' Soundbanks

2020-03-24 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- Changelog| 1 + libavformat/Makefile | 1 + libavformat/allformats.c | 1 + libavformat/pp_bnk.c | 229 +++ libavformat/version.h| 2 +- 5 files changed, 233 insertions(+), 1 deletion(-) cr

[FFmpeg-devel] [PATCH v4 1/2] avcodec: add support for Cunning Developments' ADPCM

2020-03-24 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- Changelog | 1 + doc/general.texi| 1 + libavcodec/Makefile | 1 + libavcodec/adpcm.c | 33 + libavcodec/adpcm_data.c | 13 + libavcodec/adpcm_data.h | 2 ++ libavcodec/allcodecs.c |

[FFmpeg-devel] [PATCH v4 0/2] [PATCH v3 0/2] Pro Pinball Series Soundbank demuxer + decoder.

2020-03-24 Thread Zane van Iperen
Adds support for the soundbank files used by the Pro Pinball series of games. v4: - fix adpcm index table type v3: - fix potential memory leak if read_header() fails - fix a buffer overread - attempt seek before updating state - remove unneeded check - naming fixes v2: - Add sanity

[FFmpeg-devel] [PATCH] doc/general.texi: AviSynth+ works on Linux now, AvxSynth is gone.

2020-03-24 Thread Stephen Hutchinson
Related to this are the following changes: * Mention the two methods that AviSynth+ provides for installing just the headers. * Expand on users installing AviSynth on their system a little more. --- This is the only patch that needed changes. I'll just ping the other three. doc/general.texi |

Re: [FFmpeg-devel] [PATCH 2/4] avisynth: switch to AviSynth+ on Linux

2020-03-24 Thread Stephen Hutchinson
On 3/12/20 7:38 PM, Stephen Hutchinson wrote: AviSynth+ now supports non-Windows OSes, making AvxSynth obsolete. Since we no longer support AviSynth 2.5 (which is essentially what AvxSynth is), remove AvxSynth support and replace it with AviSynth+. As a result, the USING_AVISYNTH defines can be

Re: [FFmpeg-devel] [PATCH 1/4] compat: remove avisynth headers

2020-03-24 Thread Stephen Hutchinson
On 3/12/20 7:37 PM, Stephen Hutchinson wrote: --- compat/avisynth/avisynth_c.h | 1264 - compat/avisynth/avs/capi.h| 94 -- compat/avisynth/avs/config.h | 70 - compat/avisynth/avs/types.h | 57 -

Re: [FFmpeg-devel] [PATCH 4/4] avisynth: fix deprecation warning

2020-03-24 Thread Stephen Hutchinson
On 3/12/20 7:38 PM, Stephen Hutchinson wrote: --- libavformat/avisynth.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavformat/avisynth.c b/libavformat/avisynth.c index 43b65badc9..2c08ace8db 100644 --- a/libavformat/avisynth.c +++ b/libavformat/avisynth.c @@ -555

[FFmpeg-devel] [PATCH] avcodec/jpeg2000dec: error check when processing tlm marker

2020-03-24 Thread gautamramk
From: Gautam Ramakrishnan Validate the value of ST field in the TLM marker of JPEG2000. Throw an error when ST takes value of 0x11. --- libavcodec/jpeg2000dec.c | 6 +- 1 file changed, 5 insertions(+), 1 deletion(-) diff --git a/libavcodec/jpeg2000dec.c b/libavcodec/jpeg2000dec.c index 019d

Re: [FFmpeg-devel] [PATCH] avcodec/decode: Clear format on ff_get_buffer() failure

2020-03-24 Thread Michael Niedermayer
On Tue, Mar 24, 2020 at 10:59:21AM +0100, Anton Khirnov wrote: > Quoting Michael Niedermayer (2020-03-24 01:41:43) > > Fixes: out of array access > > Fixes: > > 21193/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_WAVPACK_fuzzer-5125168956702720 > > > > Found-by: continuous fuzzing process >

Re: [FFmpeg-devel] [PATCH 2/2] avformat/hls: Don't strdup non-null-terminated string

2020-03-24 Thread Andreas Rheinhardt
Steven Liu: > > >> 2020年3月22日 上午7:28,Andreas Rheinhardt 写道: >> >> Andreas Rheinhardt: >>> If an URI indicated that the data protocol was in use, it would be >>> copied into a temporary buffer via strncpy(dst, src, strlen(src)), >>> thereby ensuring that the trailing \0 would not be copied, despi

Re: [FFmpeg-devel] JPEG2000 Decoder/Encoder Enhancements

2020-03-24 Thread Michael Niedermayer
On Tue, Mar 24, 2020 at 09:42:07AM +0530, Gautam Ramakrishnan wrote: > Hi Michael, > > I do not mind spending most of the time myself. I just need a person > to go to when I have doubts. I really do not mind doing it without it > being through GSoC either. Just wanted to try contributing to the >

Re: [FFmpeg-devel] [PATCH 4/4] avfilter/vf_paletteuse: Forward error codes

2020-03-24 Thread Andreas Rheinhardt
Paul B Mahol: > lgtm > > On 1/27/20, Andreas Rheinhardt wrote: >> Signed-off-by: Andreas Rheinhardt >> --- >> libavfilter/vf_paletteuse.c | 8 >> 1 file changed, 4 insertions(+), 4 deletions(-) >> >> diff --git a/libavfilter/vf_paletteuse.c b/libavfilter/vf_paletteuse.c >> index 255c9d

Re: [FFmpeg-devel] [PATCH] avcodec/dfa: Use array of fixed-sized strings for fixed-sized strings

2020-03-24 Thread Andreas Rheinhardt
Paul B Mahol: > LGTM > > On 3/18/20, Andreas Rheinhardt wrote: >> Surprisingly neither GCC nor Clang did this transformation on their own. >> >> Signed-off-by: Andreas Rheinhardt >> --- >> libavcodec/dfa.c | 2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) >> >> diff --git a/libavcodec/df

Re: [FFmpeg-devel] [PATCH] avcodec/jpeg2000dec: error check when processing tlm marker

2020-03-24 Thread Paul B Mahol
On 3/24/20, gautamr...@gmail.com wrote: > From: Gautam Ramakrishnan > > Validate the value of ST field in the TLM marker of JPEG2000. > Throw an error when ST takes value of 0x11. > --- > libavcodec/jpeg2000dec.c | 6 +- > 1 file changed, 5 insertions(+), 1 deletion(-) > > diff --git a/libav

Re: [FFmpeg-devel] [PATCH 1/7] avformat/dss: Use AV_DICT_DONT_STRDUP_VAL to save a malloc+memcpy

2020-03-24 Thread Andreas Rheinhardt
Paul B Mahol: > lgtm > > On 11/10/19, Andreas Rheinhardt wrote: >> Signed-off-by: Andreas Rheinhardt >> --- >> libavformat/dss.c | 10 +++--- >> 1 file changed, 3 insertions(+), 7 deletions(-) >> >> diff --git a/libavformat/dss.c b/libavformat/dss.c >> index d7f9cafe47..8bc6af134e 100644 >>

Re: [FFmpeg-devel] [PATCH] [PATCH] POWER8 VSX vectorization libswscale/input.c Track ticket 5570

2020-03-24 Thread Carl Eugen Hoyos
Am Di., 24. März 2020 um 14:28 Uhr schrieb Pestov Vyacheslav : > > yuy2ToY_c: 10157 > yuy2ToY_c_vsx: 2353 > > yuy2ToUV_c: 4907 > yuy2ToUV_c_vsx: 1357 > > rgb24ToY_c: 21172 > rgb24ToY_c_vsx: 9191 > > rgb24ToUV_c: 33568 > rgb24ToUV_c_vsx: 12746 > > bgr24ToY_c: 20983 > bgr24ToY_c_vsx: 9381 > > bgr24To

Re: [FFmpeg-devel] JPEG2000 Decoder/Encoder Enhancements

2020-03-24 Thread Carl Eugen Hoyos
Am Di., 24. März 2020 um 21:37 Uhr schrieb Michael Niedermayer : > > On Tue, Mar 24, 2020 at 09:42:07AM +0530, Gautam Ramakrishnan wrote: > > Hi Michael, > > > > I do not mind spending most of the time myself. I just need a person > > to go to when I have doubts. I really do not mind doing it witho

Re: [FFmpeg-devel] [PATCH] avformat/webmdashenc: Don't use custom option for bitexactness

2020-03-24 Thread Andreas Rheinhardt
Andreas Rheinhardt: > The WebM DASH Manifest muxer can write manifests for live streams and > these contain an entry that depends on the time the manifest is written; > an AVOption to make the output reproducible has been added for tests. > But this is unnecessary, as there already is a method for

Re: [FFmpeg-devel] [PATCH] avformat/rtp: Pass sources and block filter addresses via sdp file for rtp

2020-03-24 Thread Ross Nicholson
This patch will correctly pass any sources or block filters from the URL via SDP to the underlying protocol. Example URL: rtp://232.0.10.234:1?sources=87.141.215.251 Prior to this patch the sources params would be ignored and the stream reading would fail. > On 4 Mar 2020, at 23:47, phunky

Re: [FFmpeg-devel] [PATCH] avcodec/hevc, h2645_parse: Fix HEVC NAL unit names and constants

2020-03-24 Thread Andreas Rheinhardt
Anton Khirnov: > Quoting Andreas Rheinhardt (2020-03-18 14:41:23) >> This commit fixes the names and constants of the reserved NAL units >> with nal_unit_type 22 resp. 23. They were "IRAP_IRAP_VLC2x", but are >> actually "RSV_IRAP_VLC2x". >> >> This also required a change to cbs_h265_syntax_templat

[FFmpeg-devel] [PATCH] avformat/movenc: move the AVProducerReferenceTime struct to MOVTrack

2020-03-24 Thread James Almer
We only care about the prft timestamp of the first sample in each chunk, so no need to store every single one within each MOVIentry. Should reduce memory usage. Signed-off-by: James Almer --- libavformat/movenc.c | 23 +-- libavformat/movenc.h | 3 ++- 2 files changed, 15 i

Re: [FFmpeg-devel] [PATCH] avformat/movenc: move the AVProducerReferenceTime struct to MOVTrack

2020-03-24 Thread Andreas Rheinhardt
James Almer: > We only care about the prft timestamp of the first sample in each chunk, so > no need to store every single one within each MOVIentry. > > Should reduce memory usage. > > Signed-off-by: James Almer > --- > libavformat/movenc.c | 23 +-- > libavformat/movenc.h

Re: [FFmpeg-devel] [PATCH] avformat/movenc: move the AVProducerReferenceTime struct to MOVTrack

2020-03-24 Thread James Almer
On 3/24/2020 9:01 PM, Andreas Rheinhardt wrote: > James Almer: >> We only care about the prft timestamp of the first sample in each chunk, so >> no need to store every single one within each MOVIentry. >> >> Should reduce memory usage. >> >> Signed-off-by: James Almer >> --- >> libavformat/movenc

Re: [FFmpeg-devel] [PATCH] avcodec/jpeg2000dec: error check when processing tlm marker

2020-03-24 Thread Michael Niedermayer
On Wed, Mar 25, 2020 at 01:06:15AM +0530, gautamr...@gmail.com wrote: > From: Gautam Ramakrishnan > > Validate the value of ST field in the TLM marker of JPEG2000. > Throw an error when ST takes value of 0x11. > --- > libavcodec/jpeg2000dec.c | 6 +- > 1 file changed, 5 insertions(+), 1 dele

Re: [FFmpeg-devel] [PATCH] Check return value from avio_read() to verify data actually read

2020-03-24 Thread Michael Niedermayer
On Mon, Mar 23, 2020 at 05:52:01PM -0700, John Rummell wrote: > Chromium fuzzers have caught places where uninitialized data was used due > to calls to avio_read() not verifying that the number of bytes expected was > actually read. So updating the code to check the result from avio_read(). > mov

Re: [FFmpeg-devel] [PATCH 05/17] avformat/webm_chunk: Don't use child AVFormatContext for logging

2020-03-24 Thread Andreas Rheinhardt
Andreas Rheinhardt: > Signed-off-by: Andreas Rheinhardt > --- > libavformat/webm_chunk.c | 7 +++ > 1 file changed, 3 insertions(+), 4 deletions(-) > > diff --git a/libavformat/webm_chunk.c b/libavformat/webm_chunk.c > index bc3d346a00..0d4e3598ed 100644 > --- a/libavformat/webm_chunk.c > ++

Re: [FFmpeg-devel] [PATCH 10/14] avformat/matroskadec: move the elements semantic in a separate file

2020-03-24 Thread Andreas Rheinhardt
Steve Lhomme: > From: Steve Lhomme > > So the file can be generated from the Matroska Schema. > > The EbmlSyntax structures are not shared between files. > matroska_segments and matroska_cluster_enter also have their size predefined. > > No functional changes. > --- > libavformat/Makefile

Re: [FFmpeg-devel] [PATCH] avcodec/jpeg2000dec: error check when processing tlm marker

2020-03-24 Thread Gautam Ramakrishnan
That was an extremely careless error. Apologies for that. Shall fix that immediately. However, is changing the return type of get_tlm() the right way? On Wed, Mar 25, 2020 at 6:06 AM Michael Niedermayer wrote: > > On Wed, Mar 25, 2020 at 01:06:15AM +0530, gautamr...@gmail.com wrote: > > From: Gau

[FFmpeg-devel] [PATCH] avcodec/jpeg2000dec: error check when processing tlm marker

2020-03-24 Thread gautamramk
From: Gautam Ramakrishnan Validate the value of ST field in the TLM marker of JPEG2000. Throw an error when ST takes value of 0x11. --- libavcodec/jpeg2000dec.c | 8 ++-- 1 file changed, 6 insertions(+), 2 deletions(-) diff --git a/libavcodec/jpeg2000dec.c b/libavcodec/jpeg2000dec.c index 0

[FFmpeg-devel] [PATCH v2] avformat/matroskaenc: Write level 1 elements in one go

2020-03-24 Thread Andreas Rheinhardt
Up until now, writing level 1 elements proceeded as follows: First, the element id was written to the ordinary output AVIOContext and a dynamic buffer was opened for the content of the level 1 element in start_ebml_master_crc32(). Then this buffer was actually used and after it was closed (in end_e

Re: [FFmpeg-devel] [PATCH] avcodec/decode: Clear format on ff_get_buffer() failure

2020-03-24 Thread Anton Khirnov
Quoting Michael Niedermayer (2020-03-24 21:23:58) > On Tue, Mar 24, 2020 at 10:59:21AM +0100, Anton Khirnov wrote: > > Quoting Michael Niedermayer (2020-03-24 01:41:43) > > > Fixes: out of array access > > > Fixes: > > > 21193/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_WAVPACK_fuzzer-512516