---
libavcodec/h264dec.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/h264dec.c b/libavcodec/h264dec.c
index b2447e9..bffce52 100644
--- a/libavcodec/h264dec.c
+++ b/libavcodec/h264dec.c
@@ -1000,7 +1000,7 @@ static int h264_decode_frame(AVCodecContext *avctx, voi
Simplify macro TRANSPOSE_4H in mmiutils.h and add TRANSPOSE_8B as a common
macro.
---
libavcodec/mips/vc1dsp_mmi.c | 12 +++
libavcodec/mips/vp8dsp_mmi.c | 72 +
libavutil/mips/mmiutils.h| 84
3 files changed
Constraint "g" means compiler can store variable in memory or register.
When we use constraint "g" for a variable and this variable was operated by
instruction which only support register operands may lead "invalid operands"
error.
---
libavcodec/mips/vc1dsp_mmi.c | 6 +++---
1 file changed, 3 in
On Thu, Sep 06, 2018 at 03:38:28PM +0800, Zhao Zhili wrote:
> ---
> libavcodec/h264dec.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
why do you think the checks are unneeded ?
the commit message is not sufficient to understand the reasons for this change
does this fix a bug or ticket
On Thu, Sep 06, 2018 at 11:36:22AM +0530, Gagandeep Singh wrote:
> On Fri, Aug 17, 2018 at 11:34 AM Gagandeep Singh
> wrote:
>
> >
> >
> > On Thu, Aug 16, 2018 at 2:37 AM Kieran Kunhya wrote:
> >
> >> On Tue, 14 Aug 2018 at 08:43 Gagandeep Singh
> >> wrote:
> >>
> >> > Second patch for fixing d
These conditions are checked again in is_extra(). This patch makes no
functional changes.
---
libavcodec/h264dec.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/h264dec.c b/libavcodec/h264dec.c
index b2447e9..bffce52 100644
--- a/libavcodec/h264dec.c
+++ b/libavcod
---
libavcodec/h264dec.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/libavcodec/h264dec.c b/libavcodec/h264dec.c
index bffce52..6f7530d 100644
--- a/libavcodec/h264dec.c
+++ b/libavcodec/h264dec.c
@@ -871,6 +871,8 @@ static int is_extra(const uint8_t *buf, int buf_size)
{
int cnt=
On 2018年09月06日 17:01, Zhao Zhili wrote:
These conditions are checked again in is_extra(). This patch makes no
functional changes.
I made a mistake. The patch makes no functional changes only after
http://ffmpeg.org/pipermail/ffmpeg-devel/2018-September/233991.html
---
libavcodec/h264dec.c
RGB32(AV_PIX_FMT_BGRA on intel platforms) format may be used as overlay with
alpha blending.
So add AV_PIX_FMT_BGRA format support.
Rename RGB32 to be BGRA to make it clearer as Mark Thompson's suggestion.
V2: Add P010 format support else will introduce HEVC 10bit encoding regression.
Thanks
Signed-off-by: Paul B Mahol
---
libavcodec/scpr.c | 368 +++---
libavcodec/scpr.h | 349 +
libavcodec/scpr3.c | 1189
libavcodec/scpr3.h | 82 +++
4 files changed, 1680 insertions(+), 308 deletions(-)
create mode 100644 libav
On Thu, Sep 06, 2018 at 11:50:12AM +0530, Gagandeep Singh wrote:
> On Thu, Sep 6, 2018 at 11:34 AM Gagandeep Singh
> wrote:
>
> >
> >
> > On Sat, Aug 18, 2018 at 1:47 AM Michael Niedermayer
> > wrote:
> >
> >> On Fri, Aug 17, 2018 at 11:45:04AM +0530, Gagandeep Singh wrote:
> >> [...]
> >> >
> >
On Thu, Sep 06, 2018 at 11:34:57AM +0530, Gagandeep Singh wrote:
> On Sat, Aug 18, 2018 at 1:47 AM Michael Niedermayer
> wrote:
>
> > On Fri, Aug 17, 2018 at 11:45:04AM +0530, Gagandeep Singh wrote:
> > [...]
> > >
> > > > [...]
> > > > > @@ -726,14 +814,15 @@ static int cfhd_decode(AVCodecContex
At 2018-09-06 08:43:05, "Mark Thompson" wrote:
>On 05/09/18 14:38, hwren wrote:
>> Signed-off-by: hwren
[...]
>> +if (cae->xavs2_opts) {
>> +AVDictionary *dict= NULL;
>> +AVDictionaryEntry *en = NULL;
>> +
>> +if (!av_dict_parse_string(&dict, cae->xavs2_op
I have prepared a patch that adds two things.
On the Decklink input side, it adds a parameter called 'passthrough'
which makes it possible to change from the default behaviour on cards
that can handle both inputs and outputs. The default behaviour on such
cards depends on the model but many of them
Signed-off-by: hwren
---
libavformat/allformats.c | 1 +
libavformat/rawenc.c | 13 +
2 files changed, 14 insertions(+)
diff --git a/libavformat/allformats.c b/libavformat/allformats.c
index adcc8d9..c17cdc2 100644
--- a/libavformat/allformats.c
+++ b/libavformat/allformats.c
@@
Signed-off-by: hwren
---
Changelog | 1 +
configure | 4 +
doc/encoders.texi | 41 +++
doc/general.texi | 14 +++
libavcodec/Makefile| 1 +
libavcodec/allcodecs.c | 1 +
libavcodec/libxavs2.c | 303 +++
Sending this again as the mime type was wrong for the patch on the last message.
I have prepared a patch that adds two things.
On the Decklink input side, it adds a parameter called 'passthrough'
which makes it possible to change from the default behaviour on cards
that can handle both inputs and o
> Am 06.09.2018 um 16:07 schrieb Baldur Gislason :
> I have prepared a patch that adds two things.
Instead please send two patches each adding one thing.
What is supposed to happen if the user specifies “-sdi_link 3”?
Silently assuming “0” is the worst answer imo.
Thank you, Carl Eugen
__
Sample for FATE is here: http://chromashift.org/mp4-with-mov-in24-ver.mp4
Derek Buitenhuis (1):
Add FATE test for QT format audio descriptors in MP4
Justin Ruggles (1):
Use QT format for audio sample descriptors depending on stsd version.
libavformat/isom.h | 1 +
liba
Signed-off-by: Derek Buitenhuis
---
tests/fate/mov.mak | 3 +++
tests/ref/fate/mov-mp4-with-mov-in24-ver | 3 +++
2 files changed, 6 insertions(+)
create mode 100644 tests/ref/fate/mov-mp4-with-mov-in24-ver
diff --git a/tests/fate/mov.mak b/tests/fate/mov.mak
index 3d9e428
From: Justin Ruggles
ISOBMFF does not allow AudioSampleEntryV1 in stsd version 0, so
assume the descriptor format is QTFF SoundDescriptionV1. ISOBMFF does
not define a version 2.
This fixes audio decoding for some MP4 files generated with Apple
tools. The additional fields present in SoundDescri
Currently there is ignoring "rotate" flag in metadata for the case when
encoding is needing. The patch is propagating this flag to destination
video.
i.g.:
ffmpeg -noautorotate -i input.mp4 -metadata:s:v:0 rotate=0 -vcodec libx264
output.mp4
this patch is allow us to do things like this: skip rota
2018-09-06 17:35 GMT+02:00, Derek Buitenhuis :
> From: Justin Ruggles
>
> ISOBMFF does not allow AudioSampleEntryV1 in stsd version 0, so
> assume the descriptor format is QTFF SoundDescriptionV1. ISOBMFF does
> not define a version 2.
>
> This fixes audio decoding for some MP4 files generated wit
On 9/4/2018 5:09 PM, Michael Niedermayer wrote:
> On Mon, Sep 03, 2018 at 10:29:13AM -0300, James Almer wrote:
>> On 9/3/2018 5:17 AM, Michael Niedermayer wrote:
>>> On Sun, Sep 02, 2018 at 09:34:23PM -0300, James Almer wrote:
From: Luca Barbato
Merged-by: James Almer
---
On 06/09/2018 17:13, Carl Eugen Hoyos wrote:
> Please mention ticket #7376 (and the Handbrake issue) in the commit
> message.
Wasn't aware there were tickets already, woops.
Added locally.
- Derek
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
h
2018-09-06 13:48 GMT+02:00, Paul B Mahol :
> ffmpeg | branch: master | Paul B Mahol | Thu Sep 6
> 13:39:22 2018 +0200| [237bbf6678a0c3fc6962716edf72db1063de860c] | committer:
> Paul B Mahol
>
> avcodec/dnxhddec: ask for samples with alpha
Did you look at the samples that were already provided?
h
From 193d415c5b6f29be8f75839d5be4a5ca03bbac10 Mon Sep 17 00:00:00 2001
From: Ilya Shcherbak
Date: Thu, 6 Sep 2018 18:30:20 +0300
Subject: [PATCH] Added rotation override for encoding case
---
fftools/ffmpeg.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/fftools/ffmpeg.c b/fftools/ffm
On 9/6/18, Carl Eugen Hoyos wrote:
> 2018-09-06 13:48 GMT+02:00, Paul B Mahol :
>> ffmpeg | branch: master | Paul B Mahol | Thu Sep 6
>> 13:39:22 2018 +0200| [237bbf6678a0c3fc6962716edf72db1063de860c] |
>> committer:
>> Paul B Mahol
>>
>> avcodec/dnxhddec: ask for samples with alpha
>
> Did you
On 09/06/2018 09:18 AM, Derek Buitenhuis wrote:
> On 06/09/2018 17:13, Carl Eugen Hoyos wrote:
>> Please mention ticket #7376 (and the Handbrake issue) in the commit
>> message.
> Wasn't aware there were tickets already, woops.
>
> Added locally.
>
>
Looks like this also supersedes my earlier patc
On Wed, Sep 5, 2018 at 6:29 PM James Darnley wrote:
>
> On 2018-09-05 22:52, Sigríður Regína Sigurþórsdóttir wrote:
> > +{"reserve_free_space", "Reserve a given amount of space at the
> > beginning og the file for unspecified purpose."
>
> I added the "metadata_header_padding" global option ma
On 05-09-2018 06:06 AM, Michael Niedermayer wrote:
On Mon, Sep 03, 2018 at 10:48:45AM +0530, Gyan Doshi wrote:
On 31-08-2018 10:26 AM, Gyan Doshi wrote:
On 31-08-2018 09:57 AM, Gyan Doshi wrote:
On 31-08-2018 04:28 AM, Marton Balint wrote:
Is there any real use case when same source and des
The documentation states that av_file_map can only be used for reading and for
WIN32 we are already requesting a read only mapping.
Signed-off-by: Marton Balint
---
libavutil/file.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavutil/file.c b/libavutil/file.c
index 24a8
Signed-off-by: Marton Balint
---
libavutil/file.c | 8
libavutil/file.h | 2 ++
2 files changed, 10 insertions(+)
diff --git a/libavutil/file.c b/libavutil/file.c
index 2153e51379..64f11fed76 100644
--- a/libavutil/file.c
+++ b/libavutil/file.c
@@ -85,6 +85,11 @@ int av_file_map(const c
On 2018-09-06 19:39, Sigríður Regína Sigurþórsdóttir wrote:
> +if (s->metadata_header_padding) {
> +if (s->metadata_header_padding == 1)
> +s->metadata_header_padding++;
> +put_ebml_void(pb, s->metadata_header_padding);
> +}
Unfortunately I was forced to make th
2018-09-06 21:18 GMT+02:00, James Darnley :
> On 2018-09-06 19:39, Sigríður Regína Sigurþórsdóttir wrote:
>> +if (s->metadata_header_padding) {
>> +if (s->metadata_header_padding == 1)
>> +s->metadata_header_padding++;
>> +put_ebml_void(pb, s->metadata_header_padding
On 9/6/2018 4:18 PM, James Darnley wrote:
> On 2018-09-06 19:39, Sigríður Regína Sigurþórsdóttir wrote:
>> +if (s->metadata_header_padding) {
>> +if (s->metadata_header_padding == 1)
>> +s->metadata_header_padding++;
>> +put_ebml_void(pb, s->metadata_header_padding);
Signed-off-by: Paul B Mahol
---
configure | 1 +
libavcodec/Makefile | 1 +
libavcodec/allcodecs.c | 1 +
libavcodec/avcodec.h| 1 +
libavcodec/codec_desc.c | 7 +
libavcodec/rasc.c | 789
libavformat/riff.c |
On Sat, 1 Sep 2018, Bodecs Bela wrote:
Hi Balint,
2018.08.25. 20:35 keltezéssel, Marton Balint írta:
To delay filtering until a given wallclock timestamp.
Signed-off-by: Marton Balint
---
doc/filters.texi | 36 ++
libavfilter/Makefile | 2 +
libavfilter/allfilter
Signed-off-by: Marton Balint
---
doc/outdevs.texi | 4
libavdevice/decklink_enc.cpp | 1 +
libavdevice/decklink_enc_c.c | 4
libavdevice/version.h| 2 +-
4 files changed, 10 insertions(+), 1 deletion(-)
diff --git a/doc/outdevs.texi b/doc/outdevs.texi
index 30d376d7
Hi Balint,
2018.09.06. 22:20 keltezéssel, Marton Balint írta:
On Sat, 1 Sep 2018, Bodecs Bela wrote:
Hi Balint,
2018.08.25. 20:35 keltezéssel, Marton Balint írta:
To delay filtering until a given wallclock timestamp.
Signed-off-by: Marton Balint
---
doc/filters.texi | 36
On Tue, Aug 28, 2018 at 12:56 PM Jacob Trimble wrote:
>
> On Mon, Aug 20, 2018 at 11:39 AM Jacob Trimble wrote:
> >
> > On Thu, Aug 9, 2018 at 9:14 AM Jacob Trimble wrote:
> > >
> > > On Wed, Aug 1, 2018 at 1:46 PM Jacob Trimble wrote:
> > > >
> > > > On Mon, Jul 23, 2018 at 2:01 PM Jacob Trimb
On Thu, 6 Sep 2018, Bodecs Bela wrote:
Hi Balint,
2018.09.06. 22:20 keltezéssel, Marton Balint írta:
On Sat, 1 Sep 2018, Bodecs Bela wrote:
Hi Balint,
2018.08.25. 20:35 keltezéssel, Marton Balint írta:
To delay filtering until a given wallclock timestamp.
Signed-off-by: Marton Balint
On Thu, Sep 06, 2018 at 01:10:31PM -0300, James Almer wrote:
> On 9/4/2018 5:09 PM, Michael Niedermayer wrote:
> > On Mon, Sep 03, 2018 at 10:29:13AM -0300, James Almer wrote:
> >> On 9/3/2018 5:17 AM, Michael Niedermayer wrote:
> >>> On Sun, Sep 02, 2018 at 09:34:23PM -0300, James Almer wrote:
> >
On 8/27/2018 6:07 PM, John Stebbins wrote:
> On 08/27/2018 02:03 PM, James Almer wrote:
>> On 8/27/2018 5:48 PM, John Stebbins wrote:
>>> On 08/27/2018 01:29 PM, James Almer wrote:
On 8/27/2018 4:57 PM, John Stebbins wrote:
> Fixes ticket #6897
> ---
> libavformat/movenc.c | 40 ++
On 9/6/2018 7:26 PM, Michael Niedermayer wrote:
> On Thu, Sep 06, 2018 at 01:10:31PM -0300, James Almer wrote:
>> On 9/4/2018 5:09 PM, Michael Niedermayer wrote:
>>> On Mon, Sep 03, 2018 at 10:29:13AM -0300, James Almer wrote:
On 9/3/2018 5:17 AM, Michael Niedermayer wrote:
> On Sun, Sep 0
On Thu, Sep 06, 2018 at 08:58:36PM +0200, Marton Balint wrote:
> The documentation states that av_file_map can only be used for reading and for
> WIN32 we are already requesting a read only mapping.
libavutil/tests/file.c disagrees and its unhappy with this patch
thx
[...]
--
Michael GnuPG
On Thu, Sep 06, 2018 at 10:05:50PM +0200, Paul B Mahol wrote:
> Signed-off-by: Paul B Mahol
> ---
> configure | 1 +
> libavcodec/Makefile | 1 +
> libavcodec/allcodecs.c | 1 +
> libavcodec/avcodec.h| 1 +
> libavcodec/codec_desc.c | 7 +
> libavcodec/rasc.c
>-Original Message-
>From: ffmpeg-devel-boun...@ffmpeg.org [mailto:ffmpeg-devel-boun...@ffmpeg.org]
>On Behalf Of
>Shiyou Yin
>Sent: Wednesday, September 5, 2018 6:31 PM
>To: ffmpeg-devel@ffmpeg.org
>Cc: gxw
>Subject: [FFmpeg-devel] [PATCH 2/2] avcodec/mips: [loongson] optimize vp8
>decod
>-Original Message-
>From: ffmpeg-devel-boun...@ffmpeg.org [mailto:ffmpeg-devel-boun...@ffmpeg.org]
>On Behalf Of
>Shiyou Yin
>Sent: Thursday, September 6, 2018 4:11 PM
>To: ffmpeg-devel@ffmpeg.org
>Subject: [FFmpeg-devel] [PATCH 1/2] avcodec/mips: [loongson] fix improper use
>of register
>-Original Message-
>From: ffmpeg-devel-boun...@ffmpeg.org [mailto:ffmpeg-devel-boun...@ffmpeg.org]
>On Behalf Of
>Shiyou Yin
>Sent: Thursday, September 6, 2018 4:11 PM
>To: ffmpeg-devel@ffmpeg.org
>Subject: [FFmpeg-devel] [PATCH 2/2] avutil/mips: [loongson] simplify macro
>TRANSPOSE_4H a
50 matches
Mail list logo