v1.1->v1.2: Changed ifdefs around vc1_get_INTCOMPFIELD, vc1_get_LUMSCALE2,
and vc1_get_LUMSHIFT2 to av_unused.
avcodec/vaapi: add fields for VAAPI VC-1 interlaced decoding
Pass necessary bitstream elements to the VAAPI VC-1 decoder in order
to start doing interlaced decoding in hardware.
Signed-
On 1 March 2018 at 01:19, Michael Niedermayer
wrote:
> On Wed, Feb 28, 2018 at 12:33:55PM -0900, Lou Logan wrote:
> > On Wed, Feb 28, 2018, at 11:25 AM, Jan Ekström wrote:
> > >
> > > Looking at how much it got updated the last time when it misbehaved
> > > shows really well how that worked the l
Hi,
On Thu, Mar 1, 2018 at 6:49 AM, Ricardo Constantino
wrote:
> There's a lot more places where people can get their armchair politics
> satisfied than ffmpeg.org.
>
I 100% agree with this ...
> A banner or a news post would make more sense.
... but I pretty strongly disagree with this.
L
Liu Steven (2018-02-28):
> LGTM
LGTM too, pushed.
Regards,
--
Nicolas George
signature.asc
Description: Digital signature
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
On Thu, 1 Mar 2018 11:49:16 +
Ricardo Constantino wrote:
> On 1 March 2018 at 01:19, Michael Niedermayer
> wrote:
>
> > On Wed, Feb 28, 2018 at 12:33:55PM -0900, Lou Logan wrote:
> > > On Wed, Feb 28, 2018, at 11:25 AM, Jan Ekström wrote:
> > > >
> > > > Looking at how much it got updat
Signed-off-by: Rostislav Pehlivanov
---
libavutil/frame.c | 39 ---
libavutil/frame.h | 13 +
2 files changed, 37 insertions(+), 15 deletions(-)
diff --git a/libavutil/frame.c b/libavutil/frame.c
index 662a7e5ab5..601906fcc2 100644
--- a/libavutil/
On Thu, 1 Mar 2018 12:32:14 +
Rostislav Pehlivanov wrote:
> Signed-off-by: Rostislav Pehlivanov
> ---
> libavutil/frame.c | 39 ---
> libavutil/frame.h | 13 +
> 2 files changed, 37 insertions(+), 15 deletions(-)
>
> diff --git a/libavutil/f
Signed-off-by: Rostislav Pehlivanov
---
Updated with description of that the function will do.
Originally the function made a reference from the bufferref but someone
said that it shouldn't. I don't think that this is very useful so I've
changed it back so that it refs the buffer (and leaves it u
Signed-off-by: Rostislav Pehlivanov
---
Sending again, forgot to amend.
Updated with description of that the function will do.
Originally the function made a reference from the bufferref but someone
said that it shouldn't. I don't think that this is very useful so I've
changed it back so that it
On 3/1/2018 10:55 AM, Rostislav Pehlivanov wrote:
> Signed-off-by: Rostislav Pehlivanov
> ---
>
> Sending again, forgot to amend.
>
> Updated with description of that the function will do.
> Originally the function made a reference from the bufferref but someone
> said that it shouldn't. I don't
James Almer (2018-03-01):
> I prefer if the function takes ownership of the reference rather than
> create a new one on success.
> If it creates a new one, then the caller still needs to do something
> with the reference passed to the function afterwards regardless of
> outcome, as shown in your ch
This adds a way for an API user to transfer QP data and metadata without
having to keep the reference to AVFrame, and without having to
explicitly care about QP APIs. It might also provide a way to finally
remove the deprecated QP related fields. In the end, the QP table should
be handled in a very
Everything related to the QP data is deprecated, with qp_table_buf being
an inconsistent exception. Some parts were under the deprecation guards,
some not. It probably didn't even compile.
---
libavutil/frame.c | 7 ---
libavutil/frame.h | 1 +
2 files changed, 5 insertions(+), 3 deletions(-)
Signed-off-by: Rostislav Pehlivanov
---
Changed so that the function will not create a new reference.
libavutil/frame.c | 45 +
libavutil/frame.h | 17 +
2 files changed, 42 insertions(+), 20 deletions(-)
diff --git a/libavutil/frame.
On 3/1/2018 1:48 PM, Rostislav Pehlivanov wrote:
> Signed-off-by: Rostislav Pehlivanov
> ---
>
> Changed so that the function will not create a new reference.
>
> libavutil/frame.c | 45 +
> libavutil/frame.h | 17 +
> 2 files changed,
On Thu, Mar 01, 2018 at 09:07:17 +0100, Jerome Borsboom wrote:
> v1.1->v1.2: Changed ifdefs around vc1_get_INTCOMPFIELD, vc1_get_LUMSCALE2,
> and vc1_get_LUMSHIFT2 to av_unused.
When emailing like this, you need to place the additional (manually
edited?) comments below the patch's '---' line. Othe
Signed-off-by: Rostislav Pehlivanov
---
Yeah, that sounds better, thanks.
libavutil/frame.c | 45 +
libavutil/frame.h | 16
2 files changed, 41 insertions(+), 20 deletions(-)
diff --git a/libavutil/frame.c b/libavutil/frame.c
index 6
bump, this is a minor patch
> Hadn't seen that one, it does indeed describe this exact problem.
> I've included it in the commit message, new patch attached.
>
> On 20.02.2018 at 22:30 Carl Eugen Hoyos wrote:
>> 2018-02-20 19:40 GMT+01:00 Stefan _ :
>>
>>> attached patch fixes a small issue with th
On 3/1/2018 2:09 PM, Rostislav Pehlivanov wrote:
> Signed-off-by: Rostislav Pehlivanov
> ---
>
> Yeah, that sounds better, thanks.
>
> libavutil/frame.c | 45 +
> libavutil/frame.h | 16
> 2 files changed, 41 insertions(+), 20 deletio
Also fixes a theoretical memory leak in av_frame_new_side_data_from_buf
where if ret was successfully allocated but the realloc call failed,
ret wouldn't be freed.
Signed-off-by: Rostislav Pehlivanov
---
libavutil/frame.c | 42 +-
libavutil/frame.h | 16 ++
On 2/27/18, Maxton wrote:
> On 2018-02-27 4:10, Carl Eugen Hoyos wrote:
>> 2018-02-27 9:26 GMT+01:00 Maxton :
>>> I looked at the code in avcodec/wmaprodec.c and noticed that
>>> the maximum number of channels was set to 8, but I think this
>>> is a mistake as the number of channels should logical
On 3/1/2018 3:58 PM, Rostislav Pehlivanov wrote:
> Also fixes a theoretical memory leak in av_frame_new_side_data_from_buf
> where if ret was successfully allocated but the realloc call failed,
> ret wouldn't be freed.
Currently, if realloc fails, ret is never allocated to begin with.
There's no
supported suffixes are:
- s: seconds (default when no suffix specified)
- m or ms: milliseconds
- u or us: microseconds
---
libavutil/parseutils.c | 15 +--
1 file changed, 13 insertions(+), 2 deletions(-)
diff --git a/libavutil/parseutils.c b/libavutil/parseutils.c
index 7ca07b37a1..
On Thu, Mar 01, 2018 at 01:27:06AM +, Rostislav Pehlivanov wrote:
> On 28 February 2018 at 23:34, Aurelien Jacobs wrote:
>
> > On Wed, Feb 28, 2018 at 12:59:40AM +, Rostislav Pehlivanov wrote:
> > > On 27 February 2018 at 23:56, Aurelien Jacobs wrote:
> > >
> > > >
> > > > So I've update
On 1 March 2018 at 19:19, James Almer wrote:
> On 3/1/2018 3:58 PM, Rostislav Pehlivanov wrote:
> > Also fixes a theoretical memory leak in av_frame_new_side_data_from_buf
> > where if ret was successfully allocated but the realloc call failed,
> > ret wouldn't be freed.
>
> Currently, if realloc
On 18/02/28 11:33 PM, Carl Eugen Hoyos wrote:
If you send this as a patch made with "git format-patch" to this
mailing list, it may be easier to test and answer your questions.
Good to know about that. I'll keep that in mind and use when/if all else fails.
For some use-cases, setting time-st
On Wed, Feb 28, 2018 at 09:47:15AM +0100, Tobias Rapp wrote:
> On 27.02.2018 19:03, Michael Niedermayer wrote:
> >On Tue, Feb 27, 2018 at 08:49:19AM +0100, Tobias Rapp wrote:
> >>On 27.02.2018 01:12, Michael Niedermayer wrote:
> >>>On Mon, Feb 26, 2018 at 05:09:04PM +0100, Tobias Rapp wrote:
>
On Tue, Feb 27, 2018 at 01:11:56PM -0800, Xiaohan Wang (王消寒) wrote:
> Sure. Updated!
>
> On Tue, Feb 27, 2018 at 2:38 AM, Michael Niedermayer > wrote:
>
> > On Mon, Feb 26, 2018 at 10:37:51AM -0800, Xiaohan Wang (王消寒) wrote:
> > > Thanks! Updated the patch. Please take a look again.
> > >
> > >
On Tue, 27 Feb 2018, Marton Balint wrote:
On Thu, 22 Feb 2018, Paul B Mahol wrote:
On 2/22/18, Tomas Haerdin wrote:
ons 2018-02-21 klockan 23:06 +0100 skrev Marton Balint:
On Wed, 21 Feb 2018, Tomas Haerdin wrote:
> loer 2018-02-17 klockan 22:45 +0100 skrev Marton Balint:
> > The referen
Signed-off-by: Marton Balint
---
libavformat/mxfdec.c | 22 ++
1 file changed, 14 insertions(+), 8 deletions(-)
diff --git a/libavformat/mxfdec.c b/libavformat/mxfdec.c
index d4291f5dc7..70091e0dc9 100644
--- a/libavformat/mxfdec.c
+++ b/libavformat/mxfdec.c
@@ -1347,24 +1347
Consider edit rate when determining edit_units_per_packet and also make sure
that checks are done in edit rate time base and not in stream time base.
Fixes some errors reported with the sample in ticket #5863.
Signed-off-by: Marton Balint
---
libavformat/mxfdec.c | 15 ++-
1 file ch
On 01/03/18 08:07, Jerome Borsboom wrote:
> v1.1->v1.2: Changed ifdefs around vc1_get_INTCOMPFIELD, vc1_get_LUMSCALE2,
> and vc1_get_LUMSHIFT2 to av_unused.
>
> avcodec/vaapi: add fields for VAAPI VC-1 interlaced decoding
>
> Pass necessary bitstream elements to the VAAPI VC-1 decoder in order
>
On 1 March 2018 at 20:45, Aurelien Jacobs wrote
>
> So what I propose is to rename sbc_delay to sbc_latency (for example),
> and to add a opus_latecy using AV_OPT_TYPE_DURATION that will deprecate
> opus_delay. I think that's the best way forward if you care about
> consistency.
>
Yeah, that's g
On 2018/2/28 20:37, Steven Liu wrote:
>
>> On 28 Feb 2018, at 08:26, Jun Zhao wrote:
>>
>> ping
>>
>> On 2018/2/23 15:12, Jun Zhao wrote:
>>
> Signed-off-by: Jun Zhao
> ---
> doc/bitstream_filters.texi | 9 +
> 1 file changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/doc/bitstr
From 0a0a10824511ef9d5b3c49ee652a918603841826 Mon Sep 17 00:00:00 2001
From: Jun Zhao
Date: Fri, 23 Feb 2018 13:53:05 +0800
Subject: [PATCH V2] doc/bitstream_filters: correct dump_extra bsfs docs.
Update dump_extra bit stream filter docs to follow current
code implement.
Signed-off-by: Jun Zhao
On Thu, Mar 01, 2018 at 04:58:22PM +0100, wm4 wrote:
> This adds a way for an API user to transfer QP data and metadata without
> having to keep the reference to AVFrame, and without having to
> explicitly care about QP APIs. It might also provide a way to finally
> remove the deprecated QP related
On 2018/3/2 6:43, Mark Thompson wrote:
> On 01/03/18 08:07, Jerome Borsboom wrote:
>> v1.1->v1.2: Changed ifdefs around vc1_get_INTCOMPFIELD, vc1_get_LUMSCALE2,
>> and vc1_get_LUMSHIFT2 to av_unused.
>>
>> avcodec/vaapi: add fields for VAAPI VC-1 interlaced decoding
>>
>> Pass necessary bitstream
> On 28 Feb 2018, at 12:50, Jeyapal, Karthick wrote:
>
>
>
> On 2/28/18 10:18 AM, Steven Liu wrote:
>> fix ticket: #7044
>> Get the first video stream to reference for split segment
>> when there have more than one video stream
>>
>> Signed-off-by: Steven Liu
>> ---
>> libavformat/hlsenc.c
Currently always shows "Selected ratecontrol mode is not supported by
the QSV runtime. Choose a different mode", but sometimes it is not
accurate.
Signed-off-by: Zhong Li
---
libavcodec/qsvenc.c | 31 +--
1 file changed, 25 insertions(+), 6 deletions(-)
diff --git a/
nvenc doesn't support P016, but we have two problems today:
1) We declare support for YUV444P16 which nvenc also doesn't support.
We do this because it's the only pix_fmt we have that can
approximate nvenc's internal format that is YUV444P10 with data in
MSBs instead of LSBs. Because the
nvdec: Declare that nvdec can (potentially) handle 12bit hevc
nvenc: Claim support for p016 as an input format. It will be truncated,
but it would be truncated by swscale anyway, as we don't do any dithering
for 10bit outputs. This allows for full transcoding of 12bit content to
10bit output, and
To make the best use of existing code, I generalised the wrapper
that currently does yuv420p10 to p010 to support any mixture of
input and output sizes between 10 and 16 bits. This had the side
effect of yielding a working code path for all yuv420p1x formats
to p01x.
Signed-off-by: Philip Langdale
Signed-off-by: Philip Langdale
---
libavcodec/hevcdec.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/libavcodec/hevcdec.c b/libavcodec/hevcdec.c
index fc4eb781dc..c8877626d2 100644
--- a/libavcodec/hevcdec.c
+++ b/libavcodec/hevcdec.c
@@ -404,6 +404,11 @@ static enum AVPixelFormat get
From: Vishwanath Dixit
---
libavformat/dashenc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index 83e0cff..489e458 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -1308,7 +1308,7 @@ static int dash_write_pac
From: Ravindra Patagar
Signed-off-by: Ravindra
---
doc/muxers.texi | 3 +++
libavformat/hlsenc.c | 5 -
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/doc/muxers.texi b/doc/muxers.texi
index c156ec0..e41f8c6 100644
--- a/doc/muxers.texi
+++ b/doc/muxers.texi
@@ -964,6 +9
From: Ravindra Patagar
Signed-off-by: Ravindra
---
doc/muxers.texi | 2 ++
libavformat/dashenc.c | 4
2 files changed, 6 insertions(+)
diff --git a/doc/muxers.texi b/doc/muxers.texi
index e41f8c6..c456a42 100644
--- a/doc/muxers.texi
+++ b/doc/muxers.texi
@@ -264,6 +264,8 @@ of the
> On 2 Mar 2018, at 14:56, rpata...@akamai.com wrote:
>
> From: Ravindra Patagar
>
> Signed-off-by: Ravindra
> ---
> doc/muxers.texi | 3 +++
> libavformat/hlsenc.c | 5 -
> 2 files changed, 7 insertions(+), 1 deletion(-)
>
> diff --git a/doc/muxers.texi b/doc/muxers.texi
> index c156
47 matches
Mail list logo