On Mon, Nov 03, 2014 at 06:45:41AM -0800, Kevin Mitchell wrote:
> I got rid of the macros, and changed the precision to 2**20 (the
> inconsistency in the final statistics was due to overflow because
> PRECISION was too high). Now it should be small enough that it would
> take 78hrs of 60fps to over
I got rid of the macros, and changed the precision to 2**20 (the
inconsistency in the final statistics was due to overflow because
PRECISION was too high). Now it should be small enough that it would
take 78hrs of 60fps to overflow. It also now separately keeps track of
the absolute total and log t
On Sun, Nov 02, 2014 at 09:38:17PM -0800, Kevin Mitchell wrote:
> Ok, I fixed the logic by removing round() and added an integer power
> function to replace pow()
> doc/filters.texi |5 ++
> libavfilter/version.h |2 -
> libavfilter/vf_idet.c | 93
> +++
Ok, I fixed the logic by removing round() and added an integer power
function to replace pow()
From f66e072d477964ebcfe38eafe40d12030a91df14 Mon Sep 17 00:00:00 2001
From: Kevin Mitchell
Date: Sun, 2 Nov 2014 21:30:51 -0800
Subject: [PATCH 1/2] avfilter/vf_idet: add a "half_life" option for statis
On Sun, Nov 02, 2014 at 06:20:06PM -0800, Kevin Mitchell wrote:
> I made the decay multiplication fixed point. I moved all the fixed
> point logic to macros which hopefully makes it easier to read.
>
> I also removed the total_frames count since it is now likely to become
> inconsistent with the a
I made the decay multiplication fixed point. I moved all the fixed
point logic to macros which hopefully makes it easier to read.
I also removed the total_frames count since it is now likely to become
inconsistent with the actual classification totals anyway.
I've gone back to just outputting rou
On Sun, Nov 02, 2014 at 05:03:44AM -0800, Kevin Mitchell wrote:
> Removed the unrelated documentation changes, used uint64_t instead of float.
> doc/filters.texi |8 +
> libavfilter/version.h |2 -
> libavfilter/vf_idet.c | 79
> ++--
Removed the unrelated documentation changes, used uint64_t instead of float.
From 0fc44ce601266e94fb8c6137091f3eb91616a235 Mon Sep 17 00:00:00 2001
From: Kevin Mitchell
Date: Sun, 2 Nov 2014 04:37:13 -0800
Subject: [PATCH 1/2] avfilter/vf_idet: add a "half_life" option for statistics
This can be
On Sat, Nov 01, 2014 at 05:59:20PM -0700, Kevin Mitchell wrote:
> Ok, changed to half life.
>
> On Sat, Nov 1, 2014 at 10:52 AM, Michael Niedermayer wrote:
> > On Sat, Nov 01, 2014 at 07:08:53AM -0700, Kevin Mitchell wrote:
> >>
> >
> >> doc/filters.texi |7 +++
> >> libavfilter/ver
Ok, changed to half life.
On Sat, Nov 1, 2014 at 10:52 AM, Michael Niedermayer wrote:
> On Sat, Nov 01, 2014 at 07:08:53AM -0700, Kevin Mitchell wrote:
>>
>
>> doc/filters.texi |7 +++
>> libavfilter/version.h |2 +-
>> libavfilter/vf_idet.c | 45 ++
On Sat, Nov 01, 2014 at 07:08:53AM -0700, Kevin Mitchell wrote:
>
> doc/filters.texi |7 +++
> libavfilter/version.h |2 +-
> libavfilter/vf_idet.c | 45 +
> libavfilter/vf_idet.h |2 ++
> 4 files changed, 43 insertions(+), 13 de
From 2ac0c4b6bab752c92ffa615c028cd4582441f680 Mon Sep 17 00:00:00 2001
From: Kevin Mitchell
Date: Sat, 1 Nov 2014 05:38:35 -0700
Subject: [PATCH 2/3] avfilter/vf_idet: add a "reset_count" option like
cropdetect
This can be useful for videos in which the interlacing pattern changes.
Also log th
12 matches
Mail list logo