Re: [FFmpeg-devel] [PATCH] lavfi: get rid of FF_INTERNAL_FIELDS

2023-02-04 Thread Uoti Urpala
On Fri, 2023-02-03 at 15:45 +0100, Nicolas George wrote: > Andreas Rheinhardt (12023-02-01): > > "One special guarantee is made in order to simplify the use of unions: > > if a union contains several structures that share a common initial > > sequence (see below), and if the union object currently

Re: [FFmpeg-devel] [PATCH] avutil: Rename RSHIFT macro to ROUNDED_RSHIFT

2019-01-27 Thread Uoti Urpala
On Mon, 2019-01-28 at 00:04 +0100, Henrik Gramner wrote: > On Mon, Jan 21, 2019 at 9:54 PM James Almer wrote: > > There's also no good way to deprecate a define and replace it with > > another while informing the library user, so for something purely > > cosmetic like this i don't think it's worth

Re: [FFmpeg-devel] Rename RSHIFT macro to ROUNDED_RSHIFT

2019-01-22 Thread Uoti Urpala
On Tue, 2019-01-22 at 15:35 -0300, James Almer wrote: > I'm not against renaming it to AV_ROUNDED_RSHIFT or similar, but other > than an entry in APIChanges we have no way to let library users that > RSHIFT will be removed two or so years from now. How about: static inline void __attribute__ ((de

Re: [FFmpeg-devel] [PATCH 1/2] avcodec/htmlsubtitles: Protect very slow redundant sscanf() calls by optimized use of strchr()

2017-06-10 Thread Uoti Urpala
On Sat, 2017-06-10 at 16:18 +0200, Michael Niedermayer wrote: > So we are guranteed that anyone who wants to exploit this has the > ability to do so as long as they can use the search mask and are able > to remux the data into whatever format they need. > And i belive this publication of issues is

Re: [FFmpeg-devel] [PATCH] pthread_frame: don't return stale error codes after flush

2017-04-06 Thread Uoti Urpala
On Thu, 2017-04-06 at 18:18 +0200, wm4 wrote: > > >  p->got_frame = 0; > > >  av_frame_unref(p->frame); > > > +p->result = 0; Shouldn't p->result be similarly reset together with p->got_frame also in ff_thread_decode_frame()? A similar problem seems possible: - a normal dec