On Fri, Jan 26, 2024 at 9:45 PM Martin Storsjö wrote:
> On Fri, 26 Jan 2024, Martin Storsjö wrote:
>
> > These inline implementations of AV_COPY64, AV_SWAP64 and AV_ZERO64
> > are known to clobber the FPU state - which has to be restored
> > with the 'emms' instruction afterwards.
> >
> > This wa
On Sat, Jan 27, 2024 at 12:21 AM wrote:
> From: Frank Plowman
>
> nal->skipped_bytes_pos contains the positions of errors relative to the
> start of the slice header, whereas the position they were tested against
> is relative to the start of the slice data, i.e. one byte after the end
> of the
This patch adds support for the DRI marker in the JPEG RTP encoder.
Apologies for the bad line breaks in the previous patch. The production line
for this patch is 100% Linux.
Signed-off-by: Sebastien Cote
---
libavformat/rtpenc_jpeg.c | 28
1 file changed, 28 insert
From: Thomas Siedel
Add transport stream stream type 0x33 for vvc.
Add STREAM_TYPE_VIDEO_VVC to MPEG-1/2 and MPEG-2 transport stream.
Add basic transport stream support for TS mux/demux.
Tested with:
ffmpeg -i NovosobornayaSquare_1920x1080.mp4 -c:v libvvenc test.ts && ffmpeg -i
test.ts -f null
---
libavformat/mpegtsenc.c | 45 +
1 file changed, 28 insertions(+), 17 deletions(-)
diff --git a/libavformat/mpegtsenc.c b/libavformat/mpegtsenc.c
index 0843516ee6..ff1c4de640 100644
--- a/libavformat/mpegtsenc.c
+++ b/libavformat/mpegtsenc.c
@@ -1834,6 +
---
libavformat/mpegtsenc.c | 32 +++-
1 file changed, 19 insertions(+), 13 deletions(-)
diff --git a/libavformat/mpegtsenc.c b/libavformat/mpegtsenc.c
index 01b8c8d87a..0843516ee6 100644
--- a/libavformat/mpegtsenc.c
+++ b/libavformat/mpegtsenc.c
@@ -31,6 +31,7 @@
#i
---
libavformat/mpegtsenc.c | 26 --
1 file changed, 8 insertions(+), 18 deletions(-)
diff --git a/libavformat/mpegtsenc.c b/libavformat/mpegtsenc.c
index 418fa08ad5..01b8c8d87a 100644
--- a/libavformat/mpegtsenc.c
+++ b/libavformat/mpegtsenc.c
@@ -1759,16 +1759,16 @@ stat
---
libavformat/mpegtsenc.c | 33 ++---
1 file changed, 18 insertions(+), 15 deletions(-)
diff --git a/libavformat/mpegtsenc.c b/libavformat/mpegtsenc.c
index 84edd418f0..418fa08ad5 100644
--- a/libavformat/mpegtsenc.c
+++ b/libavformat/mpegtsenc.c
@@ -2257,23 +2257,26
From: Thomas Siedel
Add muxer for vvcc byte stream format.
Add AV_CODEC_ID_VVC to ff_mp4_obj_type.
Add AV_CODEC_ID_VVC to ISO Media codec (VvcConfigurationBox vvi1,
vvc1 defined in ISO/IEC 14496-15:2021).
Add VvcConfigurationBox vvcC which extends FullBox type in
ISO/IEC 14496-15:2021.
Tested wi
Major changes for mpegtsenc since v2:
Remove VVC from get_m2ts_stream_type (Marton)
Refact check_h26x_startcode to remove duplicate code (Marton)
Refact mpegts_check_bitstream to remove duplicate code (Marton)
Refact out h26x_prefix_aud
Remove h264, hevc magic numbers to improve readability
Nuo Mi
From: James Almer
"When aps_params_type is equal to ALF_APS or SCALING_APS, the value of
aps_adaptation_parameter_set_id shall be
in the range of 0 to 7, inclusive.
When aps_params_type is equal to LMCS_APS, the value of
aps_adaptation_parameter_set_id shall be in the range of 0
to 3, inclusive
On Fri, Jan 26, 2024 at 11:12:53AM -0700, Sebastien Cote wrote:
> This patch adds support for the DRI marker in the JPEG RTP payloader.
>
> ---
> libavformat/rtpenc_jpeg.c | 28
> 1 file changed, 28 insertions(+)
>
> diff --git a/libavformat/rtpenc_jpeg.c b/libavform
On 1/26/2024 6:46 PM, Michael Niedermayer wrote:
"When aps_params_type is equal to ALF_APS or SCALING_APS, the value of
aps_adaptation_parameter_set_id shall be
in the range of 0 to 7, inclusive.
When aps_params_type is equal to LMCS_APS, the value of
aps_adaptation_parameter_set_id shall be in
Such frames will crash when pthread functions are called on the NULL pointer
Fixes: member access within null pointer of type 'VVCFrameThread' (aka 'struct
VVCFrameThread')
Fixes:
65160/clusterfuzz-testcase-minimized-ffmpeg_BSF_VVC_METADATA_fuzzer-4665241535119360
(partly)
Fixes:
65636/cluster
"When aps_params_type is equal to ALF_APS or SCALING_APS, the value of
aps_adaptation_parameter_set_id shall be
in the range of 0 to 7, inclusive.
When aps_params_type is equal to LMCS_APS, the value of
aps_adaptation_parameter_set_id shall be in the range of 0
to 3, inclusive."
Fixes: out of ar
It is not possible to encode a index into an empty list. Thus
this must be invalid at this point or before.
Its likely a broader earlier check can be used here, someone knowing
VVC should look at that. Its not immedeatly obvious from the spec
by looking for numlayerolss
Fixes: out of array access
I tested against
https://patchwork.ffmpeg.org/project/ffmpeg/list/?series=10566, seems happy.
On Fri, Jan 26, 2024 at 10:58 AM Andreas Rheinhardt <
andreas.rheinha...@outlook.com> wrote:
> Andreas Rheinhardt:
> > Signed-off-by: Andreas Rheinhardt
> > ---
> > libavcodec/dxvenc.c | 8
> >
Andreas Rheinhardt:
> Signed-off-by: Andreas Rheinhardt
> ---
> libavcodec/dxvenc.c | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/libavcodec/dxvenc.c b/libavcodec/dxvenc.c
> index 3a5b310c9b..10473038cc 100644
> --- a/libavcodec/dxvenc.c
> +++ b/libavcodec/dxve
On 1/26/2024 6:13 AM, p...@frankplowman.com wrote:
From: Frank Plowman
Resolves the following undefined behavior sanitiser error:
runtime error: shift exponent 32 is too large for 32-bit type 'int'
Signed-off-by: Frank Plowman
---
libavcodec/vvc/vvc_intra_template.c | 2 +-
1 file changed,
On 1/26/2024 1:43 AM, Nuo Mi wrote:
LGTM
Applied.
On Fri, Jan 26, 2024 at 1:05 AM wrote:
From: Frank Plowman
Signed-off-by: Frank Plowman
---
libavcodec/vvc/vvc_ctu.c | 4 ++--
libavcodec/vvc/vvc_ps.c | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/libavcodec
On Fri, Jan 26, 2024 at 07:18:46PM +0100, Michael Niedermayer wrote:
> On Thu, Jan 25, 2024 at 10:43:47AM -0300, James Almer wrote:
> > Signed-off-by: James Almer
> > ---
> > doc/APIchanges| 2 +-
> > libavcodec/version.h | 2 +-
> > libavcodec/version_major.h| 2 +-
>
On 1/26/2024 3:18 PM, Michael Niedermayer wrote:
On Thu, Jan 25, 2024 at 10:43:47AM -0300, James Almer wrote:
Signed-off-by: James Almer
---
doc/APIchanges| 2 +-
libavcodec/version.h | 2 +-
libavcodec/version_major.h| 2 +-
libavdevice/version.h | 2 +
On Thu, Jan 25, 2024 at 10:43:47AM -0300, James Almer wrote:
> Signed-off-by: James Almer
> ---
> doc/APIchanges| 2 +-
> libavcodec/version.h | 2 +-
> libavcodec/version_major.h| 2 +-
> libavdevice/version.h | 2 +-
> libavdevice/version_major.h | 2 +-
>
This patch adds support for the DRI marker in the JPEG RTP payloader.
---
libavformat/rtpenc_jpeg.c | 28
1 file changed, 28 insertions(+)
diff --git a/libavformat/rtpenc_jpeg.c b/libavformat/rtpenc_jpeg.c
index e4e95931f4..60f56680e2 100644
--- a/libavformat/rtpenc_
On Fri, Jan 26, 2024 at 10:02 AM Cédric Le Barz wrote:
>
> Set aspect ratio for jpeg2000 images.
"The image area on the reference grid is defined by its upper left
hand reference grid point at location (XOsiz, YOsiz), and its lower
right hand reference grid point at location (Xsiz – 1, Ysiz – 1)"
Add "footer_with_hmd" option: this option activates the writing of the
header metadata in the footer partition.
--- Begin Message ---
Signed-off-by: Cedric Le Barz
---
ffmpeg/libavformat/mxfenc.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/ffmpeg/libavformat/mxfenc
Set aspect ratio for jpeg2000 images.
--- Begin Message ---
Signed-off-by: Cedric Le Barz
---
ffmpeg/libavformat/mxfenc.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/ffmpeg/libavformat/mxfenc.c b/ffmpeg/libavformat/mxfenc.c
index 0f13068..7ea19ca 100644
--- a/ffmpeg/l
Use same heuristic as in fftools.
Signed-off-by: Nicolas Gaullier
---
libavformat/concatdec.c | 17 +++-
tests/ref/fate/concat-demuxer-simple2-lavf-ts | 40 ++-
2 files changed, 54 insertions(+), 3 deletions(-)
diff --git a/libavformat/concatdec.c b/lib
I have a bunch of patches about probing and making better concatdec, this is
the first one.
Unfortunately, this is mostly about heuristics and find_stream_info things no
one like very much.
This first patch seems very straightforward: there is already an heuristic in
fftools for seeking,
and th
On Fri, 26 Jan 2024, James Almer wrote:
On 1/26/2024 1:52 PM, Martin Storsjö wrote:
On Fri, 26 Jan 2024, James Almer wrote:
On 1/26/2024 1:44 PM, Vittorio Giovara wrote:
On Thu, Jan 25, 2024 at 2:48 PM James Almer wrote:
Signed-off-by: James Almer
---
doc/APIchanges | 2
On 1/26/2024 1:52 PM, Martin Storsjö wrote:
On Fri, 26 Jan 2024, James Almer wrote:
On 1/26/2024 1:44 PM, Vittorio Giovara wrote:
On Thu, Jan 25, 2024 at 2:48 PM James Almer wrote:
Signed-off-by: James Almer
---
doc/APIchanges | 2 +-
libavcodec/version.h | 2 +-
On Fri, 26 Jan 2024, James Almer wrote:
On 1/26/2024 1:44 PM, Vittorio Giovara wrote:
On Thu, Jan 25, 2024 at 2:48 PM James Almer wrote:
Signed-off-by: James Almer
---
doc/APIchanges| 2 +-
libavcodec/version.h | 2 +-
libavcodec/version_major.h| 2 +-
liba
On 1/26/2024 1:44 PM, Vittorio Giovara wrote:
On Thu, Jan 25, 2024 at 2:48 PM James Almer wrote:
Signed-off-by: James Almer
---
doc/APIchanges| 2 +-
libavcodec/version.h | 2 +-
libavcodec/version_major.h| 2 +-
libavdevice/version.h | 2 +-
libavde
On Thu, Jan 25, 2024 at 2:48 PM James Almer wrote:
> Signed-off-by: James Almer
> ---
> doc/APIchanges| 2 +-
> libavcodec/version.h | 2 +-
> libavcodec/version_major.h| 2 +-
> libavdevice/version.h | 2 +-
> libavdevice/version_major.h | 2 +-
> libavfi
Quoting James Almer (2024-01-26 17:22:06)
> On 1/26/2024 1:17 PM, Anton Khirnov wrote:
> > Quoting James Almer (2024-01-26 17:09:32)
> >> On 1/26/2024 9:17 AM, Anton Khirnov wrote:
> >>> Quoting Lynne (2024-01-26 13:11:33)
> Jan 26, 2024, 11:40 by an...@khirnov.net:
>
> > ---
> >
Quoting Andreas Rheinhardt (2024-01-26 13:35:56)
>
> This is inconsistent with the behaviour for arch-specific subfolders.
Does it need to be consistent? Bitstream filters typically share more
headers with decoders and parsers than arch-specific code.
> It also interferes with the files not in t
On 1/26/2024 1:17 PM, Anton Khirnov wrote:
Quoting James Almer (2024-01-26 17:09:32)
On 1/26/2024 9:17 AM, Anton Khirnov wrote:
Quoting Lynne (2024-01-26 13:11:33)
Jan 26, 2024, 11:40 by an...@khirnov.net:
---
libavcodec/Makefile | 49 +---
libavcod
From: Frank Plowman
nal->skipped_bytes_pos contains the positions of errors relative to the
start of the slice header, whereas the position they were tested against
is relative to the start of the slice data, i.e. one byte after the end
of the slice header.
Patch fixes this by storing the size o
Quoting James Almer (2024-01-26 17:09:32)
> On 1/26/2024 9:17 AM, Anton Khirnov wrote:
> > Quoting Lynne (2024-01-26 13:11:33)
> >> Jan 26, 2024, 11:40 by an...@khirnov.net:
> >>
> >>> ---
> >>> libavcodec/Makefile | 49 +---
> >>> libavcodec/bsf/Makefile
On 1/26/2024 9:17 AM, Anton Khirnov wrote:
Quoting Lynne (2024-01-26 13:11:33)
Jan 26, 2024, 11:40 by an...@khirnov.net:
---
libavcodec/Makefile | 49 +---
libavcodec/bsf/Makefile | 56 +++
Is that the general dir
On Fri, Jan 26, 2024 at 11:18 PM Thomas Siedel
wrote:
> On Fri, 5 Jan 2024 at 01:21, Nuo Mi wrote:
>
> > On Fri, Nov 3, 2023 at 5:58 PM Thomas Siedel >
> > wrote:
> >
> > > Add muxer for vvcc byte stream format.
> > > Add AV_CODEC_ID_VVC to ff_mp4_obj_type.
> > > Add AV_CODEC_ID_VVC to ISO Medi
On Fri, Jan 26, 2024 at 10:04 PM Thomas Siedel
wrote:
> Thanks for picking up the patch set!
>
> On Thu, 25 Jan 2024 at 13:26, Nuo Mi wrote:
>
>> From: Thomas Siedel
>>
>> Add muxer for vvcc byte stream format.
>> Add AV_CODEC_ID_VVC to ff_mp4_obj_type.
>> Add AV_CODEC_ID_VVC to ISO Media codec
On Fri, 5 Jan 2024 at 01:21, Nuo Mi wrote:
> On Fri, Nov 3, 2023 at 5:58 PM Thomas Siedel
> wrote:
>
> > Add muxer for vvcc byte stream format.
> > Add AV_CODEC_ID_VVC to ff_mp4_obj_type.
> > Add AV_CODEC_ID_VVC to ISO Media codec (VvcConfigurationBox vvi1,
> > vvc1 defined in ISO/IEC 14496-15:2
On Fri, 5 Jan 2024 at 01:31, James Almer wrote:
> On 11/3/2023 6:57 AM, Thomas Siedel wrote:
> > Add muxer for vvcc byte stream format.
> > Add AV_CODEC_ID_VVC to ff_mp4_obj_type.
> > Add AV_CODEC_ID_VVC to ISO Media codec (VvcConfigurationBox vvi1,
> > vvc1 defined in ISO/IEC 14496-15:2021).
> >
The video param change check will print loglines below debug level
for each frame which is different from the inlink parameters. This
can spam the console. It is now printed at warning level once for
each param change else it is kept at debug level.
Partially addresses #10823
---
libavfilter/buff
Thanks for picking up the patch set!
On Thu, 25 Jan 2024 at 13:26, Nuo Mi wrote:
> From: Thomas Siedel
>
> Add muxer for vvcc byte stream format.
> Add AV_CODEC_ID_VVC to ff_mp4_obj_type.
> Add AV_CODEC_ID_VVC to ISO Media codec (VvcConfigurationBox vvi1,
> vvc1 defined in ISO/IEC 14496-15:2021
On Fri, 26 Jan 2024, Martin Storsjö wrote:
These inline implementations of AV_COPY64, AV_SWAP64 and AV_ZERO64
are known to clobber the FPU state - which has to be restored
with the 'emms' instruction afterwards.
This was known and signaled with the FF_COPY_SWAP_ZERO_USES_MMX
define, which calli
These inline implementations of AV_COPY64, AV_SWAP64 and AV_ZERO64
are known to clobber the FPU state - which has to be restored
with the 'emms' instruction afterwards.
This was known and signaled with the FF_COPY_SWAP_ZERO_USES_MMX
define, which calling code seems to have been supposed to check,
Anton Khirnov:
> ---
> libavcodec/Makefile | 49 +---
> libavcodec/bsf/Makefile | 56 +++
> .../aac_adtstoasc.c} | 0
> .../av1_frame_merge.c}| 0
> .../av1_frame_split.c}
Quoting Lynne (2024-01-26 13:11:33)
> Jan 26, 2024, 11:40 by an...@khirnov.net:
>
> > ---
> > libavcodec/Makefile | 49 +---
> > libavcodec/bsf/Makefile | 56 +++
> >
>
> Is that the general direction we want to take?
> I
> On Jan 26, 2024, at 20:11, Lynne wrote:
>
> Jan 26, 2024, 11:40 by an...@khirnov.net:
>
>> ---
>> libavcodec/Makefile | 49 +---
>> libavcodec/bsf/Makefile | 56 +++
>>
>
> Is that the general direction we want to t
Jan 26, 2024, 11:40 by an...@khirnov.net:
> ---
> libavcodec/Makefile | 49 +---
> libavcodec/bsf/Makefile | 56 +++
>
Is that the general direction we want to take?
I don't mind it, but I'm wondering if I should do this
---
libavcodec/Makefile | 49 +---
libavcodec/bsf/Makefile | 56 +++
.../aac_adtstoasc.c} | 0
.../av1_frame_merge.c}| 0
.../av1_frame_split.c}|
> On Jan 26, 2024, at 17:36, Anton Khirnov wrote:
>
> Quoting Niklas Haas (2024-01-10 10:05:46)
>> From: Niklas Haas
>>
>> Fixes error spam from the `ffplay` tool since commit 2d555dc82d, caused
>> by an oversight on my part - I didn't notice during development that
>> `ffplay` goes through
Quoting Niklas Haas (2024-01-10 10:05:46)
> From: Niklas Haas
>
> Fixes error spam from the `ffplay` tool since commit 2d555dc82d, caused
> by an oversight on my part - I didn't notice during development that
> `ffplay` goes through its own filtering code path separate from
> fftools/ffmpeg_filte
From: Frank Plowman
Resolves the following undefined behavior sanitiser error:
runtime error: shift exponent 32 is too large for 32-bit type 'int'
Signed-off-by: Frank Plowman
---
libavcodec/vvc/vvc_intra_template.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec
56 matches
Mail list logo