This commit applies clang-format to the source and fixes typos.
TETS: ffmpeg -i fate-suite/vp8-test-vectors-r1/* -vcodec copy -bsf:v
trace_headers -f null -
Signed-off-by: Jianhui Dai
---
libavcodec/cbs_vp8.c | 54 ++--
1 file changed, 37 insertions(+), 1
On Ma, 2023-12-18 at 14:36 +0800, wenbin.chen-at-intel@ffmpeg.org wrote:
> From: Wenbin Chen
>
> Signed-off-by: Wenbin Chen
> ---
> libavfilter/vf_dnn_detect.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/libavfilter/vf_dnn_detect.c b/libavfilter/vf_dnn_detect.c
On Ma, 2023-12-18 at 14:36 +0800, wenbin.chen-at-intel@ffmpeg.org wrote:
> From: Wenbin Chen
>
> Signed-off-by: Wenbin Chen
> ---
> libavfilter/vf_dnn_detect.c | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/libavfilter/vf_dnn_detect.c b/libavfilter/vf_dnn_detect.c
> index fcc64
On Do, 2023-12-07 at 17:59 +0100, Anton Khirnov wrote:
> Quoting Timo Rothenpieler (2023-12-06 13:26:51)
> > On 06/12/2023 07:51, Xiang, Haihao wrote:
> > > On Di, 2023-12-05 at 12:47 +0100, Timo Rothenpieler wrote:
> > > > On 05.12.2023 09:15, Xiang, Haihao wrote:
> > > > > From: Haihao Xiang
> >
On Vr, 2023-12-15 at 07:19 +, hung kuishing wrote:
> > From: ffmpeg-devel On Behalf Of Xiang,
> > Haihao
> > Sent: Thursday, December 7, 2023 3:37 PM
> > To: ffmpeg-devel@ffmpeg.org
> > Subject: Re: [FFmpeg-devel] [PATCH] doc/examples/qsv_transcode: EINVAL is
> > more appropriate and ENAVAIL w
From: Wenbin Chen
Signed-off-by: Wenbin Chen
---
libavfilter/vf_dnn_detect.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavfilter/vf_dnn_detect.c b/libavfilter/vf_dnn_detect.c
index 52d5c3d798..88865c8a8e 100644
--- a/libavfilter/vf_dnn_detect.c
+++ b/libavfilter/vf_d
From: Wenbin Chen
Signed-off-by: Wenbin Chen
---
libavfilter/vf_dnn_detect.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/libavfilter/vf_dnn_detect.c b/libavfilter/vf_dnn_detect.c
index fcc64118b6..52d5c3d798 100644
--- a/libavfilter/vf_dnn_detect.c
+++ b/libavfilter/vf_dnn_detect.c
@@
On Di, 2023-12-05 at 14:46 +0800, Tong Wu wrote:
> From: Wu Jianhua
>
> Signed-off-by: Wu Jianhua
> Signed-off-by: Tong Wu
> ---
>
> Compared to v11, v12 set the initial value to 0 for the fence value,
> fixing a potential dynamic pool sync issue. Hence removed the non zero
> initial_pool_size
On 2023-12-16 03:44 pm, Gyan Doshi wrote:
During a resampling operation where
1) user has specified first_pts
2) SWR_FLAG_RESAMPLE is not set initially (directly or otherwise)
3) first_pts has been fulfilled (always using hard compensation)
then upon first encountering a delay where a soft c
configure: Enable section_data_rel_ro for FreeBSD and NetBSD aarch64 / arm
Signed-off-by: Brad Smith
---
configure | 2 ++
1 file changed, 2 insertions(+)
diff --git a/configure b/configure
index 078aa9437a..226874600a 100755
--- a/configure
+++ b/configure
@@ -5601,6 +5601,7 @@ case $target_os
On date Saturday 2023-12-16 09:13:21 +0100, ffmpeg-devel Mailing List wrote:
> ---
> Changelog| 1 +
> MAINTAINERS | 1 +
> configure| 2 +
> doc/filters.texi | 33 +
> libavfilter/Makefile | 1 +
> libavfilter/allfilters.c |
On date Monday 2023-12-11 02:35:22 +0100, Clément Bœsch wrote:
> This makes the function closer to encode_dcs() in proresenc_kostya.
> ---
> libavcodec/proresenc_anatoliy.c | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
Should be good.
On date Monday 2023-12-11 02:35:21 +0100, Clément Bœsch wrote:
> This makes the function closer to encode_dcs() in proresenc_kostya.
> ---
> libavcodec/proresenc_anatoliy.c | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
Should be good.
On date Monday 2023-12-11 02:35:20 +0100, Clément Bœsch wrote:
> ---
> libavcodec/proresenc_anatoliy.c | 7 ---
> 1 file changed, 4 insertions(+), 3 deletions(-)
LGTM
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/l
On date Monday 2023-12-11 02:35:19 +0100, Clément Bœsch wrote:
> This makes the function closer to encode_dcs() in proresenc_kostya.
> ---
> libavcodec/proresenc_anatoliy.c | 9 +
> 1 file changed, 5 insertions(+), 4 deletions(-)
should be good
On date Monday 2023-12-11 02:35:18 +0100, Clément Bœsch wrote:
> ---
> libavcodec/proresenc_anatoliy.c | 10 +-
> 1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/libavcodec/proresenc_anatoliy.c b/libavcodec/proresenc_anatoliy.c
> index f8feff850f..97d681467d 100644
> ---
On date Monday 2023-12-11 02:35:17 +0100, Clément Bœsch wrote:
> This makes the function closer to encode_dcs() in proresenc_kostya.
> ---
> libavcodec/proresenc_anatoliy.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/libavcodec/proresenc_anatoliy.c b/libavcodec/pr
On date Monday 2023-12-11 02:35:16 +0100, Clément Bœsch wrote:
> This makes the function closer to encode_dcs() in proresenc_kostya.
> ---
> libavcodec/proresenc_anatoliy.c | 16
> 1 file changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/libavcodec/proresenc_anatoliy.c b/
On date Monday 2023-12-11 02:35:15 +0100, Clément Bœsch wrote:
> Also replaces 16384 with 0x4000.
>
> This makes the function slightly closer to same function in proresenc_kostya.
LGTM (and possibly improves readability by removing an unnecessary indirection).
On date Monday 2023-12-11 02:35:14 +0100, Clément Bœsch wrote:
> This matches the function of the same name in proresenc_kostya.
> ---
> libavcodec/proresenc_anatoliy.c | 10 +-
> 1 file changed, 5 insertions(+), 5 deletions(-)
LGTM.
___
ffmpeg-
On date Monday 2023-12-11 02:35:13 +0100, Clément Bœsch wrote:
> Code is functionally identical, it's just rename of variables, cosmetics
> and branch logic shuffling.
> ---
> libavcodec/proresenc_anatoliy.c | 45 +
> 1 file changed, 23 insertions(+), 22 deletions(-
Before:
179987 decicycles in av_tx (r2c), 1048573 runs, 3 skips
After:
56458 decicycles in av_tx (r2c), 1048576 runs, 0 skips
Patch attached
>From 1a0d97791b9a7eba8ac08e212ae60ef9961c75c5 Mon Sep 17 00:00:00 2001
From: Lynne
Date: Mon, 11 Dec 2023 13:29:21 +0100
Subject: [PATCH] x86/tx
On Sat, Dec 16, 2023 at 09:13:21AM +0100, Thilo Borgmann via ffmpeg-devel wrote:
[...]
> +// get number of bytes from cur to '\0'
> +static int buf_get_zero(FsyncContext *ctx)
maybe doxygen syntax would make sense for comments descrining functions
its not public api but still maybe
> +{
> +
This can be used to run tests multple times, with e.g. differing
QEMU settings, by adding something like this to the FATE configuration
file:
target_exec="qemu-aarch64-static"
fate_targets="fate-checkasm fate-cpu"
fate_environments="sve128 sve256 sve512"
sve128_env="QEMU_CPU=max,s
The ffmpeg coding style doesn't usually use const on scalar
parameters (or on the pointer values - as opposed to the type
that is pointed to, where it has a semantic meaning), contrary
to the dav1d coding style (where this was imported from).
This avoids warnings about differences in the type sign
On Sun, 17 Dec 2023, James Almer wrote:
On 12/17/2023 9:36 AM, Martin Storsjö wrote:
The names of the cpu flags, when parsed from a string with
av_parse_cpu_caps, are parsed by the libavutil eval functions. These
interpret dashes as subtractions. Therefore, these previous cpu flag
names haven't
On Sun, 17 Dec 2023, Rémi Denis-Courmont wrote:
Le sunnuntaina 17. joulukuuta 2023, 18.09.45 EET James Almer a écrit :
On 12/17/2023 6:13 AM, Rémi Denis-Courmont wrote:
> ---
>
> tests/checkasm/lpc.c | 47 ++--
> 1 file changed, 45 insertions(+), 2 d
On 12/17/2023 1:24 PM, zhupengfei via ffmpeg-devel wrote:
From: Zhu Pengfei <411294...@qq.com>
Signed-off-by: Zhu Pengfei <411294...@qq.com>
---
libavformat/flvenc.c | 155 +++
1 file changed, 155 insertions(+)
diff --git a/libavformat/flvenc.c b/libav
On date Monday 2023-12-11 02:35:12 +0100, Clément Bœsch wrote:
> ---
> libavcodec/proresenc_anatoliy.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/libavcodec/proresenc_anatoliy.c b/libavcodec/proresenc_anatoliy.c
> index d6f5cefc16..804ff6ddf7 100644
> --- a/libavcode
On date Monday 2023-12-11 02:35:11 +0100, Clément Bœsch wrote:
> ---
> libavcodec/proresenc_kostya.c | 8 ++--
> 1 file changed, 2 insertions(+), 6 deletions(-)
>
> diff --git a/libavcodec/proresenc_kostya.c b/libavcodec/proresenc_kostya.c
> index 103051830a..e0aa7cf47a 100644
> --- a/libavco
On date Sunday 2023-12-17 18:29:33 +0100, Lena wrote:
> Added more context in the error message and did a final test that it all
> works.
>
> Thanks for the smooth patch submission process!
>
>
> x11grab can capture windows by their ID, but gdigrab can only capture windows
> by their names, in
On date Saturday 2023-12-09 19:13:46 +0100, Stefano Sabatini wrote:
> On date Thursday 2023-11-30 01:49:14 +0100, Stefano Sabatini wrote:
> > ---
> > configure | 4 +
> > libavfilter/Makefile| 1 +
> > libavfilter/allfilters.c| 1 +
> > libavfilter/vsrc_qrencode
Added more context in the error message and did a final test that it all works.
Thanks for the smooth patch submission process!
x11grab can capture windows by their ID, but gdigrab can only capture windows
by their names, internally calling FindWindowW to lookup its handle.
This patch simply a
Le sunnuntaina 17. joulukuuta 2023, 18.09.45 EET James Almer a écrit :
> On 12/17/2023 6:13 AM, Rémi Denis-Courmont wrote:
> > ---
> >
> > tests/checkasm/lpc.c | 47 ++--
> > 1 file changed, 45 insertions(+), 2 deletions(-)
> >
> > diff --git a/tests/che
From: Zhu Pengfei <411294...@qq.com>
Signed-off-by: Zhu Pengfei <411294...@qq.com>
---
libavformat/flvdec.c | 178 ++-
1 file changed, 177 insertions(+), 1 deletion(-)
diff --git a/libavformat/flvdec.c b/libavformat/flvdec.c
index e25b5bd163..6d40b4c7d5 10
From: Zhu Pengfei <411294...@qq.com>
Signed-off-by: Zhu Pengfei <411294...@qq.com>
---
libavformat/flvenc.c | 155 +++
1 file changed, 155 insertions(+)
diff --git a/libavformat/flvenc.c b/libavformat/flvenc.c
index f6d10f331c..7268394b93 100644
--- a/liba
On 12/17/2023 6:13 AM, Rémi Denis-Courmont wrote:
---
tests/checkasm/lpc.c | 47 ++--
1 file changed, 45 insertions(+), 2 deletions(-)
diff --git a/tests/checkasm/lpc.c b/tests/checkasm/lpc.c
index 592e34c03d..9b33f8a3b0 100644
--- a/tests/checkasm/lpc.
The penultimate loop iteration could pick any vl such that:
vlenb/4 < vl <= vlenb/2
Thus if the total length is not a multiple of vlenb/2, the vfadd.vf
on the penultimate iteration would yield corrupt values for the last
iteration.
To avoid this, force vl = vlen/2 until the last iteration. Unfort
On 12/17/2023 10:18 AM, Michael Niedermayer wrote:
Fixes: abort()
Fixes:
64232/clusterfuzz-testcase-minimized-ffmpeg_BSF_TRACE_HEADERS_fuzzer-5417957987319808
Found-by: continuous fuzzing process
https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg
Signed-off-by: Michael Niedermayer
On 12/17/2023 9:36 AM, Martin Storsjö wrote:
The names of the cpu flags, when parsed from a string with
av_parse_cpu_caps, are parsed by the libavutil eval functions. These
interpret dashes as subtractions. Therefore, these previous cpu flag
names haven't been possible to set.
Use the official n
Le sunnuntaina 17. joulukuuta 2023, 14.36.08 EET Martin Storsjö a écrit :
> The names of the cpu flags, when parsed from a string with
> av_parse_cpu_caps, are parsed by the libavutil eval functions. These
> interpret dashes as subtractions. Therefore, these previous cpu flag
> names haven't been p
Fixes: abort()
Fixes:
64232/clusterfuzz-testcase-minimized-ffmpeg_BSF_TRACE_HEADERS_fuzzer-5417957987319808
Found-by: continuous fuzzing process
https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg
Signed-off-by: Michael Niedermayer
---
libavcodec/cbs_vp8.c | 2 +-
1 file changed, 1
From: Zhao Zhili
>From AOSP doc, these values are device and codec specific, but lower
values generally result in more efficient (smaller-sized) encoding.
For example, global_quality 50 on Pixel 6 results a 1080P 30 FPS
HEVC with 3744 kb/s, while global_quality 80 results 28178 kb/s.
Fix #10689
The names of the cpu flags, when parsed from a string with
av_parse_cpu_caps, are parsed by the libavutil eval functions. These
interpret dashes as subtractions. Therefore, these previous cpu flag
names haven't been possible to set.
Use the official names for these extensions, as the previous ad-h
On Sat, Dec 16, 2023 at 09:20:24AM -0300, James Almer wrote:
> On 12/16/2023 9:16 AM, Michael Niedermayer wrote:
> > Fixes: abort()
> > Fixes:
> > 64232/clusterfuzz-testcase-minimized-ffmpeg_BSF_TRACE_HEADERS_fuzzer-5417957987319808
> >
> > Found-by: continuous fuzzing process
> > https://github
On Sat, Dec 16, 2023 at 11:55:08AM -0300, James Almer wrote:
> On 12/16/2023 11:52 AM, Paul B Mahol wrote:
> > On Sat, Dec 16, 2023 at 3:49 PM James Almer wrote:
> >
> > > On 12/16/2023 11:47 AM, Paul B Mahol wrote:
> > > > On Sat, Dec 16, 2023 at 3:45 PM James Almer wrote:
> > > >
> > > > > On
From: Zhao Zhili
A dummy frame is created with format NONE passed to enc_open(),
which doesn't prepare for it. The null pointer dereference happened
at av_pix_fmt_desc_get(enc_ctx->pix_fmt)->comp[0].depth.
frame #0: 0x00bc34a4 ffmpeg_g`enc_open(opaque=0xb47efe2db690,
frame=0xb47
From: Zhao Zhili
Signed-off-by: Zhao Zhili
---
fftools/ffmpeg_enc.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/fftools/ffmpeg_enc.c b/fftools/ffmpeg_enc.c
index 9141dab6a4..ac38e8db75 100644
--- a/fftools/ffmpeg_enc.c
+++ b/fftools/ffmpeg_enc.c
@@ -206,6 +206,7 @@ int enc_open(void *
Le sunnuntaina 17. joulukuuta 2023, 11.11.30 EET Martin Storsjö a écrit :
> >> AV_CPU_FLAG_RVV_I32 }, .unit = "flags" }, -{ "rvv-f32",
> >> NULL,
> >> 0, AV_OPT_TYPE_CONST, { .i64 = AV_CPU_FLAG_RVV_F32 }, .unit = "flags"
> >> }, -{ "rvv-i64", NULL, 0, AV_OPT_TYPE_CONST, {
---
tests/checkasm/lpc.c | 47 ++--
1 file changed, 45 insertions(+), 2 deletions(-)
diff --git a/tests/checkasm/lpc.c b/tests/checkasm/lpc.c
index 592e34c03d..9b33f8a3b0 100644
--- a/tests/checkasm/lpc.c
+++ b/tests/checkasm/lpc.c
@@ -57,10 +57,46 @@ stati
On Sun, 17 Dec 2023, Rémi Denis-Courmont wrote:
Le perjantaina 15. joulukuuta 2023, 22.52.51 EET Martin Storsjö a écrit :
The names of the cpu flags, when parsed from a string with
av_parse_cpu_caps, are parsed by the libavutil eval functions. These
interpret dashes as subtractions. Therefore,
Le perjantaina 15. joulukuuta 2023, 22.52.51 EET Martin Storsjö a écrit :
> The names of the cpu flags, when parsed from a string with
> av_parse_cpu_caps, are parsed by the libavutil eval functions. These
> interpret dashes as subtractions. Therefore, these previous cpu flag
> names haven't been p
52 matches
Mail list logo