Fixes: out of array access
Fixes: rtpdec_h264.c149/poc
Found-by: Hardik Shah of Vehere
Reviewed-by: Martin Storsjö
Signed-off-by: Michael Niedermayer
---
libavformat/rtsp.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/rtsp.c b/libavformat/rtsp.c
index c4f78f97
Surprising no one, the insane usage rule has a catch.
Only happens in the layered_dpb path, which was poorly tested.
Fixes:
"[AVHWDeviceContext @ 0x557f4b87dc00] Validation Error: [
VUID-VkImageMemoryBarrier2-srcQueueFamilyIndex-07122 ] Object 0: handle =
0xaf316ce, type = VK_OBJECT_TYP
Meant to be applied on top of my previous patch to fix frame context dimension
allocation.
Fixes:
"Validation Error: [ VUID-VkImageViewCreateInfo-imageViewType-04974 ] Object 0:
handle = 0x9f9b413c, type = VK_OBJECT_TYPE_IMAGE; | MessageID =
0xc120e150 | vkCreateImageView():
Using pCrea
Oct 24, 2023, 21:05 by an...@khirnov.net:
> Quoting Lynne (2023-10-24 06:37:03)
>
>> Fixes several samples.
>>
>> There may be issues with cropping, but so far, I have not found any
>> in my samples set.
>>
>
> Frames ctx dimensions should be the allocated ones, cropping does not
> enter into this
Quoting Michael Niedermayer (2023-10-10 19:33:44)
> On Tue, Oct 10, 2023 at 03:38:22PM +0200, Anton Khirnov wrote:
> >
> > And for people who do want voting right - gathering and maintaining the
> > required commit count requires only a very modest effort. So if someone
> > loses voting rights the
Hi all,
as discussed at the dev meeting at VDD, we need to have a series of
votes, the first of which concerns defining when is the GA voter list to
be updated.
As the previous attempt to vote on this was hampered by email delivery
issues, and also criticized due to inadequate advance announcement
Hi,
I broke the libvmaf_cuda build after
6028728bb829c04cc68c66c846c75a70bf4c0613. Fix is attached. I will
merge this patch soon.
Thanks,
Kyle
0001-avfilter-libvmaf-fix-broken-cuda-build.patch
Description: Binary data
___
ffmpeg-devel mailing list
ffm
Quoting Lynne (2023-10-24 06:37:03)
> Fixes several samples.
>
> There may be issues with cropping, but so far, I have not found any
> in my samples set.
Frames ctx dimensions should be the allocated ones, cropping does not
enter into this.
--
Anton Khirnov
_
Hi,
On Sun, 24 Sept 2023 at 11:12, Clément Péron wrote:
>
> Hi,
>
> I plan to resent this series without the latest patch.
>
> Regarding Patch 1 and 2 do you have any comment?
>
> One thing is that unlike the decode.c which has a common
> ff_decode_frame_props_from_pkt() there is no such thing fo
On Mon, Oct 23, 2023 at 11:24 PM Andreas Rheinhardt <
andreas.rheinha...@outlook.com> wrote:
> Nuo Mi:
> > On Mon, Oct 23, 2023 at 7:46 PM Andreas Rheinhardt <
> > andreas.rheinha...@outlook.com> wrote:
> >
> >> Nuo Mi:
> >>> On Sun, Oct 22, 2023 at 8:58 PM Andreas Rheinhardt <
> >>> andreas.rhein
The code already checks for the end everywhere
Signed-off-by: Michael Niedermayer
---
libavcodec/magicyuv.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/libavcodec/magicyuv.c b/libavcodec/magicyuv.c
index 78d7f44cd65..2ab29df2f51 100644
--- a/libavcodec/magicyuv.c
+++ b/libavcodec/magicyu
Signed-off-by: Michael Niedermayer
---
libavcodec/get_bits.h | 61 ---
1 file changed, 58 insertions(+), 3 deletions(-)
diff --git a/libavcodec/get_bits.h b/libavcodec/get_bits.h
index 86cea00494a..806e4b16f49 100644
--- a/libavcodec/get_bits.h
+++ b/libav
Signed-off-by: Michael Niedermayer
---
libavcodec/get_bits.h | 8 ++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/libavcodec/get_bits.h b/libavcodec/get_bits.h
index cfcf97c021c..86cea00494a 100644
--- a/libavcodec/get_bits.h
+++ b/libavcodec/get_bits.h
@@ -581,8 +581,12 @@
This will permit further optimizations
Signed-off-by: Michael Niedermayer
---
libavcodec/magicyuv.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/libavcodec/magicyuv.c b/libavcodec/magicyuv.c
index 4a143cdbbf7..78d7f44cd65 100644
--- a/libavcodec/magicyuv.c
+++ b/libav
On Tue, Oct 24, 2023, 08:23 Martin Storsjö wrote:
> Skip doing the whole getauxval(AT_HWCAP) if HWCAP_CPUID isn't
> defined.
> ---
> libavutil/aarch64/cpu.c | 6 +-
> 1 file changed, 1 insertion(+), 5 deletions(-)
>
> diff --git a/libavutil/aarch64/cpu.c b/libavutil/aarch64/cpu.c
> index bd7
Clang versions before 17 (Xcode versions up to and including 15.0)
had a very annoying bug in its behaviour of the ".arch" directive
in assembly. If the directive only contained a level, such as
".arch armv8.2-a", it did validate the name of the level, but it
didn't apply the level to what instruct
Skip doing the whole getauxval(AT_HWCAP) if HWCAP_CPUID isn't
defined.
---
libavutil/aarch64/cpu.c | 6 +-
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/libavutil/aarch64/cpu.c b/libavutil/aarch64/cpu.c
index bd780e8591..2b50c426bc 100644
--- a/libavutil/aarch64/cpu.c
+++ b/liba
On Wed, 18 Oct 2023, Martin Storsjö wrote:
This eases actual development of the assembly functions, by only
allowing extension instructions within the sections that explicitly
enable them, instead of having all extensions enabled everywhere.
---
libavcodec/aarch64/hevcdsp_epel_neon.S | 3 ++-
li
Various parts of this file are restructured slightly for readability,
such as spacing in arithmetic operations, and putting `if (ret < 0)`
clauses on separate lines.
Signed-off-by: Leo Izen
---
libavcodec/pngdec.c | 241 +++-
1 file changed, 124 insertions
On 10/23/23 12:04, Michael Niedermayer wrote:
On Mon, Oct 23, 2023 at 02:10:35AM -0400, Leo Izen wrote:
On 10/22/23 17:51, Michael Niedermayer wrote:
This makes the code more testable as uninitialized fields are 0
and not random values from the last call
Signed-off-by: Michael Niedermayer
---
20 matches
Mail list logo