new spammer in ticket 2776
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".
And remove the AVOID_PROBING flag, given it's the last av1 decoder to be tested
either way.
This fixes a regression introduced in 1652f2492f88434010053289d946dab6a57e4d58,
where even if forcing the native av1 decoder, if another decoder was present,
like libdav1d or libaom-av1, they'd be used for p
Improves readability.
Signed-off-by: Andreas Rheinhardt
---
libavfilter/vf_framepack.c | 26 ++
1 file changed, 14 insertions(+), 12 deletions(-)
diff --git a/libavfilter/vf_framepack.c b/libavfilter/vf_framepack.c
index cbfcf1e036..3b915f 100644
--- a/libavfilter/vf
av_image_copy() accepts const uint8_t* const * as source;
lots of user have uint8_t* const * and therefore either
cast (the majority) or copy the array of pointers.
This commit changes this by adding a static inline wrapper
for av_image_copy() that casts between the two types
so that we do not nee
Signed-off-by: Andreas Rheinhardt
---
libavcodec/v210dec.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/libavcodec/v210dec.c b/libavcodec/v210dec.c
index 814d65bbda..04bcc612b7 100644
--- a/libavcodec/v210dec.c
+++ b/libavcodec/v210dec.c
@@ -33,7 +33,7 @@
typedef s
They do not modify the AVFifo state.
Signed-off-by: Andreas Rheinhardt
---
doc/APIchanges | 3 +++
libavutil/fifo.c | 4 ++--
libavutil/fifo.h | 4 ++--
3 files changed, 7 insertions(+), 4 deletions(-)
diff --git a/doc/APIchanges b/doc/APIchanges
index 2dbcd47fc3..0914a4da32 100644
--- a/doc/
Also constify AVAudioFifo* in the peek functions
besides constifying intermediate pointers (void**->void * const *).
Signed-off-by: Andreas Rheinhardt
---
doc/APIchanges | 4
libavutil/audio_fifo.c | 9 +
libavutil/audio_fifo.h | 9 +
3 files changed, 14 insertions(+
This is the samplefmt analogon of the imgutils changes
from the preceding commit.
Signed-off-by: Andreas Rheinhardt
---
doc/APIchanges| 3 +++
libavutil/samplefmt.c | 4 ++--
libavutil/samplefmt.h | 4 ++--
3 files changed, 7 insertions(+), 4 deletions(-)
diff --git a/doc/APIchanges b/d
This is done immediately without waiting for the next major bump
just as in 9546b3a1cbcd94e9107f85c8f1d2175efc6cf083 and
4eaaa38d3dfb8863a62f3646a62e4098b1c078d5.
Signed-off-by: Andreas Rheinhardt
---
doc/APIchanges | 4
libavutil/imgutils.c | 14 +++---
libavutil/imgutils.h
They are currently non-const for reasons unknown, although
avio_write() accepts a const buffer.
Signed-off-by: Andreas Rheinhardt
---
rtmpcrypt.c sometimes modifies the buffer whose content
it is supposed to write.
doc/APIchanges | 4
libavformat/avio.c |
It is only included because two very rarely used functions
use pointers to URLContexts; use struct URLContext instead.
Also move ffio_geturlcontext() so that one can avoid
a forward declaration of struct URLContext (which would be
necessary as soon as FF_API_AVIODIRCONTEXT is no more).
Signed-off-
Incompatibility of the flags and the protocol's capabilities
are checked generically (see url_alloc_for_protocol()).
Signed-off-by: Andreas Rheinhardt
---
libavformat/teeproto.c | 4
1 file changed, 4 deletions(-)
diff --git a/libavformat/teeproto.c b/libavformat/teeproto.c
index 33877ed80
Signed-off-by: Andreas Rheinhardt
---
libavformat/avio.c | 1 -
libavformat/bluray.c | 1 -
libavformat/concat.c | 4 +++-
libavformat/crypto.c | 2 --
libavformat/hlsproto.c | 1 -
libavformat/httpauth.c | 1 -
libavformat/libsmbclient.c | 2 --
libavformat/md5p
The stuff declared in said header is actually unusable in libavdevice.
Signed-off-by: Andreas Rheinhardt
---
libavdevice/lavfi.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/libavdevice/lavfi.c b/libavdevice/lavfi.c
index b2cec0400b..ec7ebdbc90 100644
--- a/libavdevice/lavfi.c
+++ b/libavd
Signed-off-by: Andreas Rheinhardt
---
libavformat/teeproto.c | 14 --
1 file changed, 14 deletions(-)
diff --git a/libavformat/teeproto.c b/libavformat/teeproto.c
index dca97a6741..7dd5065f4b 100644
--- a/libavformat/teeproto.c
+++ b/libavformat/teeproto.c
@@ -20,7 +20,6 @@
*/
#
Signed-off-by: Andreas Rheinhardt
---
libavformat/dashenc.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index e98d54a61d..96f4a5fbdf 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -207,14 +207,14 @@ typed
A switch is simpler than a lookup over a table with
three entries, only two of which can happen at all.
Signed-off-by: Andreas Rheinhardt
---
libavformat/dashenc.c | 21 ++---
1 file changed, 6 insertions(+), 15 deletions(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashe
Signed-off-by: Andreas Rheinhardt
---
libavformat/dashenc.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index 1fac35a909..9c3ba2c389 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -205,7 +205,7 @@ typedef
Signed-off-by: Andreas Rheinhardt
---
libavformat/dashenc.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index 5615430d86..1fac35a909 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -206,7 +206,7 @@ typed
Signed-off-by: Andreas Rheinhardt
---
libavformat/dashenc.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index 69ceae2cbf..5615430d86 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -1292,7 +1292,7 @@ sta
It is undefined behaviour even in cases where it works
(it works because both are pointers). Instead change
the functions involved to use the type expected by the AVIO-API
and add inline wrappers for our internal callers.
Signed-off-by: Andreas Rheinhardt
---
libavformat/avio.c| 15 +
Fixes many warnings when using -Wcast-qual.
Signed-off-by: Andreas Rheinhardt
---
libavformat/internal.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/internal.h b/libavformat/internal.h
index 051e8e2893..c7512898b5 100644
--- a/libavformat/internal.h
+++ b/liba
It is undefined behaviour even in cases where it works
(it works because it is only a const uint8_t* vs. uint8_t* difference).
Signed-off-by: Andreas Rheinhardt
---
libavformat/avio.c | 25 -
1 file changed, 16 insertions(+), 9 deletions(-)
diff --git a/libavformat/avio.
This is a workaround for an issue introduced in commit
1652f2492f88434010053289d946dab6a57e4d58. It is not meant to be applied
to the tree.
Signed-off-by: Andreas Rheinhardt
---
tests/fate-run.sh | 2 +-
tests/fate/demux.mak | 2 +-
tests/fate/lavf-container.mak | 4 ++--
3
It is undefined behaviour even in cases where it works
(it works because both are pointers). Instead change
the functions involved to use the type expected by the AVIO-API
and add inline wrappers for our internal callers.
Signed-off-by: Andreas Rheinhardt
---
libavformat/avio.c| 15 +
Fixes many warnings when using -Wcast-qual.
Signed-off-by: Andreas Rheinhardt
---
libavformat/internal.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/internal.h b/libavformat/internal.h
index 051e8e2893..c7512898b5 100644
--- a/libavformat/internal.h
+++ b/liba
It is undefined behaviour even in cases where it works
(it works because it is only a const uint8_t* vs. uint8_t* difference).
Signed-off-by: Andreas Rheinhardt
---
libavformat/avio.c | 25 -
1 file changed, 16 insertions(+), 9 deletions(-)
diff --git a/libavformat/avio.
On 9/6/2023 2:53 PM, Tomas Härdin wrote:
ons 2023-09-06 klockan 11:38 -0300 skrev James Almer:
Signed-off-by: James Almer
---
This is an initial proof of concept for AVStream groups, something
that's
needed for quite a few existing and upcoming formats that lavf has no
way to
currently export.
ons 2023-09-06 klockan 12:16 +0200 skrev Bart Styczen:
> If an MXF file has reel_name stored in a stream, while copying or
> remuxing file, some (most) of the stream metadata is lost.
> Here’s the file:
> https://streams.videolan.org/ffmpeg/incoming/original.mxf
> After running ffmpeg -i original.m
ons 2023-09-06 klockan 11:38 -0300 skrev James Almer:
> Signed-off-by: James Almer
> ---
> This is an initial proof of concept for AVStream groups, something
> that's
> needed for quite a few existing and upcoming formats that lavf has no
> way to
> currently export. Said formats define a single v
Signed-off-by: James Almer
---
libavcodec/avcodec.h | 2 +-
libavcodec/hevcdec.c | 15 ++-
libavcodec/internal.h | 3 +++
libavcodec/utils.c| 10 ++
4 files changed, 28 insertions(+), 2 deletions(-)
diff --git a/libavcodec/avcodec.h b/libavcodec/avcodec.h
index 1f4772
This is no longer needed as the side data is available for decoders in the
AVCodecContext.
Signed-off-by: James Almer
---
fftools/ffplay.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/fftools/ffplay.c b/fftools/ffplay.c
index a0d5811c94..b489e6264a 100644
--- a/fftools/ffplay.c
+++ b/fft
Signed-off-by: James Almer
---
fftools/ffprobe.c | 30 ++
1 file changed, 14 insertions(+), 16 deletions(-)
diff --git a/fftools/ffprobe.c b/fftools/ffprobe.c
index 4fcfe1164b..28ccb45b26 100644
--- a/fftools/ffprobe.c
+++ b/fftools/ffprobe.c
@@ -2279,16 +2279,9 @@ st
This is no longer needed as the side data is available for decoders in the
AVCodecContext.
The tests affected reflect the removal of useless CPB and Stereo 3D side
data in packets.
Signed-off-by: James Almer
---
fftools/ffmpeg_demux.c| 22 ---
tests/ref/fa
Signed-off-by: James Almer
---
fftools/ffplay.c | 8 ++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/fftools/ffplay.c b/fftools/ffplay.c
index 006da7ab57..a0d5811c94 100644
--- a/fftools/ffplay.c
+++ b/fftools/ffplay.c
@@ -1916,8 +1916,12 @@ static int configure_video_filte
Signed-off-by: James Almer
---
libavcodec/decode.c | 55 +
libavcodec/decode.h | 2 +-
2 files changed, 47 insertions(+), 10 deletions(-)
diff --git a/libavcodec/decode.c b/libavcodec/decode.c
index 169ee79acd..1a431ba7d7 100644
--- a/libavcodec/decod
Signed-off-by: James Almer
---
fftools/ffmpeg_demux.c| 11 +++
fftools/ffmpeg_enc.c | 31 +--
fftools/ffmpeg_filter.c | 5 -
fftools/ffmpeg_mux_init.c | 19 ++-
4 files changed, 30 insertions(+), 36 deletions(-)
diff --git a/fft
Deprecate AVStream.side_data and its helpers in favor of the AVStream's
codecpar.side_data.
This will considerably simplify the propagation of global side data to decoders
and from encoders. Instead of having to do it inside packets, it will be
available during init().
Global and frame specific si
This will simplify the propagation of side data to decoders and from encoders.
Global side data will now reside in the AVCodecContext, thus be available
during init(), removing the need to propagate it inside packets.
Global and frame specific side data will therefore be distinct.
Signed-off-by:
This will be useful in the following commits.
Signed-off-by: James Almer
---
libavcodec/avpacket.c | 99 +++
libavcodec/packet.h | 74
2 files changed, 173 insertions(+)
diff --git a/libavcodec/avpacket.c b/libavcodec/av
Changes since the previous version:
- Removed the AVPacketSideDataSet from AVCodecContext, using instead the
existing coded_side_data field, at Anton's request.
I still prefer using a new field of type AVPacketSideDataSet, given that the
user can currently only fill coded_side_data manually (See
On Wed, 6 Sept 2023 at 19:09, Timo Rothenpieler wrote:
>
> On 06.09.2023 18:54, Kacper Michajlow wrote:
> > On Wed, 6 Sept 2023 at 12:15, Timo Rothenpieler
> > wrote:
> >>
> >> On 06/09/2023 01:26, Kacper Michajłow wrote:
> >>> Other C++ standard libraries exist. Also, this is not a proper way t
On 06.09.2023 18:54, Kacper Michajlow wrote:
On Wed, 6 Sept 2023 at 12:15, Timo Rothenpieler wrote:
On 06/09/2023 01:26, Kacper Michajłow wrote:
Other C++ standard libraries exist. Also, this is not a proper way to
link the standard library anyway. Instead when a C++ dependency is
detected, s
On Wed, 2023-09-06 at 11:14 -0300, James Almer wrote:
> Makes the output of the native decoder consistent with external
> decoders like
> libdav1d with fate-enhanced-flv-av1.
>
> Signed-off-by: James Almer
> ---
> libavcodec/av1dec.c | 1 -
> tests/ref/fate/enhanced-flv-av1 | 2 +-
>
On Wed, 6 Sept 2023 at 12:15, Timo Rothenpieler wrote:
>
> On 06/09/2023 01:26, Kacper Michajłow wrote:
> > Other C++ standard libraries exist. Also, this is not a proper way to
> > link the standard library anyway. Instead when a C++ dependency is
> > detected, switch to the C++ compiler driver t
On Wed, Sep 06, 2023 at 04:25:00PM +0200, Alan Kelly via ffmpeg-devel wrote:
> ---
> libswscale/x86/swscale.c| 19 ---
> libswscale/x86/yuv2yuvX.asm | 24 ++--
> 2 files changed, 26 insertions(+), 17 deletions(-)
ffmpeg -i lena.pnm -vf scale=32:32,scale=4:4
> On Aug 17, 2023, at 11:36 PM, Damiano Galassi wrote:
>
> Ping
>
I believe this is still waiting for a FATE test to be added.
- Cosmin
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To uns
On Wed, 6 Sept 2023 at 15:24, Alan Kelly via ffmpeg-devel <
ffmpeg-devel@ffmpeg.org> wrote:
> ---
> libswscale/x86/swscale.c| 7 +++
> libswscale/x86/yuv2yuvX.asm | 19 ++-
> 2 files changed, 25 insertions(+), 1 deletion(-)
>
Could you include benchmarks below the main c
Signed-off-by: James Almer
---
This is an initial proof of concept for AVStream groups, something that's
needed for quite a few existing and upcoming formats that lavf has no way to
currently export. Said formats define a single video or audio stream composed
by merging several individualy multipl
On Tue, Sep 5, 2023 at 12:03 AM Michael Niedermayer
wrote:
> On Mon, Sep 04, 2023 at 02:30:00PM +0200, Alan Kelly via ffmpeg-devel
> wrote:
> > Hi,
> >
> > Any issues with this patch or can it be merged?
>
> are all cases covered by tests ?
> if yes and the tests pass, it should be ok
>
> thx
>
>
---
libswscale/x86/swscale.c| 19 ---
libswscale/x86/yuv2yuvX.asm | 24 ++--
2 files changed, 26 insertions(+), 17 deletions(-)
diff --git a/libswscale/x86/swscale.c b/libswscale/x86/swscale.c
index 00e42b4bec..6980002e9e 100644
--- a/libswscale/x86/swscale
---
libswscale/x86/swscale.c| 7 +++
libswscale/x86/yuv2yuvX.asm | 19 ++-
2 files changed, 25 insertions(+), 1 deletion(-)
diff --git a/libswscale/x86/swscale.c b/libswscale/x86/swscale.c
index ff16398988..00e42b4bec 100644
--- a/libswscale/x86/swscale.c
+++ b/libswscale
Makes the output of the native decoder consistent with external decoders like
libdav1d with fate-enhanced-flv-av1.
Signed-off-by: James Almer
---
libavcodec/av1dec.c | 1 -
tests/ref/fate/enhanced-flv-av1 | 2 +-
2 files changed, 1 insertion(+), 2 deletions(-)
diff --git a/libavcode
On 9/5/2023 2:43 PM, James Almer wrote:
This reverts commit eb88ccb92e05018b1060cf8126b30eeeff551d3b.
AVCodecContext fields are the proper place for a decoder to export such values.
This change is in preparation for the following commits.
---
libavcodec/avcodec.h | 2 +-
libavcodec/mpeg12d
On Wed, Sep 6, 2023 at 1:30 PM Andreas Rheinhardt <
andreas.rheinha...@outlook.com> wrote:
> Paul B Mahol:
> > On Wed, Sep 6, 2023 at 11:26 AM Andreas Rheinhardt <
> > andreas.rheinha...@outlook.com> wrote:
> >
> >> Paul B Mahol:
> >>>
> >>> +chunk_type = avio_rb32(pb);
> >>> +chunk_size =
Anton Khirnov:
> Quoting Tomas Härdin (2023-09-06 08:16:12)
>> ons 2023-09-06 klockan 02:35 +0200 skrev Paul B Mahol:
>>> + if (avctx->height & 1) {
>>> + for (j = 0; j < avctx->width + 1 >> 1; j++) {
>>
>> Don't we usually wrap shifted expressions in parentheses? I know >> is
>> lower pr
Paul B Mahol:
> On Wed, Sep 6, 2023 at 11:26 AM Andreas Rheinhardt <
> andreas.rheinha...@outlook.com> wrote:
>
>> Paul B Mahol:
>>>
>>> +chunk_type = avio_rb32(pb);
>>> +chunk_size = avio_rb32(pb);
>>
>> You are not checking whether the chunk here exceeds its containing chunk.
>>
>>>
>>>
Quoting Tomas Härdin (2023-09-06 08:16:12)
> ons 2023-09-06 klockan 02:35 +0200 skrev Paul B Mahol:
> > + if (avctx->height & 1) {
> > + for (j = 0; j < avctx->width + 1 >> 1; j++) {
>
> Don't we usually wrap shifted expressions in parentheses? I know >> is
> lower presedence than + (a w
Quoting Stefano Sabatini (2023-09-06 00:59:44)
> > > > As I already said above - function parameter names in a prototype are
> > > > purely cosmetic and have no effect on anything besides doxygen. You can
> > > > change them at will and even remove them entirely without breaking API
> > > > or ABI.
On 06/09/2023 01:26, Kacper Michajłow wrote:
Other C++ standard libraries exist. Also, this is not a proper way to
link the standard library anyway. Instead when a C++ dependency is
detected, switch to the C++ compiler driver to properly link everything.
Signed-off-by: Kacper Michajłow
---
co
Andreas Rheinhardt:
> Once upon a time, 413abbe16465a7b49472ac110e42939e853e24a1
> added versions of some put_no_rnd_pixels functions for use
> in VP3 and Theora (with an explicit check so that they are
> only used for VP3 and Theora). When this was moved to hpeldsp
> (from dsputil) in 3ced55d51c2e
On Wed, Sep 6, 2023 at 11:26 AM Andreas Rheinhardt <
andreas.rheinha...@outlook.com> wrote:
> Paul B Mahol:
> >
> > +chunk_type = avio_rb32(pb);
> > +chunk_size = avio_rb32(pb);
>
> You are not checking whether the chunk here exceeds its containing chunk.
>
> >
> > +av_fast_malloc(&usm
Andreas Rheinhardt:
> This provides coverage for the case in which the displaymatrix
> is ignored.
>
> Signed-off-by: Andreas Rheinhardt
> ---
> In this case, both the x and y axis are rotated in the same way,
> yet both axes are scaled by different factors, so that it is not
> an orthogonal tran
Andreas Rheinhardt:
> They do mostly the same.
>
> Signed-off-by: Andreas Rheinhardt
> ---
> libavcodec/Makefile | 3 +--
> libavcodec/parsers.c | 3 +--
> libavcodec/rv34_parser.c | 16 ++--
> 3 files changed, 4 insertions(+), 18 deletions(-)
>
> diff --git a/libavcodec/
Andreas Rheinhardt:
> AVCodec is only ever used as an incomplete type (i.e. via a pointer
> to an AVCodec) in avformat.h and it is not really part of the core
> of avformat.h or libavformat; almost none of our internal users
> make use of it (and none make use of hwcontext.h, which is implicitly
>
Paul B Mahol:
>
> +chunk_type = avio_rb32(pb);
> +chunk_size = avio_rb32(pb);
You are not checking whether the chunk here exceeds its containing chunk.
>
> +av_fast_malloc(&usm->header, &usm->header_size,
> + chunk_size + AV_INPUT_BUFFER_PADDING_SIZE);
> +if (!
On Friday, 18 August 2023 at 08:36, Damiano Galassi wrote:
> Ping
FWIW, this will be required by the next HandBrake release, so it would
be great if this were included in 6.1.
Regards,
Dominik
--
Fedora https://fedoraproject.org
There should be a science of discontent. People need hard times a
On Tuesday, 27 June 2023 at 19:37, Dominik 'Rathann' Mierzejewski wrote:
> On Tuesday, 27 June 2023 at 19:23, Dominik 'Rathann' Mierzejewski wrote:
> > Hi!
> > I'm forwarding this patch from HandBrake. Original author is
> > Damiano Galassi (galad87@github).
> >
> > Apparently, this is required to
On Wed, Sep 6, 2023 at 8:12 AM Tomas Härdin wrote:
> ons 2023-09-06 klockan 02:10 +0200 skrev Paul B Mahol:
> > +static const uint16_t sr_table[16] = {
> > +0, 1764, 3528, 3840, 160, 320, 441, 480, 640, 882, 960, 1920, 0,
> > 0, 0, 0
> > +};
>
> Why not premultiply these by 50?
>
Because tha
69 matches
Mail list logo