On 8/24/23 15:22, Leo Izen wrote:
On 8/2/23 16:33, Leo Izen wrote:
Changes from v6:
- Added dummy stub libavformat/jpegxl_parse.c to fix shared builds
Changes from v5:
- Attached an extra commit to fix existing bug with libjxldec
- Made various changes based on comments by Andreas Reinhardt
--
On Sat, Aug 26, 2023 at 2:40 PM Kieran Kunhya wrote:
>
> On Sat, 26 Aug 2023 at 07:32, Jun Zhao wrote:
>
> > replace ITU-T T35(A/53 CC) SEI type by enum value
> >
> > Signed-off-by: Jun Zhao
> > ---
> > libavcodec/libx264.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff
On Sat, 26 Aug 2023 at 23:19, Lynne wrote:
>
> Aug 13, 2023, 00:15 by kaspe...@gmail.com:
>
> > On Sat, 12 Aug 2023 at 16:45, Lynne wrote:
> >
> >>
> >> It's of interest to API users, and of interest to us,
> >> as a DCT/DST can be implemented via matrix multiplies.
> >>
> >> Bumps up the require
9-patch patchset to fix various memory leaks
>From dc6770a375d26eb019002aba6a760fb26c1aa3ba Mon Sep 17 00:00:00 2001
From: Lynne
Date: Sat, 26 Aug 2023 21:53:03 +
Subject: [PATCH 9/9] vulkan: do not leak bound_buffer_indices
---
libavutil/vulkan.c | 1 +
1 file changed, 1 insertion(+)
diff
Aug 13, 2023, 00:15 by kaspe...@gmail.com:
> On Sat, 12 Aug 2023 at 16:45, Lynne wrote:
>
>>
>> It's of interest to API users, and of interest to us,
>> as a DCT/DST can be implemented via matrix multiplies.
>>
>> Bumps up the required header version to 1.3.255, released
>> 2 months ago, so it's
On Sat, Aug 26, 2023 at 05:11:30PM +0200, Anton Khirnov wrote:
> This function converts packet timestamps from the input stream timebase
> to OutputStream.mux_timebase, which may or may not be equal to the
> actual output AVStream timebase (and even when it is, this may not
> always be the optimal
Quoting Andreas Rheinhardt (2023-08-26 20:36:25)
> Anton Khirnov:
> > Document our longstanding de facto policies on things like correctness,
> > thread-safety, UB, etc.
> > ---
> > doc/developer.texi | 50 +-
> > 1 file changed, 36 insertions(+), 14 del
Anton Khirnov:
> Document our longstanding de facto policies on things like correctness,
> thread-safety, UB, etc.
> ---
> doc/developer.texi | 50 +-
> 1 file changed, 36 insertions(+), 14 deletions(-)
>
> diff --git a/doc/developer.texi b/doc/develope
It's targeted at our users, not developers, so it makes more sense to
group it with other text targeted at our users.
---
doc/developer.texi | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/doc/developer.texi b/doc/developer.texi
index 0c2f2cd7d1..85515f5d37 100644
--- a
The section consistes of a single short paragraph linking to other
chapters. The enclosing chapter also has no other sections, all other
text is placed in the chapter directly.
Keeping a separate section for this paragraph just adds more clutter.
---
doc/developer.texi | 2 --
1 file changed, 2 de
Document our longstanding de facto policies on things like correctness,
thread-safety, UB, etc.
---
doc/developer.texi | 50 +-
1 file changed, 36 insertions(+), 14 deletions(-)
diff --git a/doc/developer.texi b/doc/developer.texi
index df43119f98..afa0
The patches/committing section currently contains several
partially-overlapping rules on commit messages. Merge and simplify them
into one item.
---
doc/developer.texi | 41 ++---
1 file changed, 18 insertions(+), 23 deletions(-)
diff --git a/doc/developer.texi
It dates back to pre-2005 days, when people generally tended to commit
their work directly without going through the mailing list. Few
developers do it today, and never outside of their standalone modules.
This item is thus confusing and misleading and is better removed.
---
doc/developer.texi | 9
Adding new fields to _functions_ makes no sense, it was supposed to be
structs.
---
doc/developer.texi | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/doc/developer.texi b/doc/developer.texi
index d27716ab97..df43119f98 100644
--- a/doc/developer.texi
+++ b/doc/developer.texi
@
On Sat, Aug 26, 2023 at 07:55:10PM +0200, Anton Khirnov wrote:
> Quoting Michael Niedermayer (2023-08-26 18:53:50)
> > Fixes: NoLegacy.ape
>
> Can you make a FATE test?
The file seems 34mb, ill try to cut it down to something smaller
thx
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF673
Hi Stefano
On Sat, Aug 26, 2023 at 03:21:44PM +0200, Stefano Sabatini wrote:
> Use in place of deprecated sws_getGaussianVec.
> ---
> libavfilter/vf_sab.c | 17 +
> libavfilter/vf_smartblur.c | 8
> libswscale/utils.c | 32 ++--
>
Quoting Michael Niedermayer (2023-08-26 18:53:50)
> Fixes: NoLegacy.ape
Can you make a FATE test?
--
Anton Khirnov
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above,
On Sat, Aug 26, 2023 at 6:54 PM Michael Niedermayer
wrote:
> Fixes: NoLegacy.ape
> Found-by: Matt Ashland
> Signed-off-by: Michael Niedermayer
> ---
> libavcodec/apedec.c | 106 +++-
> 1 file changed, 84 insertions(+), 22 deletions(-)
>
> diff --git a/li
Fixes: NoLegacy.ape
Found-by: Matt Ashland
Signed-off-by: Michael Niedermayer
---
libavcodec/apedec.c | 106 +++-
1 file changed, 84 insertions(+), 22 deletions(-)
diff --git a/libavcodec/apedec.c b/libavcodec/apedec.c
index 8bd625ca05..249fc22e24 100644
Signed-off-by: Michael Niedermayer
---
libavcodec/apedec.c | 4
1 file changed, 4 deletions(-)
diff --git a/libavcodec/apedec.c b/libavcodec/apedec.c
index a9d5eb7f33..8bd625ca05 100644
--- a/libavcodec/apedec.c
+++ b/libavcodec/apedec.c
@@ -145,8 +145,6 @@ typedef struct APEPredictor64 {
Quoting Stefano Sabatini (2023-08-26 14:23:28)
> Use in place of sws_getGaussianVec.
>
> The new function enable better log handling, and provide better naming
> for the variance variable, now named standard_deviation to reflect the
> meaning of the parameter.
Logging to NULL does not seem like a
Stefano Sabatini:
> Use in place of sws_getGaussianVec.
>
> The new function enable better log handling, and provide better naming
Better log handling? Why?
> for the variance variable, now named standard_deviation to reflect the
> meaning of the parameter.
> ---
> doc/APIchanges |
>From ffmpeg_enc to ffmpeg_filter, which is a more appropriate
place for it.
fate-lavf-gxf* no longer spuriously duplicate the first video frame, due
to different rounding.
---
fftools/ffmpeg_enc.c| 9 +
fftools/ffmpeg_filter.c | 8 +++-
tests/ref/lavf/gxf | 2 +-
tests/ref/l
This function converts packet timestamps from the input stream timebase
to OutputStream.mux_timebase, which may or may not be equal to the
actual output AVStream timebase (and even when it is, this may not
always be the optimal choice due to bitstream filtering).
Just keep the timestamps in input
This function is primarily a destructor for OutputFile, the underlying
AVIOContext is normally closed earlier (right after writing the
trailer).
---
fftools/ffmpeg.c | 3 +--
fftools/ffmpeg.h | 2 +-
fftools/ffmpeg_mux.c | 2 +-
3 files changed, 3 insertions(+), 4 deletions(-)
diff --git
---
fftools/ffmpeg_filter.c | 122
1 file changed, 61 insertions(+), 61 deletions(-)
diff --git a/fftools/ffmpeg_filter.c b/fftools/ffmpeg_filter.c
index 5bf2431fb9..1343e48fab 100644
--- a/fftools/ffmpeg_filter.c
+++ b/fftools/ffmpeg_filter.c
@@ -1746,72
Mainly this fixes handling special values of -enc_time_base ('demux' or
'filter') for audio. It also prints a warning if -enc_time_base is
specified for subtitles, instead of ignoring it silently (current
subtitle encoding API only works with AV_TIME_BASE_Q).
---
fftools/ffmpeg_enc.c | 154 +++
Sending an empty packet already does that implicitly.
---
fftools/ffmpeg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/fftools/ffmpeg.c b/fftools/ffmpeg.c
index 6130fd06fc..c7822f8045 100644
--- a/fftools/ffmpeg.c
+++ b/fftools/ffmpeg.c
@@ -1124,7 +1124,7 @@ static int proc
This is easier to read.
---
fftools/ffmpeg_filter.c | 41 -
1 file changed, 24 insertions(+), 17 deletions(-)
diff --git a/fftools/ffmpeg_filter.c b/fftools/ffmpeg_filter.c
index 74b57191d1..5bf2431fb9 100644
--- a/fftools/ffmpeg_filter.c
+++ b/fftools/ffmp
---
fftools/ffmpeg_enc.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/fftools/ffmpeg_enc.c b/fftools/ffmpeg_enc.c
index 80a49fe606..f28884e50c 100644
--- a/fftools/ffmpeg_enc.c
+++ b/fftools/ffmpeg_enc.c
@@ -249,15 +249,15 @@ static int enc_choose_timebase
Stop accessing filtergraph internals from keyboard reading code.
---
fftools/ffmpeg.c| 26 --
fftools/ffmpeg.h| 3 +++
fftools/ffmpeg_filter.c | 24
3 files changed, 31 insertions(+), 22 deletions(-)
diff --git a/fftools/ffmpeg.c b
---
fftools/ffmpeg_enc.c | 66 ++--
1 file changed, 33 insertions(+), 33 deletions(-)
diff --git a/fftools/ffmpeg_enc.c b/fftools/ffmpeg_enc.c
index c4874b4d78..4b5bd3d9b4 100644
--- a/fftools/ffmpeg_enc.c
+++ b/fftools/ffmpeg_enc.c
@@ -228,44 +228,44 @@ st
That is a more appropriate place for this.
---
fftools/ffmpeg_enc.c | 14 ++
1 file changed, 6 insertions(+), 8 deletions(-)
diff --git a/fftools/ffmpeg_enc.c b/fftools/ffmpeg_enc.c
index 0586ba17c4..590ce5d7be 100644
--- a/fftools/ffmpeg_enc.c
+++ b/fftools/ffmpeg_enc.c
@@ -968,12 +9
When no output video framerate is specified by the user with -r or can
be inferred from the filtergraph, encoder setup will arbitrarily decide
that the framerate is 25fps. However, making up any framerate value for
VFR encoding is at best unnecessary.
Changes the results of the sub2video tests, wh
Output stream will be closed implicitly after a NULL packet is sent to
it, there is no need to explicitly call close_output_stream().
---
fftools/ffmpeg.c | 9 +
1 file changed, 1 insertion(+), 8 deletions(-)
diff --git a/fftools/ffmpeg.c b/fftools/ffmpeg.c
index c7822f8045..8b0f31aac6 10
Bitstream filtering input timebase is not always necessarily equal to
OutputStream.mux_timebase. Also, set AVPacket.time_base correctly for
packets output by bitstream filters
Do not rescale at all in of_output_packet() when not doing bitstream
filtering, as it's unnecessary - write_packet() will
---
fftools/ffmpeg_filter.c | 32 ++--
1 file changed, 14 insertions(+), 18 deletions(-)
diff --git a/fftools/ffmpeg_filter.c b/fftools/ffmpeg_filter.c
index 1343e48fab..e65e7cb64d 100644
--- a/fftools/ffmpeg_filter.c
+++ b/fftools/ffmpeg_filter.c
@@ -1745,13 +1745,13
It does not need an OutputFile and an OutputStream, only the target
timebase and the timestamp offset.
---
fftools/ffmpeg_enc.c | 25 ++---
1 file changed, 10 insertions(+), 15 deletions(-)
diff --git a/fftools/ffmpeg_enc.c b/fftools/ffmpeg_enc.c
index 4f8c765256..efa940fba9 1
---
fftools/ffmpeg_enc.c | 46 +++-
1 file changed, 24 insertions(+), 22 deletions(-)
diff --git a/fftools/ffmpeg_enc.c b/fftools/ffmpeg_enc.c
index 590ce5d7be..4f8c765256 100644
--- a/fftools/ffmpeg_enc.c
+++ b/fftools/ffmpeg_enc.c
@@ -1051,6 +1051,30 @@ f
Lavfi uses 1/0 to signal unknown/VFR, which should not be passed to
encoders.
---
fftools/ffmpeg_filter.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/fftools/ffmpeg_filter.c b/fftools/ffmpeg_filter.c
index 925b5116cc..177a6f7e5c 100644
--- a/fftools/ffmpeg_filter.c
+
Stefano Sabatini:
> Use in place of deprecated sws_getGaussianVec.
This patchset should have been sent as a reply to the patch actually
adding sws_get_gaussian_vec.
> ---
> libavfilter/vf_sab.c | 17 +
> libavfilter/vf_smartblur.c | 8
> libswscale/utils.c
The custom-allocator logic has been completely defunct since a while,
since nothing depends on those targets, they never get used.
This updates jemalloc to pkg-config, adds the fallback option for
potential arbitrary allocators, and finally actually adds the libraries
to LDFLAGS.
---
configure | 1
Extend descriptions for the application=lowdelay and cutoff options.
Based on notes by Mingye Wang.
Address issue:
http://trac.ffmpeg.org/ticket/10330
---
doc/encoders.texi | 7 +--
libavcodec/libopusenc.c | 2 +-
2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/doc/encode
Correctly define the option values as a standard deviation rather than a
variance.
Address trac issue:
http://trac.ffmpeg.org/ticket/9068
---
doc/filters.texi | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
diff --git a/doc/filters.texi b/doc/filters.texi
index 90e6c433c4..
Use in place of deprecated sws_getGaussianVec.
---
libavfilter/vf_sab.c | 17 +
libavfilter/vf_smartblur.c | 8
libswscale/utils.c | 32 ++--
3 files changed, 31 insertions(+), 26 deletions(-)
diff --git a/libavfilter/vf_sab.c b/
Use in place of sws_getGaussianVec.
The new function enable better log handling, and provide better naming
for the variance variable, now named standard_deviation to reflect the
meaning of the parameter.
---
doc/APIchanges | 3 +++
libswscale/swscale.h | 21 ++-
Drop reference to constants removed in 94eed68ace9f2416af8.
In particular, rename me_method to me_quality and add description for
supported values.
Address trac issue:
http://trac.ffmpeg.org/ticket/10003
---
doc/encoders.texi | 21 +
1 file changed, 9 insertions(+), 12 deleti
Will apply soon.
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".
On Sat, 26 Aug 2023, Steven Liu wrote:
Marton Balint 于2023年8月26日周六 15:52写道:
Hi Marton,
[...]
>
>> +av_strlcpy(fourcc, fourcc_data, sizeof(fourcc));
>> +ff_amf_write_string(&p, fourcc);
>> +} else {
>> +av_log(s, AV_LO
checkasm bench:
put_hevc_qpel_uni_v4_8_c: 146.2
put_hevc_qpel_uni_v4_8_neon: 43.2
put_hevc_qpel_uni_v6_8_c: 303.9
put_hevc_qpel_uni_v6_8_neon: 69.7
put_hevc_qpel_uni_v8_8_c: 495.2
put_hevc_qpel_uni_v8_8_neon: 74.7
put_hevc_qpel_uni_v12_8_c: 1100.9
put_hevc_qpel_uni_v12_8_neon: 222.4
put_hevc_qpel_
checkasm bench:
put_hevc_epel_uni_hv4_8_c: 204.7
put_hevc_epel_uni_hv4_8_i8mm: 70.2
put_hevc_epel_uni_hv6_8_c: 378.2
put_hevc_epel_uni_hv6_8_i8mm: 131.9
put_hevc_epel_uni_hv8_8_c: 637.7
put_hevc_epel_uni_hv8_8_i8mm: 137.9
put_hevc_epel_uni_hv12_8_c: 1301.9
put_hevc_epel_uni_hv12_8_i8mm: 314.2
put_
checkasm bench:
put_hevc_qpel_uni_hv4_8_c: 489.2
put_hevc_qpel_uni_hv4_8_i8mm: 105.7
put_hevc_qpel_uni_hv6_8_c: 852.7
put_hevc_qpel_uni_hv6_8_i8mm: 268.7
put_hevc_qpel_uni_hv8_8_c: 1345.7
put_hevc_qpel_uni_hv8_8_i8mm: 300.4
put_hevc_qpel_uni_hv12_8_c: 2757.4
put_hevc_qpel_uni_hv12_8_i8mm: 581.4
pu
checkasm bench:
put_hevc_epel_uni_hv64_8_i8mm: 6568.7
put_hevc_epel_uni_v4_8_c: 88.7
put_hevc_epel_uni_v4_8_neon: 32.7
put_hevc_epel_uni_v6_8_c: 185.4
put_hevc_epel_uni_v6_8_neon: 44.9
put_hevc_epel_uni_v8_8_c: 333.9
put_hevc_epel_uni_v8_8_neon: 44.4
put_hevc_epel_uni_v12_8_c: 728.7
put_hevc_epel_
Marton Balint 于2023年8月26日周六 15:52写道:
Hi Marton,
>
>
>
> On Fri, 25 Aug 2023, Steven Liu wrote:
>
> > Steven Liu 于2023年8月25日周五 18:05写道:
> >>
> >> Add option named rtmp_enhanced_codec,
> >> it would support hvc1,av01,vp09 now,
> >> the fourcc is using Array of strings.
> >>
> >> Signed-off-by: Stev
On Fri, 25 Aug 2023, Steven Liu wrote:
Steven Liu 于2023年8月25日周五 18:05写道:
Add option named rtmp_enhanced_codec,
it would support hvc1,av01,vp09 now,
the fourcc is using Array of strings.
Signed-off-by: Steven Liu
---
doc/protocols.texi | 6 ++
libavformat/rtmpproto.c | 37 ++
55 matches
Mail list logo