On Tue, 31 Aug 2021, at 08:44, Chen, Wenbin wrote:
> Ok, I will submit again.
Wait for the review. :D
--
Jean-Baptiste Kempf - President
+33 672 704 734
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-d
Ok, I will submit again.
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Jean-Baptiste Kempf
> Sent: Tuesday, August 31, 2021 2:07 PM
> To: ffmpeg-devel@ffmpeg.org
> Subject: Re: [FFmpeg-devel] [PATCH 01/10] libavfilter/vulkan: Fix problem
> when device have queue_count greater t
maryam ebrahimzadeh:
> avcodec/vble: Return value check for init_get_bits
>
> As the second argument for init_get_bits can be crafted,
> a return value check for this function call is necessary.
> So replace init_get_bits with init_get_bits8 and remove a duplicate check
> before
> the callsite.
>
Hello,
On Tue, 31 Aug 2021, at 03:43, wenbin.c...@intel.com wrote:
> From: "Chen,Wenbin"
> ...
> Signed-off-by: Wenbin Chen
> ...
> email sent by "wenbin.c...@intel.com" (no name)
In this thread of patches, you have 3 ways of writing your name & email.
You should fix it (and IMHO, use the last
This will gives out more accurate information in case of this
decoder used but doesn't specificed a hwaccel.
For example:
ffmpeg -c:v av1 -i INPUT OUTPUT
Signed-off-by: Fei Wang
---
This is improvement for patch:
https://patchwork.ffmpeg.org/project/ffmpeg/list/?series=4660
https://patchwork.ffm
From: "Chen,Wenbin"
Add hwupload and hwdownload support to vulkan when frames are allocated
in one memory
Signed-off-by: Wenbin Chen
---
libavutil/hwcontext_vulkan.c | 10 --
1 file changed, 8 insertions(+), 2 deletions(-)
diff --git a/libavutil/hwcontext_vulkan.c b/libavutil/hwcontex
From: Wenbin Chen
On the lastset intel-vulkan-driver the VK_EXT_image_drm_format_modifier
flags is enabled. As what driver log recommand, we need to use
VK_IMAGE_TILING_LINEAR or VK_IMAGE_DRM_FORMAT_MODIFIER_EXT to create
VKImage. Add code to get supported modifier for sw_format and use these
mod
From: "Chen,Wenbin"
The vaapi can import external frame, but the planes of the external
frames should be in the same drm object. I add a new function to
allocate vkFrame in one memory and vulkan device will choose a way
to allocate memory according to one_memory flag.
A new variable is added to A
From: "Chen,Wenbin"
According to spec, if we use VkBindImagePlaneMemoryInfo to bind image
we mush create image with disjoint flag.
The offset in subresourcelayout is relative to the base address of
the plane, but the offset in drm is relative to the drm objectis so
I think this offset should be 0
From: "Chen,Wenbin"
Vaapi can import external surface, but all the planes of the external
frames should be in the same drm object. A new flag is introduced and
vulkan can choose to allocate planes in one memory according this flag.
This flag will be enabled when the vulkan device is derived from
From: "Chen,Wenbin"
Vulkan will map nv12 to R8 and GR88, so add this map to vaapi to support
vulkan frame.
Signed-off-by: Wenbin Chen
---
libavutil/hwcontext_vaapi.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/libavutil/hwcontext_vaapi.c b/libavutil/hwcontext_vaapi.c
index 75acc851d6..
From: Bas Nieuwenhuizen
This way we can pass explicit modifiers in. Sometimes the
modifier matters for the number of memory planes that
libva accepts, in particular when dealing with
driver-compressed textures. Furthermore the driver might
not actually be able to determine the implicit modifier
i
From: "Chen,Wenbin"
We chould set waitSem and signalSem differently. Current ffmpeg-vulkan
uses the same sem to set waitSem and signalSem and it doesn't work on
latest intel-vulkan-driver. The commit:
a193060221c4df123e26a562949cae5df3e73cde on mesa causes this problem.
This commit add code to re
From: "Chen,Wenbin"
We should configure VkImageSubresource according to tiling rather than
extension. We use extension to set tiling only when we map from drm.
Normally the output VkImages are not created in this way, and it will
report error when we map these VkImage to drm, so we should configu
From: "Chen,Wenbin"
If the descriptorSetCount is greater than the number of setLayouts,
vkAllocateDescriptorSets will report error. Now fix it.
Now the following command can run on the device that has queue_count greater
than one:
ffmpeg -v verbose -init_hw_device vulkan=vul:0 -filter_hw_device
On Fri, Aug 20, 2021 at 09:29:33PM +0800, lance.lmw...@gmail.com wrote:
> From: Limin Wang
>
> Signed-off-by: Limin Wang
> ---
> fftools/cmdutils.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fftools/cmdutils.c b/fftools/cmdutils.c
> index 2dd035a..ae34118 100644
>
On Sun, Aug 29, 2021 at 10:05 PM Jan Ekström wrote:
>
> On Sun, Aug 29, 2021 at 9:21 PM Paul B Mahol wrote:
> >
> > probably fine if fate passes
>
> Yea, FATE passes :) . I think this stuff not being noticed until now
> is due to nothing checking the metadata values returned by vf_scale
> (since
On Sun, Aug 29, 2021 at 7:43 PM Jan Ekström wrote:
>
> Unlike libx264, libx265 does not handle the chroma format check
> on its own side, so in order to not write out values which are
> supposed to be ignored according to the specification, we limit
> the writing out of chroma sample location to 4
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Paul B Mahol
> Sent: Monday, 30 August 2021 21:51
> To: FFmpeg development discussions and patches de...@ffmpeg.org>
> Subject: Re: [FFmpeg-devel] [PATCH v2 4/8] avfilter/overlay_subs: Add
> overlay_subs filter
>
> No, I think y
No, I think you lack mayor skills and motivations to tackle this subject.
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org wi
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Paul B Mahol
> Sent: Monday, 30 August 2021 20:10
> To: FFmpeg development discussions and patches de...@ffmpeg.org>
> Subject: Re: [FFmpeg-devel] [PATCH v2 4/8] avfilter/overlay_subs: Add
> overlay_subs filter
>
> NACK, code du
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Andreas Rheinhardt
> Sent: Monday, 30 August 2021 20:45
> To: ffmpeg-devel@ffmpeg.org
> Subject: Re: [FFmpeg-devel] [PATCH v2 4/8] avfilter/overlay_subs: Add
> overlay_subs filter
>
> Soft Works:
> > Signed-off-by: softworkz
> >
Soft Works:
> Signed-off-by: softworkz
> ---
> v2 Update:
>
> - Implemented Andreas' suggestions
> - overlay_subs filter:
> - removed duplicated code
> - implemented direct (no pre-conversion) blending of graphical
> subtitle rects
> - Supported input formats:
> - all packed RGB for
avcodec/vble: Return value check for init_get_bits
As the second argument for init_get_bits can be crafted,
a return value check for this function call is necessary.
So replace init_get_bits with init_get_bits8 and remove a duplicate check before
the callsite.
---
libavcodec/vble.c | 6 --
1
NACK, code duplicated.
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".
On Mon, Aug 30, 2021 at 5:36 PM Paul Buxton
wrote:
> Thats, great thanks.
>
> How did you generate the NANs? I don't believe under normal operation
> (i.e. with data converted from YUV video to RGB) we would expect to see
> negative values for the RGB data, so I guess it was from some specific
>
Then remove old incomplete checks.
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".
On Mon, 16. Aug 20:42, Michael Niedermayer wrote:
> On Sun, Aug 15, 2021 at 01:53:23PM -0400, Andriy Gelman wrote:
> > On Sun, 15. Aug 17:15, Michael Niedermayer wrote:
> > > On Sun, Aug 15, 2021 at 08:18:17AM -0400, Andriy Gelman wrote:
> > > > On Sun, 15. Aug 11:17, Nicolas George wrote:
> > > >
Thats, great thanks.
How did you generate the NANs? I don't believe under normal operation (i.e.
with data converted from YUV video to RGB) we would expect to see negative
values for the RGB data, so I guess it was from some specific input tests?
Regards,
Paul
On Sun, Aug 29, 2021 at 12:38 PM Pa
Andreas Rheinhardt:
> AVFormatContext.internal is already allocated by
> avformat_alloc_context() on success; and on error,
> avformat_alloc_context() cleans up manually without
> avformat_free_context().
>
> Signed-off-by: Andreas Rheinhardt
> ---
> libavformat/utils.c | 2 --
> 1 file changed,
On Sat, Aug 28, 2021 at 4:45 AM Michael Niedermayer
wrote:
> On Sat, Aug 07, 2021 at 09:33:27PM +0200, Michael Niedermayer wrote:
> > On Sat, Aug 07, 2021 at 06:15:05PM +0800, Linjie Fu wrote:
> > > From: Linjie Fu
> > >
> > > This reverts commit b3a0548a981db52911dd34d9de254c4fee0a8f79.
> >
> >
On Mon, Aug 30, 2021 at 11:38:53AM +0200, Michael Niedermayer wrote:
> On Mon, Aug 30, 2021 at 10:34:18AM +0200, Anton Khirnov wrote:
> > Quoting Michael Niedermayer (2021-08-29 22:22:04)
> > > On Sun, Aug 29, 2021 at 06:48:36PM +0200, Anton Khirnov wrote:
> > > > Quoting Michael Niedermayer (2021-
When a color indexing transform with 16 or fewer colors is used,
WebP uses "pixel packing", i.e. storing several pixels in one byte,
which virtually reduces the width of the image (see WebPContext's
reduced_width field). This reduced_width should always be used when
reading and applying subsequent
From: Jan Ekström
Unfortunately the current production versions of this software
do not 100% adhere to the CMAF specification, and have decided
to utilize the HTML5 media track identifier for audio descriptions.
This way the default mode of operation is according to the CMAF
specification, but i
From: Jan Ekström
This information is coded in a standard MP4 KindBox and utilizes the
scheme and values as per the DASH role scheme defined in MPEG-DASH.
Other schemes are technically allowed, but where multiple schemes
define the same concepts, the DASH scheme should be utilized.
Such flagging
First patch implements the CMAF specified way of flagging what in FFmpeg
are are called stream dispositions. Other identifiers such as HTML media track
kinds are allowed, but if there is a DASH identifier for something, it should
be utilized in stead.
Second patch is a compatibility patch for one
On Mon, Aug 30, 2021 at 10:34:18AM +0200, Anton Khirnov wrote:
> Quoting Michael Niedermayer (2021-08-29 22:22:04)
> > On Sun, Aug 29, 2021 at 06:48:36PM +0200, Anton Khirnov wrote:
> > > Quoting Michael Niedermayer (2021-08-09 22:30:06)
> > > > On Sun, Aug 08, 2021 at 07:29:41PM +0200, Anton Khirn
Quoting Derek Buitenhuis (2021-08-09 15:43:02)
> On 8/9/2021 11:29 AM, Anton Khirnov wrote:
> > diff --git a/libavfilter/Makefile b/libavfilter/Makefile
> > index b0348ccfa3..27dd0c4b47 100644
> > --- a/libavfilter/Makefile
> > +++ b/libavfilter/Makefile
> > @@ -559,7 +559,8 @@ SKIPHEADERS-$(CONFIG
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Nicolas George
> Sent: Monday, 30 August 2021 10:48
> To: FFmpeg development discussions and patches de...@ffmpeg.org>
> Subject: Re: [FFmpeg-devel] [PATCH v2 0/8] A New Take on the Immortal
> Sub2Video Code
>
> Soft Works (1202
Soft Works (12021-08-30):
> You didn't reply to my questions, neither did you explain your plans.
I have given you pointers to the answers. I have documented my plans.
Are you asking me to spend time and effort explaining again to you
specifically? Are you asking me to be your personal teacher? I
On Mon, Aug 30, 2021 at 3:56 AM Wang, Fei W wrote:
>
> If so, the only way to fix is keep previous check with avctx->hwaccel
> but change its log context like "The AV1 decoder requires a hw acceleration
> to be specified or the specified hw doesn't support AV1 decoding."
>
That sounds right, you
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Nicolas George
> Sent: Monday, 30 August 2021 10:24
> To: FFmpeg development discussions and patches de...@ffmpeg.org>
> Subject: Re: [FFmpeg-devel] [PATCH v2 0/8] A New Take on the Immortal
> Sub2Video Code
>
> Soft Works (1202
Quoting Michael Niedermayer (2021-08-29 22:22:04)
> On Sun, Aug 29, 2021 at 06:48:36PM +0200, Anton Khirnov wrote:
> > Quoting Michael Niedermayer (2021-08-09 22:30:06)
> > > On Sun, Aug 08, 2021 at 07:29:41PM +0200, Anton Khirnov wrote:
> > > > ---
> > > > libavfilter/vf_scale.c | 1 +
> > > > 1
Soft Works (12021-08-30):
> v2 Update:
>
> - Implemented Andreas' suggestions
> - overlay_subs filter:
> - removed duplicated code
> - implemented direct (no pre-conversion) blending of graphical
> subtitle rects
> - Supported input formats:
> - all packed RGB formats (with and witho
There are some other checks in init_get_bits function that make the function
return AVERROR_INVALIDDATA. So it is essential to check the return value.
Line 629 in libavcodec/get_bits.h function init_get_bits_xe:
if (bit_size >= INT_MAX - FFMAX(7, AV_INPUT_BUFFER_PADDING_SIZE*8) || bit_size
< 0
Signed-off-by: softworkz
---
v2 Update:
- Implemented Andreas' suggestions
- overlay_subs filter:
- removed duplicated code
- implemented direct (no pre-conversion) blending of graphical
subtitle rects
- Supported input formats:
- all packed RGB formats (with and without alpha)
Signed-off-by: softworkz
---
v2 Update:
- Implemented Andreas' suggestions
- overlay_subs filter:
- removed duplicated code
- implemented direct (no pre-conversion) blending of graphical
subtitle rects
- Supported input formats:
- all packed RGB formats (with and without alpha)
Signed-off-by: softworkz
---
v2 Update:
- Implemented Andreas' suggestions
- overlay_subs filter:
- removed duplicated code
- implemented direct (no pre-conversion) blending of graphical
subtitle rects
- Supported input formats:
- all packed RGB formats (with and without alpha)
Signed-off-by: softworkz
---
v2 Update:
- Implemented Andreas' suggestions
- overlay_subs filter:
- removed duplicated code
- implemented direct (no pre-conversion) blending of graphical
subtitle rects
- Supported input formats:
- all packed RGB formats (with and without alpha)
Signed-off-by: softworkz
---
v2 Update:
- Implemented Andreas' suggestions
- overlay_subs filter:
- removed duplicated code
- implemented direct (no pre-conversion) blending of graphical
subtitle rects
- Supported input formats:
- all packed RGB formats (with and without alpha)
Signed-off-by: softworkz
---
v2 Update:
- Implemented Andreas' suggestions
- overlay_subs filter:
- removed duplicated code
- implemented direct (no pre-conversion) blending of graphical
subtitle rects
- Supported input formats:
- all packed RGB formats (with and without alpha)
Signed-off-by: softworkz
---
v2 Update:
- Implemented Andreas' suggestions
- overlay_subs filter:
- removed duplicated code
- implemented direct (no pre-conversion) blending of graphical
subtitle rects
- Supported input formats:
- all packed RGB formats (with and without alpha)
Signed-off-by: softworkz
---
v2 Update:
- Implemented Andreas' suggestions
- overlay_subs filter:
- removed duplicated code
- implemented direct (no pre-conversion) blending of graphical
subtitle rects
- Supported input formats:
- all packed RGB formats (with and without alpha)
v2 Update:
- Implemented Andreas' suggestions
- overlay_subs filter:
- removed duplicated code
- implemented direct (no pre-conversion) blending of graphical
subtitle rects
- Supported input formats:
- all packed RGB formats (with and without alpha)
- yuv420p, yuv422p, yuv444
On Mon, 2021-08-30 at 05:52 +, Soft Works wrote:
> > -Original Message-
> > From: ffmpeg-devel On Behalf Of
> > Xiang, Haihao
> > Sent: Monday, 30 August 2021 06:20
> > To: ffmpeg-devel@ffmpeg.org
> > Subject: Re: [FFmpeg-devel] [PATCH v5 00/20] clean-up QSV filters
> >
> > On Thu, 20
55 matches
Mail list logo