Re: [FFmpeg-devel] [PATCH 5/6] avformat/udp: clarify option description for timeout unit

2020-10-14 Thread lance . lmwang
On Wed, Oct 14, 2020 at 05:03:56PM +0200, Nicolas George wrote: > lance.lmw...@gmail.com (12020-10-14): > > From: Limin Wang > > > > Signed-off-by: Limin Wang > > --- > > libavformat/udp.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/libavformat/udp.c b/libavf

[FFmpeg-devel] [PATCH 4/5] lavu/hwcontext_amf: Engine selection support for AMF context

2020-10-14 Thread OvchinnikovDmitrii
--- libavcodec/amfenc.c | 9 +++- libavcodec/amfenc.h | 1 + libavcodec/amfenc_h264.c | 8 +++ libavcodec/amfenc_hevc.c | 8 +++ libavutil/hwcontext_amf.c | 104 ++ libavutil/hwcontext_amf.h | 7 +++ 6 files changed, 116 insertions(+), 21

[FFmpeg-devel] [PATCH 5/5] lavf/vf_scale_amf: AMF scaler/format converter filter

2020-10-14 Thread OvchinnikovDmitrii
From: Alexander Kravchenko --- configure | 1 + libavfilter/Makefile | 1 + libavfilter/allfilters.c | 1 + libavfilter/vf_scale_amf.c | 623 + 4 files changed, 626 insertions(+) create mode 100644 libavfilter/vf_scale_amf.c di

[FFmpeg-devel] [PATCH 2/5] lavu/hwcontext_amf: HWContext for AMF based components

2020-10-14 Thread OvchinnikovDmitrii
From: Alexander Kravchenko --- libavutil/Makefile | 2 + libavutil/hwcontext.c | 4 + libavutil/hwcontext.h | 1 + libavutil/hwcontext_amf.c | 284 + libavutil/hwcontext_amf.h | 54 +++ libavutil/hwcontext_interna

[FFmpeg-devel] [PATCH 1/2] avcodec/movtextenc: fix writing to bytestream on BE arches

2020-10-14 Thread Andriy Gelman
From: Andriy Gelman Fixes fate-binsub-movtextenc on PPC64 Currently tags are written in reverse order on BE arches. This is fixed by using MKBETAG() and AV_RB32() to be arch agnostics. Also s->font_count is of type int. On BE arches with 32bit int, count = AV_RB16(&s->font_count) will read two

[FFmpeg-devel] [PATCH 2/2] avcodec/movtextenc: cosmetics

2020-10-14 Thread Andriy Gelman
From: Andriy Gelman Change pointer position. Signed-off-by: Andriy Gelman --- libavcodec/movtextenc.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/libavcodec/movtextenc.c b/libavcodec/movtextenc.c index f38cd9cba2..5f60b8db61 100644 --- a/libavcodec/movtex

Re: [FFmpeg-devel] [PATCH 5/6] avformat/subviewerdec: fail on AV_NOPTS_VALUE

2020-10-14 Thread Michael Niedermayer
On Sun, Jul 19, 2020 at 07:42:17PM +0200, Michael Niedermayer wrote: > Such values are not supported by ff_subtitles_queue* > > Fixes: signed integer overflow: 10 - -9223372036854775808 cannot be > represented in type 'long' > Fixes: > 24193/clusterfuzz-testcase-minimized-ffmpeg_DEMUXER_fuzzer-5

Re: [FFmpeg-devel] [PATCH 1/6] avformat/rtpdec: update the previous with new seq

2020-10-14 Thread Martin Storsjö
On Wed, 14 Oct 2020, lance.lmw...@gmail.com wrote: From: Limin Wang If the rtp input is discontinued, we'll drop all the new received packets now, It's better to update the previous seq with the new seq so that the following packets will not be dropped always. Signed-off-by: Limin Wang --- l

Re: [FFmpeg-devel] [PATCH 1/2] avcodec/notchlc: Check uncompressed size against input for LZ4

2020-10-14 Thread Paul B Mahol
On Wed, Oct 14, 2020 at 09:17:40PM +0200, Michael Niedermayer wrote: > On Wed, Oct 14, 2020 at 07:54:34PM +0200, Paul B Mahol wrote: > > On Wed, Oct 14, 2020 at 05:53:07PM +0200, Michael Niedermayer wrote: > > > Fixes: OOM > > > Fixes: > > > 26168/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_

Re: [FFmpeg-devel] [PATCH 2/3] ffmpeg.c: refine picking default video stream

2020-10-14 Thread Michael Niedermayer
On Wed, Oct 14, 2020 at 02:26:51PM -0300, James Almer wrote: > On 10/14/2020 2:09 PM, Michael Niedermayer wrote: > > On Wed, Oct 14, 2020 at 10:53:10AM +0200, Anton Khirnov wrote: > >> Use a floating-point score value to take into account bitrate, when > >> multiple streams with the same resolution

Re: [FFmpeg-devel] [PATCH 1/2] avcodec/notchlc: Check uncompressed size against input for LZ4

2020-10-14 Thread Michael Niedermayer
On Wed, Oct 14, 2020 at 07:54:34PM +0200, Paul B Mahol wrote: > On Wed, Oct 14, 2020 at 05:53:07PM +0200, Michael Niedermayer wrote: > > Fixes: OOM > > Fixes: > > 26168/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_NOTCHLC_fuzzer-6019839015256064 > > > > Found-by: continuous fuzzing process

Re: [FFmpeg-devel] [PATCH 1/9] avcodec/asvdec: Reduce the size of some VLCs

2020-10-14 Thread Michael Niedermayer
On Tue, Oct 13, 2020 at 11:10:09AM +0200, Andreas Rheinhardt wrote: > Signed-off-by: Andreas Rheinhardt > --- > libavcodec/asvdec.c | 27 +++ > 1 file changed, 15 insertions(+), 12 deletions(-) ok thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611E

Re: [FFmpeg-devel] [PATCH 2/9] avcodec/asvdec: Use init_get_bits8()

2020-10-14 Thread Michael Niedermayer
On Tue, Oct 13, 2020 at 11:10:10AM +0200, Andreas Rheinhardt wrote: > Signed-off-by: Andreas Rheinhardt > --- > libavcodec/asvdec.c | 4 +++- > 1 file changed, 3 insertions(+), 1 deletion(-) ok thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB "Nothing to h

Re: [FFmpeg-devel] [PATCH 4/9] avcodec/asvenc: Inline constants

2020-10-14 Thread Michael Niedermayer
On Tue, Oct 13, 2020 at 11:10:12AM +0200, Andreas Rheinhardt wrote: > Signed-off-by: Andreas Rheinhardt > --- > libavcodec/asvenc.c | 8 > 1 file changed, 4 insertions(+), 4 deletions(-) ok thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB "I am no

Re: [FFmpeg-devel] [PATCH 6/9] avcodec/asvenc: Avoid reversing output data twice

2020-10-14 Thread Michael Niedermayer
On Tue, Oct 13, 2020 at 11:10:14AM +0200, Andreas Rheinhardt wrote: > The ASUS V2 format is designed for a little-endian bitstream reader, yet > our encoder used an ordinary big-endian bitstream writer to write it; > the bits of every byte were swapped at the end and some data (namely the > numbers

Re: [FFmpeg-devel] [PATCH 8/9] avcodec/v3/408enc: Remove empty close functions

2020-10-14 Thread Michael Niedermayer
On Tue, Oct 13, 2020 at 11:10:16AM +0200, Andreas Rheinhardt wrote: > Signed-off-by: Andreas Rheinhardt > --- > libavcodec/v308enc.c | 6 -- > libavcodec/v408enc.c | 7 --- > 2 files changed, 13 deletions(-) LGTM thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611E

Re: [FFmpeg-devel] [PATCH 2/3] ffmpeg.c: refine picking default video stream

2020-10-14 Thread Gyan Doshi
On 14-10-2020 02:23 pm, Anton Khirnov wrote: Use a floating-point score value to take into account bitrate, when multiple streams with the same resolution are present. Stop accessing private AVStream.codec_info_nb_frames field, as the sample in question http://samples.ffmpeg.org/ffmpeg-bugs/tr

Re: [FFmpeg-devel] [PATCH 1/2] avcodec/notchlc: Check uncompressed size against input for LZ4

2020-10-14 Thread Paul B Mahol
On Wed, Oct 14, 2020 at 05:53:07PM +0200, Michael Niedermayer wrote: > Fixes: OOM > Fixes: > 26168/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_NOTCHLC_fuzzer-6019839015256064 > > Found-by: continuous fuzzing process > https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg > Signed-

Re: [FFmpeg-devel] [PATCH 2/3] ffmpeg.c: refine picking default video stream

2020-10-14 Thread James Almer
On 10/14/2020 2:09 PM, Michael Niedermayer wrote: > On Wed, Oct 14, 2020 at 10:53:10AM +0200, Anton Khirnov wrote: >> Use a floating-point score value to take into account bitrate, when >> multiple streams with the same resolution are present. >> >> Stop accessing private AVStream.codec_info_nb_fra

Re: [FFmpeg-devel] [PATCH 9/9] avcodec/ylc: Inline constants

2020-10-14 Thread Michael Niedermayer
On Tue, Oct 13, 2020 at 11:10:17AM +0200, Andreas Rheinhardt wrote: > Signed-off-by: Andreas Rheinhardt > --- > libavcodec/ylc.c | 10 +- > 1 file changed, 5 insertions(+), 5 deletions(-) > > diff --git a/libavcodec/ylc.c b/libavcodec/ylc.c > index 2afe3fc9d5..ecfecc0292 100644 > --- a/l

Re: [FFmpeg-devel] [PATCH 1/3] ffmpeg.c: rename 'area' to 'score'

2020-10-14 Thread Michael Niedermayer
On Wed, Oct 14, 2020 at 10:53:09AM +0200, Anton Khirnov wrote: > Other factors besides area are used to pick the best video stream, so > the name 'area' is misleading. > --- > fftools/ffmpeg_opt.c | 12 ++-- > 1 file changed, 6 insertions(+), 6 deletions(-) yes, *score is a better name,

Re: [FFmpeg-devel] [PATCH] Unbreak av_malloc_max(0) API/ABI

2020-10-14 Thread Joakim Tjernlund
On Tue, 2020-10-13 at 20:33 +0200, Joakim Tjernlund wrote: > On Tue, 2020-10-13 at 20:11 +0200, Andreas Rheinhardt wrote: > > > > Joakim Tjernlund: > > > On Tue, 2020-10-13 at 15:24 +0100, Derek Buitenhuis wrote: > > > > > > > > On 13/10/2020 15:19, Joakim Tjernlund wrote: > > > > > For now just

Re: [FFmpeg-devel] [PATCH 2/3] ffmpeg.c: refine picking default video stream

2020-10-14 Thread Michael Niedermayer
On Wed, Oct 14, 2020 at 10:53:10AM +0200, Anton Khirnov wrote: > Use a floating-point score value to take into account bitrate, when > multiple streams with the same resolution are present. > > Stop accessing private AVStream.codec_info_nb_frames field, as the > sample in question > http://samples

[FFmpeg-devel] [PATCH 2/2] avcodec/decode/ff_get_buffer: Check for overflow in FFALIGN()

2020-10-14 Thread Michael Niedermayer
Fixes: signed integer overflow: 2147483647 + 64 cannot be represented in type 'int' Fixes: 26218/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_CRI_fuzzer-5734075396259840 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Micha

[FFmpeg-devel] [PATCH 1/2] avcodec/notchlc: Check uncompressed size against input for LZ4

2020-10-14 Thread Michael Niedermayer
Fixes: OOM Fixes: 26168/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_NOTCHLC_fuzzer-6019839015256064 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Michael Niedermayer --- libavcodec/notchlc.c | 3 +++ 1 file changed, 3 i

[FFmpeg-devel] [PATCH 6/6] avformat/udp: cosmetics

2020-10-14 Thread lance . lmwang
From: Limin Wang Signed-off-by: Limin Wang --- libavformat/udp.c | 31 +++ 1 file changed, 15 insertions(+), 16 deletions(-) diff --git a/libavformat/udp.c b/libavformat/udp.c index ee5fa84..0ff7deb 100644 --- a/libavformat/udp.c +++ b/libavformat/udp.c @@ -190,7 +1

Re: [FFmpeg-devel] [PATCH 5/6] avformat/udp: clarify option description for timeout unit

2020-10-14 Thread Nicolas George
lance.lmw...@gmail.com (12020-10-14): > From: Limin Wang > > Signed-off-by: Limin Wang > --- > libavformat/udp.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavformat/udp.c b/libavformat/udp.c > index 30d8041..ee5fa84 100644 > --- a/libavformat/udp.c > +++ b/liba

[FFmpeg-devel] [PATCH 1/6] avformat/rtpdec: update the previous with new seq

2020-10-14 Thread lance . lmwang
From: Limin Wang If the rtp input is discontinued, we'll drop all the new received packets now, It's better to update the previous seq with the new seq so that the following packets will not be dropped always. Signed-off-by: Limin Wang --- libavformat/rtpdec.c | 1 + 1 file changed, 1 insertio

[FFmpeg-devel] [PATCH 5/6] avformat/udp: clarify option description for timeout unit

2020-10-14 Thread lance . lmwang
From: Limin Wang Signed-off-by: Limin Wang --- libavformat/udp.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavformat/udp.c b/libavformat/udp.c index 30d8041..ee5fa84 100644 --- a/libavformat/udp.c +++ b/libavformat/udp.c @@ -138,7 +138,7 @@ static const AVOption opti

[FFmpeg-devel] [PATCH 3/6] avformat/rtsp: support for listen_timeout option for sdp

2020-10-14 Thread lance . lmwang
From: Limin Wang Now the listen timeout is hardcoded(10s). How to test(30s timeout): ./ffprobe -listen_timeout 30 -protocol_whitelist rtp,udp,file -i test.sdp Signed-off-by: Limin Wang --- libavformat/rtsp.c | 10 ++ 1 file changed, 6 insertions(+), 4 deletions(-) diff --git a/libavf

[FFmpeg-devel] [PATCH 4/6] avformat/rtsp: reuse POLLING_TIME and remove POLL_TIMEOUT_MS

2020-10-14 Thread lance . lmwang
From: Limin Wang Signed-off-by: Limin Wang --- libavformat/rtsp.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/libavformat/rtsp.c b/libavformat/rtsp.c index 4ecd702..49c2d52 100644 --- a/libavformat/rtsp.c +++ b/libavformat/rtsp.c @@ -51,9 +51,7 @@ #include "rtpe

[FFmpeg-devel] [PATCH 2/6] avformat/rtpproto: support for rtp read timeout

2020-10-14 Thread lance . lmwang
From: Limin Wang then we can set the rtp read timeout instead of infinite timeout. How to test(5s timeout): ./ffprobe -i rtp://192.168.1.67:1234?timeout=500 Signed-off-by: Limin Wang --- doc/protocols.texi | 3 +++ libavformat/rtpproto.c | 12 +++- 2 files changed, 14 inserti

[FFmpeg-devel] [PATCH 1/6 v2] avdevice/alldevices: stop using deprecated linked list API

2020-10-14 Thread James Almer
Signed-off-by: James Almer --- libavdevice/alldevices.c | 72 libavdevice/avdevice.c | 46 - 2 files changed, 72 insertions(+), 46 deletions(-) diff --git a/libavdevice/alldevices.c b/libavdevice/alldevices.c index a6f68dd3bb..c3

Re: [FFmpeg-devel] [PATCH 2/3] avdevice: add new API for iterating input and output devices

2020-10-14 Thread James Almer
On 10/14/2020 10:56 AM, Anton Khirnov wrote: > Quoting James Almer (2020-10-09 22:18:10) >> And deprecate the linked list based one. >> >> Based on a patch by Josh de Kock. >> >> Signed-off-by: James Almer >> --- >> doc/APIchanges | 5 + >> libavdevice/alldevices.c | 22 +++

Re: [FFmpeg-devel] [PATCH 2/3] avdevice: add new API for iterating input and output devices

2020-10-14 Thread Anton Khirnov
Quoting James Almer (2020-10-09 22:18:10) > And deprecate the linked list based one. > > Based on a patch by Josh de Kock. > > Signed-off-by: James Almer > --- > doc/APIchanges | 5 + > libavdevice/alldevices.c | 22 ++ > libavdevice/avdevice.h | 36

Re: [FFmpeg-devel] [PATCH 1/3] avdevice/alldevices: stop using deprecated linked list API

2020-10-14 Thread Anton Khirnov
Quoting James Almer (2020-10-09 22:18:09) > Signed-off-by: James Almer > --- > libavdevice/alldevices.c | 76 > libavdevice/avdevice.c | 46 > 2 files changed, 76 insertions(+), 46 deletions(-) > > diff --git a/libavdevice/allde

Re: [FFmpeg-devel] [RFC] License for tools/uncoded_frame.c

2020-10-14 Thread Gyan Doshi
Ping. Anyone? On 10-10-2020 05:22 pm, Gyan Doshi wrote: No license is attached to tools/uncoded_frame.c as of 11a6347f9e Does LGPL v2.1 apply, by default? Regards, Gyan ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/

[FFmpeg-devel] [PATCH 7/7] avcodec/adpcmenc: remove BLKSIZE #define

2020-10-14 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- libavcodec/adpcm.h| 2 -- libavcodec/adpcmenc.c | 2 +- 2 files changed, 1 insertion(+), 3 deletions(-) diff --git a/libavcodec/adpcm.h b/libavcodec/adpcm.h index dc0d49ac61..0ffc3da1d0 100644 --- a/libavcodec/adpcm.h +++ b/libavcodec/adpcm.h @@ -28,8 +28,6

[FFmpeg-devel] [PATCH 6/7] avcodec/adpcm_ima_wav: support variable block size for encoding

2020-10-14 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- libavcodec/adpcmenc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavcodec/adpcmenc.c b/libavcodec/adpcmenc.c index 800a9b0b00..83c7e7ee05 100644 --- a/libavcodec/adpcmenc.c +++ b/libavcodec/adpcmenc.c @@ -113,11 +113,11 @@ static a

[FFmpeg-devel] [PATCH 5/7] avcodec/adpcm_yamaha: support variable block size for encoding

2020-10-14 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- libavcodec/adpcmenc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavcodec/adpcmenc.c b/libavcodec/adpcmenc.c index d234d3dbf2..800a9b0b00 100644 --- a/libavcodec/adpcmenc.c +++ b/libavcodec/adpcmenc.c @@ -142,8 +142,8 @@ static av_

[FFmpeg-devel] [PATCH 2/7] avcodec/adpcm_ms: support variable block size for encoding

2020-10-14 Thread Zane van Iperen
Fixes tickets #6585 and #7109 Signed-off-by: Zane van Iperen --- libavcodec/adpcmenc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavcodec/adpcmenc.c b/libavcodec/adpcmenc.c index 0038a10830..fc29bf8571 100644 --- a/libavcodec/adpcmenc.c +++ b/libavcodec/adpcmenc.c

[FFmpeg-devel] [PATCH 4/7] avcodec/adpcm_ima_apm: support variable block size for encoding

2020-10-14 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- libavcodec/adpcmenc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavcodec/adpcmenc.c b/libavcodec/adpcmenc.c index 2907ac8d77..d234d3dbf2 100644 --- a/libavcodec/adpcmenc.c +++ b/libavcodec/adpcmenc.c @@ -160,8 +160,8 @@ static av_

[FFmpeg-devel] [PATCH 3/7] avcodec/adpcm_ima_ssi: support variable block size for encoding

2020-10-14 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- libavcodec/adpcmenc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavcodec/adpcmenc.c b/libavcodec/adpcmenc.c index fc29bf8571..2907ac8d77 100644 --- a/libavcodec/adpcmenc.c +++ b/libavcodec/adpcmenc.c @@ -156,8 +156,8 @@ static av_

[FFmpeg-devel] [PATCH 1/7] avcodec/adpcmenc: add "block_size" option

2020-10-14 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- libavcodec/adpcmenc.c | 32 1 file changed, 32 insertions(+) diff --git a/libavcodec/adpcmenc.c b/libavcodec/adpcmenc.c index 24bd31c4a9..0038a10830 100644 --- a/libavcodec/adpcmenc.c +++ b/libavcodec/adpcmenc.c @@ -22,6 +22,8 @

[FFmpeg-devel] [PATCH 2/3] ffmpeg.c: refine picking default video stream

2020-10-14 Thread Anton Khirnov
Use a floating-point score value to take into account bitrate, when multiple streams with the same resolution are present. Stop accessing private AVStream.codec_info_nb_frames field, as the sample in question http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket2639/Thailand-Wave.wmv is now handled by

[FFmpeg-devel] [PATCH 3/3] ffmpeg.c: refactor picking default video stream

2020-10-14 Thread Anton Khirnov
Do not bother computing the score for streams that are going to be skipped. This is easier to follow. --- fftools/ffmpeg_opt.c | 13 +++-- 1 file changed, 7 insertions(+), 6 deletions(-) diff --git a/fftools/ffmpeg_opt.c b/fftools/ffmpeg_opt.c index afef23919c..eebb678e5e 100644 --- a/fft

[FFmpeg-devel] [PATCH 1/3] ffmpeg.c: rename 'area' to 'score'

2020-10-14 Thread Anton Khirnov
Other factors besides area are used to pick the best video stream, so the name 'area' is misleading. --- fftools/ffmpeg_opt.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/fftools/ffmpeg_opt.c b/fftools/ffmpeg_opt.c index 19f719e3ff..a0d1b06f2d 100644 --- a/fftoo