[FFmpeg-devel] [PATCH] libavcodec/pnm_parser: do not loose skipped parts in reporting of how much was consumed

2018-09-03 Thread Michael Niedermayer
Fixes: Timeout Fixes: 9759/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_PPM_fuzzer-5655277650051072 Fixes: 9753/clusterfuzz-testcase-minimized-ffmpeg_AV_CODEC_ID_PGMYUV_fuzzer-5764378543521792 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmp

Re: [FFmpeg-devel] [PATCH 2/4] libavcodec: v4l2m2m: output AVDRMFrameDescriptor

2018-09-03 Thread Mark Thompson
On 17/08/18 04:36, Lukas Rusak wrote: > On Sat, 2018-08-04 at 22:43 +0100, Mark Thompson wrote: >> On 04/08/18 01:40, Lukas Rusak wrote: >>> This allows for a zero-copy output by exporting the v4l2 buffer >>> then wrapping that buffer >>> in the AVDRMFrameDescriptor like it is done in rkmpp. >>> >>

Re: [FFmpeg-devel] [PATCH 1/2] libavcodec/libx264: do not define X264_API_IMPORTS

2018-09-03 Thread Hendrik Leppkes
On Mon, Sep 3, 2018 at 7:27 PM wrote: > > From: Anonymous Maarten > > These defines should be passed by pkg-config. Are they? Because if not, you should get that fixed upstream first before these commits are acceptable and cause regressions. - Hendrik ___

[FFmpeg-devel] Do not define API_IMPORTS for libx264 and libx265

2018-09-03 Thread anonymous . maarten
When building ffmpeg on Visual Studio, libavcodec/libx264.c and libavcodec/libx265.c assume that ffmpeg is linked to a dynamic libx264 and libx265 library. Instead, this information is delivered by pkg-config. Linking ffmpeg to a static libx264 causes LNK4049 warnings to be emitted. Because warn

[FFmpeg-devel] [PATCH 1/2] libavcodec/libx264: do not define X264_API_IMPORTS

2018-09-03 Thread anonymous . maarten
From: Anonymous Maarten These defines should be passed by pkg-config. --- libavcodec/libx264.c | 4 1 file changed, 4 deletions(-) diff --git a/libavcodec/libx264.c b/libavcodec/libx264.c index 54e6703d73..b6f4c102c4 100644 --- a/libavcodec/libx264.c +++ b/libavcodec/libx264.c @@ -29,10 +2

[FFmpeg-devel] [PATCH 2/2] libavcodec/libx265: do not define X265_API_IMPORTS

2018-09-03 Thread anonymous . maarten
From: Anonymous Maarten The defines should be passed by pkg-config. Signed-off-by: Anonymous Maarten --- libavcodec/libx265.c | 4 1 file changed, 4 deletions(-) diff --git a/libavcodec/libx265.c b/libavcodec/libx265.c index 27c90b323f..f794205198 100644 --- a/libavcodec/libx265.c +++ b/

Re: [FFmpeg-devel] [PATCH] avcodec/utvideodec: use cached bitstream reader only on targets with fast 64bit ops

2018-09-03 Thread Carl Eugen Hoyos
2018-09-02 19:46 GMT+02:00, James Almer : > fast_64 is a > configure time constant used in a lot of speed critical modules to > choose between using 32bit or 64bit ops, so seeing how this new > bitstream reader uses a 64bit cache I'd expect it to be slower in such > targets as well. Do you have a

Re: [FFmpeg-devel] [PATCH] frame: Simplify the video allocation

2018-09-03 Thread James Almer
On 9/3/2018 11:56 AM, James Darnley wrote: > On 2018-09-03 15:29, James Almer wrote: >> pass 32 - 1 to both av_image_fill_pointers() calls directly? > > Please do not add a magic number where nobody will find it. Use one of > the 3 already existing methods for knowing the alignment necessary for

Re: [FFmpeg-devel] [PATCH] frame: Simplify the video allocation

2018-09-03 Thread James Darnley
On 2018-09-03 15:29, James Almer wrote: > pass 32 - 1 to both av_image_fill_pointers() calls directly? Please do not add a magic number where nobody will find it. Use one of the 3 already existing methods for knowing the alignment necessary for assembly. If this is unrelated, my apologies.

Re: [FFmpeg-devel] [PATCH 8/8] avformat/dashdec: refine compute current fragment for presentation_timeoffset mode

2018-09-03 Thread Steven Liu
> On Sep 3, 2018, at 19:55, Carl Eugen Hoyos wrote: > > 2018-09-03 12:06 GMT+02:00, Steven Liu : >> use ((wallclock - availability_start_time) * timescale >> -presentation_timeoffset) / duration > > Please mention ticket #7382 if it is related. Ok, will mention ticket #7382. > > Carl Eugen >

Re: [FFmpeg-devel] [PATCH] frame: Simplify the video allocation

2018-09-03 Thread James Almer
On 9/3/2018 5:17 AM, Michael Niedermayer wrote: > On Sun, Sep 02, 2018 at 09:34:23PM -0300, James Almer wrote: >> From: Luca Barbato >> >> Merged-by: James Almer >> --- >> This is the next merge in the queue. It's a critical part of the AVFrame API, >> so even if FATE passes I'd rather have other

Re: [FFmpeg-devel] [PATCH 8/8] avformat/dashdec: refine compute current fragment for presentation_timeoffset mode

2018-09-03 Thread Carl Eugen Hoyos
2018-09-03 12:06 GMT+02:00, Steven Liu : > use ((wallclock - availability_start_time) * timescale > -presentation_timeoffset) / duration Please mention ticket #7382 if it is related. Carl Eugen ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http:

Re: [FFmpeg-devel] [PATCH 8/8] avformat/dashdec: refine compute current fragment for presentation_timeoffset mode

2018-09-03 Thread Carl Eugen Hoyos
2018-09-03 12:06 GMT+02:00, Steven Liu : > use ((wallclock - availability_start_time) * timescale > -presentation_timeoffset) / duration Please mention ticket #7382 if it is related. Carl Eugen ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http:

Re: [FFmpeg-devel] [PATCH] avfilter/vf_transpose adding NPP transpose filter

2018-09-03 Thread Timo Rothenpieler
I did some re-formating and added the missing configure bit. Updated patch for that can be found on Github: https://github.com/BtbN/FFmpeg/commit/3e9ad52cfbebfade0d26758dad862e0c0a002c91 https://github.com/BtbN/FFmpeg/commit/3e9ad52cfbebfade0d26758dad862e0c0a002c91.patch smime.p7s Description

Re: [FFmpeg-devel] [PATCH] avfilter/vf_transpose adding NPP transpose filter

2018-09-03 Thread Timo Rothenpieler
Minus the missing configure dependency, documentation entry and minor bump, the filter looks fine to me code wise. Two issues though: From my understanding, it's not a transpose filter, but a rotation one, fixed to 90 degree angles. Unless I'm missing something in the code, it's not doing any

[FFmpeg-devel] [PATCH 7/8] avformat/dashdec: reindent code for previous commit

2018-09-03 Thread Steven Liu
Signed-off-by: Steven Liu --- libavformat/dashdec.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavformat/dashdec.c b/libavformat/dashdec.c index 2a2d7455cd..854d7edc59 100644 --- a/libavformat/dashdec.c +++ b/libavformat/dashdec.c @@ -1346,7 +1346,7 @@ static int64_t ca

[FFmpeg-devel] [PATCH 6/8] avformat/dashdec: add min_buffer_time process logic

2018-09-03 Thread Steven Liu
if there have min_buffer_time in playlist, use the min_buffer_time value for realtime. Signed-off-by: Steven Liu --- libavformat/dashdec.c | 4 1 file changed, 4 insertions(+) diff --git a/libavformat/dashdec.c b/libavformat/dashdec.c index 40e12e19ce..2a2d7455cd 100644 --- a/libavformat/d

[FFmpeg-devel] [PATCH 2/8] avformat/dashdec: refine adaptionset attribute members

2018-09-03 Thread Steven Liu
Signed-off-by: Steven Liu --- libavformat/dashdec.c | 27 +++ 1 file changed, 27 insertions(+) diff --git a/libavformat/dashdec.c b/libavformat/dashdec.c index 0977517ce5..ff6684c511 100644 --- a/libavformat/dashdec.c +++ b/libavformat/dashdec.c @@ -122,6 +122,19 @@ struc

[FFmpeg-devel] [PATCH 8/8] avformat/dashdec: refine compute current fragment for presentation_timeoffset mode

2018-09-03 Thread Steven Liu
use ((wallclock - availability_start_time) * timescale -presentation_timeoffset) / duration Signed-off-by: Steven Liu --- libavformat/dashdec.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavformat/dashdec.c b/libavformat/dashdec.c index 854d7edc59..1fce8861a1 100644 -

[FFmpeg-devel] [PATCH 4/8] avformat/dashdec: reindent code for previous commit

2018-09-03 Thread Steven Liu
Signed-off-by: Steven Liu --- libavformat/dashdec.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavformat/dashdec.c b/libavformat/dashdec.c index 9d69045d37..14a54a02cf 100644 --- a/libavformat/dashdec.c +++ b/libavformat/dashdec.c @@ -1577,7 +1577,7 @@ static int read_f

[FFmpeg-devel] [PATCH 1/8] avformat/dashdec: refine mpd element of attribute name availabilityEndTime

2018-09-03 Thread Steven Liu
Signed-off-by: Steven Liu --- libavformat/dashdec.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/libavformat/dashdec.c b/libavformat/dashdec.c index 0435f25412..0977517ce5 100644 --- a/libavformat/dashdec.c +++ b/libavformat/dashdec.c @@ -132,6 +132,7 @@ typedef struct DASHContext {

[FFmpeg-devel] [PATCH 3/8] avformat/dashdec: remove redundant code

2018-09-03 Thread Steven Liu
Signed-off-by: Steven Liu --- libavformat/dashdec.c | 19 +++ 1 file changed, 3 insertions(+), 16 deletions(-) diff --git a/libavformat/dashdec.c b/libavformat/dashdec.c index ff6684c511..9d69045d37 100644 --- a/libavformat/dashdec.c +++ b/libavformat/dashdec.c @@ -1568,14 +1568,

[FFmpeg-devel] [PATCH 5/8] avformat/dashdec: add trace message for get the logic output message

2018-09-03 Thread Steven Liu
Signed-off-by: Steven Liu --- libavformat/dashdec.c | 18 ++ 1 file changed, 18 insertions(+) diff --git a/libavformat/dashdec.c b/libavformat/dashdec.c index 14a54a02cf..40e12e19ce 100644 --- a/libavformat/dashdec.c +++ b/libavformat/dashdec.c @@ -919,18 +919,22 @@ static int pa

Re: [FFmpeg-devel] [PATCH] frame: Simplify the video allocation

2018-09-03 Thread Maxym Dmytrychenko
On Mon, Sep 3, 2018 at 10:17 AM Michael Niedermayer wrote: > On Sun, Sep 02, 2018 at 09:34:23PM -0300, James Almer wrote: > > From: Luca Barbato > > > > Merged-by: James Almer > > --- > > This is the next merge in the queue. It's a critical part of the AVFrame > API, > > so even if FATE passes

Re: [FFmpeg-devel] [PATCH] frame: Simplify the video allocation

2018-09-03 Thread Michael Niedermayer
On Sun, Sep 02, 2018 at 09:34:23PM -0300, James Almer wrote: > From: Luca Barbato > > Merged-by: James Almer > --- > This is the next merge in the queue. It's a critical part of the AVFrame API, > so even if FATE passes I'd rather have others look at it and test in case > something breaks. > >

Re: [FFmpeg-devel] [PATCH] avformat/libsrt: fix merge of payload_size option

2018-09-03 Thread Marton Balint
On Sun, 2 Sep 2018, James Almer wrote: On 9/2/2018 8:58 PM, Marton Balint wrote: Fixes a compile error and re-adds pkt_size as a url?option as well. Sorry about that. I made sure to keep the logic as you added it a few days ago instead of adopting the one from libav, including keeping the o