On 12.04.2018 02:01, Lou Logan wrote:
On Tue, Apr 10, 2018, at 11:11 PM, Tobias Rapp wrote:
BTW: Is there some documentation on the generic flags syntax used in
FFmpeg for options like "-fflags" or "-cpuflags" and how to combine the
tokens with "+" or "-"? I couldn't find something on a quick s
On 4/11/18 11:47 PM, Carl Eugen Hoyos wrote:
> 2018-04-11 9:00 GMT+02:00, vdi...@akamai.com :
>
>> +#if FF_API_DASH_MIN_SEG_DURATION
>> +{ "min_seg_duration", "minimum segment duration (in microseconds) (will
>> be deprecated)"
>
> "is deprecated"
> But since this is a user option added after
On 2018/4/3 9:50, Ruiling Song wrote:
> The existing version which was cherry-picked from Libav does not work
> with FFmpeg framework, because ff_request_frame() was totally
> different between Libav (recursive) and FFmpeg (non-recursive).
> The existing overlay_qsv implementation depends on the
> -Original Message-
> From: Li, Zhong
> Sent: Tuesday, April 10, 2018 11:39 AM
> To: FFmpeg development discussions and patches
> Cc: Song, Ruiling
> Subject: RE: [FFmpeg-devel] [PATCH v2 1/2] lavf: make overlay_qsv work based
> on framesync
>
> > From: ffmpeg-devel [mailto:ffmpeg-dev
Fixes: crbug 829153
Reported-by: Matt Wolenetz
Reviewed-by: Matt Wolenetz
Signed-off-by: Michael Niedermayer
---
libavformat/utils.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/utils.c b/libavformat/utils.c
index 3e482a3bbc..f958c073b0 100644
--- a/libavform
Fixes: out of array access
Fixes: poc_0411
Found-by: GwanYeong Kim
Tested-by: GwanYeong Kim
Signed-off-by: Michael Niedermayer
---
libavcodec/utils.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/libavcodec/utils.c b/libavcodec/utils.c
index 8c7d056da6..59d41ccbb6 100
From: Steven Liu
When using hls_list_size with hls_flags delete_segments, currently
hls_list_size * 2 +- segments remain on disk. With this new option,
the amount of disk space used can be controlled by the user.
fix ticket: #7131
Signed-off-by: Steven Liu
Signed-off-by: Aman Gupta
---
doc/m
On 2018/4/11 16:52, Marton Balint wrote:
>
>
> On Wed, 11 Apr 2018, Jun Zhao wrote:
>
>>
>>
>> On 2018/4/10 21:54, Marton Balint wrote:
>>>
>>>
>>> On Tue, 10 Apr 2018, Jun Zhao wrote:
>>>
>>>
>>> Maybe you should use ff_read_line_to_bprint instead? It already chops
>>> the trailing lin
On Wed, Apr 11, 2018 at 12:42:07PM -0700, Richard Shaffer wrote:
> On Mon, Apr 9, 2018 at 1:05 AM, Mattias Amnefelt wrote:
>
> > On 2018-04-05 01:00, Mattias Amnefelt wrote:
> >
> >> On 2018-04-04 09:22, Mattias Amnefelt wrote:
> >>
> >>> On 2018-04-04 03:42, James Almer wrote:
> >>>
> On 4/
---
I found this bug while working on my qualification task. When closing
a listening HTTP AVIOContext http_shutdown() tries to write the
chunked-transfer-encoding trailer to the listening Context.
libavformat/http.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/
On Tue, Apr 10, 2018, at 11:11 PM, Tobias Rapp wrote:
>
> BTW: Is there some documentation on the generic flags syntax used in
> FFmpeg for options like "-fflags" or "-cpuflags" and how to combine the
> tokens with "+" or "-"? I couldn't find something on a quick scan.
Doesn't appear to be docum
On Wed, Apr 11, 2018 at 8:07 PM, Carl Eugen Hoyos wrote:
> 2018-04-11 13:40 GMT+02:00, Hendrik Leppkes :
>> If a frame starts very close to a packet boundary, the start code may
>> already have been added to the parsing buffer, indicated by a small
>> negative value of "i", while the header is sti
On Tue, Apr 10, 2018 at 03:53:36PM -0700, Aman Gupta wrote:
> From: Aman Gupta
>
> Before adding uvlinesize check, I was seeing failures decoding
> some video with ffmpeg compiled with --enable-gray and using
> AV_CODEC_FLAG_GRAY.
>
> [mpeg2video @ 0x7fa193818c00] get_buffer() failed (stride ch
I am sorry, sending patch one more time. Outlook was wrapping text.
Sending patch in message body and in attachment
---
libavcodec/amfenc.c | 123 +++-
1 file changed, 102 insertions(+), 21 deletions(-)
diff --git a/libavcodec/amfenc.c b/libavcodec
On Wed, Apr 11, 2018 at 10:37:41PM +0200, Bodecs Bela wrote:
> fate test enclosed
>
>
> 2018.04.04. 10:39 keltezéssel, Bodecs Bela írta:
> >
> >
> >2018.04.04. 2:37 keltezéssel, Michael Niedermayer írta:
> >>On Sun, Apr 01, 2018 at 11:42:34PM +0200, Bodecs Bela wrote:
> >>>Dear All,
> >>>
> >>>cu
Resending patch (mailer mangled the patch)
---
libavcodec/amfenc.c | 123 +++-
1 file changed, 102 insertions(+), 21 deletions(-)
diff --git a/libavcodec/amfenc.c b/libavcodec/amfenc.c
index b9418b6791..c1f65f909d 100644
--- a/libavcodec/amfenc.c
+
---
libavcodec/amfenc.c | 123
+++-
1 file changed, 102 insertions(+), 21 deletions(-)
diff --git a/libavcodec/amfenc.c b/libavcodec/amfenc.c
index b9418b6791..c1f65f909d 100644
--- a/libavcodec/amfenc.c
+++ b/libavcodec/amfenc.c
@@ -24,6 +24,9 @@
On Wed, Apr 11, 2018 at 11:44:47AM +0200, Jerome Martinez wrote:
> On 11/04/2018 00:16, Lou Logan wrote:
> >On Tue, Apr 10, 2018, at 2:05 PM, Michael Niedermayer wrote:
> >>what do you mean by "Git and me are not good friends" ?
> >>If git hates you and sometimes does things that you didnt intend a
fate test enclosed
2018.04.04. 10:39 keltezéssel, Bodecs Bela írta:
2018.04.04. 2:37 keltezéssel, Michael Niedermayer írta:
On Sun, Apr 01, 2018 at 11:42:34PM +0200, Bodecs Bela wrote:
Dear All,
currently when specifying the program id you can only decide to select
all stream of the specif
On Mon, Apr 9, 2018 at 1:05 AM, Mattias Amnefelt wrote:
> On 2018-04-05 01:00, Mattias Amnefelt wrote:
>
>> On 2018-04-04 09:22, Mattias Amnefelt wrote:
>>
>>> On 2018-04-04 03:42, James Almer wrote:
>>>
On 4/3/2018 10:40 PM, Carl Eugen Hoyos wrote:
> 2018-04-04 3:38 GMT+02:00, Jame
2018-04-11 9:00 GMT+02:00, vdi...@akamai.com :
> +#if FF_API_DASH_MIN_SEG_DURATION
> +{ "min_seg_duration", "minimum segment duration (in microseconds) (will
> be deprecated)"
"is deprecated"
But since this is a user option added after the last release, you
may also choose to simply delete it
2017-02-22 22:33 GMT+01:00, Rostislav Pehlivanov :
> On 22 February 2017 at 20:18, Damien Riegel <
> damien.rie...@savoirfairelinux.com> wrote:
>
>> On Fri, Feb 17, 2017 at 03:01:05PM -0500, Damien Riegel wrote:
>> > Hi,
>> >
>> > On Thu, Feb 16, 2017 at 06:19:00PM +, Rostislav Pehlivanov wrote
2018-04-11 13:40 GMT+02:00, Hendrik Leppkes :
> If a frame starts very close to a packet boundary, the start code may
> already have been added to the parsing buffer, indicated by a small
> negative value of "i", while the header is still being tracked in the
> "state" variable.
Do you have a samp
On Wed, 11 Apr 2018 14:25:15 +0100
Rostislav Pehlivanov wrote:
> On 11 April 2018 at 06:22, Timo Teräs wrote:
>
> > Ping.
> >
> > Any comments on this?
> >
> > There was also recently the flacenc support for cover images, and
> > the question if some of this code should be moved to generic code
On Wed, Apr 11, 2018, at 8:23 AM, Gyan Doshi wrote:
> As suggested by Lou Logan, this patch adds myself as a docs maintainer.
I suggested this because the documentation can always use more improvements, we
need more active documentation maintainers, and he has previously shown
interest in this.
As suggested by Lou Logan, this patch adds myself as a docs maintainer.
Thanks,
Gyan
From b18cb5bfb7c8df130892f9ec9552287edac2b17a Mon Sep 17 00:00:00 2001
From: Gyan Doshi
Date: Wed, 11 Apr 2018 21:46:03 +0530
Subject: [PATCH] MAINTAINERS: add myself to documentation section
---
MAINTAINERS |
On 4/11/2018 8:46 AM, Hendrik Leppkes wrote:
> ---
> libavcodec/hevcdec.c | 11 +++
> 1 file changed, 11 insertions(+)
>
> diff --git a/libavcodec/hevcdec.c b/libavcodec/hevcdec.c
> index c8877626d2..e8227a510b 100644
> --- a/libavcodec/hevcdec.c
> +++ b/libavcodec/hevcdec.c
> @@ -344,6 +
On Wed, 11 Apr 2018 13:48:59 +0200
t...@rothenpieler.org wrote:
> From: Timo Rothenpieler
>
> ---
> libavcodec/hevc_ps.c| 5 ++---
> libavcodec/hevc_ps.h| 1 +
> libavcodec/nvdec_hevc.c | 6 ++
> 3 files changed, 9 insertions(+), 3 deletions(-)
>
> diff --git a/libavcodec/hevc_ps.c
On 4/11/2018 9:06 AM, Hendrik Leppkes wrote:
> ---
> libavcodec/vp9.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/libavcodec/vp9.c b/libavcodec/vp9.c
> index 0fac638ec9..b1178c9c0c 100644
> --- a/libavcodec/vp9.c
> +++ b/libavcodec/vp9.c
> @@ -188,6 +188,7 @@ static i
On 4 April 2018 at 15:09, Paul B Mahol wrote:
> Signed-off-by: Paul B Mahol
> ---
> libavcodec/Makefile | 1 +
> libavcodec/allcodecs.c | 1 +
> libavcodec/avcodec.h| 1 +
> libavcodec/codec_desc.c | 8 +
> libavcodec/siren.c | 847 ++
>
On 11 April 2018 at 06:22, Timo Teräs wrote:
> Ping.
>
> Any comments on this?
>
> There was also recently the flacenc support for cover images, and the
> question if some of this code should be moved to generic code in mux.c so
> both can share it: e.g. storing the image packets to attached_pic
Fixes decoding on the Samsung Chromebook Pro which do not set the codec
output format stride and slice-height fields.
---
libavcodec/mediacodecdec_common.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/libavcodec/mediacodecdec_common.c
b/libavcodec/mediacodecdec_common.c
On 28 March 2018 at 22:59, Drew Allen
wrote:
> Hello all,
>
> My name is Andrew Allen and I'm a contributor to Opus, supporting new
> channel mappings 2 and 3 for ambisonics compression. I've attached a patch
> to support the new OpusProjectionEncoder and OpusProjectionDecoder APIs for
> handling
On 10 April 2018 at 22:21, Patrick Keroulas <
patrick.kerou...@savoirfairelinux.com> wrote:
> From: Damien Riegel
>
> This codec is already capable of depacking some combinations of pixel
> formats and depth as defined in the RFC4175. The only difference between
> progressive and interlace is tha
On 10 April 2018 at 22:21, Patrick Keroulas <
patrick.kerou...@savoirfairelinux.com> wrote:
> From: Damien Riegel
>
> ff_get_buffer is used to allocate a buffer to hold frame's content. This
> function was called in the function in charge of decoding an AVPacket
> containing raw video with the yu
On 10 April 2018 at 22:21, Patrick Keroulas <
patrick.kerou...@savoirfairelinux.com> wrote:
> From: Damien Riegel
>
> This codec is already capable of depacking some combinations of pixel
> formats and depth as defined in the RFC4175. The only difference between
> progressive and interlace is tha
On 10 April 2018 at 22:21, Patrick Keroulas <
patrick.kerou...@savoirfairelinux.com> wrote:
> From: Damien Riegel
>
> In order to handle the interlaced formats, the demuxer has only a few
> things to do:
> - parse the SDP correctly and propagate the information
> - check the field bit in the RF
---
libavcodec/vp9.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/vp9.c b/libavcodec/vp9.c
index 0fac638ec9..b1178c9c0c 100644
--- a/libavcodec/vp9.c
+++ b/libavcodec/vp9.c
@@ -188,6 +188,7 @@ static int update_size(AVCodecContext *avctx, int w, int h)
---
libavcodec/dxva2.c | 8 +++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/libavcodec/dxva2.c b/libavcodec/dxva2.c
index 6d831599af..32416112bf 100644
--- a/libavcodec/dxva2.c
+++ b/libavcodec/dxva2.c
@@ -44,6 +44,7 @@ DEFINE_GUID(ff_DXVA2_ModeVC1_D2010, 0x1b81beA4,
0x
---
libavcodec/hevcdec.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/libavcodec/hevcdec.c b/libavcodec/hevcdec.c
index c8877626d2..e8227a510b 100644
--- a/libavcodec/hevcdec.c
+++ b/libavcodec/hevcdec.c
@@ -344,6 +344,17 @@ static void export_stream_params(AVCodecContext *avct
If a frame starts very close to a packet boundary, the start code may
already have been added to the parsing buffer, indicated by a small
negative value of "i", while the header is still being tracked in the
"state" variable.
Reduce the remaining size accordingly, otherwise trying to find the next
From: Timo Rothenpieler
---
libavcodec/hevc_ps.c| 5 ++---
libavcodec/hevc_ps.h| 1 +
libavcodec/nvdec_hevc.c | 6 ++
3 files changed, 9 insertions(+), 3 deletions(-)
diff --git a/libavcodec/hevc_ps.c b/libavcodec/hevc_ps.c
index 1f18d0335b..f877fa572c 100644
--- a/libavcodec/hevc_p
On 11/04/2018 00:16, Lou Logan wrote:
On Tue, Apr 10, 2018, at 2:05 PM, Michael Niedermayer wrote:
what do you mean by "Git and me are not good friends" ?
If git hates you and sometimes does things that you didnt intend at all then
that would be a problem with direct pushes as theres no way to u
On Tue, Apr 3, 2018 at 4:06 PM, Anssi Hannula wrote:
> Hi,
>
> Hendrik Leppkes kirjoitti 2018-04-03 13:35:
>>
>> Such streams are found on Blu-ray, and identified as EAC3 type in
>> avformat, while the bitstream of the core stream is actually a pure AC3
>> frame.
>>
>> Adjust the parsing according
Hello,
Thanks for the comments.
New patchs in attach :
001 : Add display_scale volume
Change since prev patch :
- use enum for the value
- move the max_draw calc part to an inline func (avoid code duplication).
002 : Add Persistent max display
Change since prev patch
- Use only one param (dm_du
On Wed, Apr 11, 2018 at 10:42 AM, Tobias Rapp wrote:
> On 11.04.2018 10:23, Kieran O Leary wrote:
>>
>> Hi Carl,
>>
>> On Sat, Dec 16, 2017 at 2:31 PM, Carl Eugen Hoyos
>> wrote:
>>>
>>> 2017-12-15 22:22 GMT+01:00 Tobias Rapp :
>>>
+{ "dpx_color_trc", "Transfer Characteristics", OFFSET(
On Wed, 11 Apr 2018, Jun Zhao wrote:
On 2018/4/10 21:54, Marton Balint wrote:
On Tue, 10 Apr 2018, Jun Zhao wrote:
Maybe you should use ff_read_line_to_bprint instead? It already chops
the trailing line endings, not any whitespace though. Generally I
think we should deprecate ff_get
On Wed, Apr 11, 2018 at 9:42 AM, Tobias Rapp wrote:
> On 11.04.2018 10:23, Kieran O Leary wrote:
>>
>> Hi Carl,
>>
>> On Sat, Dec 16, 2017 at 2:31 PM, Carl Eugen Hoyos
>> wrote:
>>>
>>> 2017-12-15 22:22 GMT+01:00 Tobias Rapp :
>>>
+{ "dpx_color_trc", "Transfer Characteristics", OFFSET(c
On 11.04.2018 10:23, Kieran O Leary wrote:
Hi Carl,
On Sat, Dec 16, 2017 at 2:31 PM, Carl Eugen Hoyos wrote:
2017-12-15 22:22 GMT+01:00 Tobias Rapp :
+{ "dpx_color_trc", "Transfer Characteristics", OFFSET(color_trc), AV_OPT_TYPE_INT,
{ .i64 = DPX_TRC_UNDEFINED }, DPX_TRC_UNDEFINED, DPX
Hi Carl,
On Sat, Dec 16, 2017 at 2:31 PM, Carl Eugen Hoyos wrote:
> 2017-12-15 22:22 GMT+01:00 Tobias Rapp :
>
>> +{ "dpx_color_trc", "Transfer Characteristics", OFFSET(color_trc),
>> AV_OPT_TYPE_INT, { .i64 = DPX_TRC_UNDEFINED }, DPX_TRC_UNDEFINED,
>> DPX_TRC_NB-1, VE, "trc" },
>
> This s
Updates documentation after the changes to loglevel flag prefix parsing
in 4b736bc921ed96ad6d312ce0cbe0de29b9e3fe81.
Signed-off-by: Tobias Rapp
---
doc/fftools-common-opts.texi | 37 +
1 file changed, 29 insertions(+), 8 deletions(-)
diff --git a/doc/fftools-
On 10.04.2018 22:26, Lou Logan wrote:
On Mon, Apr 9, 2018, at 10:59 PM, Tobias Rapp wrote:
+For example to enable repeated log output and set @var{loglevel} to
+@code{verbose}:
+@example
+ffmpeg -loglevel repeat+verbose -i input output
+@end example
Just to show all current flags and the logl
From: Vishwanath Dixit
---
libavformat/dashenc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index 6d06486..bf8698f 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -555,7 +555,7 @@ static int write_adaptation
From: Vishwanath Dixit
The logic is applicable only when use_template is enabled and use_timeline
is disabled. The logic monitors the flow of segment indexes. If a streams's
segment index value is not at the expected real time position, then
the logic corrects that index value.
Typically this lo
From: Vishwanath Dixit
---
libavformat/dashenc.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index 9c29c05..1d34bb9 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -827,20 +827,23 @@ static int write_m
From: Vishwanath Dixit
---
libavformat/dashenc.c | 20 +---
1 file changed, 9 insertions(+), 11 deletions(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index 1d34bb9..6d06486 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -78,7 +78,6 @@ typedef
From: Vishwanath Dixit
availability time of Nth segment = availabilityStartTime + (N*segment duration)
- availabilityTimeOffset.
This field helps to reduce the latency by about a segment duration in streaming
mode.
---
libavformat/dashenc.c | 14 +-
1 file changed, 13 insertions(+)
From: Vishwanath Dixit
---
libavformat/dashenc.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index 70409e5..9c29c05 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -86,6 +86,8 @@ typedef struct OutputStream {
From: Vishwanath Dixit
@availabilityStartTime specifies the anchor for the computation of the earliest
availability time (in UTC) for any Segment in the Media Presentation.
As per this requirement, the @AvailabilityStartTime should be set to the
wallclock time at which the first frame of the fir
From: Vishwanath Dixit
Calling 'write_manifest' from 'write_header' was causing creation of
first MPD with invalid values. Ex: zero @duration param value. Also,
the manifest files (MPD or M3U8s) should be created when at-least
one media frame is ready for consumption.
---
libavformat/dashenc.c |
From: Vishwanath Dixit
---
libavformat/dashenc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/dashenc.c b/libavformat/dashenc.c
index ad52730..4c2e63c 100644
--- a/libavformat/dashenc.c
+++ b/libavformat/dashenc.c
@@ -347,7 +347,7 @@ static void output_segment_
From: Vishwanath Dixit
When use_template is enabled and use_timeline is disabled, typically
it is required to generate the segments at the configured segment duration
rate on an average. This commit is particularly needed to handle the
segmentation when video frame rates are fractional like 29.97
From: Vishwanath Dixit
---
doc/muxers.texi | 4 +++-
libavformat/dashenc.c | 23 ++-
libavformat/version.h | 3 +++
3 files changed, 24 insertions(+), 6 deletions(-)
diff --git a/doc/muxers.texi b/doc/muxers.texi
index cb75c26..8dbfede 100644
--- a/doc/muxers.texi
++
63 matches
Mail list logo