L'octidi 8 nivôse, an CCXXV, Paul B Mahol a écrit :
> How that plays out with filtergraphs with 1000 filter links?
I think you need to read the code more carefully to realize it does not
change anything at all. The "reserved[a lot]" field only makes a
difference for applications that incorrectly a
On 12/28/16, Nicolas George wrote:
> Le septidi 7 nivose, an CCXXV, Paul B Mahol a ecrit :
>> Yes, what's point of that?
>
> The answer is there:
>
> https://ffmpeg.org/pipermail/ffmpeg-devel/2016-November/202772.html
How that plays out with filtergraphs with 1000 filter links?
__
Le septidi 7 nivôse, an CCXXV, Paul B Mahol a écrit :
> Yes, what's point of that?
The answer is there:
https://ffmpeg.org/pipermail/ffmpeg-devel/2016-November/202772.html
Regards,
--
Nicolas George
signature.asc
Description: Digital signature
__
From: Michael Bradshaw
Signed-off-by: Michael Bradshaw
---
ffmpeg.c | 6 --
ffmpeg.h | 2 ++
ffmpeg_opt.c | 16 +++-
3 files changed, 21 insertions(+), 3 deletions(-)
diff --git a/ffmpeg.c b/ffmpeg.c
index ec9da3e..9ad9535 100644
--- a/ffmpeg.c
+++ b/ffmpeg.c
@@ -2910
Hey everyone,
I made a completely new patch to both fix the newline corruption (hopefully),
and to address comments. Also, I found that one of the tests wasn't being
checked, so I fixed that too.
> your patch is missing docs (document -huffman optimal by creating mjpeg
> encoder section in doc/en
From: Michael Bradshaw
Hi,
Attached patch adds a -time_base parameter to ffmpeg output streams. This
parameter sets the initial AVStream.time_base value for the output streams,
thus providing a time base hint to the muxer.
Please review.
Michael Bradshaw (1):
ffmpeg: Add -time_base option
From: Michael Bradshaw
Signed-off-by: Michael Bradshaw
---
libavformat/matroskaenc.c | 38 +++---
1 file changed, 31 insertions(+), 7 deletions(-)
diff --git a/libavformat/matroskaenc.c b/libavformat/matroskaenc.c
index 827d755..2c2c930 100644
--- a/libavformat/
From: Michael Bradshaw
Hi,
Attached match makes the MKV/WebM muxer accept the time_base hint as specified
in AVStream[1]. If the time_base of all the streams are the same and can be
represented in Matroska, then the time_base hint is used. Otherwise, it
defaults to milliseconds (which is the
From: Michael Bradshaw
Hi,
Attached patch condenses a statement from two lines to one. It's purely
cosmetic, but I find it makes the code easier to read. Please review.
Michael Bradshaw (1):
ffmpeg: Move statement to a single line
ffmpeg_opt.c | 3 +--
1 file changed, 1 insertion(+), 2 del
From: Michael Bradshaw
Signed-off-by: Michael Bradshaw
---
ffmpeg_opt.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/ffmpeg_opt.c b/ffmpeg_opt.c
index 6862456..af71604 100644
--- a/ffmpeg_opt.c
+++ b/ffmpeg_opt.c
@@ -1384,8 +1384,7 @@ static OutputStream *new_output_str
From: Michael Bradshaw
Hi,
Attached patch sets key frame/picture type for decoded frames. Please review.
Michael Bradshaw (1):
avcodec/libopenjpegdec: Set key frame metadata
libavcodec/libopenjpegdec.c | 2 ++
1 file changed, 2 insertions(+)
--
2.10.1 (Apple Git-78)
_
From: Michael Bradshaw
Signed-off-by: Michael Bradshaw
---
libavcodec/libopenjpegdec.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/libavcodec/libopenjpegdec.c b/libavcodec/libopenjpegdec.c
index b4ce834..f09f4ba 100644
--- a/libavcodec/libopenjpegdec.c
+++ b/libavcodec/libopenjpegdec.
Signed-off-by: Thomas Turner
---
libavutil/tests/audio_fifo.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/libavutil/tests/audio_fifo.c b/libavutil/tests/audio_fifo.c
index 2cef6f0..861cebb 100644
--- a/libavutil/tests/audio_fifo.c
+++ b/libavutil/tests/audio_fifo.c
@@
Signed-off-by: James Almer
Signed-off-by: Thomas Turner
---
libavutil/tests/audio_fifo.c | 22 +-
1 file changed, 9 insertions(+), 13 deletions(-)
diff --git a/libavutil/tests/audio_fifo.c b/libavutil/tests/audio_fifo.c
index 34c8573..9dc6054 100644
--- a/libavutil/tests/au
Prevents memory leak when read_samples_from_audio_fifo() is
called more than once by deallocating before reallocating
more memory.
Fixes space indentation for contents in ERROR().
Signed-off-by: Thomas Turner
---
libavutil/tests/audio_fifo.c | 20 ++--
1 file changed, 14 inserti
Signed-off-by: Michael Niedermayer
---
libavfilter/vf_pad.c | 43 ++-
1 file changed, 42 insertions(+), 1 deletion(-)
diff --git a/libavfilter/vf_pad.c b/libavfilter/vf_pad.c
index dfc873cd39..9739a0fdf6 100644
--- a/libavfilter/vf_pad.c
+++ b/libavfilter/
On 12/25/2016 3:14 PM, James Almer wrote:
> On 12/25/2016 1:11 PM, Ronald S. Bultje wrote:
>> Hi,
>>
>> On Sat, Dec 24, 2016 at 9:29 AM, Paul B Mahol wrote:
>>
>>> On 12/24/16, Ronald S. Bultje wrote:
Hi,
On Sat, Dec 24, 2016 at 6:09 AM, Paul B Mahol wrote:
> On 12/24/16,
ICC stdatomic.h implementation seems to be incomplete or broken,
missing the ATOMIC_VAR_INIT() macro.
Should fix ticket #6049
Signed-off-by: James Almer
---
configure | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure b/configure
index d723b8e..56a0b65 100755
--- a/co
On Tue, Dec 27, 2016 at 07:37:09 +, Jerry Jiang wrote:
> This is my first patch submitted to FFmpeg, so I'm sure that I missed
> something. Please bear with me. :P This patch implements the solution
> outlined here: https://guru.multimedia.cx/small-tasks-for-ffmpeg/
Apart from the newline-corr
On Tue, Dec 27, 2016 at 07:02:05PM +0100, Nicolas George wrote:
> Signed-off-by: Nicolas George
> ---
> libavdevice/lavfi.c | 37 +++--
> 1 file changed, 19 insertions(+), 18 deletions(-)
>
>
> Unchanged.
if the API is pushed then this LGTM
thx
[...]
--
Micha
On Tue, Dec 27, 2016 at 07:02:03PM +0100, Nicolas George wrote:
> Signed-off-by: Nicolas George
> ---
> ffmpeg.c| 46 --
> ffmpeg_filter.c | 12 ++--
> 2 files changed, 30 insertions(+), 28 deletions(-)
>
>
> Unchanged.
if the API is
On Tue, Dec 27, 2016 at 11:31:17AM +0100, Paul B Mahol wrote:
> On 12/27/16, Clement Boesch wrote:
> > Fixes ffmpeg -h filter=transpose
> >
> > ---
> > Should we instead ignore the flags for AV_OPT_TYPE_CONST?
> > ---
> > libavfilter/vf_transpose.c | 8
> > 1 file changed, 4 insertions(+
On 12/27/2016 6:27 PM, Nicolas George wrote:
> Le septidi 7 nivôse, an CCXXV, James Almer a écrit :
>> I made three questions. All of them where ignored, and what i got instead
>> was a "You
>> are late, this is not new code".
>
> All three of them have answers in the original discussion. You can
On 12/27/16, James Almer wrote:
> On 12/27/2016 3:02 PM, Nicolas George wrote:
>> AVFilterLink contains fields of internal types that are better
>> isolated. Furthermore, with the prospect of inter-filters
>> threading, it is better if filters do not access links directly.
>>
>> Signed-off-by: Nic
Le septidi 7 nivôse, an CCXXV, James Almer a écrit :
> I made three questions. All of them where ignored, and what i got instead was
> a "You
> are late, this is not new code".
All three of them have answers in the original discussion. You can read
it yourself.
If you want more courteous answers
On 12/27/2016 5:40 PM, Nicolas George wrote:
> Le septidi 7 nivôse, an CCXXV, James Almer a écrit :
>> Where have i heard this before? Something something ffserver.
>
> Actually, for ffserver, it turned out that there was no decision at all.
There sure was. A discussion, a decision, and a patch,
Le septidi 7 nivôse, an CCXXV, James Almer a écrit :
> Where have i heard this before? Something something ffserver.
Actually, for ffserver, it turned out that there was no decision at all.
And for ffserver, the situation changed between the pretended decision
and the revoke. No situation changed
On 12/27/2016 5:09 PM, Nicolas George wrote:
> Le septidi 7 nivôse, an CCXXV, James Almer a écrit :
>> It may not be something added with this patchset, but It's pretty much new
>> and
>> recent code, questioned by more people than just me prior to it being pushed.
>
> There was a discussion, the
Le septidi 7 nivôse, an CCXXV, James Almer a écrit :
> It may not be something added with this patchset, but It's pretty much new and
> recent code, questioned by more people than just me prior to it being pushed.
There was a discussion, then there was a consensus.
> It's clear you're on the defe
On Tue, Dec 27, 2016 at 07:02:08PM +0100, Nicolas George wrote:
> Also remove include framequeue.h, since it is pulled by
> avfilterlink.h.
>
> Signed-off-by: Nicolas George
> ---
> libavfilter/af_amerge.c| 3 +--
> libavfilter/avfilter.c | 3 +--
> libavfilter/avfiltergraph.c
On Tue, Dec 27, 2016 at 07:02:07PM +0100, Nicolas George wrote:
> AVFilterLink contains fields of internal types that are better
> isolated. Furthermore, with the prospect of inter-filters
> threading, it is better if filters do not access links directly.
>
> Signed-off-by: Nicolas George
> ---
>
On 12/27/2016 3:38 PM, Nicolas George wrote:
> Le septidi 7 nivôse, an CCXXV, James Almer a écrit :
>> How is this any different than the above notice? Everything below time_base
>> is also meant for internal use and shouldn't be accessed by applications or
>> other ffmpeg libraries.
>> Is extendin
Le septidi 7 nivôse, an CCXXV, James Almer a écrit :
> It got my support, making it the same amount of support the other proposal
> got.
That makes one.
> But please don't pretend one got more support than the other when two people
> replied to your question and each gave a different answer.
Goo
Le septidi 7 nivôse, an CCXXV, James Almer a écrit :
> How is this any different than the above notice? Everything below time_base
> is also meant for internal use and shouldn't be accessed by applications or
> other ffmpeg libraries.
> Is extending the scope of FF_INTERNAL_FIELDS to cover the abov
On 12/27/2016 3:02 PM, Nicolas George wrote:
> AVFilterLink contains fields of internal types that are better
> isolated. Furthermore, with the prospect of inter-filters
> threading, it is better if filters do not access links directly.
>
> Signed-off-by: Nicolas George
> ---
> libavfilter/Makef
On 12/27/2016 3:02 PM, Nicolas George wrote:
> The proposal of using a single function and a structure to return all fields
> did not raise a lot of enthousiasm.
It got my support, making it the same amount of support the other proposal
got.
If you ultimately went with this one it's because you f
Also remove include framequeue.h, since it is pulled by
avfilterlink.h.
Signed-off-by: Nicolas George
---
libavfilter/af_amerge.c| 3 +--
libavfilter/avfilter.c | 3 +--
libavfilter/avfiltergraph.c| 3 +--
libavfilter/buffersink.c | 3 +--
libavfilter/f_interleave.c
Signed-off-by: Nicolas George
---
libavfilter/avfilterlink.h | 5 +
1 file changed, 5 insertions(+)
I made the phrasing "filters implementation" intentionally vague: it can
mean filters within libavfilter or external filters as Michael wants.
diff --git a/libavfilter/avfilterlink.h b/liba
AVFilterLink contains fields of internal types that are better
isolated. Furthermore, with the prospect of inter-filters
threading, it is better if filters do not access links directly.
Signed-off-by: Nicolas George
---
libavfilter/Makefile | 1 +
libavfilter/avfilter.h | 217 +--
Signed-off-by: Nicolas George
---
libavfilter/tests/filtfmts.c | 1 +
1 file changed, 1 insertion(+)
Unchanged.
diff --git a/libavfilter/tests/filtfmts.c b/libavfilter/tests/filtfmts.c
index f59199c9a9..199d74d7a9 100644
--- a/libavfilter/tests/filtfmts.c
+++ b/libavfilter/tests/filtfmts.c
@@
TODO APIChanges entry.
Signed-off-by: Nicolas George
---
libavfilter/avfilter.h | 2 ++
libavfilter/version.h | 4
2 files changed, 6 insertions(+)
Once again, I am not the one who wants AVFilterLink private. Patches 1-5 are
worthy in their own right; for the others I will let people dis
Signed-off-by: Nicolas George
---
ffmpeg.c| 46 --
ffmpeg_filter.c | 12 ++--
2 files changed, 30 insertions(+), 28 deletions(-)
Unchanged.
diff --git a/ffmpeg.c b/ffmpeg.c
index ec9da3e6e2..5f7699e150 100644
--- a/ffmpeg.c
+++ b/ffm
Signed-off-by: Nicolas George
---
libavdevice/lavfi.c | 37 +++--
1 file changed, 19 insertions(+), 18 deletions(-)
Unchanged.
diff --git a/libavdevice/lavfi.c b/libavdevice/lavfi.c
index f9b2694650..eca3f15934 100644
--- a/libavdevice/lavfi.c
+++ b/libavdevice
av_buffersink_get_frame_rate() did already exist; its argument becomes const.
TODO minor version bump and APIChange entry
Signed-off-by: Nicolas George
---
libavfilter/buffersink.c | 25 +++--
libavfilter/buffersink.h | 22 --
2 files changed, 39 insertio
Signed-off-by: Nicolas George
---
ffplay.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
Unchanged.
diff --git a/ffplay.c b/ffplay.c
index bca2d5cbaa..967679e60b 100644
--- a/ffplay.c
+++ b/ffplay.c
@@ -2076,7 +2076,7 @@ static int audio_thread(void *arg)
On Mon, Dec 26, 2016 at 06:21:18PM -0800, Thomas Turner wrote:
> Signed-off-by: Thomas Turner
> ---
> libavutil/tests/audio_fifo.c | 181
> ---
> tests/ref/fate/audio_fifo| 34 +++-
> 2 files changed, 130 insertions(+), 85 deletions(-)
The commit
On Mon, Dec 26, 2016 at 12:25:16PM -0600, Burt P wrote:
> Additional/Modified FATE tests improve code coverage from 63.7% to 98.1%.
>
> Changed fate-suite sample files:
> * filter/hdcd-mix.flac (958K) added. It is a much better test than
> filter/hdcd.flac (910K), which is now unused, but can't
---
libavcodec/wmavoice.c | 44 +---
1 file changed, 17 insertions(+), 27 deletions(-)
diff --git a/libavcodec/wmavoice.c b/libavcodec/wmavoice.c
index cd5958c..4b283e3 100644
--- a/libavcodec/wmavoice.c
+++ b/libavcodec/wmavoice.c
@@ -104,26 +104,24 @@ sta
Hi,
On Tue, Dec 20, 2016 at 7:10 PM, Ronald S. Bultje
wrote:
> Hi,
>
> On Mon, Dec 5, 2016 at 4:15 PM, Ronald S. Bultje
> wrote:
>
>> ---
>> tests/checkasm/vp9dsp.c | 22 ++
>> 1 file changed, 14 insertions(+), 8 deletions(-)
>>
>> diff --git a/tests/checkasm/vp9dsp.c b/tes
Hi,
On Wed, Dec 21, 2016 at 2:50 AM, Paul B Mahol wrote:
> On 12/21/16, Ronald S. Bultje wrote:
> > Otherwise the scale factor becomes NaN, resulting in corrupt output.
> > Fixes #5426.
> > ---
> > libavcodec/wmavoice.c | 3 ++-
> > 1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff -
On Tue, 27 Dec 2016 07:37:09 +
Jerry Jiang wrote:
> Hey everyone,
>
> This is my first patch submitted to FFmpeg, so I'm sure that I missed
> something. Please bear with me. :P This patch implements the solution
> outlined here: https://guru.multimedia.cx/small-tasks-for-ffmpeg/
hi! it is i
On Mon, 26 Dec 2016 21:35:12 +0100
Michael Niedermayer wrote:
> -int stop_encoding = 0;
it would be nice if the commit message was "ffmpeg: remove stop_encoding
function , it is dead / unused code"
or so, with the function name in the message? easier to grep?
i have not tested patch...
On Tue, Dec 27, 2016 at 07:37:09AM +, Jerry Jiang wrote:
> Hey everyone,
>
> This is my first patch submitted to FFmpeg, so I'm sure that I missed
> something. Please bear with me. :P This patch implements the solution
> outlined here: https://guru.multimedia.cx/small-tasks-for-ffmpeg/
>
> Ac
On 12/27/16, Clement Boesch wrote:
> Fixes ffmpeg -h filter=transpose
>
> ---
> Should we instead ignore the flags for AV_OPT_TYPE_CONST?
> ---
> libavfilter/vf_transpose.c | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/libavfilter/vf_transpose.c b/libavfilter/vf
Thanks for looking at our patch!
> What's the performance impact like when you enable it? Any reason why it
> shouldn't be made the default?
From local testing on converting a random video using the mjpeg codec, we
were able to encode at a speed of 207 fps with the -huffman optimal flag, a
speed
On 27 December 2016 at 07:37, Jerry Jiang wrote:
> Hey everyone,
>
> This is my first patch submitted to FFmpeg, so I'm sure that I missed
> something. Please bear with me. :P This patch implements the solution
> outlined here: https://guru.multimedia.cx/small-tasks-for-ffmpeg/
>
>
Hi, thanks for
Fixes ffmpeg -h filter=transpose
---
Should we instead ignore the flags for AV_OPT_TYPE_CONST?
---
libavfilter/vf_transpose.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/libavfilter/vf_transpose.c b/libavfilter/vf_transpose.c
index 28226c3cfd..75b4dda41f 100644
---
57 matches
Mail list logo