Re: [FFmpeg-devel] [PATCH 2/2] avformat/mpegts: Skip over broken 0x80 headers

2016-04-23 Thread Michael Niedermayer
On Sat, Apr 23, 2016 at 06:09:37PM -0700, Ronald S. Bultje wrote: > Hi, > > On Sun, Apr 10, 2016 at 11:12 AM, Michael Niedermayer < > mich...@niedermayer.cc> wrote: > > > @@ -2344,6 +2344,12 @@ static int mpegts_resync(AVFormatContext *s, int > > seekback) > > > > avio_seek(pb, -FFMIN(seekba

Re: [FFmpeg-devel] [PATCH 2/2] avformat/mpegts: Skip over broken 0x80 headers

2016-04-23 Thread Ronald S. Bultje
Hi, On Sun, Apr 10, 2016 at 11:12 AM, Michael Niedermayer < mich...@niedermayer.cc> wrote: > @@ -2344,6 +2344,12 @@ static int mpegts_resync(AVFormatContext *s, int > seekback) > > avio_seek(pb, -FFMIN(seekback, pos), SEEK_CUR); > > +//Special case for files like 01c56b0dc1.ts > +if

Re: [FFmpeg-devel] [PATCH 2/2] avformat/mpegts: Skip over broken 0x80 headers

2016-04-23 Thread Michael Niedermayer
On Sun, Apr 10, 2016 at 11:13:55PM +0200, Michael Niedermayer wrote: > On Sun, Apr 10, 2016 at 08:23:58PM +0200, Paul B Mahol wrote: > > On 4/10/16, Michael Niedermayer wrote: > > > This fixes demuxing of 01c56b0dc1.ts > > > > > > Signed-off-by: Michael Niedermayer > > > --- > > > libavformat/mp

Re: [FFmpeg-devel] [PATCHv2] add signature filter for MPEG7 video signature

2016-04-23 Thread Michael Niedermayer
On Tue, Apr 19, 2016 at 04:37:16PM +0200, Gerion Entrup wrote: > On Dienstag, 19. April 2016 13:25:53 CEST Moritz Barsnick wrote: [...] > +static const ElemCat* elements[ELEMENT_COUNT] = { &elem_a1, &elem_a2, > + &elem_d1, &elem_d2, > &elem_d3, &ele

Re: [FFmpeg-devel] Fate/exr : Add test for piz

2016-04-23 Thread Michael Niedermayer
On Sat, Apr 23, 2016 at 10:26:27PM +0200, Martin Vignali wrote: > 2016-04-13 19:07 GMT+02:00 Michael Niedermayer : > > > On Wed, Apr 13, 2016 at 06:48:33PM +0200, Martin Vignali wrote: > > > 2016-04-13 16:45 GMT+02:00 Michael Niedermayer : > > > > > > > On Wed, Apr 13, 2016 at 01:53:08PM +0200, Ma

Re: [FFmpeg-devel] Fate/exr : Add test for piz

2016-04-23 Thread Martin Vignali
2016-04-13 19:07 GMT+02:00 Michael Niedermayer : > On Wed, Apr 13, 2016 at 06:48:33PM +0200, Martin Vignali wrote: > > 2016-04-13 16:45 GMT+02:00 Michael Niedermayer : > > > > > On Wed, Apr 13, 2016 at 01:53:08PM +0200, Martin Vignali wrote: > > > > Hello, > > > > > > > > In attach a patch to add

Re: [FFmpeg-devel] [PATCH 2/3] configure: Do not create/install versioned DLLs on OS/2.

2016-04-23 Thread Michael Niedermayer
On Wed, Apr 20, 2016 at 11:15:39PM -0700, Dave Yeo wrote: > On 04/20/16 03:48 PM, Dmitriy Kuminov wrote: > >I do care about consistency, collaboration and prevention of artificial > >entropy growth. > > One option is to make ln_s a configure option, something like the > attached, which is a work i

Re: [FFmpeg-devel] [PATCH] avcodec/utils: Assert that the number of consumed bytes in avcodec_decode_audio4() is <= the input size

2016-04-23 Thread Michael Niedermayer
On Sat, Apr 23, 2016 at 05:41:49PM +0200, wm4 wrote: > On Sat, 23 Apr 2016 17:34:56 +0200 > Michael Niedermayer wrote: > > > Signed-off-by: Michael Niedermayer > > --- > > libavcodec/utils.c |2 ++ > > 1 file changed, 2 insertions(+) > > > > diff --git a/libavcodec/utils.c b/libavcodec/uti

[FFmpeg-devel] [PATCH] configure: Don't require nonfree for nvenc

2016-04-23 Thread Timo Rothenpieler
As the nvEncodeApi.h header is now MIT licensed, this can be dropped. The loaded CUDA and NVENC libraries are part of the nvidia driver, and thus count as system libraries. --- configure | 1 - 1 file changed, 1 deletion(-) diff --git a/configure b/configure index 97f374b..1a4ff56 100755 --- a/co

Re: [FFmpeg-devel] [PATCH v2 04/12] lavc/videotoolboxenc: Add entropy setting

2016-04-23 Thread Hendrik Leppkes
On Sat, Apr 23, 2016 at 6:27 PM, Carl Eugen Hoyos wrote: > Rick Kern gmail.com> writes: > >> Add an entropy setting to choose between CAVLC and CABAC. > > Am I correct that it is impossible to do this similar to > libx264? > libx264 in avcodec uses "coder" with values "cabac"/"ac" or "cavlc"/"vl

Re: [FFmpeg-devel] [PATCH v2 04/12] lavc/videotoolboxenc: Add entropy setting

2016-04-23 Thread Carl Eugen Hoyos
Rick Kern gmail.com> writes: > Add an entropy setting to choose between CAVLC and CABAC. Am I correct that it is impossible to do this similar to libx264? Carl Eugen ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/lis

Re: [FFmpeg-devel] [PATCH v2 07/12] lavc/videotoolboxenc: Handle out-of-memory and fix memory leak

2016-04-23 Thread Carl Eugen Hoyos
Rick Kern gmail.com> writes: > +if (!interval) return AVERROR(ENOMEM); Most people here believe that a line break makes this more readable, feel free to ignore though. Carl Eugen ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://f

Re: [FFmpeg-devel] [PATCH v2 12/12] lavc/videotoolboxenc: Set colorimetry values

2016-04-23 Thread Carl Eugen Hoyos
Rick Kern gmail.com> writes: > +check_func_headers CoreVideo/CVImageBuffer.h > kCVImageBufferColorPrimaries_ITU_R_2020 I would have expected "enabled videotoolbox && check_func_headers" which should also make the changes to the "enable vda..." above unneded, but I may miss something. > +

Re: [FFmpeg-devel] [PATCH v2 09/12] lavc/videotoolboxenc: add concatentation properties

2016-04-23 Thread Carl Eugen Hoyos
Rick Kern gmail.com> writes: > +OFFSET(frames_before), AV_OPT_TYPE_BOOL, { .i64 = -1 }, -1, 1, VE }, I would have expected this to be "0, 1", no? Carl Eugen ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/

Re: [FFmpeg-devel] [PATCH] avcodec/utils: do_decode: Assert that the decoder return value is not larger than the packet size

2016-04-23 Thread wm4
On Sat, 23 Apr 2016 17:35:54 +0200 Michael Niedermayer wrote: > On Fri, Apr 22, 2016 at 04:04:54PM +0200, wm4 wrote: > > On Fri, 22 Apr 2016 11:59:14 +0200 > > Michael Niedermayer wrote: > > > > > On Fri, Apr 22, 2016 at 09:11:52AM +0200, wm4 wrote: > > > > On Fri, 22 Apr 2016 05:14:30 +020

Re: [FFmpeg-devel] [PATCH v2 03/12] lavc/videotoolboxenc: Require hardware encoding

2016-04-23 Thread Carl Eugen Hoyos
Rick Kern gmail.com> writes: > +#if !TARGET_OS_IPHONE > +{ "allow_sw", "Allow software encoding", OFFSET(allow_sw), I have no strong opinion, but shouldn't the option always exist (but only work in some cases)? Carl Eugen ___ ffmpeg-devel maili

Re: [FFmpeg-devel] [PATCH v2 01/12] lavc/videotoolboxenc: Use shared pixel buffer pool

2016-04-23 Thread Carl Eugen Hoyos
Rick Kern gmail.com> writes: > +if(!*refPtr) return; Is this needed (I don't know)? If yes, please make it two lines. > +CFRelease(*refPtr); > +*refPtr = NULL; > +switch (fmt) { > +case AV_PIX_FMT_NV12: > +switch (range) { > +case AVCOL_RANGE_

Re: [FFmpeg-devel] [PATCH] pgssubdec: fix subpicture output colorspace and range

2016-04-23 Thread Carl Eugen Hoyos
Jan Ekstrom gmail.com> writes: > >> +int hdtv; > > > > Please rename to sdtv so you can remove the assignment > > from init_decoder(). > > What would that make of the default value? The default value for (all) context variables is 0. I am just trying to make the patch smaller, the assignm

Re: [FFmpeg-devel] [PATCH] avcodec/utils: Assert that the number of consumed bytes in avcodec_decode_audio4() is <= the input size

2016-04-23 Thread wm4
On Sat, 23 Apr 2016 17:34:56 +0200 Michael Niedermayer wrote: > Signed-off-by: Michael Niedermayer > --- > libavcodec/utils.c |2 ++ > 1 file changed, 2 insertions(+) > > diff --git a/libavcodec/utils.c b/libavcodec/utils.c > index 946ecb9..21ad3cf 100644 > --- a/libavcodec/utils.c > +++ b

Re: [FFmpeg-devel] [PATCH] avcodec/utils: do_decode: Assert that the decoder return value is not larger than the packet size

2016-04-23 Thread Michael Niedermayer
On Fri, Apr 22, 2016 at 04:04:54PM +0200, wm4 wrote: > On Fri, 22 Apr 2016 11:59:14 +0200 > Michael Niedermayer wrote: > > > On Fri, Apr 22, 2016 at 09:11:52AM +0200, wm4 wrote: > > > On Fri, 22 Apr 2016 05:14:30 +0200 > > > Michael Niedermayer wrote: > > > > > > > Signed-off-by: Michael Nied

[FFmpeg-devel] [PATCH] avcodec/utils: Assert that the number of consumed bytes in avcodec_decode_audio4() is <= the input size

2016-04-23 Thread Michael Niedermayer
Signed-off-by: Michael Niedermayer --- libavcodec/utils.c |2 ++ 1 file changed, 2 insertions(+) diff --git a/libavcodec/utils.c b/libavcodec/utils.c index 946ecb9..21ad3cf 100644 --- a/libavcodec/utils.c +++ b/libavcodec/utils.c @@ -2422,6 +2422,8 @@ fail: av_frame_unref(frame)

Re: [FFmpeg-devel] CONFIG_W64_DEMUXER and dead-code elimination

2016-04-23 Thread wm4
On Sat, 23 Apr 2016 14:52:12 +0200 Reimar Döffinger wrote: > On 23.04.2016, at 13:21, wm4 wrote: > > > On Sat, 23 Apr 2016 01:16:31 +0200 > > Hendrik Leppkes wrote: > > > >> On Sat, Apr 23, 2016 at 1:02 AM, Bruce Dawson > >> wrote: > >>> I've noticed that when CONFIG_W64_DEMUXER is defin

Re: [FFmpeg-devel] CONFIG_W64_DEMUXER and dead-code elimination

2016-04-23 Thread Reimar Döffinger
On 23.04.2016, at 13:21, wm4 wrote: > On Sat, 23 Apr 2016 01:16:31 +0200 > Hendrik Leppkes wrote: > >> On Sat, Apr 23, 2016 at 1:02 AM, Bruce Dawson >> wrote: >>> I've noticed that when CONFIG_W64_DEMUXER is defined to zero that ffmpeg >>> compiles in a reference to ff_w64_guid_data but doesn'

Re: [FFmpeg-devel] [PATCH] pgssubdec: fix subpicture output colorspace and range

2016-04-23 Thread Hendrik Leppkes
On Sat, Apr 23, 2016 at 2:33 PM, Jan Ekstrom wrote: > On Sat, Apr 23, 2016 at 3:21 PM, wm4 wrote: >> In that case the hdtv field should be completely removed, and the test >> put in the palette conversion code. >> > > If avctx->height is by default 0, then it would have to be something a la: > >

Re: [FFmpeg-devel] [PATCH] pgssubdec: fix subpicture output colorspace and range

2016-04-23 Thread Jan Ekstrom
On Sat, Apr 23, 2016 at 3:21 PM, wm4 wrote: > In that case the hdtv field should be completely removed, and the test > put in the palette conversion code. > If avctx->height is by default 0, then it would have to be something a la: if (!avctx->height || avctx->height > 576) { YUV_TO_RGB1_CCI

Re: [FFmpeg-devel] [PATCH] pgssubdec: fix subpicture output colorspace and range

2016-04-23 Thread Jan Ekstrom
On Sat, Apr 23, 2016 at 11:09 AM, Carl Eugen Hoyos wrote: > Please mention the relevant ticket in the commit message. OK, will do. > >> +int hdtv; > > Please rename to sdtv so you can remove the assignment from > init_decoder(). > What would that make of the default value? The current desig

Re: [FFmpeg-devel] [PATCH] pgssubdec: fix subpicture output colorspace and range

2016-04-23 Thread wm4
On Sat, 23 Apr 2016 13:53:00 +0200 Hendrik Leppkes wrote: > On Sat, Apr 23, 2016 at 1:18 PM, wm4 wrote: > > On Fri, 22 Apr 2016 23:06:37 +0300 > > Jan Ekström wrote: > > > >> Functionality used before didn't widen the values from limited to > >> full range. Additionally, now the decoder uses

Re: [FFmpeg-devel] [PATCH] pgssubdec: fix subpicture output colorspace and range

2016-04-23 Thread Jan Ekstrom
On Sat, Apr 23, 2016 at 2:53 PM, Hendrik Leppkes wrote: > Otherwise, I think Carl's suggestion might help, PGS subtitles are > generally from Blu-rays, which means most of it is HD, so swapping the > flag to detect SD conditions might make it act more "appropriate" in > absence of w/h. The defaul

Re: [FFmpeg-devel] [PATCH] pgssubdec: fix subpicture output colorspace and range

2016-04-23 Thread Hendrik Leppkes
On Sat, Apr 23, 2016 at 1:18 PM, wm4 wrote: > On Fri, 22 Apr 2016 23:06:37 +0300 > Jan Ekström wrote: > >> Functionality used before didn't widen the values from limited to >> full range. Additionally, now the decoder uses BT.709 where it >> should be used according to the video resolution. >> >>

Re: [FFmpeg-devel] CONFIG_W64_DEMUXER and dead-code elimination

2016-04-23 Thread Hendrik Leppkes
On Sat, Apr 23, 2016 at 1:21 PM, wm4 wrote: > On Sat, 23 Apr 2016 01:16:31 +0200 > Hendrik Leppkes wrote: > >> On Sat, Apr 23, 2016 at 1:02 AM, Bruce Dawson >> wrote: >> > I've noticed that when CONFIG_W64_DEMUXER is defined to zero that ffmpeg >> > compiles in a reference to ff_w64_guid_data bu

[FFmpeg-devel] libavcodec/exr : Fix slice threading

2016-04-23 Thread Martin Vignali
Hello, Patch in attach, fix slice threading (reported by James Almer in "Libavcodec/exr : add support for tile" discussion) the xsize and ysize are now in the thread data instead of exr context. Theses variables are used to store the real dimensions of a block (tile or scanline) specially in edge

Re: [FFmpeg-devel] CONFIG_W64_DEMUXER and dead-code elimination

2016-04-23 Thread wm4
On Sat, 23 Apr 2016 01:16:31 +0200 Hendrik Leppkes wrote: > On Sat, Apr 23, 2016 at 1:02 AM, Bruce Dawson > wrote: > > I've noticed that when CONFIG_W64_DEMUXER is defined to zero that ffmpeg > > compiles in a reference to ff_w64_guid_data but doesn't not link w64.o > > (which defines that symbo

Re: [FFmpeg-devel] [PATCH] pgssubdec: fix subpicture output colorspace and range

2016-04-23 Thread wm4
On Fri, 22 Apr 2016 23:06:37 +0300 Jan Ekström wrote: > Functionality used before didn't widen the values from limited to > full range. Additionally, now the decoder uses BT.709 where it > should be used according to the video resolution. > > Default for not yet set colorimetry is BT.709 due to

Re: [FFmpeg-devel] Line endings in Makefiles

2016-04-23 Thread Carl Eugen Hoyos
Andreas Weis ghulbus-inc.de> writes: > The stronger case here is in my opinion anyway the fact that this is not > something the user should have to worry about at all, especially if they > just want to do a quick build from source. +1 Carl Eugen ___

Re: [FFmpeg-devel] [PATCH v2 11/12] lavc/videotoolboxenc: Support pixel aspect ratio

2016-04-23 Thread Carl Eugen Hoyos
Rick Kern gmail.com> writes: > +if (status) { > +av_log(avctx, > + AV_LOG_ERROR, > + "Error setting pixel aspect ratio to %d:%d: %d.\n", > + avctx->sample_aspect_ratio.num, > + avctx->sample_aspect_ratio.d

Re: [FFmpeg-devel] [PATCH] pgssubdec: fix subpicture output colorspace and range

2016-04-23 Thread Carl Eugen Hoyos
Jan Ekström gmail.com> writes: > Functionality used before didn't widen the values from limited to > full range. Additionally, now the decoder uses BT.709 where it > should be used according to the video resolution. Please mention the relevant ticket in the commit message. > +int hdtv; Ple