Sorry about the duplicated wrong patch-0007,
0007-avcodec-optimize-mpegvideo-decode-for-Loongson-3-v1.patch is the right one.
> -原始邮件-
> 发件人: "周晓勇"
> 发送时间: 2015年4月22日 星期三
> 收件人: ffmpeg-devel
> 抄送: gaoxiang , "孟小甫"
> 主题: [FFmpeg-devel] Loongson Optimization Patchs and Machine Express I
On Tue, Apr 21, 2015 at 10:22:48AM +, Parag Salasakar wrote:
> These are 'optimization' patches for MSA.
> We surely have plans to add runtime CPU detection code in near future as a
> separate patch.
OK, looking forward to that.
Timothy
___
ffmpeg-d
On 22/04/15 12:20 AM, James Almer wrote:
> On 21/04/15 9:54 PM, Ronald S. Bultje wrote:
>> ---
>> libavcodec/vp9.c | 316
>> ++-
>> libavcodec/vp9_mc_template.c | 171 +++
>> libavcodec/vp9_parser.c | 5 +-
>> libavcod
On 21/04/15 9:54 PM, Ronald S. Bultje wrote:
> ---
> libavcodec/vp9.c | 316
> ++-
> libavcodec/vp9_mc_template.c | 171 +++
> libavcodec/vp9_parser.c | 5 +-
> libavcodec/vp9dsp.c | 205 ++
On Tue, Apr 21, 2015 at 08:54:52PM -0400, Ronald S. Bultje wrote:
> See sample:
> http://downloads.webmproject.org/test_data/libvpx/vp90-2-05-resize.ivf
uploaded
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
The greatest way to live with honor in this world is
On 21/04/15 7:49 PM, James Almer wrote:
> On 21/04/15 7:12 PM, Michael Niedermayer wrote:
>> On Tue, Apr 21, 2015 at 06:51:52PM -0300, James Almer wrote:
>>> On 21/04/15 6:38 PM, Michael Niedermayer wrote:
On Tue, Apr 21, 2015 at 05:45:25PM -0300, James Almer wrote:
> Signed-off-by: James
On Tue, Apr 21, 2015 at 05:35:29PM -0700, Vignesh Venkatasubramanian wrote:
> Some players do not support setting minimumUpdatePeriod to zero.
> This patch adds a new parameter that will let the users set any
> value to this field. Also updates the test and the documentation.
>
> Signed-off-by: Vi
---
libavcodec/vp9.c | 316 ++-
libavcodec/vp9_mc_template.c | 171 +++
libavcodec/vp9_parser.c | 5 +-
libavcodec/vp9dsp.c | 205 ++--
libavcodec/vp9dsp.h | 9 ++
5 files cha
See sample:
http://downloads.webmproject.org/test_data/libvpx/vp90-2-05-resize.ivf
---
tests/fate/vpx.mak | 3 +++
tests/ref/fate/vp9-05-resize | 15 +++
2 files changed, 18 insertions(+)
create mode 100644 tests/ref/fate/vp9-05-resize
diff --git a/tests/fate/vpx.mak b/tes
Some players do not support setting minimumUpdatePeriod to zero.
This patch adds a new parameter that will let the users set any
value to this field. Also updates the test and the documentation.
Signed-off-by: Vignesh Venkatasubramanian
---
doc/muxers.texi| 4
libavf
On Tue, Apr 21, 2015 at 04:36:52PM -0700, Vignesh Venkatasubramanian wrote:
> DASH spec requires the presence of either duration of the period
> or the minimumUpdatePeriod element. This patch adds the
> minimumUpdatePeriod element hardcoded with the value 0 as the
> manifest will never be updated f
On Wed, Apr 22, 2015 at 01:09:26AM +0200, wm4 wrote:
> On Wed, 22 Apr 2015 00:48:30 +0200
> Michael Niedermayer wrote:
>
> > On Tue, Apr 21, 2015 at 09:33:51PM +0200, wm4 wrote:
> > > ---
> > > Feel free to squash with the previous patch if it's too fine-grained.
> > > ---
> > > libavformat/mp3d
On Tue, Apr 21, 2015 at 06:50:20PM +0200, Andreas Cadhalpun wrote:
> On 21.04.2015 02:20, Claudio Freire wrote:
> > On Mon, Apr 20, 2015 at 9:13 PM, Michael Niedermayer
> > wrote:
> >> On Mon, Apr 20, 2015 at 09:07:14PM -0300, Claudio Freire wrote:
> >>> On Mon, Apr 20, 2015 at 8:59 PM, Claudio F
On Wed, 22 Apr 2015 00:48:30 +0200
Michael Niedermayer wrote:
> On Tue, Apr 21, 2015 at 09:33:51PM +0200, wm4 wrote:
> > ---
> > Feel free to squash with the previous patch if it's too fine-grained.
> > ---
> > libavformat/mp3dec.c | 7 ++-
> > 1 file changed, 2 insertions(+), 5 deletions(-)
On 21/04/15 7:12 PM, Michael Niedermayer wrote:
> On Tue, Apr 21, 2015 at 06:51:52PM -0300, James Almer wrote:
>> On 21/04/15 6:38 PM, Michael Niedermayer wrote:
>>> On Tue, Apr 21, 2015 at 05:45:25PM -0300, James Almer wrote:
Signed-off-by: James Almer
---
libavcodec/acelp_vectors
On Tue, Apr 21, 2015 at 09:33:51PM +0200, wm4 wrote:
> ---
> Feel free to squash with the previous patch if it's too fine-grained.
> ---
> libavformat/mp3dec.c | 7 ++-
> 1 file changed, 2 insertions(+), 5 deletions(-)
this breaks fate-seek-acodec-mp2
[...]
--
Michael GnuPG fingerprint:
On Tue, Apr 21, 2015 at 06:51:52PM -0300, James Almer wrote:
> On 21/04/15 6:38 PM, Michael Niedermayer wrote:
> > On Tue, Apr 21, 2015 at 05:45:25PM -0300, James Almer wrote:
> >> Signed-off-by: James Almer
> >> ---
> >> libavcodec/acelp_vectors.c | 8 +++-
> >> libavcodec/adpcm.c
On Tue, 21 Apr 2015 23:04:32 +0200
wm4 wrote:
> ---
> Proposal. Is not mp3-specific, and can be reused for other formats.
> ---
> doc/APIchanges | 4
> doc/formats.texi| 2 ++
> libavformat/avformat.h | 1 +
> libavformat/mp3dec.c| 4 ++--
> libavformat
On Tue, Apr 21, 2015 at 09:30:41PM +, Chris Watkins wrote:
> On Tue, Apr 21, 2015 at 2:23 PM Carl Eugen Hoyos wrote:
>
> > Christopher Watkins chromium.org> writes:
> >
> > > Hi, this patch just removes a compiler warning.
> >
> > Please mention ticket #4467 is the commit message.
> >
> >
>
On 21/04/15 6:38 PM, Michael Niedermayer wrote:
> On Tue, Apr 21, 2015 at 05:45:25PM -0300, James Almer wrote:
>> Signed-off-by: James Almer
>> ---
>> libavcodec/acelp_vectors.c | 8 +++-
>> libavcodec/adpcm.c | 2 +-
>> libavcodec/alacenc.c | 3 +--
>> libavcodec
On Tue, Apr 21, 2015 at 11:38:32PM +0200, Michael Niedermayer wrote:
> On Tue, Apr 21, 2015 at 05:45:25PM -0300, James Almer wrote:
> > Signed-off-by: James Almer
> > ---
> > libavcodec/acelp_vectors.c | 8 +++-
> > libavcodec/adpcm.c | 2 +-
> > libavcodec/alacenc.c
Le duodi 2 floréal, an CCXXIII, Pedro Arthur a écrit :
> #define SWS_SPLINE0x400
> +#define SWS_GAMMA_CORRECT 0x800
Sorry, I forgot one comment in my first email:
This has risks of conflicts if the avconv fork adds a different flag with
the same value. To avoid that, we usually leave a g
Le duodi 2 floréal, an CCXXIII, wm4 a écrit :
> #define AVFMT_FLAG_SORT_DTS0x1 ///< try to interleave outputted
> packets by dts (using this flag can slow demuxing down)
> #define AVFMT_FLAG_PRIV_OPT0x2 ///< Enable use of private options by
> delaying codec open (this could be m
On Tue, Apr 21, 2015 at 05:45:25PM -0300, James Almer wrote:
> Signed-off-by: James Almer
> ---
> libavcodec/acelp_vectors.c | 8 +++-
> libavcodec/adpcm.c | 2 +-
> libavcodec/alacenc.c | 3 +--
> libavcodec/atrac3plus.c| 4 ++--
> libavcodec/dnxhdenc.c
On Tue, Apr 21, 2015 at 2:23 PM Carl Eugen Hoyos wrote:
> Christopher Watkins chromium.org> writes:
>
> > Hi, this patch just removes a compiler warning.
>
> Please mention ticket #4467 is the commit message.
>
>
Oh, I didn't see that. Done.
From 041b6899c10a082c5d019678e78588dc26474a6c Mon Sep
On 21 April 2015 at 21:52, Ludmila Glinskih wrote:
> Sorry for the delay, thanks for comments!
>
> вт, 21 апр. 2015 г. в 1:40, Kieran Kunhya :
>
>> On 20 April 2015 at 01:03, Ludmila Glinskih wrote:
>> > Signed-off-by: Ludmila Glinskih
>> > ---
>> > libavcodec/Makefile| 1 +
>> > liba
Christopher Watkins chromium.org> writes:
> Hi, this patch just removes a compiler warning.
Please mention ticket #4467 is the commit message.
Carl Eugen
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-
OOPS
вт, 21 апр. 2015 г. в 8:03, James Almer :
> On 19/04/15 9:03 PM, Ludmila Glinskih wrote:
>
> > +static int run_test(AVCodec *enc, AVCodec *dec, AVCodecContext *enc_ctx,
> > +AVCodecContext *dec_ctx)
> > +{
> > +AVPacket enc_pkt;
> > +AVFrame *in_frame, *ou
Hi, this patch just removes a compiler warning.
Thanks!
Chris
From a0e11238d7d8199403c4ea0b4e8eef3eae0affa8 Mon Sep 17 00:00:00 2001
From: Chris Watkins
Date: Tue, 21 Apr 2015 14:14:19 -0700
Subject: [PATCH] avformat/mov.c: Use %d to print an enum, not PRIu8
Using the PRIu8 format specifier to p
вт, 21 апр. 2015 г. в 6:19, Clément Bœsch :
> On Mon, Apr 20, 2015 at 02:37:27PM +0200, Ludmila Glinskih wrote:
> > ffmpeg | branch: master | Ludmila Glinskih | Mon
> Apr 20 03:03:08 2015 +0300| [be70c79af2bbbf8818707075ebc376d0be137582] |
> committer: Michael Niedermayer
> >
> > libavcodec: Add
---
Proposal. Is not mp3-specific, and can be reused for other formats.
---
doc/APIchanges | 4
doc/formats.texi| 2 ++
libavformat/avformat.h | 1 +
libavformat/mp3dec.c| 4 ++--
libavformat/options_table.h | 1 +
5 files changed, 10 insertions(+), 2 del
Sorry for the delay, thanks for comments!
вт, 21 апр. 2015 г. в 1:40, Kieran Kunhya :
> On 20 April 2015 at 01:03, Ludmila Glinskih wrote:
> > Signed-off-by: Ludmila Glinskih
> > ---
> > libavcodec/Makefile| 1 +
> > libavcodec/api-flac-test.c | 290
>
Signed-off-by: James Almer
---
libavcodec/acelp_vectors.c | 8 +++-
libavcodec/adpcm.c | 2 +-
libavcodec/alacenc.c | 3 +--
libavcodec/atrac3plus.c| 4 ++--
libavcodec/dnxhdenc.c | 2 +-
libavcodec/dvenc.c | 2 +-
libavcodec/ffv1.h
New patch with changes.
2015-04-21 13:14 GMT-03:00 Pedro Arthur :
> I intended to fetch the correct gamma value from the video/image metada
> or pass it by flag (like gamma=x) but yet I don't know how to get the
> correct gamma based on the input, thus for now it is hardcode.
>
> 2015-04-21 12:31
On Tue, 21 Apr 2015 22:07:07 +0200
Clément Bœsch wrote:
> On Tue, Apr 21, 2015 at 09:33:52PM +0200, wm4 wrote:
> > "-usetoc 2" now invokes the generic seek and indexing mode. This mode
> > skips data until the seek target is reached, and this is exact. It also
> > makes gapless audio actually wor
On Tue, Apr 21, 2015 at 09:33:52PM +0200, wm4 wrote:
> "-usetoc 2" now invokes the generic seek and indexing mode. This mode
> skips data until the seek target is reached, and this is exact. It also
> makes gapless audio actually work if a seek past the start of the file
> is involved.
> ---
> Stra
"-usetoc 2" now invokes the generic seek and indexing mode. This mode
skips data until the seek target is reached, and this is exact. It also
makes gapless audio actually work if a seek past the start of the file
is involved.
---
Oops, accidentally removed tests/ref/fate/gapless-mp3 in the previous
OK some verbiage nits:
+@item capture_audio_device_load
I'd suggest naming it it audio_device_load_from_filename instead.
Similar for video.
+Load an audio capture filter device from file instead of searching
+it by name. It c, if the filter
+supports the serialization of its properties to.
+To
---
Feel free to squash with the previous patch if it's too fine-grained.
---
libavformat/mp3dec.c | 7 ++-
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/libavformat/mp3dec.c b/libavformat/mp3dec.c
index 0604e31..008cb23 100644
--- a/libavformat/mp3dec.c
+++ b/libavformat/mp3de
It's the most useful one, because it seeks accurately, and does not
break features like gapless audio.
---
libavformat/mp3dec.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavformat/mp3dec.c b/libavformat/mp3dec.c
index 8a4dfbd..2227428 100644
--- a/libavformat/mp3dec.c
+
These could be kept, but they are not overly useful. The only thing they
had over the remaining mp3 gapless test was seeking, which was incorrect
in both modes they used.
---
tests/fate/gapless.mak | 6 ++
tests/ref/fate/gapless-mp3-cbr | 5 -
tests/ref/fate/gapless-mp3-notoc |
"-usetoc 2" now invokes the generic seek and indexing mode. This mode
skips data until the seek target is reached, and this is exact. It also
makes gapless audio actually work if a seek past the start of the file
is involved.
---
Strange option value. On the other hand, it will be made default, so
This makes using the generic indexing code with mp3 easier at a later
point.
---
libavformat/avformat.h | 8
libavformat/utils.c| 4
2 files changed, 12 insertions(+)
diff --git a/libavformat/avformat.h b/libavformat/avformat.h
index 514e646..93cfb20 100644
--- a/libavformat/avf
On 21.04.2015 08:14, Thilo Borgmann wrote:
> Am 20.04.15 um 23:20 schrieb Andreas Cadhalpun:
>> On 19.04.2015 22:20, Luca Barbato wrote:
>>> I'd check that `master` is always between `raw_buffer` and the end of it.
>>
>> You mean something like the attached patch?
>>
>>> (I'm not sure if `div_block
On 21.04.2015 02:20, Claudio Freire wrote:
> On Mon, Apr 20, 2015 at 9:13 PM, Michael Niedermayer wrote:
>> On Mon, Apr 20, 2015 at 09:07:14PM -0300, Claudio Freire wrote:
>>> On Mon, Apr 20, 2015 at 8:59 PM, Claudio Freire
>>> wrote:
On Mon, Apr 20, 2015 at 8:32 PM, Andreas Cadhalpun
I intended to fetch the correct gamma value from the video/image metada
or pass it by flag (like gamma=x) but yet I don't know how to get the
correct gamma based on the input, thus for now it is hardcode.
2015-04-21 12:31 GMT-03:00 Kevin Wheatley :
> Pedro
>
> I understand the desire to 'degamma'
Pedro
I understand the desire to 'degamma' images prior to scaling, I'd be
interested in understanding how this could work with the colour_trc
options rather than only assuming a simple gamma.
Kevin
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
On Tue, Apr 21, 2015 at 12:07:54PM -0300, Pedro Arthur wrote:
> Patch which adds support for gamma correct scaling in libswscale.
> options.c |3 ++
> swscale.c | 51 +++
> swscale.h |1
> swscale_internal.h |9 +-
> ut
Le duodi 2 floréal, an CCXXIII, Pedro Arthur a écrit :
> Subject: [FFmpeg-devel] [GSoC] Patch which adds support for gamma correct
"sws: add support for gamma-correct scaling"
> +{ "true","enable",0,
> AV_OPT_TYPE_CONST, { .i64 = 1
Patch which adds support for gamma correct scaling in libswscale.
From fe34ea493ffae9b6c1655112a66b5e0c4cfef26d Mon Sep 17 00:00:00 2001
From: Pedro Arthur
Date: Fri, 17 Apr 2015 17:08:42 -0300
Subject: [PATCH] Add gamma encodign/decoding before/after scaling in
libswscale
---
libswscale/option
Le duodi 2 floréal, an CCXXIII, Michael Niedermayer a écrit :
> the only case iam aware of was some memory debugger which crashed
> when realloc & malloc where mixed (thats clearly a bug in the debugger
> as it should never crash, warn / fail maybe but not crash)
I was referring to this one:
comm
On Tue, Apr 21, 2015 at 03:43:59PM +0200, Nicolas George wrote:
> Le duodi 2 floréal, an CCXXIII, wm4 a écrit :
> > Isn't the problem that realloc() doesn't keep the alignment?
>
> No. That problem exists too, but is irrelevant for the current code base:
> there has been one bug of that kind about
Le duodi 2 floréal, an CCXXIII, wm4 a écrit :
> Isn't the problem that realloc() doesn't keep the alignment?
No. That problem exists too, but is irrelevant for the current code base:
there has been one bug of that kind about three years ago, AFAIK that is
all.
The problem that was addressed here
On Tue, 21 Apr 2015 15:12:36 +0200
Michael Niedermayer wrote:
> memalign() is not guranteed to be compatible with free() or realloc()
> and for platforms in this category we have --enable-memalign-hack
> (which should be enabled automatically if such system is detected)
> Trying to somehow half s
memalign() is not guranteed to be compatible with free() or realloc()
and for platforms in this category we have --enable-memalign-hack
(which should be enabled automatically if such system is detected)
Trying to somehow half support systems that can free() memalign memory
but not reallocate it see
On Tue, Apr 21, 2015 at 02:41:15PM +0200, wm4 wrote:
> On Tue, 21 Apr 2015 14:37:36 +0200
> Michael Niedermayer wrote:
>
> > On Tue, Apr 21, 2015 at 01:52:05PM +0200, wm4 wrote:
> > > On Tue, 21 Apr 2015 13:22:00 +0200
> > > Michael Niedermayer wrote:
> > >
> > > > This indicates that its safe
On Tue, Apr 21, 2015 at 02:03:43PM +0200, Nicolas George wrote:
> Le duodi 2 floréal, an CCXXIII, Michael Niedermayer a écrit :
> > This indicates that its safe to use av_free/av_malloc on the IO context
> >
> > Signed-off-by: Michael Niedermayer
> > ---
> > libavformat/avio.h|7 +++
On Tue, 21 Apr 2015 14:37:36 +0200
Michael Niedermayer wrote:
> On Tue, Apr 21, 2015 at 01:52:05PM +0200, wm4 wrote:
> > On Tue, 21 Apr 2015 13:22:00 +0200
> > Michael Niedermayer wrote:
> >
> > > This indicates that its safe to use av_free/av_malloc on the IO context
> > >
> > > Signed-off-by
On Tue, Apr 21, 2015 at 01:52:05PM +0200, wm4 wrote:
> On Tue, 21 Apr 2015 13:22:00 +0200
> Michael Niedermayer wrote:
>
> > This indicates that its safe to use av_free/av_malloc on the IO context
> >
> > Signed-off-by: Michael Niedermayer
> > ---
> > libavformat/avio.h|7 +++
> >
On Tue, 21 Apr 2015 13:22:00 +0200
Michael Niedermayer wrote:
> This indicates that its safe to use av_free/av_malloc on the IO context
>
> Signed-off-by: Michael Niedermayer
> ---
> libavformat/avio.h|7 +++
> libavformat/aviobuf.c |1 +
> libavformat/segment.c |1 +
> lib
Le duodi 2 floréal, an CCXXIII, Michael Niedermayer a écrit :
> This indicates that its safe to use av_free/av_malloc on the IO context
>
> Signed-off-by: Michael Niedermayer
> ---
> libavformat/avio.h|7 +++
> libavformat/aviobuf.c |1 +
> libavformat/segment.c |1 +
> libav
On Tue, 21 Apr 2015 13:22:00 +0200
Michael Niedermayer wrote:
> This indicates that its safe to use av_free/av_malloc on the IO context
>
> Signed-off-by: Michael Niedermayer
> ---
> libavformat/avio.h|7 +++
> libavformat/aviobuf.c |1 +
> libavformat/segment.c |1 +
> lib
Signed-off-by: Michael Niedermayer
---
libavformat/aviobuf.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/libavformat/aviobuf.c b/libavformat/aviobuf.c
index b32ff9f..3aa2b2d 100644
--- a/libavformat/aviobuf.c
+++ b/libavformat/aviobuf.c
@@ -809,6 +809,8 @@ int ffio_ensure_se
This indicates that its safe to use av_free/av_malloc on the IO context
Signed-off-by: Michael Niedermayer
---
libavformat/avio.h|7 +++
libavformat/aviobuf.c |1 +
libavformat/segment.c |1 +
libavformat/wtvdec.c |3 ++-
4 files changed, 11 insertions(+), 1 deletion(-)
its not needed anymore
Signed-off-by: Michael Niedermayer
---
libavformat/img2dec.c |6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/libavformat/img2dec.c b/libavformat/img2dec.c
index 5fc5b83..5da06b7 100644
--- a/libavformat/img2dec.c
+++ b/libavformat/img2dec.c
@@
On ma, 2015-04-13 at 09:41 -0700, Philip Langdale wrote:
> On 2015-04-13 03:39, Petri Hintukainen wrote:
> >
> > I don't know if it is a good idea to use HDMV stream types without HDMV
> > program registration descriptor. If this is fixed incrementally, fixing
> > should be started from the opposi
These are 'optimization' patches for MSA.
We surely have plans to add runtime CPU detection code in near future as a
separate patch.
Parag
-Original Message-
From: ffmpeg-devel-boun...@ffmpeg.org [mailto:ffmpeg-devel-boun...@ffmpeg.org]
On Behalf Of Timothy Gu
Sent: Tuesday, April 21, 2
Hi Ludmila
It appears several developers had additional review comments on your
patch
ccing you so you dont miss the mail
On Mon, Apr 20, 2015 at 03:03:08AM +0300, Ludmila Glinskih wrote:
> Signed-off-by: Ludmila Glinskih
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC78
68 matches
Mail list logo