On Sat, Sep 06, 2014 at 04:42:48AM +0200, Michael Niedermayer wrote:
> Fixes Ticket3909
>
> Signed-off-by: Michael Niedermayer
> ---
> ffmpeg.c |8
> 1 file changed, 8 insertions(+)
applied
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Breaking
Signed-off-by: Michael Niedermayer
---
ffplay.c |7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/ffplay.c b/ffplay.c
index 06bccce..64ec058 100644
--- a/ffplay.c
+++ b/ffplay.c
@@ -185,6 +185,7 @@ typedef struct VideoState {
int realtime;
int audio_finished;
On Tue, Sep 02, 2014 at 04:51:27PM +0200, Michael Niedermayer wrote:
> This is currently not supported
> Fixes part of Ticket 3539
>
> Signed-off-by: Michael Niedermayer
applied
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Republics decline into democracie
On Sat, Sep 06, 2014 at 09:25:51PM +0200, Reimar Döffinger wrote:
> This avoids several issue like calculating sum/maxcoef
> incorrectly due to adding up matrix entries that will
> be overwritten, as well as out-of-range writes to
> s->matrix if the maximum allowed number of channels is used.
>
>
On 06.09.2014 13:45, Reimar Döffinger wrote:
On Sat, Sep 06, 2014 at 12:13:30PM +0200, Andreas Cadhalpun wrote:
-Effectively this allows to add padding with zeros from the left.
+Effectively this allows one to add padding with zeros from the left.
Huh? I don't think the second is more correct,
On Sat, Sep 06, 2014 at 09:25:49PM +0200, Reimar Döffinger wrote:
> We only actually need to use a tiny part of it.
> Unfortunately we seem to have no real test coverage on
> the code, so this is a bit risky.
>
> Signed-off-by: Reimar Döffinger
> ---
> libswresample/rematrix.c | 14 +
On Sat, Sep 06, 2014 at 09:25:50PM +0200, Reimar Döffinger wrote:
> A branch to avoid some calculation seems unlikely to have any benefits.
>
> Signed-off-by: Reimar Döffinger
> ---
> libswresample/rematrix.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
LGTM
[...]
--
Michael
On Wed, Sep 03, 2014 at 10:49:38PM +0200, Michael Niedermayer wrote:
> On Wed, Sep 03, 2014 at 09:40:56PM +0200, Reimar Döffinger wrote:
> > Signed-off-by: Reimar Döffinger
> > ---
> > libavcodec/huffyuvdec.c | 19 +--
> > 1 file changed, 13 insertions(+), 6 deletions(-)
>
> LGTM
On Sat, Sep 06, 2014 at 03:46:03PM +0200, Stefano Sabatini wrote:
> TODO: bump micro
> ---
> doc/muxers.texi | 5 +
> libavformat/segment.c | 25 +++--
> 2 files changed, 28 insertions(+), 2 deletions(-)
>
> diff --git a/doc/muxers.texi b/doc/muxers.texi
> index d78
On Sat, Sep 06, 2014 at 01:28:41PM +0200, Christophe Gisquet wrote:
> 2014-09-06 12:40 GMT+02:00 Michael Niedermayer :
> > -// Backup context in case an alternate header is detected
> > -if( get_bits_left(gb) >= 66)
> > -memcpy(&backup, gb, sizeof(backup));
> > +memcpy(&backup,
This avoids several issue like calculating sum/maxcoef
incorrectly due to adding up matrix entries that will
be overwritten, as well as out-of-range writes to
s->matrix if the maximum allowed number of channels is used.
Signed-off-by: Reimar Döffinger
---
libswresample/rematrix.c | 10 ++
We only actually need to use a tiny part of it.
Unfortunately we seem to have no real test coverage on
the code, so this is a bit risky.
Signed-off-by: Reimar Döffinger
---
libswresample/rematrix.c | 14 +-
1 file changed, 9 insertions(+), 5 deletions(-)
diff --git a/libswresample/r
A branch to avoid some calculation seems unlikely to have any benefits.
Signed-off-by: Reimar Döffinger
---
libswresample/rematrix.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/libswresample/rematrix.c b/libswresample/rematrix.c
index 62662f8..5da3056 100644
--- a/libs
On Wed, Sep 03, 2014 at 10:48:38PM +0200, Michael Niedermayer wrote:
> On Wed, Sep 03, 2014 at 09:40:55PM +0200, Reimar Döffinger wrote:
> > We only actually need to use a tiny part of it.
> > Unfortunately we seem to have no real test coverage on
> > the code, so this is a bit risky.
> >
> > Sign
On Sat, Sep 06, 2014 at 12:13:30PM +0200, Andreas Cadhalpun wrote:
> Hi,
>
> attached patch fixes two spelling errors that crept in:
> allows to -> allows one to
> syncronization -> synchronization
>
> Please apply it before 2.4 gets released.
>
> Best regards,
> Andreas
[...]
> --- a/li
On Sat, Sep 06, 2014 at 09:12:47AM -0800, Lou Logan wrote:
> On Sat, Sep 6, 2014, at 04:37 AM, db0company wrote:
> > ---
> > src/documentation | 18 +-
> > 1 files changed, 9 insertions(+), 9 deletions(-)
>
> I don't have a strong opinion about this patch but there are two thing
On Sat, Sep 6, 2014, at 04:37 AM, db0company wrote:
> ---
> src/template_head2 |3 ++-
> 1 files changed, 2 insertions(+), 1 deletions(-)
LGTM, thanks.
I can apply, but I'll be unable to until Monday. Anyone else can feel
free to beat me to it.
___
On Sat, Sep 6, 2014, at 04:37 AM, db0company wrote:
> ---
> src/documentation | 18 +-
> 1 files changed, 9 insertions(+), 9 deletions(-)
I don't have a strong opinion about this patch but there are two things
I want to bikeshed:
1. One nice thing about the current format is th
On 9/6/14, Michael Niedermayer wrote:
> Fixes CID1237284
>
> Signed-off-by: Michael Niedermayer
> ---
> libavfilter/af_silenceremove.c |7 ++-
> 1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/libavfilter/af_silenceremove.c
> b/libavfilter/af_silenceremove.c
> index 3f6c
TODO: bump micro
---
doc/muxers.texi | 5 +
libavformat/segment.c | 25 +++--
2 files changed, 28 insertions(+), 2 deletions(-)
diff --git a/doc/muxers.texi b/doc/muxers.texi
index d7833a6..6f3ac1d 100644
--- a/doc/muxers.texi
+++ b/doc/muxers.texi
@@ -804,6 +804,11
---
src/template_head2 |3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/src/template_head2 b/src/template_head2
index a818fe2..2e61b30 100644
--- a/src/template_head2
+++ b/src/template_head2
@@ -30,9 +30,10 @@
http://trac.ffmpeg.org";>Wiki
---
src/documentation | 18 +-
1 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/src/documentation b/src/documentation
index a17725f..05408fd 100644
--- a/src/documentation
+++ b/src/documentation
@@ -29,15 +29,15 @@
Components Documentation
-
---
README |5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/README b/README
index ca70560..5076719 100644
--- a/README
+++ b/README
@@ -18,8 +18,9 @@ GENERATE THE DOCUMENTATION
To generate the documentation pages, just `./generate-doc.sh `.
In case of a major CSS up
Signed-off-by: Marton Balint
---
ffplay.c | 22 +++---
1 file changed, 15 insertions(+), 7 deletions(-)
diff --git a/ffplay.c b/ffplay.c
index c59065f..54f4584 100644
--- a/ffplay.c
+++ b/ffplay.c
@@ -263,7 +263,6 @@ typedef struct VideoState {
int video_stream;
AVStrea
Create a generic frame and a frame queue struct to handle video picture queues
and subtitle picture queues with common code. Also add the possibility to queue
AVFrames, however at the moment we only use SDL_Overlay buffers for video and
AVSubtitles for subtitles.
Signed-off-by: Marton Balint
---
On Sat, Sep 06, 2014 at 12:13:30PM +0200, Andreas Cadhalpun wrote:
> -Effectively this allows to add padding with zeros from the left.
> +Effectively this allows one to add padding with zeros from the left.
Huh? I don't think the second is more correct, and it sure sounds worse.
What is this tryin
2014-09-06 12:40 GMT+02:00 Michael Niedermayer :
> -// Backup context in case an alternate header is detected
> -if( get_bits_left(gb) >= 66)
> -memcpy(&backup, gb, sizeof(backup));
> +memcpy(&backup, gb, sizeof(backup));
I know people consider obvious comments to waste screen
Fixes CID1237284
Signed-off-by: Michael Niedermayer
---
libavfilter/af_silenceremove.c |7 ++-
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/libavfilter/af_silenceremove.c b/libavfilter/af_silenceremove.c
index 3f6cb7a..02b64ce 100644
--- a/libavfilter/af_silenceremove.c
Fixes CID1237283
Signed-off-by: Michael Niedermayer
---
libavcodec/hevc_ps.c |4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/libavcodec/hevc_ps.c b/libavcodec/hevc_ps.c
index 365652c..219af2f 100644
--- a/libavcodec/hevc_ps.c
+++ b/libavcodec/hevc_ps.c
@@ -526,9 +526,7
On Sat, Sep 06, 2014 at 08:24:10AM +0200, Reimar Döffinger wrote:
> On 06.09.2014, at 00:23, wm4 wrote:
> > On Sat, 6 Sep 2014 00:00:10 +0200
> > Michael Niedermayer wrote:
> >
> >> On Thu, Sep 04, 2014 at 10:40:27PM +0200, wm4 wrote:
> >>> ---
> >>> Follows reimar's suggestion for detecting UTF
Hi,
attached patch fixes two spelling errors that crept in:
allows to -> allows one to
syncronization -> synchronization
Please apply it before 2.4 gets released.
Best regards,
Andreas
>From 8c4c7e6f7c1f6043156838cd9041beba91025060 Mon Sep 17 00:00:00 2001
From: Andreas Cadhalpun
Date:
31 matches
Mail list logo