Hi,
Is it safe to run `eu-strip --reloc-debug-sections-only` on Linux kernel
.debug files, such as vmlinux.debug and .ko.debug modules?
It's really reduces size significantly. Description for .ko in
PR#24344 looks good (that it strips linking information that does not
needed for the kernel, but e
From: Timm Bäder
Get rid of a nested function this way.
Signed-off-by: Timm Bäder
---
libdwfl/ChangeLog | 5 +++
libdwfl/link_map.c | 104 +
2 files changed, 62 insertions(+), 47 deletions(-)
diff --git a/libdwfl/ChangeLog b/libdwfl/ChangeLog
ind
From: Timm Bäder
Get rid of a nested function this way. Add a memory_closure struct to
keep the functions clean.
Signed-off-by: Timm Bäder
---
libdwfl/ChangeLog | 5 +
libdwfl/link_map.c | 48 ++
2 files changed, 37 insertions(+), 16 deletions(
Same as the old thread. I used a memory_closure struct this time.
I quickly looked over the patches and I think we could even save
buffer and buffer_available in there to reduce the parameter count
further but then we should rename the struct (but read_data isn't the
best name either).
Hope the ch