Staging: Skein: Moved macros from skein_block.c to header
file.
The original code defined macros in the source code, making it
harder to read. Moved them to the header file, as per the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/skein/skein_block.c | 473
tasks.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/skein/TODO | 8 +-
drivers/staging/skein/skein_test.c | 831
+
drivers/staging/skein/skein_test.h | 516 +++ 3
files changed, 1351 insertions(+), 4 deletions(-) create mode
I disagree with the output of the automaton. Included below are my
compile checks before and after the patch.
The output has been scrubbed to remove information about my file layout.
--
[~ linux]$ git branch -v
master 31ade3b Linux
On Mon, 7 Dec 2015 11:37:31 +0530
Sudip Mukherjee wrote:
> And you moved skein_256_process_block() from skein_block.c to a header
> file. Is skein_256_process_block() a macro?
No, it is not a macro, it is a conditional. But as other conditionals
was already included in the header file, I felt th
The original code defined macros in the source code, making it
harder to read. Moved them to the header file, as per the TODO file.
Upadated the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/skein/TODO | 1 -
drivers/staging/skein/skein_block.c | 6 --
drivers
>From c07c57f3e045865b0acae498c631189f24aeda0b Mon Sep 17 00:00:00 2001
From: Sanidhya Solanki
Date: Thu, 10 Dec 2015 21:13:10 -0500
Subject: [PATCH] staging: gdm72xx: Code cleanups
Code cleanups as per the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/gdm72xx/gdm_qo
>From 1dbe78ce98037da5467d817a9db838d678b338ae Mon Sep 17 00:00:00 2001
From: Sanidhya Solanki
Date: Fri, 11 Dec 2015 03:08:53 -0500
Subject: [PATCH] staging: dgnc: Patch includes the checkpatch fixes
Patch contains the checkpatch fixes as asked by the TODO.
TODO file is updated as well.
Sig
On Fri, 11 Dec 2015 16:02:33 +0300
Dan Carpenter wrote:
> > Signed-off-by: Sanidhya Solanki
> > @@ -110,7 +98,16 @@ static ssize_t dgnc_vpd_show(struct device *p, struct
> > device_attribute *attr,
> > int count = 0;
> > int i = 0;
> >
> >
>From fa54ad27ad5ba8c90e0b42901af09423b1b3d0c7 Mon Sep 17 00:00:00 2001
From: Sanidhya Solanki
Date: Fri, 11 Dec 2015 21:08:06 -0500
Subject: [PATCH] staging: dgnc: Patch includes the checkpatch fixes
Patch contains the checkpatch fixes as asked by the TODO.
Unnecessary do-while() loops
>From ae99848ed2c054e3ec031b3014f4727f6ff94ea3 Mon Sep 17 00:00:00 2001
From: Sanidhya Solanki
Date: Fri, 11 Dec 2015 21:12:35 -0500
Subject: [PATCH 2/2] staging: dgnc: Update the TODO file
Patch updates the TODO file. Line regarding checkpatch
changes removed.
Signed-off-by: Sanidhya Sola
On Fri, 11 Dec 2015 16:02:33 +0300
Dan Carpenter wrote:
> On Fri, Dec 11, 2015 at 03:21:49AM -0500, Sanidhya Solanki wrote:
> > >From 1dbe78ce98037da5467d817a9db838d678b338ae Mon Sep 17 00:00:00 2001
> > From: Sanidhya Solanki
> > Date: Fri, 11 Dec 2015 03:08:53 -
Thank you everyone for your concern regarding my email client.
Unfortunately, there is a bug in "git send-email" that leads to the gmail
SMTP server rejecting certain patches sent by the git command. If I can
replicate and fix the issue for " git am" (which I do apply after emailing
to myself) I
>From a1635ea5e75cb2f10728ae4ddf3a21567958e98f Mon Sep 17 00:00:00 2001
From: Sanidhya Solanki
Date: Sat, 12 Dec 2015 02:20:03 -0500
Subject: [PATCH] [PATCH 1/3] staging: dgnc: Patch includes the checkpatch
fixes
Patch contains the spacing fixes that checkpatch prompted for,
as asked by
Patch contains the CamelCase fixes & Macro fixes that
checkpatch prompted for, as asked by the TODO.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_driver.c | 56 -
drivers/staging/dgnc/dgnc_driver.h | 25 ++--
drivers/staging/dgnc/dgnc_mgmt.c | 28 ++---
dri
Patch updates the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/dgnc/TODO b/drivers/staging/dgnc/TODO
index 0e0825b..0bdfd26 100644
--- a/drivers/staging/dgnc/TODO
+++ b/drivers/staging/dgnc/TODO
Sorry about Patch 1/3 having the header information. The rest should be fine.
I broke up the patches as you requested.
I can also confirm that git am gives me an error if the patch to be applied
does not contain the header information. Specifically, "Patch format detection
failed.".
Yes, this is
Patch contains the spacing fixes that checkpatch prompted for,
as asked by the TODO.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_cls.c| 4 +-
drivers/staging/dgnc/dgnc_driver.h | 8 --
drivers/staging/dgnc/dgnc_neo.c| 235
Patch contains the CamelCase fixes & Macro fixes that
checkpatch prompted for, as asked by the TODO.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_driver.c | 56 -
drivers/staging/dgnc/dgnc_driver.h | 25 ++--
drivers/staging/dgnc/dgnc_mgmt.c | 28 ++---
dri
Patch updates the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/dgnc/TODO b/drivers/staging/dgnc/TODO
index 0e0825b..0bdfd26 100644
--- a/drivers/staging/dgnc/TODO
+++ b/drivers/staging/dgnc/TODO
The original code defined macros in the source code, making it
harder to read. Moved them to the header file, as per the TODO file.
Updated the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/skein/TODO | 1 -
drivers/staging/skein/skein_block.c | 6 --
drivers
Can you tell me what was incorrect about them?
I thought you requested the dgnc patches to be resent without the
headers.
There are 3 of them because Dan Carpenter asked my patch to be broken
up so each one does only one thing. I also resent you the skein
subsystem patches, as I did not hear anythi
Patch contains the spacing fixes that checkpatch prompted for,
as asked by the TODO.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_cls.c| 4 +-
drivers/staging/dgnc/dgnc_driver.h | 8 --
drivers/staging/dgnc/dgnc_neo.c| 235
Patch contains the CamelCase fixes & Macro fixes that
checkpatch prompted for, as asked by the TODO.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_driver.c | 56 -
drivers/staging/dgnc/dgnc_driver.h | 25 ++--
drivers/staging/dgnc/dgnc_mgmt.c | 28 ++---
dri
Patch updates the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/dgnc/TODO b/drivers/staging/dgnc/TODO
index 0e0825b..0bdfd26 100644
--- a/drivers/staging/dgnc/TODO
+++ b/drivers/staging/dgnc/TODO
Patch contains the spacing fixes that led to checkpatch.pl warnings.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_cls.c| 4 +-
drivers/staging/dgnc/dgnc_driver.h | 8 --
drivers/staging/dgnc/dgnc_neo.c| 235 -
drivers/staging/dgnc
Patch contains the spacing fixes that led to checkpatch.pl warnings.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_cls.c| 4 +-
drivers/staging/dgnc/dgnc_driver.h | 8 --
drivers/staging/dgnc/dgnc_neo.c| 235
-
drivers/staging/dgnc
Patch contains the CamelCase fixes & Macro fixes that led to
checkpatch.pl errors.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/dgnc_driver.c | 56 -
drivers/staging/dgnc/dgnc_driver.h | 25 ++--
drivers/staging/dgnc/dgnc_mgmt.c | 28 ++---
drivers/staging/
Patch updates the TODO file.
Signed-off-by: Sanidhya Solanki
---
drivers/staging/dgnc/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/dgnc/TODO b/drivers/staging/dgnc/TODO
index 0e0825b..0bdfd26 100644
--- a/drivers/staging/dgnc/TODO
+++ b/drivers/staging/dgnc/TODO
On Tue, 15 Dec 2015 07:55:15 -0700
Mathieu Poirier wrote:
> I must admit you lost me here - what is this new version about? I
> suggest you used the [PATCH v#] convention along with a log of
> modifications from one version to another when sending new revisions.
> That way people know what to loo
29 matches
Mail list logo