[PATCH v5 46/46] usb: musb: gadget: add musb_match_ep() function

2015-07-31 Thread Robert Baldyga
Add 'match_ep' callback to utilize chip-specific knowledge in endpoint matching process. Function does the same that was done by chip-specific code inside of epautoconf. Now this code can be removed from there to separate generic code from platform specific logic. Signed-off-by: Robe

[PATCH v5 42/46] usb: gadget: move ep_matches() from epautoconf to udc-core

2015-07-31 Thread Robert Baldyga
Move ep_matches() function to udc-core and rename it to usb_gadget_ep_match_desc(). This function can be used by UDC drivers in 'match_ep' callback to avoid writing lots of repetitive code. Replace all calls of ep_matches() with usb_gadget_ep_match_desc(). Signed-off-by: Robe

Re: [PATCH v3 20/20] arm: mach-pxa: Decrement the power supply's device reference counter

2015-02-07 Thread Robert Jarzmik
Krzysztof Kozlowski writes: > Use power_supply_put() to decrement the power supply's device reference > counter. > > Signed-off-by: Krzysztof Kozlowski > Reviewed-by: Bartlomiej Zolnierkiewicz > Reviewed-by: Sebastian Reichel Acked-by: Rob

Re: [PATCH 1/3] imx-drm: Add mx6 hdmi transmitter support

2013-10-03 Thread Robert Nelson
uot;ipu-v3/imx-ipu-v3.h" Otherwise. drivers/staging/imx-drm/imx-hdmi.c:27:28: fatal error: drm/imx-ipu-v3.h: No such file or directory #include ^ compilation terminated. make[3]: *** [drivers/staging/imx-drm/imx-hdmi.o] Error 1 make[2]: *** [drivers/staging/imx-drm]

Re: [PATCH RFC 26/46] drivers/base: provide an infrastructure for componentised subsystems

2014-01-10 Thread Robert Schwebel
On Fri, Jan 10, 2014 at 07:35:30AM -0800, Greg Kroah-Hartman wrote: > > I'll sort out a new set of patches today, along with a branch to pull if > > you wish to take them that way. > > It's too late for 3.14, as my tree is now closed for that because 3.13 > should be out this weekend. But I'll be

Re: [PATCH RFC 26/46] drivers/base: provide an infrastructure for componentised subsystems

2014-01-11 Thread Robert Schwebel
On Fri, Jan 10, 2014 at 11:23:37PM +, Russell King - ARM Linux wrote: > We do this in DT by providing a "superdevice" node which specifies > the components, eg: > > imx-drm { > compatible = "fsl,drm"; > crtcs = <&ipu1>; > connectors = <&hdmi>; >

[PATCH] Staging: gdm72xx: fix coding style

2014-09-29 Thread Thibaut Robert
This patch remove a checkstyle warning in netlink_k.c. Note: This is my homework of the day. Signed-off-by: Thibaut Robert --- drivers/staging/gdm72xx/netlink_k.c | 13 ++--- 1 file changed, 6 insertions(+), 7 deletions(-) diff --git a/drivers/staging/gdm72xx/netlink_k.c b/drivers

Re: [PATCH] Staging: gdm72xx: fix coding style

2014-09-30 Thread Thibaut Robert
Le Monday 29 Sep 2014 à 11:31:24 (-0700), Joe Perches a écrit : > On Mon, 2014-09-29 at 20:15 +0200, Thibaut Robert wrote: > > This patch remove a checkstyle warning in netlink_k.c. > > Note: This is my homework of the day. > > The "Note: " line isn't useful fo

[PATCH] Staging: gdm72xx: fix coding style

2014-09-30 Thread Thibaut Robert
Remove unnecessary else after return. Follow coding style for curly braces around single statements. Fix a typo in error message. Signed-off-by: Thibaut Robert --- drivers/staging/gdm72xx/netlink_k.c | 24 +++- 1 file changed, 11 insertions(+), 13 deletions(-) diff --git a

Re: [PATCH] Staging: gdm72xx: fix coding style

2014-09-30 Thread Thibaut Robert
Le Tuesday 30 Sep 2014 à 12:23:12 (+0200), Thibaut Robert a écrit : > Remove unnecessary else after return. > Follow coding style for curly braces around single statements. > Fix a typo in error message. > > Signed-off-by: Thibaut Robert > --- > drivers/staging/gdm

[PATCH] staging: gdm72xx: fix typo and coding style

2014-09-30 Thread Thibaut Robert
Fix a typo in error message. Add missing curling braces to conform to coding style. Improve readibility. Signed-off-by: Thibaut Robert --- drivers/staging/gdm72xx/netlink_k.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/gdm72xx/netlink_k.c

Re: [PATCH v5 01/46] usb: gadget: encapsulate endpoint claiming mechanism

2015-08-20 Thread Robert Baldyga
ually enable and disable endpoints. A follow-up patch will come to drop all driver_data checks from function drivers, since those are, now, pointless. Fixes: cc476b42a39d ("usb: gadget: encapsulate endpoint claiming mechanism") Cc: Robert Baldyga S

Re: [PATCH v5 01/46] usb: gadget: encapsulate endpoint claiming mechanism

2015-08-20 Thread Robert Baldyga
On 08/20/2015 06:48 PM, Felipe Balbi wrote: On Thu, Aug 20, 2015 at 06:28:14PM +0200, Robert Baldyga wrote: Hi Felipe, On 08/20/2015 05:35 PM, Felipe Balbi wrote: [...] just letting you know that this regresses all gadget drivers making them try to disable previously disabled endpoints and

Re: [-next PATCH 3/4] treewide: Use DEVICE_ATTR_RO

2017-12-20 Thread Robert Jarzmik
xargs perl -i -e 'local $/; while (<>) { >> s/\bDEVICE_ATTR\s*\(\s*(\w+)\s*,\s*\(?(?:\s*S_IRUGO\s*|\s*0444\s*)\)?\s*,\s*\1_show\s*,\s*NULL\s*\)/DEVICE_ATTR_RO(\1)/g; >> print;}' >> >> Signed-off-by: Joe Perches >> --- >> arch/arm/mach-pxa/shar

[PATCH 00/15] ARM: pxa: switch to DMA slave maps

2018-04-02 Thread Robert Jarzmik
ware, including : - pxamci - pxa_camera - smc* - ASoC and SSP Happy review. Robert Jarzmik (15): dmaengine: pxa: use a dma slave map ARM: pxa: add dma slave map mmc: pxamci: remove the dmaengine compat need media: pxa_camera: remove the dmaengine compat need mtd: nand: pxa3xx: remov

[PATCH 02/15] ARM: pxa: add dma slave map

2018-04-02 Thread Robert Jarzmik
In order to remove the specific knowledge of the dma mapping from PXA drivers, add a default slave map for pxa architectures. This is the first step, and once all drivers are converted, pxad_filter_fn() will be made static, and the DMA resources removed from device.c. Signed-off-by: Robert

[PATCH 05/15] mtd: nand: pxa3xx: remove the dmaengine compat need

2018-04-02 Thread Robert Jarzmik
From: Robert Jarzmik As the pxa architecture switched towards the dmaengine slave map, the old compatibility mechanism to acquire the dma requestor line number and priority are not needed anymore. This patch simplifies the dma resource acquisition, using the more generic function

[PATCH 04/15] media: pxa_camera: remove the dmaengine compat need

2018-04-02 Thread Robert Jarzmik
From: Robert Jarzmik As the pxa architecture switched towards the dmaengine slave map, the old compatibility mechanism to acquire the dma requestor line number and priority are not needed anymore. This patch simplifies the dma resource acquisition, using the more generic function

[PATCH 03/15] mmc: pxamci: remove the dmaengine compat need

2018-04-02 Thread Robert Jarzmik
-off-by: Robert Jarzmik --- drivers/mmc/host/pxamci.c | 29 +++-- 1 file changed, 3 insertions(+), 26 deletions(-) diff --git a/drivers/mmc/host/pxamci.c b/drivers/mmc/host/pxamci.c index c763b404510f..6c94474e36f4 100644 --- a/drivers/mmc/host/pxamci.c +++ b/drivers/mmc

[PATCH 01/15] dmaengine: pxa: use a dma slave map

2018-04-02 Thread Robert Jarzmik
tatic, and the DMA resources removed from device.c. Signed-off-by: Robert Jarzmik Reported-by: Arnd Bergmann --- drivers/dma/pxa_dma.c | 10 +- include/linux/platform_data/mmp_dma.h | 4 2 files changed, 13 insertions(+), 1 deletion(-) diff --git a/drivers/dma/pxa_

[PATCH 08/15] ASoC: pxa: remove the dmaengine compat need

2018-04-02 Thread Robert Jarzmik
-off-by: Robert Jarzmik --- sound/arm/pxa2xx-ac97.c | 14 ++ sound/arm/pxa2xx-pcm-lib.c | 6 +++--- sound/soc/pxa/pxa2xx-ac97.c | 32 +--- 3 files changed, 10 insertions(+), 42 deletions(-) diff --git a/sound/arm/pxa2xx-ac97.c b/sound/arm/pxa2xx-ac97.c

[PATCH 10/15] ata: pata_pxa: remove the dmaengine compat need

2018-04-02 Thread Robert Jarzmik
-off-by: Robert Jarzmik --- drivers/ata/pata_pxa.c | 10 +- 1 file changed, 1 insertion(+), 9 deletions(-) diff --git a/drivers/ata/pata_pxa.c b/drivers/ata/pata_pxa.c index f6c46e9a4dc0..e8b6a2e464c9 100644 --- a/drivers/ata/pata_pxa.c +++ b/drivers/ata/pata_pxa.c @@ -25,7 +25,6

[PATCH 09/15] net: irda: pxaficp_ir: remove the dmaengine compat need

2018-04-02 Thread Robert Jarzmik
-off-by: Robert Jarzmik --- drivers/staging/irda/drivers/pxaficp_ir.c | 14 ++ 1 file changed, 2 insertions(+), 12 deletions(-) diff --git a/drivers/staging/irda/drivers/pxaficp_ir.c b/drivers/staging/irda/drivers/pxaficp_ir.c index 2ea00a6531f9..9dd6e21dc11e 100644 --- a/drivers

[PATCH 07/15] net: smc91x: remove the dmaengine compat need

2018-04-02 Thread Robert Jarzmik
From: Robert Jarzmik As the pxa architecture switched towards the dmaengine slave map, the old compatibility mechanism to acquire the dma requestor line number and priority are not needed anymore. This patch simplifies the dma resource acquisition, using the more generic function

[PATCH 06/15] net: smc911x: remove the dmaengine compat need

2018-04-02 Thread Robert Jarzmik
From: Robert Jarzmik As the pxa architecture switched towards the dmaengine slave map, the old compatibility mechanism to acquire the dma requestor line number and priority are not needed anymore. This patch simplifies the dma resource acquisition, using the more generic function

[PATCH 11/15] dmaengine: pxa: document pxad_param

2018-04-02 Thread Robert Jarzmik
Add some documentation for the pxad_param structure, and describe the contract behind the minimal required priority of a DMA channel. Signed-off-by: Robert Jarzmik --- include/linux/dma/pxa-dma.h | 9 + 1 file changed, 9 insertions(+) diff --git a/include/linux/dma/pxa-dma.h b/include

[PATCH] Staging: crystalhd: fixed whitespace and string style issues

2013-08-28 Thread Robert Foss
Fixed 3 instances of user-visible string being broken into two string. Fixed 2 instances of illegal whitespace. --- drivers/staging/crystalhd/crystalhd_cmds.c |3 +-- drivers/staging/crystalhd/crystalhd_hw.c |7 +++ drivers/staging/crystalhd/crystalhd_lnx.c |3 +-- 3 files chang

[no subject]

2022-06-07 Thread Robert Baileys
-- Hallo, lieber Begünstigter, Sie haben diese E-Mail von der Robert Bailey Foundation erhalten. Ich bin ein pensionierter Regierungsangestellter aus Harlem und ein Powerball-Lotterie-Jackpot-Gewinner von 343,8 Millionen Dollar. Ich bin der größte Jackpot-Gewinner in der Geschichte der New York

Re : Mes salutations

2022-07-08 Thread Robert SONNE
-- Mes salutations Je suis Monsieur Robert SONNE un Opérateur économique à la retraite hospitalisée pour raison de santé. Je souffre d'une maladie cardiaque et le résultat de certaines de mes analyses médicales faisait état de ce que mes jours sur terre sont comptés, alors que je di

From Mr. Kevin Robert>~

2019-02-15 Thread Mr. Robert Kevin
Hi, I am Mr. Robert Kevin, Your email still valid? Please write to me for more details. Best Regards, Mr. Robert Kevin 538 Rush Green Road, Romford RM7 0LX. UK ___ devel mailing list de...@linuxdriverproject.org http

Good day to you,

2019-08-12 Thread Dr. Thomas Robert
executive project summary/ plan and I Will provide you with details, documents and picture ID to Authenticate our investment offer. Regards, Dr. Thomas Robert. ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org

WINNING NOTIFCATION!!

2019-06-15 Thread Mrs. Abby Robert
: 201987HGDD0326. You are also advised to provide him with the under listed information as soon as possible. Congratulations again from all our staff and thank you for being part of our promotional program. Mrs. Abby Robert. THE DIRECTOR PROMOTION ___ devel

Re: [PATCH] staging: wilc1000: use kernel define byte order macros

2017-03-21 Thread Robert Perry Hooker
Thanks for taking a look, Dan. Sorry if I missed the mark here. Can you tell me a bit more about the bug this would introduce? I see that ieee80211_is_action is defined like this: static inline bool ieee80211_is_action(__le16 fc) ...and that buff[FRAME_TYPE_ID]is a u8 (since FRAME_TYPE_ID = 0).

Re: [PATCH] staging: wilc1000: use kernel define byte order macros

2017-03-22 Thread Robert Perry Hooker
I don't think buff is an ieee80211_hdr struct. I think it's the rx_buffer allocated at wilc_wlan.c:1417. Regards, Perry On Wed, 2017-03-22 at 12:24 +0300, Dan Carpenter wrote: > On Tue, Mar 21, 2017 at 03:40:10PM -0600, Robert Perry Hooker wrote: > > Thanks for taking a lo

Re: [PATCH] staging: wilc1000: use kernel define byte order macros

2017-03-23 Thread Robert Perry Hooker
Well, yes, all data is 'endian' one way or another, right? I guess the byte order of the tx/rx_buffers is host-endian (which could be big), or _maybe_ network-endian... Regards, Perry On Thu, 2017-03-23 at 11:33 +0300, Dan Carpenter wrote: > On Wed, Mar 22, 2017 at 07:53:28PM

Lening of

2020-01-06 Thread Mr . Robert Marvin
Bent u op zoek naar een lening om te investeren of een persoonlijke lening? Download het hier voor een rentevoet van 3% en e-mail ons op robertmarvin4...@gmail.com met het vereiste leenbedrag en telefoonnummer. ___ devel mailing list de...@linuxdriverpr

BMW CAR AND CHECK OF $1,000,000 LOTTERY

2020-04-20 Thread Mrs Anita Robert
BMW LOTTERY DEPARTMENT 610 North Main Street,Culpeper Virginia 22701 USA. NOTE: If you received this message in your SPAM/JUNK folder, that is because of the restrictions implemented by your Internet Service Provider, we (BMW) urge you to treat it genuinely. This is to inform you that you have b

kindly respond to my mail

2020-08-25 Thread Sgt Vivian Robert
Good Day, I am glad to contact you through this medium I’m Sgt Vivian Robert am from united state, 28 years old single I am the only surviving child of my late parents, I am America female soldier presently in Afghanistan for the training, advising the Afghan forces and also helping in

RE: [PATCH 4/8] Drivers: scsi: storvsc: Filter WRITE_SAME_16

2014-07-16 Thread Elliott, Robert (Server Storage)
> -Original Message- > From: linux-scsi-ow...@vger.kernel.org [mailto:linux-scsi- > ow...@vger.kernel.org] On Behalf Of James Bottomley > Sent: Wednesday, 16 July, 2014 1:02 PM > To: martin.peter...@oracle.com > Cc: linux-ker...@vger.kernel.org; h...@infradead.org; > de...@linuxdriverproj

RE: [PATCH 1/1] [SCSI] Fix a bug in deriving the FLUSH_TIMEOUT from the basic I/O timeout

2014-07-17 Thread Elliott, Robert (Server Storage)
In sd_sync_cache: rq->timeout *= SD_FLUSH_TIMEOUT_MULTIPLIER; Regardless of the baseline for the multiplication, a magic number of 2 is too arbitrary. That might work for an individual drive, but could be far too short for a RAID controller that runs into worst case error handling for th

RE: [PATCH 1/1] [SCSI] Fix a bug in deriving the FLUSH_TIMEOUT from the basic I/O timeout

2014-07-18 Thread Elliott, Robert (Server Storage)
> From: James Bottomley [mailto:jbottom...@parallels.com] > > On Fri, 2014-07-18 at 00:51 +, Elliott, Robert (Server Storage) > wrote: ... > > > > Also, in both sd_setup_flush_cmnd and sd_sync_cache: > > cmd->cmnd[0] = SYNCHRONIZE_C

Contact JP Morgan Chase Bank NY USA to receive your transfer $35.700,000Million USD Deposited this Morning

2020-05-21 Thread Barrister Robert Richter UN-Attorney at Law Court-Benin
Robert Richter UN-Attorney at Law Court-Benin ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Contact JP Morgan Chase Bank NY USA to receive your transfer $35.700,000Million USD Deposited this Morning

2020-05-21 Thread Barrister Robert Richter UN-Attorney at Law Court-Benin
Robert Richter UN-Attorney at Law Court-Benin ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

<    1   2   3   4