This patch fixes a missing line after declarations issue.
Signed-off-by: Johannes Postma
---
drivers/staging/ozwpan/ozusbsvc1.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/ozwpan/ozusbsvc1.c
b/drivers/staging/ozwpan/ozusbsvc1.c
index 301fee8..b6cfecb 100644
--- a
usPtr is used as __le16 *, but was defined as u16 *.
This was reported by sparse as:
drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c:1850:29: warning: cast to
restricted __le16
This patch fixes the type of usPtr.
Signed-off-by: Johannes Postma
---
drivers/staging/rtl8723au/hal
On 06/08/15 at 08:21am, Jes Sorensen wrote:
>
> Looks OK to me. Probably worth changing the *(usPtr + index) to be
> usPtr[index] as well to make the code easier to read.
>
> Jes
>
Thank you for reviewing. I will make a seperate patch for that. I will
send it after this one is accepted. Or s
This patch improves code readability in the function
rtl8723a_cal_txdesc_chksum. It improves the readability of the argument
of the function le16_to_cpu.
Signed-off-by: Johannes Postma
---
drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion
On 07/08/15 at 08:26am, Jes Sorensen wrote:
> Johannes Postma writes:
> > On 06/08/15 at 08:21am, Jes Sorensen wrote:
> >>
> >> Looks OK to me. Probably worth changing the *(usPtr + index) to be
> >> usPtr[index] as well to make the code easier to read.
> &