Signed-off-by: David Howells
Reviewed-by: Christian Brauner
cc: Greg Kroah-Hartman
cc: "Arve Hjønnevåg"
cc: Todd Kjos
cc: Martijn Coenen
cc: Joel Fernandes
cc: de...@driverdev.osuosl.org
---
drivers/android/binderfs.c | 173
1 file c
.
Signed-off-by: David Howells
Reviewed-by: Christian Brauner
cc: Greg Kroah-Hartman
cc: "Arve Hjønnevåg"
cc: Todd Kjos
cc: Martijn Coenen
cc: Joel Fernandes
cc: de...@driverdev.osuosl.org
---
drivers/android/binderfs.c | 173
1 file c
Dan Carpenter wrote:
> > + struct ipc_namespace *ipc_ns = fc->s_fs_info;
> > + put_ipc_ns(ipc_ns);
>
> I feel like put_ipc_ns(info->ipc_ns) would be more readable.
Not so much more readable as more correct.
David
___
devel mailing
>
> Reported-by: Stephen Rothwell
> Reviewed-by: Chao Yu
> Signed-off-by: Gao Xiang
I recommend pushing this one to Linus now. It's trivial enough.
Reviewed-by: David Howells
___
devel mailing list
de...@linuxdriverproject.org
http://driverd
Gao Xiang wrote:
> This patch updates .mount and .remount_sb after
> commit ("vfs: Require specification of size of
> mount data for internal mounts") in reference to
> drivers/usb/gadget/function/f_fs.c.
>
> Reported-by: Stephen Rothwell
> Signed-off-by: Gao Xiang
I've folded this into my pa
Christoph Hellwig wrote:
> Use remove_proc_subtree to remove the whole subtree on cleanup, and
> unwind the registration loop into individual calls. Switch to use
> proc_create_seq where applicable.
Note that this is likely going to clash with my patch to net-namespace all of
the afs proc files
Christoph Hellwig wrote:
> +
> +struct proc_dir_entry *proc_create_seq_data(const char *name, umode_t mode,
> + struct proc_dir_entry *parent, const struct seq_operations *ops,
> + void *data)
> +{
> ...
> +EXPORT_SYMBOL(proc_create_seq_data);
Please add documentation com
Note that your kernel hits the:
inconsistent {HARDIRQ-ON-W} -> {IN-HARDIRQ-W} usage.
swapper/0/0 [HC1[1]:SC0[0]:HE0:SE1] takes:
(ptrval) (fs_reclaim){?.+.}, at: fs_reclaim_acquire+0x12/0x35
{HARDIRQ-ON-W} state was registered at:
fs_reclaim_acquire
> followed by some editing of the kfree_sensitive() kerneldoc and the
> use of memzero_explicit() instead of memset().
>
> Suggested-by: Joe Perches
> Signed-off-by: Waiman Long
Since this changes a lot of crypto stuff, does it make sense for it to go via
the crypto tree?
Ack
some drivers support automatic configuration (e.g. PNP or PCI) in addition
to manually coded parameters.
This patch annotates drivers in drivers/staging/media/.
Suggested-by: Alan Cox
Signed-off-by: David Howells
cc: Mauro Carvalho Chehab
cc: Greg Kroah-Hartman
cc: linux-me...@vger.kernel.o
some drivers support automatic configuration (e.g. PNP or PCI) in addition
to manually coded parameters.
This patch annotates drivers in drivers/staging/speakup/.
Suggested-by: Alan Cox
Signed-off-by: David Howells
cc: Greg Kroah-Hartman
cc: spea...@linux-speakup.org
cc: de...@driverdev.osuos
some drivers support automatic configuration (e.g. PNP or PCI) in addition
to manually coded parameters.
This patch annotates drivers in drivers/staging/vme/.
Suggested-by: Alan Cox
Signed-off-by: David Howells
cc: Martyn Welch
cc: Manohar Vanga
cc: Greg Kroah-Hartman
c
some drivers support automatic configuration (e.g. PNP or PCI) in addition
to manually coded parameters.
This patch annotates drivers in drivers/staging/vme/.
Suggested-by: One Thousand Gnomes
Signed-off-by: David Howells
cc: Martyn Welch
cc: Manohar Vanga
cc: Greg Kroah-Hartman
c
some drivers support automatic configuration (e.g. PNP or PCI) in addition
to manually coded parameters.
This patch annotates drivers in drivers/staging/speakup/.
Suggested-by: One Thousand Gnomes
Signed-off-by: David Howells
cc: Greg Kroah-Hartman
cc: spea...@linux-speakup.org
c
some drivers support automatic configuration (e.g. PNP or PCI) in addition
to manually coded parameters.
This patch annotates drivers in drivers/staging/media/.
Suggested-by: One Thousand Gnomes
Signed-off-by: David Howells
cc: Mauro Carvalho Chehab
cc: Greg Kroah-Hartman
cc: lin
Mauro Carvalho Chehab wrote:
> drivers/staging/media/lirc/lirc_parallel.c:728:19: error: Expected ) in
> function declarator
Did you apply patch 1 first? That defines module_param_hw*.
David
___
devel mailing list
de...@linuxdriverproject.org
http:/
some drivers support automatic configuration (e.g. PNP or PCI) in addition
to manually coded parameters.
This patch annotates drivers in drivers/staging/i4l/.
Suggested-by: One Thousand Gnomes
Signed-off-by: David Howells
cc: Greg Kroah-Hartman
cc: de...@driverdev.osuosl.org
---
drivers/st
Arnd Bergmann wrote:
> - mn10300 appears to be wrong, broken by David Howells in
> commit 83c2dc15ce82 ("MN10300: Handle cacheable PCI regions
> in pci_iomap()") for any driver calling ioremap() by to get uncached
> memory,
It's not clear what the right thing to
Waiman Long wrote:
> The kzfree() function is normally used to clear some sensitive
> information, like encryption keys, in the buffer before freeing it back
> to the pool. Memset()
"memset()" is all lowercase.
> is currently used for buffer clearing. However unlikely, there is still a
> non-ze
19 matches
Mail list logo