The GET_BUS_DEV macro contained flow control statements that are undesirable.
This patch removes the macro and places the code in each function.
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 48 --
1 file changed, 33 insertions(+), 15
Remove the instances of multiple blank lines in the visorchannel files.
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/visorchannel/globals.h |1 -
.../unisys/visorchannel/visorchannel_funcs.c |1 -
2 files changed, 2 deletions(-)
diff --git a/drivers/staging
Remove extraneous parentheses around a variable in visorchannel_funcs.c
Signed-off-by: Bryan Thompson
---
.../unisys/visorchannel/visorchannel_funcs.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/unisys/visorchannel/visorchannel_funcs.c
b/drivers
Add braces to the else arm of an if/else block in visorchannel_funcs.c
Signed-off-by: Bryan Thompson
---
.../unisys/visorchannel/visorchannel_funcs.c |3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/unisys/visorchannel/visorchannel_funcs.c
b
Split multiple logging lines to get them closer to 80 characters per line.
Signed-off-by: Bryan Thompson
---
.../unisys/visorchannel/visorchannel_funcs.c | 18 --
1 file changed, 12 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/unisys/visorchannel
Use the appropriate whitespace for multiline statements in visorchannel_funcs.c
Signed-off-by: Bryan Thompson
---
.../unisys/visorchannel/visorchannel_funcs.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/unisys/visorchannel
Move the || logical continuation from the start of the second line of an if
statement to the end of the first line.
Signed-off-by: Bryan Thompson
---
.../unisys/visorchannel/visorchannel_funcs.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging
This series of patches address a collection of formatting issues reported
by checkpatch.pl on the files in the visorchannel directory.
Bryan Thompson (8):
staging: unisys: visorchannel: Remove multiple blank lines
staging: unisys: visorchannel: Fix alignment issues
staging: unisys
Rename the goto label used throughout visorchannel_funcs.c from Away to cleanup.
Signed-off-by: Bryan Thompson
---
.../unisys/visorchannel/visorchannel_funcs.c | 54 ++--
1 file changed, 27 insertions(+), 27 deletions(-)
diff --git a/drivers/staging/unisys/visorchannel
Remove the whitespace between a cast and the variable in visorchannel_funcs.c
Signed-off-by: Bryan Thompson
---
.../unisys/visorchannel/visorchannel_funcs.c | 22 ++--
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/unisys/visorchannel
Rename the visorchannel_debug parameter nQueues to num_queues.
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/visorchannel/visorchannel.h |2 +-
.../unisys/visorchannel/visorchannel_funcs.c |4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers
Add comments indicating the requirements and use of the insert_lock and
remove_lock in the VISORCHANNEL_Tag structure.
Signed-off-by: Bryan Thompson
---
.../unisys/visorchannel/visorchannel_funcs.c |7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers
Resending due to return address error.
This series of patches addresses two CamelCase issues and a spinlock
commenting issue reported by checkpatch on the visorchannel tree.
Bryan Thompson (3):
staging: unisys: visorchannel: Rename CamelCase variable channelBytes
staging: unisys
Rename channelBytes to channel_bytes in the series of visorchannel_create
functions provided by visorchannel.
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/visorchannel/visorchannel.h | 10
.../unisys/visorchannel/visorchannel_funcs.c | 26 ++--
2
Remove one blank line of two between function variable declaration and
implementation in
virt_pci_mod_init().
Signed-off-by: Bryan Thompson
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c |1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/unisys
Use the appropriate whitespace alignment for multiline statements in virtpci.c
Signed-off-by: Bryan Thompson
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c | 28 ++--
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/drivers
Insert a blank line between the definition of the driver_private structure and
the next statement.
Signed-off-by: Bryan Thompson
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c |1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/unisys/virtpci
Change two instances of using the sizeof a structure to the size of a specific
variable when
allocating memory in virtpci.c
Signed-off-by: Bryan Thompson
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions
Move the && logical continuation from the start of the second line of an if
statement
to the end of the first line.
Signed-off-by: Bryan Thompson
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
di
Update delete_all_virt function definition to two lines so each line is less
than 80
characters long.
Move comments on virtpci_device_add function parameters to a header block to
contain
each line to 80 characters.
Signed-off-by: Bryan Thompson
Signed-off-by: Benjamin Romer
---
drivers
Removed unnecessary blank lines from virtpci.c
Signed-off-by: Bryan Thompson
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c |3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci/virtpci.c
Update if/else blocks with braces on both the if and the else blocks in
virtpci.c.
Signed-off-by: Bryan Thompson
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c |7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/unisys
This series of patches cleans up some simple checkpatch.pl findings in virtpci.c
Bryan Thompson (9):
staging: unisys: virtpci: Add a blank line after the definition of
driver_private
staging: unisys: virtpci: Remove extraneous blank lines
staging: unisys: virtpci: Remove space between
Remove the whitespace between a cast and a variable in virtpci.c.
Signed-off-by: Bryan Thompson
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c | 28 ++--
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/drivers/staging/unisys
This patch series renames the checkpatch.pl flagged CamelCase names in virtpci.c
Bryan Thompson (12):
staging: unisys: virtpci: Fix CamelCase Chipset_DriverInfo
staging: unisys: virtpci: Fix CamelCase virtpci device list head
staging: unisys: virtpci: Fix CamelCase virtpci device list lock
Rename the following local variables in virtpci_device_add()
pIoChan changed to io_chan
pDev changed to dev
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/unisys
Rename write_vbus_chpInfo() to write_vbus_chp_info() in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys
Rename the following fix_vbus_dev_info() parameters
devNo changed to dev_no
devType changed to dev_type
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/unisys/virtpci
Rename VpcidevListLock to vpcidev_list_lock in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 32 +++---
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging
Rename BusDriverInfo variable to bus_driver_info in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci
Rename fix_vbus_devInfo() to fix_vbus_dev_info().
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci/virtpci.c
Rename VpcidevListHead to vpcidev_list_head in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 32 +++---
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging
Rename write_vbus_devInfo() to write_vbus_dev_info() in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci
Rename the following local variables in fix_vbus_dev_info()
Change pChan to chan
Change devInfo to dev_info
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/unisys
Rename pDev to dev in delete_vbus_device()
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci/virtpci.c
index a299b32
Rename write_vbus_busInfo() to write_vbus_bus_info() in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys
Rename Chipset_DriverInfo to chipset_driver_info in virtpci.c
Signed-off-by: Bryan Thompson
---
drivers/staging/unisys/virtpci/virtpci.c |8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.c
b/drivers/staging/unisys/virtpci
37 matches
Mail list logo