Hi,
On Tue, Mar 09, 2021 at 09:58:09AM +0530, Viresh Kumar wrote:
> On 08-03-21, 16:54, Alexandru Ardelean wrote:
> > The intent is the removal of the 'delay_usecs' field from the
> > spi_transfer struct, as there is a 'delay' field that does the same
> > thing.
> >
> > The spi_delay_to_ns() can b
On Mon, 2021-01-18 at 13:32 +0100, Nicolas Saenz Julienne wrote:
> Adds support to control the PWM bus available in official Raspberry Pi
> PoE HAT. Only RPi's co-processor has access to it, so commands have to
> be sent through RPi's firmware mailbox interface.
>
> Signed-off-by: Nicolas Saenz Ju
From: Eli Billauer
This is a resubmission of the XillyUSB driver, which is the USB
variant of the existing Xillybus driver.
Because these driver share some API related functions, this submission
consists of two patches:
(1) A patch moving away Xillybus' class related functions to a
separate
From: Eli Billauer
This patch is a preparation for adding another related driver, XillyUSB.
In order to share some code between the existing Xillybus driver and the
one to be added, some functions are moved to xillybus_class.c
The header file, xillybus_class.h, is temporarily placed in include/l
From: Eli Billauer
The XillyUSB driver is the USB variant for the Xillybus FPGA IP core.
Even though it presents a nearly identical API on the FPGA and host,
it's almost a complete rewrite of the driver: The framework for exchanging
data on a USB bus is fundamentally different from doing the same
Removed additional whitspaces and added space around the binary operator in the
rtl8712_xmit.h file
Signed-off-by: Selvakumar Elangovan
---
drivers/staging/rtl8712/rtl8712_xmit.h | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl8712_xmit.h
b/dr
Removed additional whitspaces and added space around the binary operator in the
rtl8712_xmit.h file
Signed-off-by: Selvakumar Elangovan
---
drivers/staging/rtl8712/rtl8712_xmit.h | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl8712_xmit.h
b/dr
On Mon, Mar 08, 2021 at 04:54:58PM +0200, Alexandru Ardelean wrote:
> The intent is the removal of the 'delay_usecs' field from the
> spi_transfer struct, as there is a 'delay' field that does the same
> thing.
>
> The spi_delay_to_ns() can be used to get the transfer delay. It works by
> using th
On Thu, Mar 04, 2021 at 10:43:45AM +0100, Jérôme Pouiller wrote:
> Hello Greg,
>
> On Tuesday 2 March 2021 16:01:25 CET Jérôme Pouiller wrote:
> > Hello Muhammad,
> >
> > Sorry, I am a bit late for the review of this patch. Thank you for your
> > contribution.
> >
> > On Thursday 11 February 20
On Tue, Mar 09, 2021 at 06:24:45PM +0530, Selvakumar Elangovan wrote:
> Removed additional whitspaces and added space around the binary operator in
> the rtl8712_xmit.h file
Please wrap your changelog at 72 columns.
And you are doing 2 different things in this patch, please only do one
"logical"
On Fri, Jan 22, 2021 at 06:01:13PM +0300, Dan Carpenter wrote:
> The "gasket_dev->num_page_tables" variable is an int but this is copying
> sizeof(u64). On 32 bit systems this would end up disclosing a kernel
> pointer to user space, but on 64 bit it copies zeroes from a struct
> hole.
>
> Fixes:
On Tuesday 9 March 2021 14:07:43 CET Greg KH wrote:
> On Thu, Mar 04, 2021 at 10:43:45AM +0100, Jérôme Pouiller wrote:
> > Hello Greg,
> >
> > On Tuesday 2 March 2021 16:01:25 CET Jérôme Pouiller wrote:
> > > Hello Muhammad,
> > >
> > > Sorry, I am a bit late for the review of this patch. Thank you
Removed additional whitespaces in the rtl8712_xmit.h file.
Signed-off-by: Selvakumar Elangovan
---
drivers/staging/rtl8712/rtl8712_xmit.h | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl8712_xmit.h
b/drivers/staging/rtl8712/rtl8712_xmit.h
index 0b56bd3ac4d0..e4c
Added space around the binary operator for readability in
rtl8712_xmit.h file
Signed-off-by: Selvakumar Elangovan
---
drivers/staging/rtl8712/rtl8712_xmit.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8712/rtl8712_xmit.h
b/drivers/staging/rtl8712/rtl87
On Tue, Mar 09, 2021 at 07:47:21PM +0530, Selvakumar Elangovan wrote:
> Removed additional whitespaces in the rtl8712_xmit.h file.
>
> Signed-off-by: Selvakumar Elangovan
> ---
> drivers/staging/rtl8712/rtl8712_xmit.h | 3 ---
> 1 file changed, 3 deletions(-)
What changed from v1? Always put t
On Tue, Mar 09, 2021 at 02:45:56PM +0100, Jérôme Pouiller wrote:
> On Tuesday 9 March 2021 14:07:43 CET Greg KH wrote:
> > On Thu, Mar 04, 2021 at 10:43:45AM +0100, Jérôme Pouiller wrote:
> > > Hello Greg,
> > >
> > > On Tuesday 2 March 2021 16:01:25 CET Jérôme Pouiller wrote:
> > > > Hello Muhamma
Removed additional whitespaces in the rtl8712_xmit.h file.
Signed-off-by: Selvakumar Elangovan
---
Changes in v3:
- Done one logical changes instead of two different changes in the same
patch.
drivers/staging/rtl8712/rtl8712_xmit.h | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drive
On Tue, Mar 09, 2021 at 06:22:25AM +0100, Sergio Paracuellos wrote:
> Vendor listed for mediatek in kernel vendor file 'vendor-prefixes.yaml'
> contains 'mediatek' as a valid vendor string. Some nodes in the device
> tree are using an invalid vendor string vfor 'mtk' instead. Fix all of
> them in d
url:
https://github.com/0day-ci/linux/commits/eli-billauer-gmail-com/Submission-of-XillyUSB-driver/20210309-193645
base: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/char-misc.git
080951f99de1e483a9a48f34c079b634f2912a54
config: x86_64-randconfig-m001-20210309 (attached as
On Tue, Mar 09, 2021 at 04:57:59PM +, Walter Harms wrote:
> why not mark it as "Deprecated" and remove it with the next version ? Maybe
> soneone will wakeup ?
We don't really have a "Deprecated" marking, we just delete them :)
thanks,
greg k-h
__
why not mark it as "Deprecated" and remove it with the next version ? Maybe
soneone will wakeup ?
re,
wh
Von: Greg Kroah-Hartman
Gesendet: Dienstag, 9. März 2021 14:26:55
An: Dan Carpenter
Cc: Rob Springer; de...@driverdev.osuosl.org; kernel-janit...@vge
allyesconfig
powerpc allmodconfig
powerpc allnoconfig
i386 randconfig-a005-20210309
i386 randconfig-a003-20210309
i386 randconfig-a002-20210309
i386 randconfig-a006-20210309
i386
allyesconfig
mips allmodconfig
powerpc allyesconfig
powerpc allmodconfig
powerpc allnoconfig
i386 randconfig-a005-20210309
i386 randconfig-a003-20210309
i386
If there in an error during a set_fmt, do not overwrite the previous
sizes with the invalid config.
Without this patch, v4l2-compliance ends up allocating 4GiB of RAM and
causing the following OOPs
[ 38.662975] ipu3-imgu :00:05.0: swiotlb buffer is full (sz: 4096 bytes)
[ 38.662980] DMA:
allyesconfig
powerpc allmodconfig
powerpc allnoconfig
i386 randconfig-a005-20210309
i386 randconfig-a003-20210309
i386 randconfig-a002-20210309
i386 randconfig-a006-20210309
i386
randconfig-a005-20210309
i386 randconfig-a003-20210309
i386 randconfig-a002-20210309
i386 randconfig-a006-20210309
i386 randconfig-a004-20210309
i386 randconfig-a001-20210309
x86_64 randconfig-a013-20210
On Mon, 8 Mar 2021 at 18:42, Lars-Peter Clausen wrote:
>
> On 3/8/21 3:54 PM, Alexandru Ardelean wrote:
> > The 'delay_usecs' field was handled for backwards compatibility in case
> > there were some users that still configured SPI delay transfers with
> > this field.
> >
> > They should all be re
On 3/10/21 8:16 AM, Alexandru Ardelean wrote:
On Mon, 8 Mar 2021 at 18:42, Lars-Peter Clausen wrote:
On 3/8/21 3:54 PM, Alexandru Ardelean wrote:
The 'delay_usecs' field was handled for backwards compatibility in case
there were some users that still configured SPI delay transfers with
this fi
28 matches
Mail list logo