On Tue, Oct 13, 2020 at 08:12:20PM -0600, Shuah Khan wrote:
> They don't add any new behavior, As Kees mentioned they do give us a
> way to clearly differentiate atomic usages that can wrap.
No it doesn't! atomic_t can wrap, this thing can wrap, no distinction.
All it does is fragment the API an
Instructions and examples on kernel data structures dumping and
coredump.
Signed-off-by: Coiby Xu
---
.../networking/device_drivers/index.rst | 1 +
.../device_drivers/qlogic/index.rst | 18 +++
.../networking/device_drivers/qlogic/qlge.rst | 118 ++
MAINTAINER
Initialize devlink health dump framework for the qlge driver so the
coredump could be done via devlink.
struct qlge_adapter is now used as the private data struct of
struct devlink so it could exist independently of struct net_device
and devlink reload could be supported in the future.
Signed-off
$ devlink health dump show DEVICE reporter coredump -p -j
{
"Core Registers": {
"segment": 1,
"values": [
0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
This patch set aims to avoid dumping registers, data structures and
coredump to dmesg and also to reduce the code size of the qlge driver.
As pointed out by Benjamin [1],
> At 2000 lines, qlge_dbg.c alone is larger than some entire ethernet
> drivers. Most of what it does is dump kernel data stru
devlink health could be used to get coredump. No need to send so much
data to the kernel ring buffer.
Signed-off-by: Coiby Xu
---
drivers/staging/qlge/TODO | 2 --
drivers/staging/qlge/qlge.h | 3 ---
drivers/staging/qlge/qlge_dbg.c | 11 ---
drivers/staging/qlge/
The debugging code in the following ifdef land
- QL_ALL_DUMP
- QL_REG_DUMP
- QL_DEV_DUMP
- QL_CB_DUMP
- QL_IB_DUMP
- QL_OB_DUMP
becomes unnecessary because,
- Device status and general registers can be obtained by ethtool.
- Coredump can be done via devlink health reporter.
- Structure re
With force_coredump module parameter set, devlink health dump will
reset the MPI RISC first which takes 5 secs to be finished.
Signed-off-by: Coiby Xu
---
drivers/staging/qlge/qlge_devlink.c | 7 +++
1 file changed, 7 insertions(+)
diff --git a/drivers/staging/qlge/qlge_devlink.c
b/drivers
Hello Pali,
On Tuesday 13 October 2020 22:11:56 CEST Pali Rohár wrote:
> Hello!
>
> On Monday 12 October 2020 12:46:32 Jerome Pouiller wrote:
> > +#define SDIO_VENDOR_ID_SILABS0x
> > +#define SDIO_DEVICE_ID_SILABS_WF200 0x1000
> > +static const struct sdio_device_id wfx_sdio_ids[] =
On Wednesday 14 October 2020 13:52:15 Jérôme Pouiller wrote:
> Hello Pali,
>
> On Tuesday 13 October 2020 22:11:56 CEST Pali Rohár wrote:
> > Hello!
> >
> > On Monday 12 October 2020 12:46:32 Jerome Pouiller wrote:
> > > +#define SDIO_VENDOR_ID_SILABS0x
> > > +#define SDIO_DEVICE_ID_S
On Wed, Oct 14, 2020 at 06:43:01PM +0800, Coiby Xu wrote:
> static int qlge_probe(struct pci_dev *pdev,
> const struct pci_device_id *pci_entry)
> {
> struct net_device *ndev = NULL;
> struct qlge_adapter *qdev = NULL;
> + struct devlink *devlink;
> stati
On Tuesday 13 October 2020 18:49:35 CEST Rob Herring wrote:
> On Mon, Oct 12, 2020 at 12:46:26PM +0200, Jerome Pouiller wrote:
> > From: Jérôme Pouiller
[...]
> > + Note that in add of the properties below, the WFx driver also supports
> > + `mac-address` and `local-mac-address` as described in
Hi Tomasz,
On 9/26/20 10:00 AM, Tomasz Figa wrote:
> Hi Helen,
>
> On Wed, Jul 22, 2020 at 12:55:32PM -0300, Helen Koike wrote:
>> From: Shunqian Zheng
>>
>> RK3399 has two ISPs, but only isp0 was tested.
>> Add isp0 node in rk3399 dtsi
>>
>> Verified with:
>> make ARCH=arm64 dtbs_check
>> DT_S
On 2020-10-14 17:27, Helen Koike wrote:
Hi Tomasz,
On 9/26/20 10:00 AM, Tomasz Figa wrote:
Hi Helen,
On Wed, Jul 22, 2020 at 12:55:32PM -0300, Helen Koike wrote:
From: Shunqian Zheng
RK3399 has two ISPs, but only isp0 was tested.
Add isp0 node in rk3399 dtsi
Verified with:
make ARCH=arm64
On Wed, Oct 14, 2020 at 6:27 PM Helen Koike wrote:
>
> Hi Tomasz,
>
> On 9/26/20 10:00 AM, Tomasz Figa wrote:
> > Hi Helen,
> >
> > On Wed, Jul 22, 2020 at 12:55:32PM -0300, Helen Koike wrote:
> >> From: Shunqian Zheng
> >>
> >> RK3399 has two ISPs, but only isp0 was tested.
> >> Add isp0 node in
Hi Rob,
Thnaks for your reply.
On 9/22/20 11:24 AM, Rob Herring wrote:
> On Wed, Jul 22, 2020 at 9:56 AM Helen Koike wrote:
>>
>> aclk_isp_wrap is a child of aclk_isp, and hclk_isp_wrap is a child of
>> hclk_isp, thus we can remove parents from the list.
>>
>> Also, for the isp0, we only need th
Thank you Tomasz and Robin for your comments,
On 10/14/20 1:43 PM, Tomasz Figa wrote:
> On Wed, Oct 14, 2020 at 6:27 PM Helen Koike wrote:
>>
>> Hi Tomasz,
>>
>> On 9/26/20 10:00 AM, Tomasz Figa wrote:
>>> Hi Helen,
>>>
>>> On Wed, Jul 22, 2020 at 12:55:32PM -0300, Helen Koike wrote:
From: S
Good day,
You have been selected to receive my grant donation. Please, contact me for
further detail.to email mrsveraael...@gmail.com
Best Regards,
Mrs. Vera Aellen.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproje
Good day,
You have been selected to receive my grant donation. Please, contact me for
further detail.to email mrsveraael...@gmail.com
Best Regards,
Mrs. Vera Aellen.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproje
On Wed, Oct 14, 2020 at 11:17:20AM +0200, Peter Zijlstra wrote:
> On Tue, Oct 13, 2020 at 08:12:20PM -0600, Shuah Khan wrote:
>
> > They don't add any new behavior, As Kees mentioned they do give us a
> > way to clearly differentiate atomic usages that can wrap.
>
> No it doesn't! atomic_t can wr
On 2020-10-14 18:43 +0800, Coiby Xu wrote:
> To avoid namespace clashes with other qlogic drivers and also for the
> sake of naming consistency, use the "qlge_" prefix as suggested in
> drivers/staging/qlge/TODO.
>
> Suggested-by: Benjamin Poirier
> Signed-off-by: Coiby Xu
> ---
> drivers/stagi
On Tue, Oct 13, 2020 at 09:37:04AM +0900, Benjamin Poirier wrote:
On 2020-10-12 19:24 +0800, Coiby Xu wrote:
[...]
> I think, but didn't check in depth, that in those drivers, the devlink
> device is tied to the pci device and can exist independently of the
> netdev, at least in principle.
>
You
On Wed, Oct 14, 2020 at 04:08:46PM +0300, Dan Carpenter wrote:
On Wed, Oct 14, 2020 at 06:43:01PM +0800, Coiby Xu wrote:
static int qlge_probe(struct pci_dev *pdev,
const struct pci_device_id *pci_entry)
{
struct net_device *ndev = NULL;
struct qlge_adapte
On Thu, Oct 15, 2020 at 10:01:36AM +0900, Benjamin Poirier wrote:
On 2020-10-14 18:43 +0800, Coiby Xu wrote:
To avoid namespace clashes with other qlogic drivers and also for the
sake of naming consistency, use the "qlge_" prefix as suggested in
drivers/staging/qlge/TODO.
Suggested-by: Benjamin
On Thu, Oct 15, 2020 at 12:26:28PM +0800, Coiby Xu wrote:
On Thu, Oct 15, 2020 at 10:01:36AM +0900, Benjamin Poirier wrote:
On 2020-10-14 18:43 +0800, Coiby Xu wrote:
To avoid namespace clashes with other qlogic drivers and also for the
sake of naming consistency, use the "qlge_" prefix as sugg
Hello,friend
Thanks for your time to read my email:)
I am Nora from Qgeem Electronic Co., LTD , CHINA.Our main product cover
Lightning series products ,
extension dock,hub,data cable,charging accessories, audio and video
switching,MFi products and other.
USB C convertor series:
Accepted w
26 matches
Mail list logo