On 24.10.19 05:53, Anshuman Khandual wrote:
On 10/22/2019 10:42 PM, David Hildenbrand wrote:
Our onlining/offlining code is unnecessarily complicated. Only memory
blocks added during boot can have holes. Hotplugged memory never has
holes. That memory is already online.
Why hot plugged memory
On Wednesday 28 August 2019 18:08:17 Greg Kroah-Hartman wrote:
> The full specification of the filesystem can be found at:
> https://docs.microsoft.com/en-us/windows/win32/fileio/exfat-specification
FYI, it looks like that this released specification is just copy+paste
from exFAT patent https://
On Thu, Oct 24, 2019 at 07:26:59AM +0200, Julia Lawall wrote:
> > If you're making significant changes to this driver, please test them
> > using the MIPS cavium_octeon_defconfig which is where this driver is
> > actually used.
> >
> > This driver has broken builds a few times recently which makes
Our onlining/offlining code is unnecessarily complicated. Only memory
blocks added during boot can have holes (a range that is not
IORESOURCE_SYSTEM_RAM). Hotplugged memory never has holes (e.g., see
add_memory_resource()). All boot memory is alread online.
Therefore, when we stop allowing to offl
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to
change that.
KVM has this weird use case that you can map anything from /dev/mem
into the guest. pfn_valid() is not a reliable check whether the memmap
was initialized and can be touched. pfn_to_online_page() makes sure
that we ha
This is the result of a recent discussion with Michal ([1], [2]). Right
now we set all pages PG_reserved when initializing hotplugged memmaps. This
includes ZONE_DEVICE memory. In case of system memory, PG_reserved is
cleared again when onlining the memory, in case of ZONE_DEVICE memory
never.
In
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to
change that.
KVM has this weird use case that you can map anything from /dev/mem
into the guest. pfn_valid() is not a reliable check whether the memmap
was initialized and can be touched. pfn_to_online_page() makes sure
that we ha
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to
change that.
KVM has this weird use case that you can map anything from /dev/mem
into the guest. pfn_valid() is not a reliable check whether the memmap
was initialized and can be touched. pfn_to_online_page() makes sure
that we ha
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to
change that.
KVM has this weird use case that you can map anything from /dev/mem
into the guest. pfn_valid() is not a reliable check whether the memmap
was initialized and can be touched. pfn_to_online_page() makes sure
that we ha
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to
change that.
Rewrite hash_page_do_lazy_icache() to make sure the function produces the
same result once we stop setting ZONE_DEVICE pages PG_reserved.
Cc: Benjamin Herrenschmidt
Cc: Paul Mackerras
Cc: Michael Ellerman
Cc: "Ane
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to
change that.
Rewrite __ioremap_check_ram() to make sure the function produces the
same result once we stop setting ZONE_DEVICE pages PG_reserved.
Cc: Dave Hansen
Cc: Andy Lutomirski
Cc: Peter Zijlstra
Cc: Thomas Gleixner
Cc:
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to
change that.
Rewrite maybe_pte_to_page() to make sure the function produces the
same result once we stop setting ZONE_DEVICE pages PG_reserved.
Cc: Benjamin Herrenschmidt
Cc: Paul Mackerras
Cc: Michael Ellerman
Cc: Christophe
ZONE_DEVICE (a.k.a. device memory) is no longer marked PG_reserved. Update
the comment.
While at it, make it match what the code is acutally doing (reject vs.
accept).
Cc: Kees Cook
Cc: Andrew Morton
Cc: "Isaac J. Manjarres"
Cc: "Matthew Wilcox (Oracle)"
Cc: Qian Cai
Cc: Thomas Gleixner
Sig
Everything should be prepared to stop setting pages PG_reserved when
initializing the memmap on memory hotplug. Most importantly, we
stop marking ZONE_DEVICE pages PG_reserved.
a) We made sure that any code that relied on PG_reserved to detect
ZONE_DEVICE memory will no longer rely on PG_reserv
On 23.10.19 09:26, David Hildenbrand wrote:
On 22.10.19 23:54, Dan Williams wrote:
Hi David,
Thanks for tackling this!
Thanks for having a look :)
[...]
I am probably a little bit too careful (but I don't want to break things).
In most places (besides KVM and vfio that are nuts), the
pfn_
The code had its own non-standard FFS_FOO return codes. Go through
and convert them all the kernel standard -EFOO codes.
Valdis Kletnieks (15):
staging: exfat: Clean up return codes - FFS_FULL
staging: exfat: Clean up return codes - FFS_NOTFOUND
staging: exfat: Clean up return codes - FFS_DI
Start cleaning up the odd scheme of return codes, starting with FFS_FULL
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_core.c | 10 +-
drivers/staging/exfat/exfat_super.c | 16
3 files changed, 13 insertions(
Convert FFS_DIRBUSY to -EBUSY
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_super.c | 2 +-
2 files changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/exfat/exfat.h b/drivers/staging/exfat/exfat.h
index 1d82de4e1a5c.
Convert FFS_NOTFOUND to -ENOENT
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_super.c | 6 +++---
2 files changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/exfat/exfat.h b/drivers/staging/exfat/exfat.h
index 4aca4a
Convert FFS_FILEEXIST to -EEXIST
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_core.c | 2 +-
drivers/staging/exfat/exfat_super.c | 14 +++---
3 files changed, 8 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/ex
Convert FFS_NOTNAMETOOLONG to -ENAMETOOLONG
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_super.c | 4 ++--
2 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/exfat/exfat.h b/drivers/staging/exfat/exfat.h
in
Convert FFS_INVALIDPATH to -EINVAL
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_core.c | 10 +-
drivers/staging/exfat/exfat_super.c | 10 +-
3 files changed, 10 insertions(+), 11 deletions(-)
diff --git a/drivers/st
Convert FFS_PERMISSIONERR to -EPERM
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_super.c | 20 ++--
2 files changed, 10 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/exfat/exfat.h b/drivers/staging/exfa
Covert FFS_INVALIDFID to -EINVAL
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_super.c | 10 +-
2 files changed, 5 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/exfat/exfat.h b/drivers/staging/exfat/exfat.h
index
Convert FFS_MEDIAERR to (mostly) -ENOENT and -EIO. Some additional code surgery
needed to propogate correct error codes upwards.
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h| 1 -
drivers/staging/exfat/exfat_blkdev.c | 18 ++---
drivers/staging/exfat/exfat_core.c
Convert FFS_FORMATERR to -EFSCORRUPTED
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 3 ++-
drivers/staging/exfat/exfat_core.c | 4 ++--
drivers/staging/exfat/exfat_super.c | 2 +-
3 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/exfat/e
Convert FFS_EOF to return 0 for a zero-length read() as per 'man 2 read'.
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_super.c | 2 +-
2 files changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/exfat/exfat.h b/drive
Convert FFS_MEMORYERR to -ENOMEM
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_core.c | 10 +-
2 files changed, 5 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/exfat/exfat.h b/drivers/staging/exfat/exfat.h
index 0
Convert FFS_ERROR to -EINVAL
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 1 -
drivers/staging/exfat/exfat_core.c | 8
drivers/staging/exfat/exfat_super.c | 20 ++--
3 files changed, 14 insertions(+), 15 deletions(-)
diff --git a/drivers/
Just replace FFS_SUCCESS with a literal 0.
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 3 -
drivers/staging/exfat/exfat_cache.c | 4 +-
drivers/staging/exfat/exfat_core.c | 90 ++---
drivers/staging/exfat/exfat_super.c | 50 ---
There are 6 FFS_* error values not used at all. Remove them.
Signed-off-by: Valdis Kletnieks
---
drivers/staging/exfat/exfat.h | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/exfat/exfat.h b/drivers/staging/exfat/exfat.h
index 2ca2710601ae..819a21d72c67 100644
--- a/driv
Remove code valid only for 5 GHz, according to the TODO.
- find and remove remaining code valid only for 5 GHz. Most of the obvious
ones have been removed, but things like channel > 14 still exist.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 12 ++--
On Thu, 2019-10-24 at 11:53 -0400, Valdis Kletnieks wrote:
> The code had its own non-standard FFS_FOO return codes. Go through
> and convert them all the kernel standard -EFOO codes.
>
> Valdis Kletnieks (15):
> staging: exfat: Clean up return codes - FFS_FULL
> staging: exfat: Clean up retur
On Thu, 24 Oct 2019 09:23:33 -0700, Joe Perches said:
> On Thu, 2019-10-24 at 11:53 -0400, Valdis Kletnieks wrote:
> > if (err) {
> > - if (err == FFS_PERMISSIONERR)
> > + if (err == -EPERM)
> > err = -EPERM;
> > else if (err == FFS_INVALIDPA
On Thu, 2019-10-24 at 11:53 -0400, Valdis Kletnieks wrote:
> Just replace FFS_SUCCESS with a literal 0.
[]
> diff --git a/drivers/staging/exfat/exfat_cache.c
> b/drivers/staging/exfat/exfat_cache.c
[]
> @@ -214,7 +214,7 @@ static u8 *FAT_getblk(struct super_block *sb, sector_t
> sec)
>
>
Cleans up checks of "Alignment should match open parenthesis"
in tree sm750fb
Gabriela Bittencourt (3):
staging: sm750fb: align arguments with open parenthesis in
ddk750_sii164.c
staging: sm750fb: align arguments with open parenthesis in file
sm750_accel.h
staging: sm750fb: align arg
Cleans up checks of "Alignment should match open parenthesis"
in file ddk750_sii164.c
Signed-off-by: Gabriela Bittencourt
---
drivers/staging/sm750fb/ddk750_sii164.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/sm750fb/ddk750_sii164.c
b/drivers/staging/sm7
Cleans up checks of "Alignment should match open parenthesis"
in file sm750_accel.h
Signed-off-by: Gabriela Bittencourt
---
drivers/staging/sm750fb/sm750_accel.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750_accel.h
b/drivers/staging/sm7
Cleans up checks of "Alignment should match open parenthesis"
in file sm750_cursor.h
Signed-off-by: Gabriela Bittencourt
---
drivers/staging/sm750fb/sm750_cursor.h | 17 +++--
1 file changed, 7 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750_cursor.h
b/dri
On Thu, 24 Oct 2019 09:23:24 -0700, Joe Perches said:
> All well and good, but does converting the error code from
> positive to negative have any impact on any of the code
> paths that use these return values?
>
> if (error > 0)
> vs
> if (error < 0)
I was keeping an eye open for tha
On Thu, 24 Oct 2019 09:29:00 -0700, Joe Perches said:
> > - if (sector_read(sb, sec, &bp->buf_bh, 1) != FFS_SUCCESS) {
> > + if (sector_read(sb, sec, &bp->buf_bh, 1) != 0) {
>
> Probably nicer to just drop the != 0
Again, that's on the to-do list.
pgpW4nZ8xnSkz.pgp
Description: PGP signatur
On Thu, Oct 24, 2019 at 11:53:12AM -0400, Valdis Kletnieks wrote:
> Start cleaning up the odd scheme of return codes, starting with FFS_FULL
> +++ b/drivers/staging/exfat/exfat.h
> @@ -221,7 +221,6 @@ static inline u16 get_row_index(u16 i)
> #define FFS_PERMISSIONERR 11
> #define FFS_NOTOP
On Thu, 24 Oct 2019 10:59:04 -0700, Matthew Wilcox said:
> Wouldn't it be better to do this as:
> Patch 1: Change all these defines to -Exxx and remove the stupid
> errno-changing
> blocks like this:
Well, except for the fact that the one for FFS_MEDIAERR required splitting the
uses into -ENODEV
TEON_SOC=y
would), but that's not strictly needed anyway - any old config with
CAVIUM_OCTEON_SOC=y would do.
Thanks,
Paul
[1]
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=0228ecf6128c92b47eadd2ac270c5574d9150c09
[2]
https://git.kernel.org/pub/scm/
at doesn't necessarily point
> you to cavium_octeon_defconfig (though grepping for CAVIUM_OCTEON_SOC=y
> would), but that's not strictly needed anyway - any old config with
> CAVIUM_OCTEON_SOC=y would do.
>
> Thanks,
> Paul
>
> [1]
> https://git.kernel.org/pu
On Thu, 2019-10-24 at 11:53 -0400, Valdis Kletnieks wrote:
> Convert FFS_PERMISSIONERR to -EPERM
[]
> diff --git a/drivers/staging/exfat/exfat_super.c
> b/drivers/staging/exfat/exfat_super.c
[]
> @@ -2526,7 +2526,7 @@ static int exfat_unlink(struct inode *dir, struct
> dentry *dentry)
>
>
In terms of namespace, the driver uses either qlge_, ql_ (used by
other qlogic drivers, with clashes, ex: ql_sem_spinlock) or nothing (with
clashes, ex: struct ob_mac_iocb_req). Rename everything to use the "qlge_"
prefix.
So I renamed three functions to the prefered namespace "qlge",
and updated
Function ql_own_firmware renamed to
qlge_own_firmware and it's clients updated.
Signed-off-by: Samuil Ivanov
---
drivers/staging/qlge/qlge.h | 2 +-
drivers/staging/qlge/qlge_dbg.c | 2 +-
drivers/staging/qlge/qlge_mpi.c | 5 ++---
3 files changed, 4 insertions(+), 5 deletions(-)
diff --git
Function ql_mb_about_fw renamed to
qlge_mb_about_fw and it's clients updated.
Signed-off-by: Samuil Ivanov
---
drivers/staging/qlge/qlge.h | 2 +-
drivers/staging/qlge/qlge_main.c | 2 +-
drivers/staging/qlge/qlge_mpi.c | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a
This is from the TODO list:
In terms of namespace, the driver uses either qlge_, ql_ (used by
other qlogic drivers, with clashes, ex: ql_sem_spinlock) or nothing (with
clashes, ex: struct ob_mac_iocb_req). Rename everything to use the "qlge_"
prefix
Function ql_soft_reset_mpi_risc renamed to
qlge_
On Fri, Oct 18, 2019 at 12:09:48AM -0700, Chandra Annamaneni wrote:
> Resolved: ERROR: else should follow close brace '}'
>
> Signed-off-by: Chandra Annamaneni
> ---
> Previous versions of these patches were not split into different
> patches, did not have different patch numbers and did not hav
On Wed, Oct 16, 2019 at 12:09:22AM +0100, Jules Irenge wrote:
> Add space betwen operator to fix check warning.
> Issue detected by checkpatch tool.
>
> Signed-off-by: Jules Irenge
> ---
> drivers/staging/vc04_services/interface/vchi/vchi_cfg.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 dele
On Wed, Oct 23, 2019 at 01:27:44AM -0400, Valdis Kletnieks wrote:
> Make as much as possible static. We're over-exuberant here for the benefit
> of a following patch, as the compiler will flag now-unused static code
This adds a bunch of compiler warnings, which isn't ok. Please fix this
up to be
On Wed, Oct 23, 2019 at 01:27:51AM -0400, Valdis Kletnieks wrote:
> Signed-off-by: Valdis Kletnieks
> ---
> drivers/staging/exfat/TODO | 20
> 1 file changed, 8 insertions(+), 12 deletions(-)
I can't take patches without any changelog text, sorry :(
_
On Thu, Oct 24, 2019 at 11:53:20AM -0400, Valdis Kletnieks wrote:
> Convert FFS_FORMATERR to -EFSCORRUPTED
>
> Signed-off-by: Valdis Kletnieks
> ---
> drivers/staging/exfat/exfat.h | 3 ++-
> drivers/staging/exfat/exfat_core.c | 4 ++--
> drivers/staging/exfat/exfat_super.c | 2 +-
> 3 fi
On Fri, Oct 25, 2019 at 12:29:38AM +0300, Samuil Ivanov wrote:
> In terms of namespace, the driver uses either qlge_, ql_ (used by
> other qlogic drivers, with clashes, ex: ql_sem_spinlock) or nothing (with
> clashes, ex: struct ob_mac_iocb_req). Rename everything to use the "qlge_"
> prefix.
>
>
56 matches
Mail list logo