On Fri, 11 Oct 2019, Julia Lawall wrote:
On Fri, 11 Oct 2019, Jules Irenge wrote:
Fix warning of logical continuations should be on the previous line.
Issue detected by checkpatch tool.
There seem to be several changes mixed together in this patch.
Don't have a subject line that is ide
Place the AND logical operator at the end of the previous line;
to fix warning of "Logical continuations should be on the previous line".
Issue detected by checkpatch tool.
Signed-off-by: Jules Irenge
---
drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera.c | 4 ++--
1 file changed, 2
The following changes since commit 54ecb8f7028c5eb3d740bb82b0f1d90f2df63c5c:
Linux 5.4-rc1 (2019-09-30 10:35:40 -0700)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
tags/staging-5.4-rc3
for you to fetch changes up to 3f3d31622a2c18
Remove typedef declaration from struct cvmx_wqe.
Also replace its previous uses with new struct declaration.
Issue found by checkpatch.pl
Signed-off-by: Wambui Karuga
---
drivers/staging/octeon/ethernet-rx.c | 6 +++---
drivers/staging/octeon/ethernet-tx.c | 2 +-
drivers/staging/octeon/ethe
Remove typedef declaration for enum cvmx_fau_reg_32.
Also replace its previous uses with new declaration format.
Issue found by checkpatch.pl
Signed-off-by: Wambui Karuga
---
drivers/staging/octeon/octeon-stubs.h | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
diff --git a/
This patchset removes the addition of new typedefs data types in octeon,
along with replacing the previous uses with the new declaration format.
v2 of the series removes the obsolete "_t" notation in the named types.
Wambui Karuga (5):
staging: octeon: remove typedef declaration for cvmx_wqe
Remove declaration of union cvmx_helper_link_info as typedef.
Also replace its previous uses with new union declaration.
Issue found by checkpatch.pl
Signed-off-by: Wambui Karuga
---
drivers/staging/octeon/ethernet-mdio.c | 6 +++---
drivers/staging/octeon/ethernet-rgmii.c | 4 ++--
drivers
Remove addition of new typedef for enum cvmx_fau_op_size.
Issue found by checkpatch.pl
Signed-off-by: Wambui Karuga
---
drivers/staging/octeon/octeon-stubs.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/octeon/octeon-stubs.h
b/drivers/staging/octeon/oc
Removes addition of new typedef declaration for
cvmx_pko_command_word0.
Also replace previous instances with new union declaration.
Signed-off-by: Wambui Karuga
---
drivers/staging/octeon/ethernet-tx.c | 2 +-
drivers/staging/octeon/octeon-stubs.h | 6 +++---
2 files changed, 4 insertions(+), 4
On Sat, 12 Oct 2019, Wambui Karuga wrote:
> This patchset removes the addition of new typedefs data types in octeon,
> along with replacing the previous uses with the new declaration format.
>
> v2 of the series removes the obsolete "_t" notation in the named types.
>
> Wambui Karuga (5):
> s
On Sat, 12 Oct 2019, Wambui Karuga wrote:
> Remove typedef declaration for enum cvmx_fau_reg_32.
> Also replace its previous uses with new declaration format.
> Issue found by checkpatch.pl
>
> Signed-off-by: Wambui Karuga
> ---
> drivers/staging/octeon/octeon-stubs.h | 14 --
> 1
This patch series addresses the use of unnecessary return variables and
line-breaks in function headers, both in
drivers/staging/rtl8712/rtl871x_mp_ioctl.c.
Wambui Karuga (2):
staging: rtl8712: remove unnecessary return variables
staging: rtl8712: clean up function headers
drivers/staging/r
Remove variables that are only used to hold and return constants and
have the functions directly return the constants.
Issue found by coccinelle:
@@
local idexpression ret;
expression e;
@@
-ret =
+return
e;
-return ret;
Signed-off-by: Wambui Karuga
---
drivers/staging/rtl8712/rtl871x_mp_
Remove unnecessary line-breaks in function headers to
improve readability of function headers.
Signed-off-by: Wambui Karuga
---
drivers/staging/rtl8712/rtl871x_mp_ioctl.c | 57 --
1 file changed, 19 insertions(+), 38 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_
On Sat, Oct 12, 2019 at 08:37:18PM +0200, Julia Lawall wrote:
>
>
> On Sat, 12 Oct 2019, Wambui Karuga wrote:
>
> > Remove typedef declaration for enum cvmx_fau_reg_32.
> > Also replace its previous uses with new declaration format.
> > Issue found by checkpatch.pl
> >
> > Signed-off-by: Wambui
The pull request you sent on Sat, 12 Oct 2019 18:16:38 +0200:
> git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
> tags/staging-5.4-rc3
has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/9cbc63485fd5e25cef5d64c28ca3318364073773
Thank you!
--
Deet-doot-d
16 matches
Mail list logo