Looks good.
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Wed, Jun 19, 2019 at 05:54:05PM +0100, Colin King wrote:
> From: Colin Ian King
>
> The break statement is indented one level too deep, fix this.
>
> Signed-off-by: Colin Ian King
> ---
> drivers/staging/vt6656/card.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a
On 2019/6/17 20:55, Colin King wrote:
> From: Colin Ian King
>
> Currently pointer de is being initialized with a value that is
> never read and a few statements later de is being re-assigned. Clean
> this up by ininitialzing de and removing the re-assignment.
>
> Addresses-Coverity: ("Unused va
Since our last attempt of a few enormous commits, we ditched our changes
and started over again, this time with a lot smaller changes per patch
adressing one small thing at a time.
Sorry for the inconvenience last time!
Christian Müller (1):
drivers/staging/rtl8129u: adjust block comments
dri
As stated in coding-styles.rst multiline comments should be structured in a way,
that the actual comment starts on the second line of the commented portion. E.g:
/*
* Multiline comments
* should look like
* this.
*/
The comments in this file were of a format, that looked like this:
/* Multil
On Wed, 19 Jun 2019, Joe Perches wrote:
> On Thu, 2019-06-20 at 11:14 +1000, Alastair D'Silva wrote:
>> On Wed, 2019-06-19 at 17:35 -0700, Joe Perches wrote:
>> > On Thu, 2019-06-20 at 09:15 +1000, Alastair D'Silva wrote:
>> > > On Wed, 2019-06-19 at 09:31 -0700, Joe Perches wrote:
>> > > > On Mon
On Wed, Jun 19, 2019 at 01:29:03PM -0300, Jason Gunthorpe wrote:
> > Yes. This will blow up badly on many platforms, as sq->queue
> > might be vmapped, ioremapped, come from a pool without page backing.
>
> Gah, this addr gets fed into io_remap_pfn_range/remap_pfn_range too..
>
> Potnuri, you sh
On Thu, Jun 20, 2019 at 11:45:34AM +0200, Christian Müller wrote:
> As stated in coding-styles.rst multiline comments should be structured in a
> way,
> that the actual comment starts on the second line of the commented portion.
> E.g:
>
> /*
> * Multiline comments
> * should look like
> * th
Remove leading p from the names of the following pointer variables:
- padapter
- pmlmepriv
- psec_priv.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/mlme_linux.c | 34 ++--
1 file changed, 17 insertions(+), 17 deletions(-)
diff
Change return type of function r8712_setstakey_cmd() to void as its
return value is never stored, checked, or otherwise used.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 9 -
drivers/staging/rtl8712/rtl871x_cmd.h | 2 +-
2 files changed, 5 insertions(+), 6
Change return type of function r8712_disassoc_cmd from u8 to void as its
return value is never stored, checked or otherwise used. Modify its
return statements accordingly.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 7 +++
drivers/staging/rtl8712/rtl871x_cmd.h
Change the return types of r8712_enqueue_cmd to void as the return value
of r8712_enqueue_cmd is never stored, checked, or otherwise used.
Also change the return type of _enqueue_cmd to void as it is only called
by r8712_enqueue_cmd which does not do anything with the return value
except return it
Remove the check for whether the value of variable psecnetwork is NULL
as psecnetwork is a field of a field of a non-NULL pointer, and
therefore cannot be NULL itself.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 4
1 file changed, 4 deletions(-)
diff --git a/
Change return type of function r8712_setopmode_cmd() from u8 to void as
its return value is never stored or checked or otherwise used.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 7 +++
drivers/staging/rtl8712/rtl871x_cmd.h | 2 +-
2 files changed, 4 insertions
Change return values of function r8712_joinbss_cmd from _SUCCESS/_FAIL
to 0/-ENOMEM respectively.
Change return type from u8 to int to accommodate return of -ENOMEM.
Similarly, change the return values (_SUCCESS to 0 and _FAIL to -ENOMEM
or -EINVAL) and type (sint to int) of the call site of r8712
Remove leading 'p' from the name of the pointer variable padapter.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl8712_efuse.c | 152
1 file changed, 76 insertions(+), 76 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl87
Change return type of function r8712_set_chplan_cmd from u8 to void as
its return value is never stored, checked or otherwise used. Change the
return statements accordingly.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 7 +++
drivers/staging/rtl8712/rtl871x_cmd.
Change return type of function r8712_setMacAddr_cmd() to void as its
return value is never stored, checked, or otherwise used. Modify its
return statements accordingly.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 7 +++
drivers/staging/rtl8712/rtl871x_cmd.h | 2
On Thu, Jun 20, 2019 at 07:20:52AM +0200, Sergio Paracuellos wrote:
> Hi Greg,
>
> On Thu, Jun 20, 2019 at 2:40 AM Greg Ungerer wrote:
> >
> > Hi Sergio,
> >
> > On 19/6/19 5:44 pm, Sergio Paracuellos wrote:
> > > Some boards seems to ignore builtin perst configuration and use gpio
> > > instead.
Hi Greg,
On Thu, Jun 20, 2019 at 2:31 PM Greg KH wrote:
[snip]
> > Ok, thanks for testing this. Let's apply this patch series first.
> >
> > GregKH, can we also apply this for linux-stable? kernel 5.1. Should I
> > sent anything else for that?
>
> Which specific patch(s) are needed for 5.1? Wh
On Wed, Jun 19, 2019 at 11:34:39PM +0530, Hariprasad Kelam wrote:
> This patch fixes below issue reported by checkpatch
>
> CHECK: Using comparison to true is error prone
> CHECK: Using comparison to false is error prone
>
> Signed-off-by: Hariprasad Kelam
> ---
> drivers/staging/rtl8723bs/hal/
Delete file odm_AntDiv.c and corresponding header file odm_AntDiv.h as
its functions and definitions are not used anywhere.
Remove reference to odm_AntDiv.h.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8723bs/hal/odm_AntDiv.c | 62 -
drivers/staging/rtl8723bs/hal/o
Remove .owner field if calls are used which set it automatically
Generated by: scripts/coccinelle/api/platform_no_drv_owner.cocci
Signed-off-by: YueHaibing
---
drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/kpc2000/kpc_dma/kpc_
This is patch v2 of erofs decompression inplace approach, no major
issues observed after v1 preliminarily applied to our products, and
changes from v1 are minor, so I drop "RFC" tag from this version.
See the bottom lines which are taken from RFC PATCH v1 and describe
the principle of these techno
stagingpages are behaved as bounce pages for temporary use.
Move to compress.h since the upcoming decompressor will
allocate stagingpages as well.
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/compress.h | 40 +++
drivers/staging/erofs/unzip_vle.c | 11 +
This patch integrates new decompression framework to
erofs decompression path, and remove the old
decompression implementation as well.
On kirin980 platform, sequential read is slightly
improved to 778MiB/s after the new decompression
backend is used.
Signed-off-by: Gao Xiang
---
drivers/stagin
This patch introduces new compacted compression indexes.
In contract to legacy compression indexes that
each 4k logical cluster has an 8-byte index,
compacted ondisk compression indexes will have
amortized 2 bytes for each 4k logical cluster (compacted 2B)
amortized 4 bytes for each 4k lo
This patch aims at compacted compression indexes:
1) cleanup z_erofs_map_blocks_iter and move into zmap.c;
2) add compacted 4/2B decoding support.
On kirin980 platform, sequential read is increased about
6% (725MiB/s -> 770MiB/s) on enwik9 dataset if compacted 2B
feature is enabled.
Signed-off-
This patch moves per-CPU buffers to utils.c in order for
the upcoming generic decompression framework to use it.
Note that I tried to use generic per-CPU buffer or
per-CPU page approaches to clean up further, but obvious
performanace regression (about 2% for sequential read) was
observed.
Therefo
This patch adds a new generic decompression framework
in order to replace the old LZ4-specific decompression code.
Even though LZ4 is still the only supported algorithm, yet
it is more cleaner and easy to integrate new algorithm than
the old almost hard-coded decompression backend.
Signed-off-by:
compressed data will be usually loaded into last pages of
the extent (the last page for 4k) for in-place decompression
(more specifically, in-place IO), as ilustration below,
start of compressed logical extent
| end of this logical extent
|
Decompressor needs to know whether it's a partial
or full decompression since only full decompression
can be decompressed in-place.
On kirin980 platform, sequential read is finally
increased to 812MiB/s after decompression inplace
is enabled.
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/i
From: Adham Abozaeid
Add passive scan support to the driver by passing the scan type to the
HW and configure the HW scan time if configured by the cfg80211.
Signed-off-by: Adham Abozaeid
---
drivers/staging/wilc1000/host_interface.c | 18 +++---
drivers/staging/wilc1000/host_i
when CRYPTO is m and KS7010 is y, building fails:
drivers/staging/ks7010/ks_hostif.o: In function `michael_mic.constprop.13':
ks_hostif.c:(.text+0x560): undefined reference to `crypto_alloc_shash'
ks_hostif.c:(.text+0x580): undefined reference to `crypto_shash_setkey'
ks_hostif.c:(.text+0x5e0): un
Change return type of function r8712_enqueue_cmd_ex from u8 to void as
its return value is never stored, checked or otherwise used. Modify
return statements accordingly.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 7 +++
drivers/staging/rtl8712/rtl871x_cmd.h |
Remove function _r8712_wdg_timeout_handler as all it does is call
r8712_wdg_wk_cmd. Modify call site of _r8712_wdg_timeout_handler to call
r8712_wdg_wk_cmd instead.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/mlme_linux.c | 2 +-
drivers/staging/rtl8712/rtl871x_mlme.c | 5 -
Change return type of function r8712_wdg_wk_cmd from u8 to void as its
return value is never stored, checked or otherwise used. Modify its
return statements accordingly.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 7 +++
drivers/staging/rtl8712/rtl871x_cmd.h |
Change return type of the function r8712_addbareq_cmd from u8 to void as
its return value is not stored, checked or otherwise used. Also modify
its return statements accordingly.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 7 +++
drivers/staging/rtl8712/rtl871x
Remove unused function r8712_setrfintfs_cmd.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 21 -
drivers/staging/rtl8712/rtl871x_cmd.h | 1 -
2 files changed, 22 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_cmd.c
b/drivers/staging/
Change return type of function r8712_disconnectCtrlEx_cmd from u8 to
void as its return value is never stored, checked or otherwise used.
Modify its return statements accordingly.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 7 +++
drivers/staging/rtl8712/rtl871
Remove unused function r8712_setfwra_cmd.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 20
drivers/staging/rtl8712/rtl871x_cmd.h | 1 -
2 files changed, 21 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_cmd.c
b/drivers/staging/rtl8
Remove unused function r8712_setbasicrate_cmd.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 21 -
drivers/staging/rtl8712/rtl871x_cmd.h | 1 -
2 files changed, 22 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_cmd.c
b/drivers/stagin
Remove function r8712_init_cmd_priv as all it does is call
_init_cmd_priv.
Rename _init_cmd_priv to r8712_init_cmd_priv to maintain compatibility
with call sites.
Change type of new r8712_init_cmd_priv from static to non-static as
original r8712_init_cmd_priv was non-static.
Change return type of n
Remove unused function r8712_setfwdig_cmd().
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_cmd.c | 20
drivers/staging/rtl8712/rtl871x_cmd.h | 1 -
2 files changed, 21 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_cmd.c
b/drivers/staging/r
When there is no pcie link detected we have to properly disable the
port pcie clock.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 7 +++
1 file changed, 7 insertions(+)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-
This patch series properly handle minor issues in this driver. These are:
* Disable pcie port clock on pci dirver instead of doing it in the phy
driver. The pci driver is the correct place to do this.
* Add a missing call to phy_exit function to properly handle the function
'mt7621_pcie_init_po
Add missing call to 'phy_exit' function if the phy_power_on call fails.
With this call added the error path is properly handled.
Fixes: 07420a02b003 ("staging: mt7621-pci: use gpio perst instead of builtin
behaviour")
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c
This driver has dependencies on mt7621-gpio and mt7621-pci-phy which
are init in later stages. Hence, when this driver is probed it is always
returning 'EPROBE_DEFER' and being initialized afterwards. Use function
'module_init' to just initialize later.
Signed-off-by: Sergio Paracuellos
---
driv
The clock which has been used here is not about the phy but the pcie port.
It has been properly handled into host pcie driver code. Hence, remove it
from here which is the correct thing to do.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci-phy/pci-mt7621-phy.c | 8
1 f
From: Aliasgar Surti
checkpatch reported "WARNING: line over 80 characters".
This patch fixes the warning for file soc_camera/soc_ov5642.c
Signed-off-by: Aliasgar Surti
---
drivers/staging/media/soc_camera/soc_ov5642.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/d
50 matches
Mail list logo