On 10/06/19 11:19 AM, Greg KH wrote:
On Mon, Jun 10, 2019 at 10:08:21AM +0530, Nishka Dasgupta wrote:
On 09/06/19 4:32 PM, Greg KH wrote:
On Fri, Jun 07, 2019 at 12:41:23PM +0530, Nishka Dasgupta wrote:
Remove variables that are declared and assigned values but not otherwise
used.
Issue found
Hi Peter,
> Similar things go on in:
>
> drivers/hwmon/lm90.c
> drivers/leds/leds-is31fl319x.c
> drivers/of/unittest.c
Right. I'll fix them, too.
> And drivers/rtc/rtc-fm3130.c has a couple of these:
These are fixed in patch 26 of this series.
Thanks and happy hacking,
Wolfram
signature
On 06/06, Greg KH wrote:
> On Tue, Jun 04, 2019 at 12:29:13AM +0200, Simon Sandström wrote:
> >
> > - dev_dbg(&pdev->dev, "kp2000_pcie_probe(pdev = [%p], id = [%p])\n",
> > - pdev, id);
> > + dev_dbg(&pdev->dev, "%s(pdev = [%p], id = [%p])\n",
> > + __func__, pdev, id);
>
On Mon, Jun 10, 2019 at 12:44:05PM +0530, Nishka Dasgupta wrote:
> On 10/06/19 11:19 AM, Greg KH wrote:
> > On Mon, Jun 10, 2019 at 10:08:21AM +0530, Nishka Dasgupta wrote:
> > > On 09/06/19 4:32 PM, Greg KH wrote:
> > > > On Fri, Jun 07, 2019 at 12:41:23PM +0530, Nishka Dasgupta wrote:
> > > > > R
On 10/06/19 12:55 PM, Greg KH wrote:
On Mon, Jun 10, 2019 at 12:44:05PM +0530, Nishka Dasgupta wrote:
On 10/06/19 11:19 AM, Greg KH wrote:
On Mon, Jun 10, 2019 at 10:08:21AM +0530, Nishka Dasgupta wrote:
On 09/06/19 4:32 PM, Greg KH wrote:
On Fri, Jun 07, 2019 at 12:41:23PM +0530, Nishka Dasg
Change return type of function rtw_os_recvbuf_resource_free to void as
its return value is never stored, checked or otherwise used.
Signed-off-by: Nishka Dasgupta
---
Changes in v2:
- Send as part of patch series.
drivers/staging/rtl8723bs/include/recv_osdep.h | 2 +-
drivers/staging/rtl8723bs/
Remove variables that are declared and initialised but never used.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
Changes in v2:
- Send as part of patch series.
drivers/staging/rtl8723bs/hal/rtl8723b_cmd.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging
Remove the variables RegRATR and RegRRSR as they are never used after
initialisation and assignment.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
Changes in v2:
- Send as part of patch series.
drivers/staging/rtl8723bs/hal/sdio_halinit.c | 11 ---
1 file changed, 11 d
Remove return variables and in multiple functions and return the values
directly, as the functions all return 0 in all cases.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
Changes in v2:
- Send as part of patch series.
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 12 +++---
Remove local variable change_priority, as it takes the value of the
argument priority; as both of these variables are of type u8, priority
can be modified without changing the value of its copy at the call site.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
Changes in v2:
- Send
Remove assignment of return value of function rtw_get_sec_ie as it is
never checked or used.
Remove return statement of rtw_get_sec_ie as its return value is never
stored or checked or used.
Change return type of rtw_get_sec_ie to void.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
Remove variables that are declared and assigned values but not otherwise
used.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
Changes in v2:
- Send as part of patch series.
drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 9 -
1 file changed, 9 deletions(-)
diff --git a
Remove variables and use the values directly.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
Changes in v2:
- Send as part of a patch series.
drivers/staging/rtl8723bs/hal/hal_btcoex.c | 10 ++
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/drivers/stagin
Remove assignment of the return value of rtw_os_recv_resource_alloc as
this assignment at the call site is never used.
Remove return statement from rtw_os_recv_resource_alloc() as its return
variable is never used.
Change the type of the function to void.
Signed-off-by: Nishka Dasgupta
---
Change
Remove variable pos as it is not used after (or before) being assigned a
value.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
Changes in v2:
- Send as part of patch series.
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
remove inb_p and outb_p to call readq/writeq directly.
Signed-off-by: Hao Xu
---
Changes in v2:
- remove the macros inb_p/outb_p and use readq/writeq directly, per
https://lkml.kernel.org/lkml/20190608134505.ga...@arch-01.home/
---
drivers/staging/kpc2000/kpc2000_i2c.c | 112 ---
On Mon, Jun 10, 2019 at 09:20:09AM +0200, Simon Sandström wrote:
> On 06/06, Greg KH wrote:
> > On Tue, Jun 04, 2019 at 12:29:13AM +0200, Simon Sandström wrote:
> > >
> > > - dev_dbg(&pdev->dev, "kp2000_pcie_probe(pdev = [%p], id = [%p])\n",
> > > - pdev, id);
> > > + dev_dbg(&pdev->dev,
Change the return values of function r8712_setdatarate_cmd from _SUCCESS
and _FAIL to 0 and -ENOMEM respectively.
Change the return type of the function from u8 to int to reflect this.
Change the call site of the function to check for 0 instead of _SUCCESS.
Return the value at the call site directl
Change return values of r8712_createbss_cmd from _SUCCESS and _FAIL to 0
and -ENOMEM respectively.
Change return type of the function from unsigned to int to reflect this.
Change call site to check for 0 instead of _SUCCESS.
Signed-off-by: Nishka Dasgupta
---
Changes in v2:
- Fix commit subject.
These patches removes unnecessary debug prints in staging/kpc2000.
Debug prints that just informs about function entry or exit can be
removed as ftrace can be used to get this information.
Simon Sandström (5):
staging: kpc2000: remove unnecessary debug prints in cell_probe.c
staging: kpc2000:
Debug prints that are used only to inform about function entry or exit
can be removed as ftrace can be used to get this information.
Signed-off-by: Simon Sandström
---
drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/kpc2000/
Debug prints that are used only to inform about function entry or exit
can be removed as ftrace can be used to get this information.
Signed-off-by: Simon Sandström
---
drivers/staging/kpc2000/kpc2000/core.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/kpc2000/kpc2000/
Debug prints that are used only to inform about function entry or exit
can be removed as ftrace can be used to get this information.
Signed-off-by: Simon Sandström
---
drivers/staging/kpc2000/kpc_dma/fileops.c | 17 -
1 file changed, 17 deletions(-)
diff --git a/drivers/staging/
Debug prints that are used only to inform about function entry or exit
can be removed as ftrace can be used to get this information.
Signed-off-by: Simon Sandström
---
drivers/staging/kpc2000/kpc_dma/dma.c | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/kpc2000/kpc_dma/dma
Debug prints that are used only to inform about function entry or exit
can be removed as ftrace can be used to get this information.
Signed-off-by: Simon Sandström
---
drivers/staging/kpc2000/kpc2000/cell_probe.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/kpc2000/kpc
There are some backward incompatible optimizations pending
for months, mainly due to on-disk format expensions.
However, we should ensure that it cannot be mounted with
old kernels. Otherwise, it will causes unexpected behaviors.
Fixes: ba2b77a82022 ("staging: erofs: add super block operations")
data_mapping_mode is too long as a member name of erofs_vnode,
datamode is straight-forward enough.
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/inode.c| 17 -
drivers/staging/erofs/internal.h | 10 --
2 files changed, 12 insertions(+), 15 deletions(-)
diff --g
Hi Sebastien,
Thanks for the patch.
On Thu 06 Jun 2019 at 16:38, Sébastien Szymanski wrote:
> i.MX7 and i.MX6UL/L have the same CSI controller. So add i.MX6UL/L support
> to imx7-media-csi driver.
>
> Signed-off-by: Sébastien Szymanski
> ---
>
> Changes for v2:
> - rebase on top of linuxtv/maste
Hi Randy,
On Fri 07 Jun 2019 at 00:10, Randy Dunlap wrote:
> On 6/6/19 8:38 AM, Sébastien Szymanski wrote:
>> i.MX7 and i.MX6UL/L have the same CSI controller. So add i.MX6UL/L support
>> to imx7-media-csi driver.
>>
>> Signed-off-by: Sébastien Szymanski
>> ---
>>
>> Changes for v2:
>> - rebase o
From: Merwin Trever Ferrao
Fixed a coding style issue.
Signed-off-by: Merwin Trever Ferrao
---
drivers/staging/wlan-ng/cfg80211.c | 32 ++
1 file changed, 15 insertions(+), 17 deletions(-)
diff --git a/drivers/staging/wlan-ng/cfg80211.c
b/drivers/staging/wlan-ng/c
Hello Greg, just a friendly ping regarding this patch. It got my Reviewed-by tag
two weeks ago, no further feedback from anyone. Is there anything you would
like us to do before queuing this?
Link to v2 that got the Reviewed-by:
https://lkml.org/lkml/2019/5/28/609
On Tue, May 28, 2019 at 1:31 PM
On Mon, Jun 10, 2019 at 08:51:10AM -0400, Sven Van Asbroeck wrote:
> Hello Greg, just a friendly ping regarding this patch. It got my Reviewed-by
> tag
> two weeks ago, no further feedback from anyone. Is there anything you would
> like us to do before queuing this?
>
> Link to v2 that got the Re
This patch fixes the checkpatch warning, removing leading spaces to make
sure that tabstop starts a new line.
Signed-off-by: Li Mingshuo
---
drivers/staging/rtl8712/rtl871x_xmit.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_xmit.h
b/dr
On Mon, Jun 10, 2019 at 10:02:27AM +0530, Nishka Dasgupta wrote:
> On 07/06/19 7:45 PM, Dan Carpenter wrote:
> > Probably you sent this patch unintentionally. The subject doesn't make
> > any sort of sense. :P
>
> So the problem with the subject line is that git send-email and vim (as
> configur
On Mon, Jun 10, 2019 at 04:08:25PM +0530, Merwin Trever Ferrao wrote:
> From: Merwin Trever Ferrao
>
> Fixed a coding style issue.
>
> Signed-off-by: Merwin Trever Ferrao
> ---
> drivers/staging/wlan-ng/cfg80211.c | 32 ++
> 1 file changed, 15 insertions(+), 17 dele
On Mon, Jun 10, 2019 at 03:48:24PM +0800, Hao Xu wrote:
> remove inb_p and outb_p to call readq/writeq directly.
>
> Signed-off-by: Hao Xu
> ---
> Changes in v2:
> - remove the macros inb_p/outb_p and use readq/writeq directly, per
> https://lkml.kernel.org/lkml/20190608134505.ga...@arch-01.home
On Mon, Jun 10, 2019 at 05:50:01AM +, Rishiraj Manwatkar wrote:
> This patch makes 4 symbols static as suggested by Sparse tool.
>
> Signed-off-by: Rishiraj Manwatkar
Your subject line is very odd, what does that really mean?
> ---
> drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c | 8 +++
In data Sunday, June 9, 2019 4:27:04 AM CEST, Mauro Carvalho Chehab ha
scritto:
> The kbuild documentation clearly shows that the documents
> there are written at different times: some use markdown,
> some use their own peculiar logic to split sections.
>
> Convert everything to ReST without affe
this patch fixes below issues reported by checkpatch
ERROR: spaces required around that '=' (ctx:WxV)
ERROR: spaces required around that '=' (ctx:WxV)
ERROR: spaces required around that '<' (ctx:VxV)
Signed-off-by: Hariprasad Kelam
---
drivers/staging/rtl8723bs/os_dep/osdep_service.c | 36 +
These two patches fixes issues pointed out by Dan in a previous
staging/kpc2000 patch thread: many comments in kp2000_pcie_probe just
repeats the code and the current label names doesn't add any information
and makes it hard to follow the code.
Rename all labels and remove the comments that just r
Use self-explanatory label names instead of the generic numbered ones,
to make it easier to follow and understand the code.
Signed-off-by: Simon Sandström
---
drivers/staging/kpc2000/kpc2000/core.c | 42 --
1 file changed, 20 insertions(+), 22 deletions(-)
diff --git a/d
Much of the code comments in kp2000_pcie_probe just repeats the code and
does not add any additional information. Delete them and make sure that
comments still left in the function all use the same style.
Signed-off-by: Simon Sandström
---
drivers/staging/kpc2000/kpc2000/core.c | 38
In data Sunday, June 9, 2019 4:27:04 AM CEST, Mauro Carvalho Chehab ha
scritto:
> The kbuild documentation clearly shows that the documents
> there are written at different times: some use markdown,
> some use their own peculiar logic to split sections.
>
> Convert everything to ReST without affe
On 2019/6/10 17:36, Gao Xiang wrote:
> There are some backward incompatible optimizations pending
> for months, mainly due to on-disk format expensions.
>
> However, we should ensure that it cannot be mounted with
> old kernels. Otherwise, it will causes unexpected behaviors.
>
> Fixes: ba2b77a82
On 2019/6/10 17:36, Gao Xiang wrote:
> data_mapping_mode is too long as a member name of erofs_vnode,
> datamode is straight-forward enough.
>
> Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Thanks,
___
devel mailing list
de...@linuxdriverproject.org
On 2019/6/8 17:49, Hariprasad Kelam wrote:
> DBG_BUGON is introduced and it could only crash when EROFS_FS_DEBUG
> (EROFS developping feature) is on.
> replace BUG_ON with DBG_BUGON.
>
> Signed-off-by: Hariprasad Kelam
Reviewed-by: Chao Yu
Thanks,
__
On 2019/6/8 17:39, Hariprasad Kelam wrote:
> fix below warnings reported by coccicheck
>
> drivers/staging/erofs/unzip_vle.c:332:11-18: WARNING: Comparison to bool
>
> Signed-off-by: Hariprasad Kelam
Reviewed-by: Chao Yu
Thanks,
___
devel mailing li
Hi Chao,
On 2019/6/11 9:37, Chao Yu wrote:
> On 2019/6/10 17:36, Gao Xiang wrote:
>> There are some backward incompatible optimizations pending
>> for months, mainly due to on-disk format expensions.
>>
>> However, we should ensure that it cannot be mounted with
>> old kernels. Otherwise, it will
On 2019/6/11 9:43, Gao Xiang wrote:
> Hi Chao,
>
> On 2019/6/11 9:37, Chao Yu wrote:
>> On 2019/6/10 17:36, Gao Xiang wrote:
>>> There are some backward incompatible optimizations pending
>>> for months, mainly due to on-disk format expensions.
>>>
>>> However, we should ensure that it cannot be m
On Mon, Jun 10, 2019 at 03:48:24PM +0800, Hao Xu wrote:
> remove inb_p and outb_p to call readq/writeq directly.
>
> Signed-off-by: Hao Xu
> ---
> Changes in v2:
> - remove the macros inb_p/outb_p and use readq/writeq directly, per
> https://lkml.kernel.org/lkml/20190608134505.ga...@arch-01.home
data_mapping_mode is too long as a member name of erofs_vnode,
datamode is straight-forward enough.
Reviewed-by: Chao Yu
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/inode.c| 17 -
drivers/staging/erofs/internal.h | 10 --
2 files changed, 12 insertions(+), 15
There are some backward incompatible features pending
for months, mainly due to on-disk format expensions.
However, we should ensure that it cannot be mounted with
old kernels. Otherwise, it will causes unexpected behaviors.
Fixes: ba2b77a82022 ("staging: erofs: add super block operations")
Cc:
This patch fixes below issues reported by checkpatch
CHECK: Comparison to NULL could be written "rtw_proc"
CHECK: Comparison to NULL could be written "!rtw_proc"
CHECK: Comparison to NULL could be written "!rtw_proc"
Signed-off-by: Hariprasad Kelam
---
drivers/staging/rtl8723bs/os_dep/rtw_proc.
CHECK: spaces preferred around that '|' (ctx:VxV)
CHECK: spaces preferred around that '|' (ctx:VxV)
CHECK: spaces preferred around that '+' (ctx:VxV)
Signed-off-by: Hariprasad Kelam
---
drivers/staging/rtl8723bs/os_dep/rtw_proc.c | 24
1 file changed, 12 insertions(+), 1
On 2019/6/11 10:42, Gao Xiang wrote:
> There are some backward incompatible features pending
> for months, mainly due to on-disk format expensions.
>
> However, we should ensure that it cannot be mounted with
> old kernels. Otherwise, it will causes unexpected behaviors.
>
> Fixes: ba2b77a82022 (
This patch removes the Sparse generated warnings. Following warnings are
reported by Sparse:
drivers/staging/kpc2000//kpc_dma/kpc_dma_driver.c:46:6: warning: symbol
'kpc_dma_del_device' was not declared. Should it be static?
drivers/staging/kpc2000//kpc_dma/kpc_dma_driver.c:91:14: warning: symbol
56 matches
Mail list logo