Function ODM_PhyStatusQuery() is just a wrapper around
ODM_PhyStatusQuery_92CSeries(). Rename ODM_PhyStatusQuery_92CSeries()
to ODM_PhyStatusQuery() and remove the wrapper.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 15 +++
1 file changed, 3 ins
This patch set contains a few small fixups to the kpc_spi driver. There
is certainly nothing groundbreaking in this patch set. It is limited to
style fixups, removing unused things, and using the managed resource API
for mapping I/O space.
Geordan Neukum (5):
staging: kpc2000: kpc_spi: Remove un
The kpc2000_spi.c file contains instances of unnecessary consecutive
newlines which negatively impact the readability of the file. Remove
all unnecessary consecutive newlines.
Signed-off-by: Geordan Neukum
---
drivers/staging/kpc2000/kpc2000_spi.c | 13 -
1 file changed, 13 deletions
The kpc_spi driver does not unmap its I/O space upon error cases in the
probe() function or upon remove(). Make the driver clean up after itself
more maintainably by migrating to using the managed resource API.
Signed-off-by: Geordan Neukum
---
drivers/staging/kpc2000/kpc2000_spi.c | 3 ++-
1 fi
The linux style guide prescribes that switch statements and their
subordinate case labels should be column-aligned rather than
double-indenting the case label. Make kpc2000_spi.c follow the desired
style with respect to switch/case alignment.
Signed-off-by: Geordan Neukum
---
drivers/staging/kpc
The kp_spi structure contains a member 'fifo_depth'. This member is
never used. Therefore, it should be removed.
Signed-off-by: Geordan Neukum
---
drivers/staging/kpc2000/kpc2000_spi.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/kpc2000/kpc2000_spi.c
b/drivers/staging/kpc
The static function kp_spi_bytes_per_word() is defined in kpc2000_spi.c,
but it is completely unused. As this function is unused, it can and
should be removed.
Signed-off-by: Geordan Neukum
---
drivers/staging/kpc2000/kpc2000_spi.c | 14 --
1 file changed, 14 deletions(-)
diff --git
MGMT_QUEUE_NUM, ETH_TYPE_LEN and PAYLOAD_TYPE_LEN are defined but
not used in the driver code, so remove them.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/include/ieee80211.h | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/ieee80211.h
b
ETH_ALEN is defined in linux/if_ether.h which is included by
osdep_service.h, so remove the redundant definition from ieee80211.h.
osdep_service.h:33:#include
etherdevice.h:25:#include
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/include/ieee80211.h | 1 -
1 file changed, 1 de
All NVIDIA Tegra SoC generations provide IOMMU support for the video
decoder engine. Document new optional device-tree property that connects
VDE with the IOMMU provider.
Signed-off-by: Dmitry Osipenko
---
Documentation/devicetree/bindings/media/nvidia,tegra-vde.txt | 2 ++
1 file changed, 2 ins
The BIT macro isn't available in userspace. Checkpatch complains about
shifts being used instead of the macro and people are starting to send
patches without realizing that it's a UAPI header file. Hence let's
replace the BIT macro with a hex values to make everyone happy.
Signed-off-by: Dmitry Os
Enable IOMMU support for the video decoder.
Signed-off-by: Dmitry Osipenko
---
arch/arm/boot/dts/tegra30.dtsi | 1 +
1 file changed, 1 insertion(+)
diff --git a/arch/arm/boot/dts/tegra30.dtsi b/arch/arm/boot/dts/tegra30.dtsi
index 934caa83c8db..ce162125e7bf 100644
--- a/arch/arm/boot/dts/tegra3
The video decoder driver was tested by time and works absolutely fine.
The reason why it is in staging is because it doesn't provide common V4L
interface yet, this shouldn't stop driver enabling in the defconfig since
our userspace (libvdpau-tegra) provides combined acceleration of decoding
and dis
Hello,
This series cleans up some of minor shortcomings that are caused by
checkpatch recommendations that are not very applicable for the driver.
Then IOMMU support is added to the driver and now it can handle sparse
memory buffers that GPU hands to VDE in a default kernel configuration
on Tegra3
All Tegra's could provide memory isolation for the video decoder
hardware using IOMMU, it is also required for Tegra30+ in order
to handle sparse dmabuf's which GPU exports in a default kernel
configuration.
Inspired-by: Thierry Reding
Signed-off-by: Dmitry Osipenko
---
drivers/staging/media/te
Frequent IOMMU remappings take about 50% of CPU usage because there is
quite a lot to remap. Defer dmabuf's unmapping by 5 seconds in order to
mitigate the mapping overhead which goes away completely and driver works
as fast as in a case of a disabled IOMMU. The case of a disabled IOMMU
should also
The __packed macro isn't available in userspace with the kernel headers.
Checkpatch asks to use the macro, which is unwanted in a case of a UAPI
header. There is no much benefit in a tight packing of the structures,
hence let's pack them manually to cleanup things a tad. Note that there
is no old-s
From: Arnd Bergmann
Date: Fri, 31 May 2019 14:32:52 +0200
> [resending, rebased on top of today's net-next]
>
> The following changes since commit 7b3ed2a137b077bc0967352088b0adb6049eed20:
>
> Merge branch '100GbE' of
> git://git.kernel.org/pub/scm/linux/kernel/git/jkirsher/next-queue
> (2019
Hi Sergio,
On 31/5/19 10:37 pm, Sergio Paracuellos wrote:
On Thu, May 30, 2019 at 3:46 AM Greg Ungerer wrote:
On 30/5/19 10:44 am, Greg Ungerer wrote:
On 29/5/19 6:08 pm, Sergio Paracuellos wrote:
[snip]
I have added gpio consumer stuff and reorder a bit the code to be more
similar to 4.20.
On Sun, 2019-06-02 at 18:35 +0200, Michael Straube wrote:
> ETH_ALEN is defined in linux/if_ether.h which is included by
> osdep_service.h, so remove the redundant definition from ieee80211.h.
[]
> diff --git a/drivers/staging/rtl8188eu/include/ieee80211.h
> b/drivers/staging/rtl8188eu/include/iee
Hi Greg,
No luck for us also today :-(
On Mon, Jun 3, 2019 at 3:26 AM Greg Ungerer wrote:
>
> Hi Sergio,
>
> On 31/5/19 10:37 pm, Sergio Paracuellos wrote:
> > On Thu, May 30, 2019 at 3:46 AM Greg Ungerer wrote:
> >> On 30/5/19 10:44 am, Greg Ungerer wrote:
> >>> On 29/5/19 6:08 pm, Sergio Para
On 2019-06-02 22:07, Joe Perches wrote:
On Sun, 2019-06-02 at 18:35 +0200, Michael Straube wrote:
ETH_ALEN is defined in linux/if_ether.h which is included by
osdep_service.h, so remove the redundant definition from ieee80211.h.
[]
diff --git a/drivers/staging/rtl8188eu/include/ieee80211.h
b/
22 matches
Mail list logo