Hi,
On Tue, 2019-04-02 at 13:51 +0200, Hans Verkuil wrote:
> On 2/14/19 10:53 AM, Paul Kocialkowski wrote:
[...]
> > +.. c:type:: v4l2_hevc_dpb_entry
> > +
> > +.. cssclass:: longtable
> > +
> > +.. flat-table:: struct v4l2_hevc_dpb_entry
> > +:header-rows: 0
> > +:stub-columns: 0
> > +
Hi,
On Mon, 2019-04-08 at 10:18 +0200, Paul Kocialkowski wrote:
> Hi,
>
> Le dimanche 07 avril 2019 à 20:47 +0200, Jernej Skrabec a écrit :
> > Currently, MEDIA_IOC_G_TOPOLOGY ioctl on cedrus fails due to incorrect
> > initialization order. Fix that by moving video_register_device() before
> > v4
Replace rtw_malloc with kmalloc to make code OS independent
use kmalloc second argument as GFP_ATOMIC as these are called by functions
that holds lock.
Signed-off-by: Bhanusree Pola
---
drivers/staging/rtl8723bs/core/rtw_ap.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git
Avoid typedefs for structure types to maintain kernel coding style.
Remove typedefs for _ODM_Phy_Dbg_Info and _ODM_Mac_Status_Info_.
This part is done by the following semantic patch:
@r1@
identifier i;
type t;
@@
typedef struct i {
...
}t;
@r2@
type r1.t;
identifier v;
@@
t v;
@script:python m
On Fri, Apr 19, 2019 at 04:42:56PM +0530, Bhanusree Pola wrote:
> Avoid typedefs for structure types to maintain kernel coding style.
> Remove typedefs for _ODM_Phy_Dbg_Info and _ODM_Mac_Status_Info_.
> This part is done by the following semantic patch:
>
>
> @r1@
> identifier i;
> type t;
> @@
>
On Fri, Apr 19, 2019 at 03:52:43PM +0530, Bhanusree Pola wrote:
> Replace rtw_malloc with kmalloc to make code OS independent
> use kmalloc second argument as GFP_ATOMIC as these are called by functions
> that holds lock.
>
> Signed-off-by: Bhanusree Pola
> ---
> drivers/staging/rtl8723bs/core/r
Am 19.04.19 um 01:31 schrieb Nicholas Mc Guire:
> The kzalloc here was being used without checking the return - if the
> kzalloc fails return VCHIQ_ERROR. The call-site of
> vchiq_platform_init_state() vchiq_init_state() was not responding
> to an allocation failure so checks for != VCHIQ_SUCCESS
Avoid typedefs for structure types to maintain kernel coding style.
Remove typedefs for _ODM_Phy_Dbg_Info and _ODM_Mac_Status_Info_.
This part is done by the following semantic patch:
@r1@
identifier i;
type t;
@@
typedef struct i {
...
}t;
@r2@
type r1.t;
identifier v;
@@
t v;
@script:python m
The following changes since commit 79a3aaa7b82e3106be97842dedfd8429248896e6:
Linux 5.1-rc3 (2019-03-31 14:39:29 -0700)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
tags/staging-5.1-rc6
for you to fetch changes up to af4b54a2e5ba18
On Wed, Apr 17, 2019 at 01:21:12PM +0100, Okash Khawaja wrote:
> Hi,
>
> The v2 renames set_selection() and do_set_selection() to following
> more explicit names:
>
> set_selection_user() /* includes copying data from user space */
> set_selection_kernel() /* no copying from user space */
>
> T
On Fri, 19 Apr 2019 at 16:52, Greg Kroah-Hartman
wrote:
>
> On Fri, Apr 19, 2019 at 03:52:43PM +0530, Bhanusree Pola wrote:
> > Replace rtw_malloc with kmalloc to make code OS independent
> > use kmalloc second argument as GFP_ATOMIC as these are called by functions
> > that holds lock.
> >
> > Si
Dear,
I am Mr.Marck Csady a solicitor at law, i need your assistance to
represent my late client fund valued at $2.5 million dollars that his
bank wants to comfiscate, You bear the same last name with my late
client and he is also a national of your country.
Please if you are interested to assist
These drivers have been outside of the kernel tree since the 2.x days,
and it's time to bring them into the tree so they can get properly
cleaned up.
This first dump of drivers is based on a tarball Matt gave to me, minus
an odd "dma" driver that I could not get to build at all. I renamed a
few f
The pull request you sent on Fri, 19 Apr 2019 14:31:04 +0200:
> git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
> tags/staging-5.1-rc6
has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/b222e9af0a250141b302d671d2d1e73e9079c544
Thank you!
--
Deet-doot-d
On Fri, Apr 19, 2019 at 07:02:47PM +0530, Bhanusree Mahesh wrote:
> On Fri, 19 Apr 2019 at 16:52, Greg Kroah-Hartman
> wrote:
> >
> > On Fri, Apr 19, 2019 at 03:52:43PM +0530, Bhanusree Pola wrote:
> > > Replace rtw_malloc with kmalloc to make code OS independent
> > > use kmalloc second argument
Remove unwanted assignments and replace return types.
Issue suggested by Coccinelle.
Signed-off-by: Madhumitha Prabakaran
---
drivers/staging/rtl8723bs/core/rtw_sta_mgt.c | 7 ++-
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_sta_mgt.c
b/d
Remove unwanted variable and replace the respective return type.
Issue suggested by Coccinelle.
Signed-off-by: Madhumitha Prabakaran
---
drivers/staging/mt7621-mmc/sd.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/mt7621-mmc/sd.c b/drivers/staging/mt762
Remove unnecessary variable and replace return type.
Issue suggested by Coccinelle.
Signed-off-by: Madhumitha Prabakaran
---
drivers/staging/vc04_services/bcm2835-camera/controls.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/vc04_services/bcm2835-ca
Replace return type and remove the respective assignment.
Issue found by Coccinelle.
Signed-off-by: Madhumitha Prabakaran
---
drivers/staging/rtlwifi/core.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/rtlwifi/core.c b/drivers/staging/rtlwifi/core.c
ind
Hi Madhumitha,
Am 19.04.19 um 23:23 schrieb Madhumitha Prabakaran:
> Remove unnecessary variable and replace return type.
>
> Issue suggested by Coccinelle.
>
> Signed-off-by: Madhumitha Prabakaran
> ---
> drivers/staging/vc04_services/bcm2835-camera/controls.c | 7 +--
> 1 file changed, 1 i
On Tue, Apr 16, 2019 at 10:19:47PM +0200, Arnd Bergmann wrote:
> Each of these drivers has a copy of the same trivial helper function to
> convert the pointer argument and then call the native ioctl handler.
>
> We now have a generic implementation of that, so use it.
>
> Acked-by: Greg Kroah-Har
On 04/19 :49, Stefan Wahren wrote:
> Hi Madhumitha,
>
> Am 19.04.19 um 23:23 schrieb Madhumitha Prabakaran:
> > Remove unnecessary variable and replace return type.
> >
> > Issue suggested by Coccinelle.
> >
> > Signed-off-by: Madhumitha Prabakaran
> > ---
> > drivers/staging/vc04_services/bcm2
From: Moses Christopher
- Resolve the following warning from the Kconfig,
"WARNING: prefer 'help' over '---help---' for new help texts"
Signed-off-by: Moses Christopher
---
drivers/staging/fsl-dpaa2/Kconfig | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/s
23 matches
Mail list logo