Re: [PATCH v14 05/13] media: staging/imx7: add MIPI CSI-2 receiver subdev for i.MX7

2019-02-20 Thread Hans Verkuil
On 2/6/19 4:13 PM, Rui Miguel Silva wrote: > Adds MIPI CSI-2 subdev for i.MX7 to connect with sensors with a MIPI > CSI-2 interface. > > Signed-off-by: Rui Miguel Silva > --- > drivers/staging/media/imx/Makefile |1 + > drivers/staging/media/imx/imx7-mipi-csis.c | 1186 ++

Re: [PATCH] staging: erofs: remove rcu_read_lock() in erofs_try_to_free_cached_page

2019-02-20 Thread Greg Kroah-Hartman
On Wed, Feb 20, 2019 at 10:38:53AM +0800, Gao Xiang wrote: > Hi Greg, > > Could you consider take some time on these two patches for linux-5.1-rc1? > 1) staging: erofs: fix race of initializing xattrs of a inode at the same > time > 2) staging: erofs: remove rcu_read_lock() in erofs_try_to_free

Re: [PATCH] staging: erofs: remove rcu_read_lock() in erofs_try_to_free_cached_page

2019-02-20 Thread Gao Xiang
On 2019/2/20 18:20, Greg Kroah-Hartman wrote: > On Wed, Feb 20, 2019 at 10:38:53AM +0800, Gao Xiang wrote: >> Hi Greg, >> >> Could you consider take some time on these two patches for linux-5.1-rc1? >> 1) staging: erofs: fix race of initializing xattrs of a inode at the same >> time >> 2) sta

Re: [PATCH 1/2] media: imx7-media-csi: don't store a floating pointer

2019-02-20 Thread Rui Miguel Silva
Oi Mauro, On Tue 19 Feb 2019 at 13:24, Mauro Carvalho Chehab wrote: if imx7_csi_try_fmt() fails, outcc variable won't be initialized and csi->cc[IMX7_CSI_PAD_SRC] would be pointing to a random location. Signed-off-by: Mauro Carvalho Chehab Thanks for this, looks good. Reviewed-by: Rui Miguel

Re: [PATCH 2/2] media: imx7-media-csi: get rid of unused var

2019-02-20 Thread Rui Miguel Silva
Oi Mauro, On Tue 19 Feb 2019 at 13:24, Mauro Carvalho Chehab wrote: drivers/staging/media/imx/imx7-media-csi.c: In function 'imx7_csi_enum_mbus_code': drivers/staging/media/imx/imx7-media-csi.c:926:33: warning: variable 'in_cc' set but not used [-Wunused-but-set-variable] const str

Re: [PATCH v14 05/13] media: staging/imx7: add MIPI CSI-2 receiver subdev for i.MX7

2019-02-20 Thread Rui Miguel Silva
Hi Hans, On Wed 20 Feb 2019 at 08:56, Hans Verkuil wrote: On 2/6/19 4:13 PM, Rui Miguel Silva wrote: Adds MIPI CSI-2 subdev for i.MX7 to connect with sensors with a MIPI CSI-2 interface. Signed-off-by: Rui Miguel Silva --- drivers/staging/media/imx/Makefile |1 + drivers/staging/

Re: [PATCH v2 1/2] staging: iio: frequency: ad9834: Move frequency to standard iio types

2019-02-20 Thread Jonathan Cameron
On Thu, 14 Feb 2019 18:41:29 +0200 Beniamin Bia wrote: > Frequency attribute is added with a standard type from iio framework > instead of custom attribute. This is a small step towards removing any > unnecessary custom attribute. Ad9834 will diverge from ad9833 in the > future, that is why we ha

Re: [PATCH v2 2/2] staging: iio: frequency: ad9834: Move phase and scale to standard iio attribute

2019-02-20 Thread Jonathan Cameron
On Thu, 14 Feb 2019 18:41:30 +0200 Beniamin Bia wrote: > The custom phase and scale attributes were moved to standard iio types. > > Signed-off-by: Beniamin Bia Hi, This hits the same fundamental questions of ABI as the FSK elements in the previous patch, just now for Phase Shift Keying. Unf

[PATCH] staging: octeon-usb: fix misspelled "re-enable"

2019-02-20 Thread Sumit Pundir
Fixes misspelled "re-enable" in comment. Reported by checkpatch.pl Signed-off-by: Sumit Pundir --- drivers/staging/octeon-usb/octeon-hcd.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/octeon-usb/octeon-hcd.h b/drivers/staging/octeon-usb/octeon-hcd.h index

[driver-core:driver-core-testing 64/64] htmldocs: include/linux/device.h:866: warning: Function parameter or member 'supplier_preactivated' not described in 'device_link'

2019-02-20 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git driver-core-testing head: 36003d4cf57ca431fb3f94d317bcca426a2394d6 commit: 36003d4cf57ca431fb3f94d317bcca426a2394d6 [64/64] driver core: Fix PM-runtime for links added during consumer probe reproduce: make htmldocs

Re: [PATCH] staging:iio:ad7152: Rename misspelled RESEVERD -> RESERVED

2019-02-20 Thread Jonathan Cameron
... > > Thanks for answering Jonathan and Stefan. > > I would like to contribute with the ad7150 driver. Could you please > give me some hints on what can I do to move this driver > out of staging? > > I note that device registration (devm_iio_device_register) is not > the last function called a

Re: [RESEND PATCH 0/7] Add FOLL_LONGTERM to GUP fast and use it

2019-02-20 Thread Christoph Hellwig
On Tue, Feb 19, 2019 at 09:30:33PM -0800, ira.we...@intel.com wrote: > From: Ira Weiny > > Resending these as I had only 1 minor comment which I believe we have covered > in this series. I was anticipating these going through the mm tree as they > depend on a cleanup patch there and the IB chang

RE: [PATCH v2 1/2] Drivers: hv: vmbus: Change server monitor_pages index to 0

2019-02-20 Thread Michael Kelley
From: Kimberly Brown Sent: Monday, February 18, 2019 9:38 PM > > Change the monitor_pages index in server_monitor_pending_show() to '0'. > '0' is the correct monitor_pages index for the server. A comment for the > monitor_pages field in the vmbus_connection struct definition indicates > that th

RE: [PATCH v2 2/2] Drivers: hv: vmbus: Return -EINVAL if monitor_allocated not set

2019-02-20 Thread Michael Kelley
From: Kimberly Brown Sent: Monday, February 18, 2019 9:38 PM > > There are two methods for signaling the host: the monitor page mechanism > and hypercalls. The monitor page mechanism is used by performance > critical channels (storage, networking, etc.) because it provides > improved throughput

Re: [RESEND PATCH 0/7] Add FOLL_LONGTERM to GUP fast and use it

2019-02-20 Thread Ira Weiny
On Wed, Feb 20, 2019 at 07:19:30AM -0800, Christoph Hellwig wrote: > On Tue, Feb 19, 2019 at 09:30:33PM -0800, ira.we...@intel.com wrote: > > From: Ira Weiny > > > > Resending these as I had only 1 minor comment which I believe we have > > covered > > in this series. I was anticipating these go

Re: [RESEND PATCH 3/7] mm/gup: Change GUP fast to use flags rather than a write 'bool'

2019-02-20 Thread Mike Marshall
Hi Ira Martin and I looked at your patch and agree that it doesn't change functionality for Orangefs. Reviewed-by: Mike Marshall On Wed, Feb 20, 2019 at 12:32 AM wrote: > > From: Ira Weiny > > To facilitate additional options to get_user_pages_fast() change the > singular write parameter to

[PATCH] MAINTAINERS: Add mailing list for Hyper-V CORE AND DRIVERS

2019-02-20 Thread Haiyang Zhang
From: Haiyang Zhang The new mailing list is: linux-hyp...@vger.kernel.org Signed-off-by: Haiyang Zhang --- MAINTAINERS | 1 + 1 file changed, 1 insertion(+) diff --git a/MAINTAINERS b/MAINTAINERS index 86aa227b5782..ef65de3cfe1b 100644 --- a/MAINTAINERS +++ b/MAINTAINERS @@ -7137,6 +7137,7 @@

Re: [PATCH] MAINTAINERS: Add mailing list for Hyper-V CORE AND DRIVERS

2019-02-20 Thread Greg KH
On Wed, Feb 20, 2019 at 07:48:23PM +, Haiyang Zhang wrote: > From: Haiyang Zhang > > The new mailing list is: linux-hyp...@vger.kernel.org > > Signed-off-by: Haiyang Zhang > --- > MAINTAINERS | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/MAINTAINERS b/MAINTAINERS > index 86aa22

RE: [PATCH] MAINTAINERS: Add mailing list for Hyper-V CORE AND DRIVERS

2019-02-20 Thread Haiyang Zhang
> -Original Message- > From: Greg KH > Sent: Wednesday, February 20, 2019 2:52 PM > To: Haiyang Zhang > Cc: sas...@kernel.org; linux-hyp...@vger.kernel.org; > de...@linuxdriverproject.org; Stephen Hemminger > ; linux-ker...@vger.kernel.org > Subject: Re: [PATCH] MAINTAINERS: Add mailin

[PATCH v2 1/4] media: imx: csi: Allow unknown nearest upstream entities

2019-02-20 Thread Steve Longerbeam
On i.MX6, the nearest upstream entity to the CSI can only be the CSI video muxes or the Synopsys DW MIPI CSI-2 receiver. However the i.MX53 has no CSI video muxes or a MIPI CSI-2 receiver. So allow for the nearest upstream entity to the CSI to be something other than those. Fixes: bf3cfaa712e5c (

[PATCH v2 2/4] media: imx: Clear fwnode link struct for each endpoint iteration

2019-02-20 Thread Steve Longerbeam
In imx_media_create_csi_of_links(), the 'struct v4l2_fwnode_link' must be cleared for each endpoint iteration, otherwise if the remote port has no "reg" property, link.remote_port will not be reset to zero. This was discovered on the i.MX53 SMD board, since the OV5642 connects directly to ipu1_csi0

[PATCH v2 3/4] media: imx: Rename functions that add IPU-internal subdevs

2019-02-20 Thread Steve Longerbeam
For the functions that add and remove the internal IPU subdevice descriptors, rename them to make clear they are the subdevs internal to the IPU. Also rename the platform data structure for the internal IPU subdevices. No functional changes. Signed-off-by: Steve Longerbeam Acked-by: Philipp Zabel

[PATCH v2 4/4] media: imx: Don't register IPU subdevs/links if CSI port missing

2019-02-20 Thread Steve Longerbeam
The second IPU internal sub-devices were being registered and links to them created even when the second IPU is not present. This is wrong for i.MX6 S/DL and i.MX53 which have only a single IPU. Fixes: e130291212df5 ("[media] media: Add i.MX media core driver") Signed-off-by: Steve Longerbeam Re

[PATCH net-next v3 4/8] net: dsa: Add setter for SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS

2019-02-20 Thread Florian Fainelli
In preparation for removing SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS_SUPPORT, add support for a function that processes the SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS and SWITCHDEV_ATTR_ID_PORT_PRE_BRIDGE_FLAGS attributes and returns not supported for any flag set, since DSA does not currently support toggling

[PATCH net-next v3 2/8] mlxsw: spectrum: Handle PORT_PRE_BRIDGE_FLAGS

2019-02-20 Thread Florian Fainelli
In preparation for getting rid of switchdev_port_attr_get(), have mlxsw check for the bridge flags being set through switchdev_port_attr_set() when the SWITCHDEV_ATTR_ID_PORT_PRE_BRIDGE_FLAGS attribute identifier is used. Signed-off-by: Florian Fainelli --- .../ethernet/mellanox/mlxsw/spectrum_s

[PATCH net-next v3 1/8] net: switchdev: Add PORT_PRE_BRIDGE_FLAGS

2019-02-20 Thread Florian Fainelli
In preparation for removing switchdev_port_attr_get(), introduce PORT_PRE_BRIDGE_FLAGS which will be called through switchdev_port_attr_set(), in the caller's context (possibly atomic) and which must be checked by the switchdev driver in order to return whether the operation is supported or not. T

[PATCH net-next v3 3/8] staging: fsl-dpaa2: ethsw: Handle PORT_PRE_BRIDGE_FLAGS

2019-02-20 Thread Florian Fainelli
In preparation for removing SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS_SUPPORT, handle the SWITCHDEV_ATTR_ID_PORT_PRE_BRIDGE_FLAGS attribute and check that the bridge port flags being configured are supported. Signed-off-by: Florian Fainelli --- drivers/staging/fsl-dpaa2/ethsw/ethsw.c | 14

[PATCH net-next v3 0/8] net: Get rid of switchdev_port_attr_get()

2019-02-20 Thread Florian Fainelli
Hi all, This patch series splits the removal of the switchdev_ops that was proposed a few times before and first tackles the easy part which is the removal of the single call to switchdev_port_attr_get() within the bridge code. As suggestd by Ido, this patch series adds a SWITCHDEV_ATTR_ID_PORT_P

[PATCH net-next v3 6/8] net: bridge: Stop calling switchdev_port_attr_get()

2019-02-20 Thread Florian Fainelli
Now that all switchdev drivers have been converted to check the SWITCHDEV_ATTR_ID_PORT_PRE_BRIDGE_FLAGS flags and report flags that they do not support accordingly, we can migrate the bridge code to try to set that attribute first, check the results and then do the actual setting. Signed-off-by: F

[PATCH net-next v3 5/8] rocker: Check Handle PORT_PRE_BRIDGE_FLAGS

2019-02-20 Thread Florian Fainelli
In preparation for getting rid of switchdev_port_attr_get(), have rocker check for the bridge flags being set through switchdev_port_attr_set() with the SWITCHDEV_ATTR_ID_PORT_PRE_BRIDGE_FLAGS attribute identifier. Signed-off-by: Florian Fainelli --- drivers/net/ethernet/rocker/rocker_main.c | 5

[PATCH net-next v3 8/8] net: Get rid of switchdev_port_attr_get()

2019-02-20 Thread Florian Fainelli
With the bridge no longer calling switchdev_port_attr_get() to obtain the supported bridge port flags from a driver but instead trying to set the bridge port flags directly and relying on driver to reject unsupported configurations, we can effectively get rid of switchdev_port_attr_get() entirely s

[PATCH net-next v3 7/8] net: Remove SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS_SUPPORT

2019-02-20 Thread Florian Fainelli
Now that we have converted the bridge code and the drivers to check for bridge port(s) flags at the time we try to set them, there is no need for a get() -> set() sequence anymore and SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS_SUPPORT therefore becomes unused. Reviewed-by: Ido Schimmel Signed-off-by: Fl

[PATCH 2/2] staging: erofs: switch to ->iterate_shared()

2019-02-20 Thread Gao Xiang
After commit 6192269444eb ("introduce a parallel variant of ->iterate()"), readdir can be done without taking exclusive inode lock of course. Signed-off-by: Gao Xiang --- drivers/staging/erofs/dir.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/erofs/dir.c b

[PATCH 1/2] staging: erofs: no need to take page lock in readdir

2019-02-20 Thread Gao Xiang
VFS will take inode_lock for readdir, therefore no need to take page lock in readdir at all just as the majority of other generic filesystems. Signed-off-by: Gao Xiang --- drivers/staging/erofs/dir.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/erofs/dir.c b/drivers/stagi

Re: [RESEND PATCH 3/7] mm/gup: Change GUP fast to use flags rather than a write 'bool'

2019-02-20 Thread Souptick Joarder
Hi Ira, On Wed, Feb 20, 2019 at 11:01 AM wrote: > > From: Ira Weiny > > To facilitate additional options to get_user_pages_fast() change the > singular write parameter to be gup_flags. > > This patch does not change any functionality. New functionality will > follow in subsequent patches. > > S

[PATCH] staging: rtlwifi: Use proper enum for return in halmac_parse_psd_data_88xx

2019-02-20 Thread Nathan Chancellor
Clang warns: drivers/staging/rtlwifi/halmac/halmac_88xx/halmac_func_88xx.c:2472:11: warning: implicit conversion from enumeration type 'enum halmac_cmd_process_status' to different enumeration type 'enum halmac_ret_status' [-Wenum-conversion] return HALMAC_CMD_PROCESS_ERROR

Re: [PATCH] staging: rtlwifi: Use proper enum for return in halmac_parse_psd_data_88xx

2019-02-20 Thread Nicholas Mc Guire
On Wed, Feb 20, 2019 at 10:25:24PM -0700, Nathan Chancellor wrote: > Clang warns: > > drivers/staging/rtlwifi/halmac/halmac_88xx/halmac_func_88xx.c:2472:11: > warning: implicit conversion from enumeration type 'enum > halmac_cmd_process_status' to different enumeration type 'enum > halmac_ret_stat