Hi Todd,
url:
https://github.com/0day-ci/linux/commits/Todd-Kjos/binder-create-node-flag-to-request-sender-s-security-context/20190111-095225
New smatch warnings:
drivers/android/binder.c:4364 binder_thread_read() warn: check that 'tr.secctx'
doesn't leak information
#
https://github.com/0
Hi,
This todo entry from staging/android/TODO intriguates me:
vsoc.c, uapi/vsoc_shm.h
- The current driver uses the same wait queue for all of the futexes in a
region. This will cause false wakeups in regions with a large number of
waiting threads. We should eventually use
On Fri, Jan 11, 2019 at 09:03:16PM +0530, Nishad Kamdar wrote:
> This patch series converts uses of the old GPIO API to the GPIO
> descriptor API. It also converts the GPIO driver to use the
> GPIO irqchip library GPIOLIB_IRQCHIP instead of repimplementing
> the same.
>
> Changes in v6:
> - Patch
On Mon, Jan 14, 2019 at 09:27:15AM +0100, Hugo Lefeuvre wrote:
> Hi,
>
> This todo entry from staging/android/TODO intriguates me:
>
> vsoc.c, uapi/vsoc_shm.h
> - The current driver uses the same wait queue for all of the futexes in a
>region. This will cause false wakeups in reg
On Sat, Jan 12, 2019 at 10:31:08PM -0800, Himadri Pandya wrote:
> On Mon, Jan 7, 2019 at 5:04 AM Dan Carpenter
> wrote:
>
> >
> > Ending a name with an underscore is quite ugly.
>
>
> Yeah. That's right. So renaming it to channel_array[ ] instead.
>
Naming is hard. Having "_array" in the nam
This documents key feature, usage, and on-disk design of erofs.
Reviewed-by: Chao Yu
Cc:
Signed-off-by: Gao Xiang
---
.../erofs/Documentation/filesystems/erofs.txt | 195 +
1 file changed, 195 insertions(+)
create mode 100644 drivers/staging/erofs/Documentation/filesy
Hi,
This is the first EROFS patchset for this new round.
An initial document describing the details of EROFS is added in this
patchset and it was previewed in
https://lists.ozlabs.org/pipermail/linux-erofs/2019-January/001227.html
In addition, Li Guifu found an unexpected crash related to fast sy
From: Chao Yu
This patch cleans up erofs_map_blocks* function and structure family,
just simply the code, no logic change.
Reviewed-by: Gao Xiang
Signed-off-by: Chao Yu
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/data.c | 31 +--
drivers/staging/erofs/
Currently, EROFS uses generic iops when xattr is off,
it seems unnecessary and a lot of extra code is there.
Let's follow what other filesystems do instead.
Reviewed-by: Chao Yu
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/inode.c| 38
drivers/stag
Let's move independent xattr-related stuffs to xattr.h.
No logic changes.
Reviewed-by: Chao Yu
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/internal.h | 5 -
drivers/staging/erofs/super.c| 1 +
drivers/staging/erofs/xattr.h| 2 ++
3 files changed, 3 insertions(+), 5 deletions(
Currently, this will hit a BUG_ON for these symlinks as follows:
- kernel message
[ cut here ]
kernel BUG at drivers/staging/erofs/xattr.c:59!
SMP PTI
CPU: 1 PID: 1170 Comm: getllxattr Not tainted 4.20.0-rc6+ #92
Hardware name: QEMU Standard PC (i440FX + PIIX, 1996), BIOS 1
On Mon, Jan 14, 2019 at 05:39:24PM +0530, Himadri Pandya wrote:
> On Mon, 14 Jan, 2019, 4:21 PM Dan Carpenter
> Naming is hard. Having "_array" in the name isn't great either. It's
> > normally obvious it's an array because of the [] characters.
> >
>
> Okay. How about renaming it to "_list[ ]
Access to reference frames that were imported from dma-buf was taken
care of and is no longer a pending item on the driver's TODO list.
Signed-off-by: Paul Kocialkowski
---
drivers/staging/media/sunxi/cedrus/TODO | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/media/sunxi
Introduce a new optional job_done operation, which allows calling back
to the driver when a job is done. Since the job might be completed
from interrupt context where some operations are not available, having
a callback from non-atomic context allows performing these operations
upon completion of a
Introduce helpers to request and release access to buffers that are
not currently selected as current output or capture buffers.
This is useful to ensure proper access to buffers imported via dma-buf
that are used as reference and thus require associated map/unmap calls
before access.
Signed-off-
This is a first attempt at implementing proper access to buffers
imported with dma-buf and used as reference frames for decoding
subsequent frames.
The main concern associated with this scenario was that memory could be
liberated while the buffer is not in a queued state. After careful
checking, i
Because we need to request and release access to reference buffers
that are backed by a dma-buf import, keep track of the buffers used
as reference and add the appropriate calls in the device_run and
job_done m2m callbacks. The latter is introduced for this purpose.
Signed-off-by: Paul Kocialkowsk
This patch series converts uses of the old GPIO API to the GPIO
descriptor API. It also converts the GPIO driver to use the
GPIO irqchip library GPIOLIB_IRQCHIP instead of repimplementing
the same.
Chnages in v7:
- Combine the three patches together.
Changes in v6:
- Patchset now contains two pa
Convert the GPIO driver to use the GPIO irqchip library
GPIOLIB_IRQCHIP instead of reimplementing the same.
Reviewed-by: Johan Hovold
Signed-off-by: Nishad Kamdar
---
Changes in v7:
- No change.
Changes in v5:
- Restore "struct irq_chip irqc" in "struct gb_gpio_controller"
This is because w
Use the gpiod interface instead of the deprecated old non-descriptor
interface while continuing to ignore gpio flags from device tree in
functions "deassert_reset()" and "assert_reset()" for now.
Reviewed-by: Johan Hovold
Signed-off-by: Nishad Kamdar
---
Changes in v7:
- No change.
Changes in v
Use the gpiod interface instead of the deprecated old non-descriptor
interface while continuing to ignore gpio flags from device tree in
"svc_reset_onoff()" for now.
Reviewed-by: Johan Hovold
Signed-off-by: Nishad Kamdar
---
Changes in v7:
- No change.
Changes in v6:
- Make error messages co
On Mon, Jan 14, 2019 at 08:25:07PM +0530, Nishad Kamdar wrote:
> This patch series converts uses of the old GPIO API to the GPIO
> descriptor API. It also converts the GPIO driver to use the
> GPIO irqchip library GPIOLIB_IRQCHIP instead of repimplementing
> the same.
>
> Chnages in v7:
> - Combi
On Mon, Jan 14, 2019 at 10:05:17AM +0100, Johan Hovold wrote:
> On Fri, Jan 11, 2019 at 09:03:16PM +0530, Nishad Kamdar wrote:
> > This patch series converts uses of the old GPIO API to the GPIO
> > descriptor API. It also converts the GPIO driver to use the
> > GPIO irqchip library GPIOLIB_IRQCHIP
To allow servers to verify client identity, allow a node
flag to be set that causes the sender's security context
to be delivered with the transaction. The BR_TRANSACTION
command is extended in BR_TRANSACTION_SEC_CTX to
contain a pointer to the security context string.
Signed-off-by: Todd Kjos
--
On Fri, 11 Jan 2019, Andrew F. Davis wrote:
> Buffers may not be mapped from the CPU so skip cache maintenance here.
> Accesses from the CPU to a cached heap should be bracketed with
> {begin,end}_cpu_access calls so maintenance should not be needed anyway.
>
> Signed-off-by: Andrew F. Davis
> -
From: Gao Xiang
This documents key feature, usage, and on-disk design of erofs.
Reviewed-by: Chao Yu
Cc:
Signed-off-by: Gao Xiang
---
change log v2:
- fix some incorrect descriptions, such as namelen -> nameoff;
- add description about target EROFS users.
Thanks,
Gao Xiang
.../erofs/Docu
On Mon, Jan 14, 2019 at 09:10:21AM -0800, Todd Kjos wrote:
> To allow servers to verify client identity, allow a node
> flag to be set that causes the sender's security context
> to be delivered with the transaction. The BR_TRANSACTION
> command is extended in BR_TRANSACTION_SEC_CTX to
> contain a
On Mon, Jan 14, 2019 at 10:50:24AM -0800, Todd Kjos wrote:
> On Mon, Jan 14, 2019 at 10:33 AM Joel Fernandes wrote:
> >
> > On Mon, Jan 14, 2019 at 09:10:21AM -0800, Todd Kjos wrote:
> > > To allow servers to verify client identity, allow a node
> > > flag to be set that causes the sender's securi
From: Haiyang Zhang
These assignments occur in multiple places. The patch refactor them
to a function for simplicity. It also puts the struct to heap area
for future expension.
Signed-off-by: Haiyang Zhang
---
drivers/net/hyperv/netvsc_drv.c | 134
1 file chang
From: Haiyang Zhang
Using ethtool to change Hash key failed on Linux VM runnig on
Hyper-V. This patch set fix them.
It targets Hyper-V tree, hyperv-fixes branch managed by
Sasha Levin .
Haiyang Zhang (3):
Fix ethtool change hash key error
Refactor assignments of struct netvsc_device_info
From: Haiyang Zhang
Hyper-V hosts require us to disable RSS before changing RSS key,
otherwise the changing request will fail. This patch fixes the
coding error.
Fixes: ff4a44199012 ("netvsc: allow get/set of RSS indirection table")
Reported-by: Wei Hu
Signed-off-by: Haiyang Zhang
---
drivers
From: Haiyang Zhang
Changing mtu, channels, or buffer sizes ops call to netvsc_attach(),
rndis_set_subchannel(), which always reset the hash key to default
value. That will override hash key changed previously. This patch
fixes the problem by save the hash key, then restore it when we re-
add the
This patch cleans up erofs_map_blocks* function and structure family,
just simply the code, no logic change.
Reviewed-by: Gao Xiang
Signed-off-by: Chao Yu
Signed-off-by: Gao Xiang
---
v2:
- remove unneed semicolon in definition of z_erofs_map_blocks_iter
drivers/staging/erofs/data.c | 31
On 1/11/19 10:05 AM, Andrew F. Davis wrote:
The "unmapped" heap is very similar to the carveout heap except
the backing memory is presumed to be unmappable by the host, in
my specific case due to firewalls. This memory can still be
allocated from and used by devices that do have access to the
bac
On 1/11/19 10:05 AM, Andrew F. Davis wrote:
Hello all,
This is a set of (hopefully) non-controversial cleanups for the ION
framework and current set of heaps. These were found as I start to
familiarize myself with the framework to help in whatever way I
can in getting all this up to the standard
>-Original Message-
>From: Laura Abbott [mailto:labb...@redhat.com]
>Sent: Friday, January 04, 2019 9:53 AM
>To: Zengtao (B) ; sumit.sem...@linaro.org
>Cc: Greg Kroah-Hartman ; Arve Hjønnevåg
>; Todd Kjos ; Martijn Coenen
>; Joel Fernandes ;
>de...@driverdev.osuosl.org; dri-de...@lists.free
This switches the fbtft driver to use GPIO descriptors
rather than numerical gpios:
Utilize the GPIO library's intrinsic handling of OF GPIOs
and polarity. If the line is flagged active low, gpiolib
will deal with this.
Remove gpios from platform device structure. Neither assign
statically number
This switches the fbtft driver to use GPIO descriptors
rather than numerical gpios:
Utilize the GPIO library's intrinsic handling of OF GPIOs
and polarity. If the line is flagged active low, gpiolib
will deal with this.
Remove gpios from platform device structure. Neither assign
statically number
Replace kzalloc() function with its 2-factor argument form, kcalloc().
This patch replaces cases of:
kzalloc(a * b, gfp)
with:
kcalloc(a, b, gfp)
This code was detected with the help of Coccinelle.
Signed-off-by: Gustavo A. R. Silva
---
drivers/staging/rtl8188eu/core/rtw_efus
On Wed, Jan 9, 2019 at 8:56 PM Brajeswar Ghosh
wrote:
>
> Remove linux/mutex.h.h which is included more than once
>
> Signed-off-by: Brajeswar Ghosh
Acked-by: Souptick Joarder
> ---
> drivers/staging/android/vsoc.c | 1 -
> 1 file changed, 1 deletion(-)
>
> diff --git a/drivers/staging/androi
40 matches
Mail list logo