This looks very nice. I have two more comments, but they can be added using
a follow-up patch (unless you need a v9 anyway):
On 08/28/2018 09:34 AM, Paul Kocialkowski wrote:
> Stateless video decoding engines require both the MPEG slices and
> associated metadata from the video stream in order to
On 08/28/2018 09:34 AM, Paul Kocialkowski wrote:
> This introduces the Cedrus VPU driver that supports the VPU found in
> Allwinner SoCs, also known as Video Engine. It is implemented through
> a v4l2 m2m decoder device and a media device (used for media requests).
> So far, it only supports MPEG2
On 08/28/2018 10:02 AM, Paul Kocialkowski wrote:
> This introduces the required definitions for HEVC decoding support with
> stateless VPUs. The controls associated to the HEVC slice format provide
> the required meta-data for decoding slices extracted from the bitstream.
>
> This interface comes
Hi Thierry, Dmitry,
Dmitry found some issues, so I'll wait for a v2.
Anyway, this driver is in staging with this TODO:
- Implement V4L2 API once it gains support for stateless decoders.
I just wanted to mention that the Request API is expected to be merged
for 4.20. A topic branch is here:
htt
On Mon, Sep 03, 2018 at 02:18:15PM +0200, Hans Verkuil wrote:
> Hi Thierry, Dmitry,
>
> Dmitry found some issues, so I'll wait for a v2.
>
> Anyway, this driver is in staging with this TODO:
>
> - Implement V4L2 API once it gains support for stateless decoders.
>
> I just wanted to mention that
On Sun, Sep 2, 2018 at 2:01 PM Janusz Krzysztofik wrote:
> In order to make use of array info obtained from gpiod_get_array() and
> speed up processing of arrays matching single GPIO chip layout, that
> information must be passed to get/set array functions. Extend the
> functions' API with that a
On Mon, Sep 3, 2018 at 6:31 AM Matthew Wilcox wrote:
> > +++ b/drivers/auxdisplay/hd44780.c
> > @@ -62,17 +62,12 @@ static void hd44780_strobe_gpio(struct hd44780 *hd)
> > /* write to an LCD panel register in 8 bit GPIO mode */
> > static void hd44780_write_gpio8(struct hd44780 *hd, u8 val, unsi
Hi Janusz,
On Sun, Sep 2, 2018 at 2:01 PM Janusz Krzysztofik wrote:
> Most users of get/set array functions iterate consecutive bits of data,
> usually a single integer, while processing array of results obtained
> from, or building an array of values to be passed to those functions.
> Save time
Replace tabs with spaces where appropriate.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_wlan_util.c
b/drivers/staging/rtl8188eu/core/rtw_wl
Remove code that is only valid for channels > 14.
This addresses the below TODO item.
- find and remove remaining code valid only for 5 GHz. Most of the obvious
ones have been removed, but things like channel > 14 still exist.
Signed-off-by: Michael Straube
---
.../staging/rtl8188eu/core/rtw_
Use if(x) instead of if(x == true).
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_wlan_util.c
b/drivers/staging/rtl8188eu/core/rtw_wlan_util.c
index
Remove unnecessary parentheses to follow kernel coding style
and clean checkpatch issues.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_wlan_util.c
Simplify function comment to a single line.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/hal/odm.c | 17 +
1 file changed, 1 insertion(+), 16 deletions(-)
diff --git a/drivers/staging/rtl8188eu/hal/odm.c
b/drivers/staging/rtl8188eu/hal/odm.c
index 9d567838a43a..
This comment adds no useful information to the code,
so remove it.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_cmd.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_cmd.c
b/drivers/staging/rtl8188eu/core/rtw_cmd.c
index 59039211dad
Many drivers with tty use the tty_stand_install(). But, there is no
need to handle the error, since it always returns 0. So, change the
return type of tty_standard_install() and tty_port_install() to void
type and remove unnecessary exception handling where we use these
functions.
Signed-off-by: J
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/isdn/i4l/isdn_tty.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/isdn/i4l/isdn_tty.c b/driv
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/hvc/hvc_console.c | 7 ++-
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/drivers/tty/hvc/hvc_console
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/s390/char/con3215.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/s390/char/con3215.c b/driv
Many drivers with tty use the tty_stand_install(). But, there is no
need to handle the error, since it always returns 0. So, change the
return type of tty_standard_install() and tty_port_install() to void
type and remove unnecessary exception handling where we use these
functions.
Change return ty
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/mips_ejtag_fdc.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/tty/mips_ejtag_fdc.c b/d
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/s390/char/tty3270.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/s390/char/tty3270.c b/
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/usb/host/xhci-dbgtty.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/usb/host/xhci-dbgtty.c
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/vt/vt.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/tty/vt/vt.c b/drivers/tty/vt/vt.
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/misc/pti.c | 28 +---
1 file changed, 13 insertions(+), 15 deletions(-)
diff --git a/drivers/mi
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
net/bluetooth/rfcomm/tty.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/net/bluetooth/rfcomm/tty.c b/ne
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/hvc/hvcs.c | 10 ++
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/drivers/tty/hvc/hvcs.c b/drive
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/synclinkmp.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/tty/synclinkmp.c b/drivers/tt
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/mmc/core/sdio_uart.c | 11 ---
1 file changed, 4 insertions(+), 7 deletions(-)
diff --git a/drivers/mmc/core/sd
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/n_gsm.c | 9 +
1 file changed, 1 insertion(+), 8 deletions(-)
diff --git a/drivers/tty/n_gsm.c b/drivers/tty/n_
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
arch/um/drivers/line.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/arch/um/drivers/line.c b/arch/u
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/synclink.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/tty/synclink.c b/drivers/tty/sy
Since tty_port_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/serial/kgdb_nmi.c | 11 +--
1 file changed, 1 insertion(+), 10 deletions(-)
diff --git a/drivers/tty/serial/kgd
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/isdn/capi/capi.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/isdn/capi/capi.c
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/staging/gdm724x/gdm_tty.c | 11 +++
1 file changed, 3 insertions(+), 8 deletions(-)
diff --git a/drivers/stagin
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/usb/class/cdc-acm.c | 10 +-
1 file changed, 1 insertion(+), 9 deletions(-)
diff --git a/drivers/usb/class/cdc-
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/staging/fwserial/fwserial.c | 22 --
1 file changed, 8 insertions(+), 14 deletions(-)
diff --git a/
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/usb/serial/usb-serial.c | 6 +-
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/drivers/usb/serial/usb-
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/vcc.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/tty/vcc.c b/drivers/tty/vcc.c
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/tty/nozomi.c | 8 +++-
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/drivers/tty/nozomi.c b/drivers/
Since tty_standard_install() always returns 0, the return type has changed
to void. Now apply this and remove the obsolete error check.
Signed-off-by: Jaejoong Kim
---
drivers/staging/greybus/uart.c | 10 ++
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/gr
Hi Jaejoong.
> Change return type for tty functions. Patch No.01
> tty: Change return type to void
Adding this patch first will generate a lot of warnings
until all users are updated.
It is usual practice to prepare all users
and then apply the infrastructure changes as the
last patch.
Then peop
Instead of having 'wilc_enable_ps' as global variable moved it to 'wilc'
structure. Rename 'wilc_enable_ps' to 'enable_ps' as its already part of
'wilc' structure
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_wlan.c | 5 ++---
drivers/staging/wilc1000/wilc_wfi_cfgoper
Moved 'aging_timer' to wilc_priv struct instead of having it as static
variable.
As 'aging_timer' is maintained for each interfaces so 'op_ifcs' check is
not required before the timer_setup() and del_timer_sync() call.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations
Fixes to use correct index to free the allocated memory for ies
information. The check was done using 'last_scanned_cnt' index and its
not correct, so use the correct index ('i') to check for before freeing
the allocated memory.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfg
Move global variable 'wilc_during_ip_timer' and 'wilc_optaining_ip' to
'wilc_vif' structure.
Rename these variables like below
wilc_during_ip_timer -> during_ip_timer
wilc_optaining_ip -> obtaining_ip.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 15 +++
This patch set mainly contains changes to avoid the use of static
and global variables. Also contains few patch to avoid the checkpatch
warning arise due to code refactor.
Changes since v1:
1. rework on patch#10, use dynamically allocating memory to maintain
multicast mac address filter list.
Cleanup patch to remove the unnecessary NULL check before freeing up ies
information in clear_shadow_scan().
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi
Cleanup patch to avoid line over 80 chars checkpatch issue introduced in
previous code refactor commit.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wlan.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wlan.c
b/drive
Refactor code to move 'periodic_rssi' as part of wilc_vif struct. Move
'dummy_statistics' from 'wilc' struct to 'wilc_vif' to maintain for
each interface separately.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 19 ---
drivers/staging/wilc1000/wil
Avoid use of static variables and moved the varibles as part of private
data. last_scanned_shadow & last_scanned_cnt variable is moved to
'wilc_priv' to maintain for each interface. After moving static
variable, clear_shadow_scan() doesn't require check 'op_ifcs'
count as now for each interface the
Cleanup code to remove the variables related to setting and getting IP
address as this case was not handled from firmware side.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 105 --
drivers/staging/wilc1000/host_interface.h | 3 -
drivers
Avoid use of static variable 'clients_count' and move it part of 'wilc'
structure.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 9 -
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 1 +
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/driver
Avoid use of static variables and move them as part of wilc_vif struct.
Move all the parameters related to tcp_ack_filter algo to wilc_vif
struct.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 4 +-
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 4 +-
Use short variable names to avoid line over 80 chars checkpatch warning
in tcp_process().
struct pending_acks_info --> struct pending_ack
int tcp_pending_ack_idx --> int ack_idx
u32 pending_ack --> u32 pending_ack_idx
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/
Cleanup patch to use appropriate variable name to fetch the periodic
statistics.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 2 +-
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/stagin
Refactor the code to avoid use of 'wilc_set_multicast_list' global
variable. Allocate the memory required to keep the multicast mac address
and pass it to the worker thread.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 13 +++--
drivers/staging/wilc1000/host_
After code refactor in previous commit now 'op_ifcs' is not require any
more, so remove it.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
b/drivers/staging
Cleanup patch to use lowercase name for get_BSSID() and HIL variable.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/coreconfigurator.c | 4 ++--
drivers/staging/wilc1000/wilc_wlan.c| 8
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wilc1
Move the static variable as part of 'wilc' priv struct.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_wlan.c | 1 +
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 1 +
drivers/staging/wilc1000/wilc_wlan.c | 10 --
3 files changed, 6 insertions(+), 6 del
Cleanup patch to avoid the avoid extra 'if' condition and clubbed the
same condition in single 'if' block.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/drivers/staging/wil
Avoid use of static variable hif_workqueue and move it inside 'wilc'
structure.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 13 -
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 1 +
2 files changed, 9 insertions(+), 5 deletions(-)
diff --git a/dri
Avoid use of static variable and move 'rcv_assoc_resp' as part of
'hif_drv' struct. Rename from 'rcv_assoc_resp' to 'assoc_resp'.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 8 +++-
drivers/staging/wilc1000/host_interface.h | 1 +
2 files changed, 4 insertions(+
Remove the use of unnecessary static variable 'p2p_listen_state'.
Already 'p2p_listen_state' is present in 'wilc_priv' struct. So making
use of that variable as its getting set in channel ready and
remain on channel expired callback.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_in
Move static variable 'wilc_connecting' as part of 'wilc_vif' private
struct. Remove "wilc_" prefix from name as its already part of wilc_vif
struct.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 4 ++--
drivers/staging/wilc1000/host_interface.h | 2 -
Refactor tcp_process() to avoid unnecessary leading tabs in the
function.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wlan.c | 52 +++-
1 file changed, 28 insertions(+), 24 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wlan.c
b/drivers/
Cleanup to remove handle_hif_exit_work(), as after code refactoring its
not required anymore.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/drivers/staging/wilc1000/h
Refactor code to move the initialization of wilc related parameters in
wilc_netdev_init() and move their deinitialization in
wilc_netdev_cleanup(). For 'hif_workqueue' creation 'clients_count' check
is not required as the single instance is maintained.
Signed-off-by: Ajay Singh
---
drivers/stagi
Refactor the wilc_netdev_init() to cleanup the memory for error
scenario and remove unnecessary 'dev' pointer check.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_wlan.c | 36 ---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 6 +++-
2 files
68 matches
Mail list logo