On Fri, Aug 24, 2018 at 11:06:56PM +0200, Sven Luthi wrote:
> Checkpatch repored "Lines should not end with a '('" for line 1283.
>
> Moved opening parenthesis of function on line 1283 onto next line.
>
> Signed-off-by: Sven Luthi
> ---
> drivers/staging/comedi/drivers/adl_pci9118.c | 4 ++--
>
On Sat, Aug 25, 2018 at 02:07:01AM +0300, GuyLuz wrote:
> From: Guy Luz
>
> Fixed a Lines should not end with a '(' issue.
>
> Signed-off-by: Guy Luz
> ---
> drivers/staging/comedi/drivers/cb_pcidas64.c | 7 +++
> 1 file changed, 3 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/s
Dear sir ,
I KELLY ALAN purchasing and sales manager of CFM INTERNATIONAL .Our
Company specialised in Supplying computer hardware and Electronic .We
want to extend our supplier list because of concurrency in prices on the
international market. We are seeking a supplier with whom we can to ha
Dear sir ,
I KELLY ALAN purchasing and sales manager of CFM INTERNATIONAL .Our
Company specialised in Supplying computer hardware and Electronic .We
want to extend our supplier list because of concurrency in prices on the
international market. We are seeking a supplier with whom we can to ha
Driver probe function calls 'devm_pci_alloc_host_bridge'. If this call fails
it is returning -ENODEV. Return -ENOMEM instead which is more accurate for
this.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff
Driver is using reset_control kernel API's to manage this so this
two macros are not needed anymore. Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 15 ---
1 file changed, 15 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt762
mt7621-pcie_port data structure has filed 'base' as the base address for
read and write related port registers. Create two inline functions
'pcie_port_read' and 'pcie_port_write' to make this task easier and
code more readable.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci
This patch series parse remaining port info from device tree storing
it in mt7621_pcie_port struct created for this.
Also minor cleanups are performed here:
- Remove not used macros.
- Use kernel reset_control functions.
- Remove unused code.
Changes in v3:
- 'mt7621_pcie_enable_p
This file has a valid SPDX license line added so reamining
GPL2+ boilerplate text is not needed at all. Remove it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 31 +++
1 file changed, 3 insertions(+), 28 deletions(-)
diff --git a/dr
There are three macros which are not being used at all.
Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt7621.c
index 61da7
Add initialization of each PCIe port reading and initializing
data using device tree.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 75 +++--
1 file changed, 71 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pc
Driver probe function is a mess and shall be refactored a lot. At first
make use of assert and deassert control factoring out a new function
called 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 88 +++--
1 f
This two lines whch are commented are not needed at all.
Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt7621.c
index eec
There are some functions in driver code that can be declared
'static'. Just do it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt
Reset bits related macros are in different parts. Reagroup
all of them together to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
Factor out a new function 'mt7621_enable_phy' for enabling the
pcie phy for each port and call it from 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 13 ++---
1 file changed, 10 insertions(+), 3 deletions(-)
diff --git a/drive
Add missing system control registers address in pcie node of
the device tree.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-dts/mt7621.dtsi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-dts/mt7621.dtsi
b/drivers/staging/mt7621-dts/
There are some printk's which can be replaced properly
using dev_* kernel functions. Use dev_info to show
N_FTS status for each port using a loop instead of duplicating
lines of code.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 13 +
1 file changed
Rename function 'mt7621_pcie_enable_port' with a name which is better
for what the function is really doing calling it 'mt7621_pcie_init_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/dr
checkpatch script is complaining about the use of printk instead
of use more proper dev_* kernel functions. Replace all of them
removing warnings.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
d
Static variables are initialised to 0 by GCC and checkpatch
script also complains about that. Make it happy.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
Chackpatch script is compalining about one comment which
is not following the kernel style. Fix it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/d
Move debug for the port N_FTS from driver probe function to the more
appropiate one 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt
Function 'bypass_pipe_rst' and 'set_phy_for_ssc' can be
written in a cleaner way. Instead of use comments to see which
bits are the ones which are being enabled add new macros with
that information using BIT and GENMASK kernel macros. Avoid the
use of set_pcie_phy which is kind of dark and use new
There are some pointer read and writes which can be replaced
properly using sysctl registers readed from device tree. Remap
sysctl registers and replace in proper places.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 38 -
1 file
Dear sir ,
I KELLY ALAN purchasing and sales manager of CFM INTERNATIONAL .Our
Company specialised in Supplying computer hardware and Electronic .We
want to extend our supplier list because of concurrency in prices on the
international market. We are seeking a supplier with whom we can to ha
26 matches
Mail list logo