This patch removed code which are valid for IEEE 802.11a i.e. 5GHz.
This is also mention in the TODO file.
Signed-off-by: Bhaskar Singh
---
drivers/staging/rtl8188eu/core/rtw_ieee80211.c | 8 +---
1 file changed, 1 insertion(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rt
Ajay Singh writes:
> On Thu, 16 Aug 2018 13:53:50 +0300
> Kalle Valo wrote:
>
>> Kalle Valo writes:
>>
>> > Ajay Singh writes:
>> >
>> >> Hi Greg,
>> >>
>> >> We all are working on submitting and reviewing patches for
>> >> wilc1000 in staging driver for quite some time.
>> >>
>> >> We wou
Removed unnecessary parentheses and this resolve the check patch issue.
Structure dereference operator have higher precedence then Address of
operator So there is no need of parentheses.
This change is purely coding style in nature and should have not effect
on runtime code execution.
Signed-off
There seem to be some problems as result of 30467e0b3be ("mm, hotplug:
fix concurrent memory hot-add deadlock"), which tried to fix a possible
lock inversion reported and discussed in [1] due to the two locks
a) device_lock()
b) mem_hotplug_lock
While add_memory() first takes b), f
Reading through the code and studying how mem_hotplug_lock is to be used,
I noticed that there are two places where we can end up calling
device_online()/device_offline() - online_pages()/offline_pages() without
the mem_hotplug_lock. And there are other places where we call
device_online()/device_o
From: Vitaly Kuznetsov
Well require to call add_memory()/add_memory_resource() with
device_hotplug_lock held, to avoid a lock inversion. Allow external modules
(e.g. hv_balloon) that make use of add_memory()/add_memory_resource() to
lock device hotplug.
Signed-off-by: Vitaly Kuznetsov
[modify p
On Fri, Aug 17, 2018 at 9:59 AM David Hildenbrand wrote:
>
> There seem to be some problems as result of 30467e0b3be ("mm, hotplug:
> fix concurrent memory hot-add deadlock"), which tried to fix a possible
> lock inversion reported and discussed in [1] due to the two locks
> a) device_lock
On 8/17/2018 9:49 AM, Kalle Valo wrote:
Ajay Singh writes:
On Thu, 16 Aug 2018 13:53:50 +0300
Kalle Valo wrote:
Kalle Valo writes:
Ajay Singh writes:
Hi Greg,
We all are working on submitting and reviewing patches for
wilc1000 in staging driver for quite some time.
We would like to
On 17.08.2018 10:20, Rafael J. Wysocki wrote:
> On Fri, Aug 17, 2018 at 9:59 AM David Hildenbrand wrote:
>>
>> There seem to be some problems as result of 30467e0b3be ("mm, hotplug:
>> fix concurrent memory hot-add deadlock"), which tried to fix a possible
>> lock inversion reported and discussed
Arend van Spriel writes:
> On 8/17/2018 9:49 AM, Kalle Valo wrote:
>> Ajay Singh writes:
>>
>>> On Thu, 16 Aug 2018 13:53:50 +0300
>>> Kalle Valo wrote:
>>>
Kalle Valo writes:
> From wireless point of view: if I see wext mentioned anywhere in the
> driver I stop right there.
On Fri, Aug 17, 2018 at 09:59:00AM +0200, David Hildenbrand wrote:
> From: Vitaly Kuznetsov
>
> Well require to call add_memory()/add_memory_resource() with
> device_hotplug_lock held, to avoid a lock inversion. Allow external modules
> (e.g. hv_balloon) that make use of add_memory()/add_memory_r
On 17.08.2018 10:41, Greg Kroah-Hartman wrote:
> On Fri, Aug 17, 2018 at 09:59:00AM +0200, David Hildenbrand wrote:
>> From: Vitaly Kuznetsov
>>
>> Well require to call add_memory()/add_memory_resource() with
>> device_hotplug_lock held, to avoid a lock inversion. Allow external modules
>> (e.g. h
On Fri, Aug 17, 2018 at 10:41 AM Greg Kroah-Hartman
wrote:
>
> On Fri, Aug 17, 2018 at 09:59:00AM +0200, David Hildenbrand wrote:
> > From: Vitaly Kuznetsov
> >
> > Well require to call add_memory()/add_memory_resource() with
> > device_hotplug_lock held, to avoid a lock inversion. Allow external
On Fri, Aug 17, 2018 at 10:56 AM David Hildenbrand wrote:
>
> On 17.08.2018 10:41, Greg Kroah-Hartman wrote:
> > On Fri, Aug 17, 2018 at 09:59:00AM +0200, David Hildenbrand wrote:
> >> From: Vitaly Kuznetsov
> >>
> >> Well require to call add_memory()/add_memory_resource() with
> >> device_hotplu
On Fri, 2018-08-17 at 01:19 +0530, Nishad Kamdar wrote:
> Use the identifier __func__ instead of gcc specific __FUNCTION__
> in dbg.h. Limit these lines to 80 characters. Issues found by
> checkpatch.
It looks like there are 4 uses in -next
drivers/staging/mt7621-mmc/dbg.h:110:host->i
On Fri, 17 Aug 2018 11:36:02 +0300
Kalle Valo wrote:
> Arend van Spriel writes:
>
> > On 8/17/2018 9:49 AM, Kalle Valo wrote:
> >> Ajay Singh writes:
> >>
> >>> On Thu, 16 Aug 2018 13:53:50 +0300
> >>> Kalle Valo wrote:
> >>>
> Kalle Valo writes:
>
> > From wireless po
On 17.08.2018 11:03, Rafael J. Wysocki wrote:
> On Fri, Aug 17, 2018 at 10:56 AM David Hildenbrand wrote:
>>
>> On 17.08.2018 10:41, Greg Kroah-Hartman wrote:
>>> On Fri, Aug 17, 2018 at 09:59:00AM +0200, David Hildenbrand wrote:
From: Vitaly Kuznetsov
Well require to call add_memo
On Fri, Aug 17, 2018 at 11:41:24AM +0200, David Hildenbrand wrote:
> On 17.08.2018 11:03, Rafael J. Wysocki wrote:
> > On Fri, Aug 17, 2018 at 10:56 AM David Hildenbrand wrote:
> >>
> >> On 17.08.2018 10:41, Greg Kroah-Hartman wrote:
> >>> On Fri, Aug 17, 2018 at 09:59:00AM +0200, David Hildenbran
On 17.08.2018 12:06, Greg Kroah-Hartman wrote:
> On Fri, Aug 17, 2018 at 11:41:24AM +0200, David Hildenbrand wrote:
>> On 17.08.2018 11:03, Rafael J. Wysocki wrote:
>>> On Fri, Aug 17, 2018 at 10:56 AM David Hildenbrand wrote:
On 17.08.2018 10:41, Greg Kroah-Hartman wrote:
> On Fri,
On Fri, Aug 17, 2018 at 01:04:58PM +0200, David Hildenbrand wrote:
> >> If there are no objections, I'll go into that direction. But I'll wait
> >> for more comments regarding the general concept first.
> >
> > It is the middle of the merge window, and maintainers are really busy
> > right now. I
On 17.08.2018 13:28, Heiko Carstens wrote:
> On Fri, Aug 17, 2018 at 01:04:58PM +0200, David Hildenbrand wrote:
If there are no objections, I'll go into that direction. But I'll wait
for more comments regarding the general concept first.
>>>
>>> It is the middle of the merge window, and m
Let's make the raw NAND API consistent by patching all helpers to
take a nand_chip object instead of an mtd_info one.
Now is nand_wait_ready()'s turn.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/bcm47xxnflash/ops_bcm4706.c | 2 +-
drivers/mtd/nand/raw/cafe_nand.c |
Let's make the raw NAND API consistent by patching all helpers to take
a nand_chip object instead of an mtd_info one.
We start with all variants of nand_scan().
Signed-off-by: Boris Brezillon
---
Documentation/driver-api/mtdnand.rst | 2 +-
drivers/mtd/nand/raw/ams-delta.c
Let's make the raw NAND API consistent by patching all helpers to
take a nand_chip object instead of an mtd_info one.
Now is nand_release()'s turn.
Signed-off-by: Boris Brezillon
---
Documentation/driver-api/mtdnand.rst | 2 +-
drivers/mtd/nand/raw/ams-delta.c | 2 +-
drivers/mt
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one.
Now is ecc->hwctl()'s turn.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/cs553x_nand.c | 3 +--
drivers/mtd/nand/raw/davinci_nand.c | 10 +-
drive
Hello,
This is the first set of patches aiming at cleaning the raw NAND API.
This one focuses on inconsistencies we have in the API + the nand_chip
and nand_ecc_ctrl interfaces. Some functions/hooks are passed a
nand_chip object, some are passed an mtd_info object and some are
passed both.
Since
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one.
Now is ecc->correct()'s turn.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/davinci_nand.c | 9 -
drivers/mtd/nand/raw/diskonchip.c | 3 +--
driv
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the chip->setup_data_interface() hook.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/atmel/na
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the chip->setup_read_retry() hook.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/nand_base.c
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the chip->waitfunc() hook.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/atmel/nand-controlle
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the nand_xxx_bbt() helpers.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/nand_base.c | 6 ++
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the chip->select_chip() hook.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/atmel/nand-contro
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
In order to do that, we first need to update the platform_nand_ctrl
hooks to take a nand_chip object instead of an mtd_
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the chip->erase() hook.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/denali.c| 4 ++--
d
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one.
Now is ecc->calculate()'s turn.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/cs553x_nand.c | 4 ++--
drivers/mtd/nand/raw/davinci_nand.c | 12 ++--
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the chip->{get,set}_features() hooks.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/mxc_nand.
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle all chip->block_xxx() hooks at once.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/cafe_nand.
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the chip->cmd_ctrl() hook.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/ams-delta.c
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle all chip->read_xxx() hooks at once.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/ams-delta.c
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the chip->dev_ready() hook.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/ams-delta.c
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the chip->cmdfunc() hook.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/au1550nd.c
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle all ecc->write_xxx() hooks at once.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/atmel/nand-
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle all ecc->read_xxx() hooks at once.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/atmel/nand-c
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle all chip->write_xxx() hooks at once.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/ams-delta.
Let's make the raw NAND API consistent by patching all helpers and
hooks to take a nand_chip object instead of an mtd_info one or
remove the mtd_info object when both are passed.
Let's tackle the nand_erase_nand() helper.
Signed-off-by: Boris Brezillon
---
drivers/mtd/nand/raw/nand_base.c | 10
On Fri, Aug 17, 2018 at 01:56:35PM +0200, David Hildenbrand wrote:
> E.g. When adding the memory block devices, we know that there won't be a
> driver to attach to (as there are no drivers for the "memory" subsystem)
> - the bus_probe_device() function that takes the device_lock() could
> pretty mu
A few coding style changes in the file rtl819x_HT.h
John Whitmore (10):
staging:rtl8192u: Replace magic number with defined constant - Style
staging:rtl8192u: Rename sHTCLng - Style
staging:rtl8192u: Remove unnecessary blank lines - Style
staging:rtl8192u: Add required spaces - Style
sta
The defined constant MIMO_PS_STATIC is used for this test for zero
elsewhere in code so the magic number '0' has been replaced with that
comment, which was actually explicitly mentioned in the comment.
This is a simple coding style change which should have no impact on
runtime code execution.
Sig
Two unions HT_CAPABILITY and HT_CAPABILITY_MACPARA have previously been
commented out of code. Since they are obviously not used in code and
the commented out unions add nothing to the code they have been removed.
This is a coding style change which should have no impact on runtime
code execution.
Correct the block comments so they conform to coding standard.
This is a coding style change which should not impact on runtime
code execution.
Signed-off-by: John Whitmore
---
.../staging/rtl8192u/ieee80211/rtl819x_HT.h | 73 +--
1 file changed, 36 insertions(+), 37 deletions
Remove unused constants, this is a coding style change which should
have no impact on runtime code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HT.h | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HT.h
b
The macro CHHLOP_IN_PROGRESS is never used in code, so has been
removed.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HT.h | 4
1 file changed, 4 deletions(-)
diff --git a/d
Add spaces required by coding style to clear checkpatch issues.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HT.h | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-
The structure HT_CAPABILITY_ELE causes a number of checkpatch / coding
style issues. The structure uses a 'typedef' directive causing an
issue regarding defining new types in the code. The name of the
structure should be lowercase, and the '__packed' directive is prefered
over the attribute directi
Removed blank lines which cause checkpatch issues.
This is a simple coding style change which should have no impact on
runtime code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HT.h | 9 -
1 file changed, 9 deletions(-)
diff --git a/drivers/sta
The constant sHTCLng causes a checkpatch issue, due to its use of
CamelCase naming. To correct the issue the constant has been renamed
to HTCLNG.
I'm not sure this is a good name as it communicates very little and
contradicts the block comment above its definition. MCS_LEN might
be a better name i
The enumerated type CHNLOP is only used as a member variable of the
structure RT_HIGH_THROUGHPUT. Whilst this member variable is initialised
it is never actually used in the code. To simplify the code both the
enumerated type and the member variable have been removed.
This is a coding style change
57 matches
Mail list logo