Remove the now unused IS_MCAST.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/include/wifi.h | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/wifi.h
b/drivers/staging/rtl8188eu/include/wifi.h
index 4a56e54e38f6..0a952edf8a81 100644
---
Use rtlwifi/phydm/phydm_reg.h instead of odm_reg.h and
remove the now unused odm_reg.h.
All defines from odm_reg.h are defined with the same values
in rtlwifi/phydm/phydm_reg.h.
Signed-off-by: Michael Straube
---
.../staging/rtl8188eu/include/odm_precomp.h | 2 +-
drivers/staging/rtl8188eu/
Use is_multicast_ether_addr instead of custom IS_MCAST in
core/rtw_recv.c. In all uses the address array/memory is
properly aligned.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_recv.c | 35 ---
1 file changed, 18 insertions(+), 17 deletions(-)
diff
Use is_multicast_ether_addr instead of custom IS_MCAST in
core/rtw_xmit.c. In all uses the address array is properly
aligned.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_xmit.c | 35 +++
1 file changed, 16 insertions(+), 19 deletions(-)
diff --git a
Use is_multicast_ether_addr instead of custom IS_MCAST in
core/rtw_security.c. In all uses the address array is properly
aligned.
Signed-off-by: Michael Straube
---
v2: checked that in all uses of is_multicast_ether_addr
the address array/memory is properly aligned and
updated the commit
Looks good. Thanks! I reviewed the series.
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Effective July, 2018 We are outsourcing companies and individuals on behalf of
a steel company located in china Commission - 5% Annually income - Between
$30,000 To $50,000 Job type -Contract duration - 8 to 12months, Time Required -
3 to 5 hours per week. Role - Account-Receivable Agent.
Best
Your photos need editing. We can do it for you.
We do editing for e-commerce photos, jewelries images and portrait photos
etc.
This will include cutout and clipping path etc , also retouching if needed.
Let;s know if you want to send photos for working.
We can do test on your photos.
Thanks,
Ke
On Thu, Aug 9, 2018 at 11:14 PM Greg Kroah-Hartman
wrote:
>
> On Thu, Aug 09, 2018 at 08:40:06PM -0700, John Joseph wrote:
> > Acked-by: John Joseph
>
> Why are you acking something you supposidly already signed-off on?
Sorry, my fault, wasn't sure what the protocol was for these so I
suggested
On 10.08.18 11:44, Dan Carpenter wrote:
Looks good. Thanks! I reviewed the series.
Reviewed-by: Dan Carpenter
Thanks,
Michael
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-de
Use is_multicast_ether_addr instead of custom IS_MCAST in
core/rtw_xmit.c. In all uses the address array is properly
aligned.
Signed-off-by: Michael Straube
Reviewed-by: Dan Carpenter
---
drivers/staging/rtl8188eu/core/rtw_xmit.c | 35 +++
1 file changed, 16 insertions(+), 1
Use is_multicast_ether_addr instead of custom IS_MCAST in
core/rtw_recv.c. In all uses the address array/memory is
properly aligned.
Signed-off-by: Michael Straube
Reviewed-by: Dan Carpenter
---
drivers/staging/rtl8188eu/core/rtw_recv.c | 35 ---
1 file changed, 18 insertion
Use rtlwifi/phydm/phydm_reg.h instead of odm_reg.h and
remove the now unused odm_reg.h.
All defines from odm_reg.h are defined with the same values
in rtlwifi/phydm/phydm_reg.h.
Signed-off-by: Michael Straube
Reviewed-by: Dan Carpenter
---
.../staging/rtl8188eu/include/odm_precomp.h | 2 +-
Remove the now unused IS_MCAST.
Signed-off-by: Michael Straube
Reviewed-by: Dan Carpenter
---
drivers/staging/rtl8188eu/include/wifi.h | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/wifi.h
b/drivers/staging/rtl8188eu/include/wifi.h
index 4a56e54e38
Use is_multicast_ether_addr instead of custom IS_MCAST in
core/rtw_security.c. In all uses the address array is properly
aligned.
Signed-off-by: Michael Straube
Reviewed-by: Dan Carpenter
---
v2: checked that in all uses of is_multicast_ether_addr
the address array/memory is properly aligned
://github.com/0day-ci/linux/commits/Leonardo-Br-s/staging-fbtft-Moves-from-macro-definition-to-macro-usage/20180810-154004
reproduce:
# apt-get install sparse
make ARCH=x86_64 allmodconfig
make C=1 CF=-D__CHECK_ENDIAN__
sparse warnings: (new ones prefixed by >>)
>
No no... I only gave it a Reviewed-by tag because I didn't want you to
resend again... :P
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Placed a check for the return value of sscanf. -EINVAL is returned if
the value is anything other than expected. Reported by checkpatch.pl
Signed-off-by: Sumit Pundir
---
drivers/staging/mt7621-mmc/dbg.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/mt762
This add the media entity subdevice and control driver for the i.MX7
CMOS Sensor Interface.
Signed-off-by: Rui Miguel Silva
---
drivers/staging/media/imx/Kconfig |9 +-
drivers/staging/media/imx/Makefile |2 +
drivers/staging/media/imx/imx7-media-csi.c | 1352 +++
Add power domain index 0 related with mipi-phy to imx7s.
While at it rename pcie power-domain node to remove pgc prefix.
Signed-off-by: Rui Miguel Silva
---
arch/arm/boot/dts/imx7s.dtsi | 8 +++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/imx7s.dtsi b/arc
Add non vendor bayer formats to the allowed format array.
Signed-off-by: Rui Miguel Silva
---
drivers/media/platform/video-mux.c | 20
1 file changed, 20 insertions(+)
diff --git a/drivers/media/platform/video-mux.c
b/drivers/media/platform/video-mux.c
index d8a6fa20879a.
The IOMUXC General Purpose Register has bitfield to control video bus
multiplexer to control the CSI input between the MIPI-CSI2 and parallel
interface. Add that register and mask.
Signed-off-by: Rui Miguel Silva
Reviewed-by: Philipp Zabel
---
arch/arm/boot/dts/imx7s.dtsi | 8 +++-
1 file c
Some imx system do not have IPU, so prepare the imx media drivers to support
this kind of devices. Rename the group ids to include an _IPU_ prefix, add a new
group id to support systems with only a CSI without IPU, and also
rename the create internal links to make it clear that only systems with IP
Adds MIPI CSI-2 subdev for i.MX7 to connect with sensors with a MIPI CSI-2
interface.
Signed-off-by: Rui Miguel Silva
---
drivers/staging/media/imx/Makefile |1 +
drivers/staging/media/imx/imx7-mipi-csis.c | 1134
2 files changed, 1135 insertions(+)
create mode
This patch adds the device tree nodes for csi, video multiplexer and mipi-csi
besides the graph connecting the necessary endpoints to make the media capture
entities to work in imx7 Warp board.
Signed-off-by: Rui Miguel Silva
---
arch/arm/boot/dts/imx7s-warp.dts | 51
Add rst document to describe the i.MX7 media driver and also a working
example from the Warp7 board usage with a OV2680 sensor.
Signed-off-by: Rui Miguel Silva
---
Documentation/media/v4l-drivers/imx7.rst | 157 ++
Documentation/media/v4l-drivers/index.rst | 1 +
2 files c
Refactor and move media device initialization code to a new common module, so it
can be used by other devices, this will allow for example a near to introduce
imx7 CSI driver, to use this media device.
Signed-off-by: Rui Miguel Silva
---
drivers/staging/media/imx/Makefile| 1 +
drivers/
Warp7 comes with a Omnivision OV2680 sensor, add the node here to make complete
the camera data path for this system. Add the needed regulator to the analog
voltage supply, the port and endpoints in mipi_csi node and the pinctrl for the
reset gpio.
Signed-off-by: Rui Miguel Silva
---
arch/arm/bo
Hi,
This series introduces the Media driver to work with the i.MX7 SoC. it uses the
already existing imx media core drivers but since the i.MX7, contrary to
i.MX5/6, do not have an IPU and because of that some changes in the imx media
core are made along this series to make it support that case.
T
Add some i.MX7 related entries to TODO file.
Signed-off-by: Rui Miguel Silva
---
drivers/staging/media/imx/TODO | 9 +
1 file changed, 9 insertions(+)
diff --git a/drivers/staging/media/imx/TODO b/drivers/staging/media/imx/TODO
index aeeb15494a49..6f29b5ca5324 100644
--- a/drivers/stagi
Add bindings documentation for i.MX7 media drivers.
The imx7 MIPI CSI2 and imx7 CMOS Sensor Interface.
Reviewed-by: Rob Herring
Signed-off-by: Rui Miguel Silva
---
.../devicetree/bindings/media/imx7-csi.txt| 45 ++
.../bindings/media/imx7-mipi-csi2.txt | 90 +
Reviewed-by: Rob Springer
On Fri, Aug 10, 2018 at 9:56 AM Rob Springer wrote:
>
> Revewed-by: Rob Springer
>
> On Thu, Aug 9, 2018 at 8:21 PM Todd Poynor wrote:
>>
>> From: Todd Poynor
>>
>> A debug log in gasket_alloc_dev() is issued regardless of whether the
>> device pointer used returned
This patch series parse remaining port info from device tree storing
it in mt7621_pcie_port struct created for this.
Also minor cleanups are performed here:
- Remove not used macros.
- Use kernel reset_control functions.
- Remove unused code.
Hope this helps.
Best regards,
Sergio
mt7621-pcie_port data structure has filed 'base' as the base address for
read and write related port registers. Create two inline functions
'pcie_port_read' and 'pcie_port_write' to make this task easier and
code more readable.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci
Driver probe function calls 'devm_pci_alloc_host_bridge'. If this call fails
it is returning -ENODEV. Return -ENOMEM instead which is more accurate for
this.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff
Driver probe function is a mess and shall be refactored a lot. At first
make use of assert and deassert control factoring out a new function
called 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 92 -
1 f
Add initialization of each PCIe port reading and initializing
data using device tree.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 74 +++--
1 file changed, 70 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pc
This file has a valid SPDX license line added so reamining
GPL2+ boilerplate text is not needed at all. Remove it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 31 +++
1 file changed, 3 insertions(+), 28 deletions(-)
diff --git a/dr
Reset bits related macros are in different parts. Reagroup
all of them together to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
There are some functions in driver code that can be declared
'static'. Just do it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt
Driver is using reset_control kernel API's to manage this so this
two macros are not needed anymore. Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 15 ---
1 file changed, 15 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt762
This two lines whch are commented are not needed at all.
Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt7621.c
index 746
There are some printk's which can be replaced properly
using dev_* kernel functions. Use dev_info to show
N_FTS status for each port using a loop instead of duplicating
lines of code.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 13 +
1 file changed
There are three macros which are not being used at all.
Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt7621.c
index 67d4b
узф щстм сфми
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On 08/10/18 13:31, Dan Carpenter wrote:
No no... I only gave it a Reviewed-by tag because I didn't want you to
resend again... :P
Ah, sorry. So I shouldn't have added the tag?
Should I remove it again? I guess not..
How are those tags (reviewed, acked, etc.) handled normaly?
I'm a bit confuse
On Fri, Aug 10, 2018 at 08:21:23PM +0200, Michael Straube wrote:
> On 08/10/18 13:31, Dan Carpenter wrote:
> > No no... I only gave it a Reviewed-by tag because I didn't want you to
> > resend again... :P
>
> Ah, sorry. So I shouldn't have added the tag?
> Should I remove it again? I guess not..
From: "K. Y. Srinivasan"
Miscellaneous fixes/enhancements.
K. Y. Srinivasan (1):
Tools: hv: Fix a bug in the key delete code
Michael Kelley (1):
Drivers: hv: vmbus: Fix synic per-cpu context initialization
Stephen Hemminger (3):
vmbus: add driver_override support
uio_hv_generic: increa
From: Stephen Hemminger
Add support for overriding the default driver for a VMBus device
in the same way that it can be done for PCI devices. This patch
adds the /sys/bus/vmbus/devices/.../driver_override file
and the logic for matching.
This is used by driverctl tool to do driver override.
http
From: Stephen Hemminger
DEBUG is leftover from the development phase, remove it.
Signed-off-by: Stephen Hemminger
Signed-off-by: K. Y. Srinivasan
---
drivers/uio/uio_hv_generic.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/uio/uio_hv_generic.c b/drivers/uio/uio_hv_generic.c
ind
From: Stephen Hemminger
When using DPDK there is significant performance boost by using
the largest possible send and receive buffer area.
Unfortunately, with UIO model there is not a good way to configure
this at run time. But it is okay to have a bigger buffer available
even if application onl
From: "K. Y. Srinivasan"
Fix a bug in the key delete code - the num_records range
from 0 to num_records-1.
Signed-off-by: K. Y. Srinivasan
Reported-by: David Binderman
Cc:
---
tools/hv/hv_kvp_daemon.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/hv/hv_kvp_daemon.
From: Michael Kelley
If hv_synic_alloc() errors out, the state of the per-cpu context
for some CPUs is unknown since the zero'ing is done as each
CPU is iterated over. In such case, hv_synic_cleanup() may try to
free memory based on uninitialized values. Fix this by zero'ing
the per-cpu context
53 matches
Mail list logo