Hi Hugo,
thank you for all your work on Pi433 driver.
For a better understanding some info about Pi433 and the ideas behind it.
Pi433 was developed by me in order to have a simple to mount
CE-compliant 433MHz shield for the Raspberry Pi. I wanted to put it on
sale on the one side and develop a fu
On Thu, Jun 21, 2018 at 10:03:45PM -0400, Hugo Lefeuvre wrote:
> I'll prepare a patch addressing both issues. However I don't own test devices
> so it would be really great if you could test it !
I have two pi433 devices now so I should be able to tests things,
just let me know...
--
Valentin
__
On Thu, Jun 21, 2018 at 1:29 AM, Joel Fernandes wrote:
> Also if you look at the kernel sources, there are dozens of drivers that
> check for correct VMA size in mmap handler and fail if it isn't sized
> correctly.
If that's the case, we should definitely do it this way for ashmem as
well. Since
On Mon, Jun 18, 2018 at 5:09 PM, Arnd Bergmann wrote:
> The timespec structure suffers from the y2038 overflow and should not
> be used. This changes handle_vsoc_cond_wait() to use ktime_t directly.
>
> Signed-off-by: Arnd Bergmann
Reviewed-by: Martijn Coenen
Thanks!
> ---
> drivers/staging/
On Fri, Jun 22, 2018 at 03:17:25AM +, Alma Eyre (Sonata Software North
America) wrote:
> Hello,
>
> This is Alma supporting Azure for Japanese customers. I had a question
> from a customer that I could not find the answers for. I saw this
> github(https://github.com/torvalds/linux/commit/88c9
SPDX license helps developers and machines to know the right license
governing a file
Signed-off-by: Mawanda Henry
---
drivers/android/binder_alloc.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/android/binder_alloc.c b/drivers/android/binder_alloc.c
index 2628806..84da232 100644
On Thu, Jun 21, 2018 at 08:21:55PM +0200, Michael Straube wrote:
> Remove braces from single line if statements.
> Also fix a comparsion to NULL in one of the conditions.
> Issues found by checkpatch.
>
> Signed-off-by: Michael Straube
> ---
> drivers/staging/rtl8723bs/core/rtw_debug.c | 6 ++---
On Thu, Jun 21, 2018 at 08:22:30PM +0200, Michael Straube wrote:
> Fix checkpatch error 'do not use assignment in if condition'.
>
> Signed-off-by: Michael Straube
> ---
> drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git
I liked the patch, but just go over the 80 character limit instead of
adding a "key" variable. It's better that it generate a checkpatch
warning and forces someone to rename the variable...
regards,
dan carpenter
___
devel mailing list
de...@linuxdriv
On Fri, Jun 22, 2018 at 03:54:22AM -0700, Joe Perches wrote:
> On Fri, 2018-06-22 at 13:40 +0300, Dan Carpenter wrote:
> > On Thu, Jun 21, 2018 at 08:22:30PM +0200, Michael Straube wrote:
> > > Fix checkpatch error 'do not use assignment in if condition'.
> []
> > > diff --git a/drivers/staging/rtl
On Fri, 2018-06-22 at 13:40 +0300, Dan Carpenter wrote:
> On Thu, Jun 21, 2018 at 08:22:30PM +0200, Michael Straube wrote:
> > Fix checkpatch error 'do not use assignment in if condition'.
[]
> > diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
> > b/drivers/staging/rtl8723bs/core/rtw_i
"Alma Eyre (Sonata Software North America)"
writes:
> Hello,
>
> This is Alma supporting Azure for Japanese customers. I had a question from a
> customer that I could not find the answers for. I saw this
> github(https://github.com/torvalds/linux/commit/88c9281a9fba67636ab26c1fd6afbc78a632374f)
On 06/22/18 12:57, Dan Carpenter wrote:
On Fri, Jun 22, 2018 at 03:54:22AM -0700, Joe Perches wrote:
On Fri, 2018-06-22 at 13:40 +0300, Dan Carpenter wrote:
On Thu, Jun 21, 2018 at 08:22:30PM +0200, Michael Straube wrote:
Fix checkpatch error 'do not use assignment in if condition'.
[]
diff
On 06/22/18 12:28, Dan Carpenter wrote:
if (count < 1)
return -EFAULT;
- if (buffer && !copy_from_user(tmp, buffer, sizeof(tmp))) {
+ if (buffer && !copy_from_user(tmp, buffer, sizeof(tmp)))
sscanf(tmp, "%u", &g_wait_hiq_empty);
- }
The o
Remove initializations of global variables with 0.
Criticized by checkpatch.
Signed-off-by: Henriette Hofmeier
Signed-off-by: Florian Harbecke
---
drivers/staging/rtl8723bs/core/rtw_efuse.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8723bs/cor
Fix errors reported by checkpatch:
* move open braces of defintions
* remove unnecessary initializations
Change comment on local variable definition to comply
with coding-style and correct to 'global variables'.
Henriette Hofmeier (3):
rtl8723bs: Move definition open brace to next line
rt
Move open braces of definitions to the next line
to comply with codestyle.
Criticized by checkpatch.
Signed-off-by: Henriette Hofmeier
Signed-off-by: Florian Harbecke
---
drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/driv
Change comment from 'local variable' to 'global variables'
and change style to comply with coding-style.
Signed-off-by: Henriette Hofmeier
Signed-off-by: Florian Harbecke
---
drivers/staging/rtl8723bs/core/rtw_efuse.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drive
Okay, in that case I will fix and resend the patch.
Kind Regards,
Chris Opperman
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Are you planning to add this for every source file in the kernel tree?
Why this file?
On Fri, Jun 22, 2018 at 2:25 AM Mawanda Henry
wrote:
>
> SPDX license helps developers and machines to know the right license
> governing a file
>
> Signed-off-by: Mawanda Henry
> ---
> drivers/android/binder_
Improve readability of prism2_add_key:
a) Reduce nesting and removed goto statement by using more return statements.
Signed-off-by: Chris Opperman
---
drivers/staging/wlan-ng/cfg80211.c | 40 +-
1 file changed, 13 insertions(+), 27 deletions(-)
diff --git a/d
Implement 'Fast' hypercall with two 64-bit input parameter. This is
going to be used for HvCallSendSyntheticClusterIpi hypercall.
Signed-off-by: Vitaly Kuznetsov
---
arch/x86/include/asm/mshyperv.h | 34 ++
1 file changed, 34 insertions(+)
diff --git a/arch/x86/i
Trace Hyper-V PV IPIs the same way we do PV TLB flush.
Signed-off-by: Vitaly Kuznetsov
---
arch/x86/hyperv/hv_apic.c | 4
arch/x86/include/asm/trace/hyperv.h | 15 +++
2 files changed, 19 insertions(+)
diff --git a/arch/x86/hyperv/hv_apic.c b/arch/x86/hyperv/hv_apic.
When reviewing my "x86/hyper-v: use cheaper HVCALL_FLUSH_VIRTUAL_ADDRESS_
{LIST,SPACE} hypercalls when possible" patch Michael suggested to apply the
same idea to PV IPIs. Here we go!
Despite what Hyper-V TLFS says about HVCALL_SEND_IPI hypercall, it can
actually be 'fast' (passing parameters thro
Current Hyper-V TLFS (v5.0b) claims that HvCallSendSyntheticClusterIpi
hypercall can't be 'fast' (passing parameters through registers) but
apparently this is not true, Windows always uses 'fast' version. We can
do the same in Linux too.
Signed-off-by: Vitaly Kuznetsov
---
arch/x86/hyperv/hv_api
When there is no need to send an IPI to a CPU with VP number > 64
we can do the job with fast HVCALL_SEND_IPI hypercall.
Signed-off-by: Vitaly Kuznetsov
---
arch/x86/hyperv/hv_apic.c | 29 -
1 file changed, 20 insertions(+), 9 deletions(-)
diff --git a/arch/x86/hyper
On Fri, 2018-06-22 at 14:48 +0200, Michael Straube wrote:
> On 06/22/18 12:57, Dan Carpenter wrote:
> > On Fri, Jun 22, 2018 at 03:54:22AM -0700, Joe Perches wrote:
> > > On Fri, 2018-06-22 at 13:40 +0300, Dan Carpenter wrote:
> > > > On Thu, Jun 21, 2018 at 08:22:30PM +0200, Michael Straube wrote:
On 06/22/18 19:28, Joe Perches wrote:
On Fri, 2018-06-22 at 14:48 +0200, Michael Straube wrote:
On 06/22/18 12:57, Dan Carpenter wrote:
On Fri, Jun 22, 2018 at 03:54:22AM -0700, Joe Perches wrote:
On Fri, 2018-06-22 at 13:40 +0300, Dan Carpenter wrote:
On Thu, Jun 21, 2018 at 08:22:30PM +0200
Changes to fix issues reported by checkpatch.
Tim Collier (4):
staging: wlan-ng: fix coding style (indentation) in prism2mib.c
staging: wlan-ng: replace WLAN_CTL_FRAMELEN with inline function in
p80211hdr.h
staging: wlan-ng: replace macro with inline function in prism2mgmt.c
staging: w
Fix two "CHECK: Macro argument 'N' may be better as '(N)' to avoid
precedence issue" messages, reported by checkpatch, by adding
parentheses around the offending macro argument references.
Signed-off-by: Tim Collier
---
drivers/staging/wlan-ng/prism2mgmt.c | 4 ++--
1 file changed, 2 insertions(
checkpatch gives the following message for the p80211rate_to_p2bit
macro:
CHECK: Macro argument reuse 'n' - possible side-effects?
To fix the message, replace the macro with an equivalent inline
function.
Signed-off-by: Tim Collier
---
drivers/staging/wlan-ng/prism2mgmt.c | 19 +++-
checkpatch reports a "CHECK" diagnostic for WLAN_CTL_FRAMELEN as the
macro reuses its argument, leading to possible side-effects. Avoid
this by replacing the macro with an equivalent function, named
wlan_ctl_framelen (as recommended in the coding style). All references
to the macro also updated acc
Fix "CHECK: Alignment should match open parenthesis" reported by
checkpatch.pl.
Signed-off-by: Tim Collier
---
drivers/staging/wlan-ng/prism2mib.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wlan-ng/prism2mib.c
b/drivers/staging/wlan-ng/prism2mib.
I intend to leave my money to you,am also giving my body to science for
research.
I want this last act of mine to be an offering to GOD and humanity.
I'm diagnosed with laryngeal cancer,respond so i know you got this.
Bless you
___
devel mailing list
de.
On Fri, Jun 22, 2018 at 08:27:24AM -0700, Todd Kjos wrote:
> Are you planning to add this for every source file in the kernel tree?
Someone has to, yes, we are planning on converting the whole tree, it's
about 1/3 done so far.
> Why this file?
Odds are checkpatch was run on this and it complaine
I intend to leave my money to you,am also giving my body to science for
research.
I want this last act of mine to be an offering to humanity.
I'm diagnosed with laryngeal cancer,respond so i know you got this.
Bless you
___
devel mailing list
de...@linux
On Fri, Jun 22, 2018 at 10:22:28AM +0200, Peter Zijlstra wrote:
> On Fri, Jun 22, 2018 at 03:17:25AM +, Alma Eyre (Sonata Software North
> America) wrote:
> > Hello,
> >
> > This is Alma supporting Azure for Japanese customers. I had a question
> > from a customer that I could not find the an
37 matches
Mail list logo