Cleanup patch to remove the curly braces used in 'case' statement to follow as
per linux standard.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 10 ++
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgo
Cleanup patch to remove unnecessary inner block ( {/**/} ) in
wilc_netdev_init().
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_wlan.c | 34 --
1 file changed, 16 insertions(+), 18 deletions(-)
diff --git a/drivers/staging/wilc1000/linux_wlan.c
b/
Using local variable instead of static varible 'del_beacon'. Also removed
the unnecessary 'if' check in handle_del_beacon().
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/wilc1000/ho
Fix "Possible unnecessary 'out of memory' message" issue reported by
checkpatch.pl script.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/drivers/staging/wilc1000/host_interfa
Cleanup patch to avoid 'struct' name with uppercase letters.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_mon.c | 6 +++---
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 2 +-
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wilc1000/linux
Changes to avoid the use of uppercase for function name.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_mon.c | 2 +-
drivers/staging/wilc1000/linux_wlan.c | 2 +-
drivers/staging/wilc1000/wilc_wfi_cfgoperations.h | 2 +-
3 files changed, 3 insertions(+), 3
Fix below issue reported by checkpatch.pl script.
'Comparison to NULL could be written "priv->wilc_gtk[key_index]"'
'Comparison to NULL could be written "priv->wilc_ptk[key_index]"'
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 4 ++--
1 file changed, 2 inser
Changes to avoid the use of uppercase for function name.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_mon.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wilc1000/linux_mon.c
b/drivers/staging/wilc1000/linux_mon.c
index 1667646..d5af736
Cleanup patch to remove the unused macro mentioned below. Also move
macro up along with other macro declaration.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wilc1000/host_interfa
This patch series contains fixes to remove unused code and changes for
checkpatch.pl script reported issues.
Ajay Singh (21):
staging: wilc1000: remove inner block in wilc_netdev_init()
staging: wilc1000: remove unnecessary 'out of memory' message in
handle_key()
staging: wilc1000: modif
Cleanup patch to remove the unnecessary code.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_spi.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_spi.c
b/drivers/staging/wilc1000/wilc_spi.c
index c17f5d2..1f2dde1 100644
--- a/drivers/staging/wil
Cleanup patch to remove the unnecessary comments used for file and functions
header.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/coreconfigurator.h | 10 --
drivers/staging/wilc1000/linux_mon.c | 44 ---
drivers/staging/wilc1000/wilc_wfi_cfgo
Rename 'WILC_WFI_band_2ghz' to avoid mixedcase for variable name.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
b/drivers/stagin
Changes to avoid the use of uppercase for function name.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_mon.c | 2 +-
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 2 +-
drivers/staging/wilc1000/wilc_wfi_cfgoperations.h | 3 ++-
3 files changed, 4 insertions(+),
Instead of using the intermediate variable to hold the value, now directly
using the allocated variable.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 8 +---
1 file changed, 1 insertion(+), 7 deletions(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b
Added changes to avoid line over 80 character issue in
remove_network_from_shadow().
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperati
Make use of is_broadcast_ether_addr() to check if mac address is broadcast
address. Remove static 'broadcast', as its not needed after use of
is_broadcast_ether_addr().
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_mon.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
dif
Cleanup patch to follow names as per linux coding style.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_mon.c | 2 +-
drivers/staging/wilc1000/linux_wlan.c | 2 +-
drivers/staging/wilc1000/wilc_wfi_cfgoperations.h | 2 +-
3 files changed, 3 insertions(+), 3
Use 'else if' in get_station(), as only one condition will statisfy.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
b/drivers/staging/wilc100
Rename 'during_ip_time' to 'DURING_IP_TIME_OUT' to have uppercase letter
for macros(#define).
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
Cleanup patch to organize macro in a file together after #include
statements.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_netdevice.h
b/driver
Remove the unnecessary file inclusion in the source code. Also follow
the convension to first include the system header then project specific
header files.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/coreconfigurator.c | 5 +
drivers/staging/wilc1000/host_interface.c
On 26.04.2018 23:54, Luc Van Oostenryck wrote:
> The method ndo_start_xmit() is defined as returning an 'netdev_tx_t',
> which is a typedef for an enum type, but the implementation in this
> driver returns an 'int'.
>
> Fix this by returning 'netdev_tx_t' in this driver too
> and accordingly chan
We're mainly discussing readability, right?
To me when people use "int" that tells me as a reader that we don't need
to think about the type. It's going to be a small number.
Say you have data which the user can control, then it's super important
to focus on the data types. We don't focus on it
On Sat, Apr 28, 2018 at 10:05:39AM +0530, Arvind Yadav wrote:
> Replace the manual validity checks for the GPIO with the
> gpio_is_valid().
>
> Signed-off-by: Arvind Yadav
> ---
> chnage in v2 :
> Returning invalid gpio as error instead of -ENODEV.
>
> drivers/staging/greybus/arche
From: Colin Ian King
There are memory leaks of params; when copy_to_user fails and also
the exit via the label 'error'. Fix this by kfree'ing params in
error exit path and jumping to this on the copy_to_user failure path.
Detected by CoverityScan, CID#1467966 ("Resource leak")
Fixes: da43b6cca
On Wed, 2 May 2018 11:39:36 +0300
Dan Carpenter wrote:
> We're mainly discussing readability, right?
>
> To me when people use "int" that tells me as a reader that we don't
> need to think about the type. It's going to be a small number.
>
> Say you have data which the user can control, then i
On Wednesday 02 May 2018 02:13 PM, Johan Hovold wrote:
On Sat, Apr 28, 2018 at 10:05:39AM +0530, Arvind Yadav wrote:
Replace the manual validity checks for the GPIO with the
gpio_is_valid().
Signed-off-by: Arvind Yadav
---
chnage in v2 :
Returning invalid gpio as error instead
On Wed, May 02, 2018 at 03:15:05PM +0530, Arvind Yadav wrote:
> On Wednesday 02 May 2018 02:13 PM, Johan Hovold wrote:
> > On Sat, Apr 28, 2018 at 10:05:39AM +0530, Arvind Yadav wrote:
> >> Replace the manual validity checks for the GPIO with the
> >> gpio_is_valid().
> >>
> >> Signed-off-by: Arvi
On Wednesday 02 May 2018 03:27 PM, Johan Hovold wrote:
On Wed, May 02, 2018 at 03:15:05PM +0530, Arvind Yadav wrote:
On Wednesday 02 May 2018 02:13 PM, Johan Hovold wrote:
On Sat, Apr 28, 2018 at 10:05:39AM +0530, Arvind Yadav wrote:
Replace the manual validity checks for the GPIO with the
On Wed, May 02, 2018 at 10:16:58AM +0100, Colin King wrote:
> From: Colin Ian King
>
> There are memory leaks of params; when copy_to_user fails and also
> the exit via the label 'error'. Fix this by kfree'ing params in
> error exit path and jumping to this on the copy_to_user failure path.
>
>
From: Colin Ian King
There are memory leaks of params; when copy_to_user fails and also
the exit via the label 'error'. Also, there is a bogos memory allocation
check on pointer 'to' when memory allocation fails on params.
Fix this by kfree'ing params in error exit path and jumping to this on
th
From: yuanhuihui
transaction consume mismatched binder work. as follow:
1) Client send transaction when left binder work in the thread->todo
list.
2) in kernel space, client consumed BC_TRANSACTION, and produced
BINDER_WORK_RETURN_ERROR into thread->todo list as target proc is dead
3) Client s
> Hello,
>
> FYI this happens in mainline kernel 4.17.0-rc3.
> It looks like a new regression since v4.17-rc1.
>
> It occurs in 2 out of 2 boots.
>
> [ 54.222599] Magic number: 14:276:994
> [ 54.223261] tty ttyd7: hash matches
> [ 54.223841] tty ttyaa: hash matches
> [ 54.227288] Lust
From: Hongchao Zhang
In keys_fill, the key_set_version could be changed after
the keys are filled, then the keys in this context won't
be refilled by the following lu_context_refill for its
version is equal to the current key_set_version.
In lu_context_refill, the key_set_version should be prote
From: "John L. Hammond"
Hoist lu_keys_guard locking out of the for loop in lu_context_exit().
Signed-off-by: John L. Hammond
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-8918
Reviewed-on: https://review.whamcloud.com/24217
Reviewed-by: Dmitry Eremin
Reviewed-by: Jinshan Xiong
Reviewed-
From: Li Xi
Most of the time, keys are never changed. So rwlock might be
better for the concurrency of key read.
Signed-off-by: Li Xi
Signed-off-by: Gu Zheng
Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-6800
Reviewed-on: http://review.whamcloud.com/15558
Reviewed-by: Faccini Bruno
Revi
From: Lai Siyao
Currently we set LU_OBJECT_HEARD_BANSHEE on object when we want
to remove object from cache, but this may lead to deadlock, because
when other process lookup such object, it needs to wait for this
object until release (done at last refcount put), while that process
maybe already h
With the work going for lu_object by Neil I noticed him solving the
same problem as the Intel developers in a very similar approach. Also
with the changes we don't want to lose these important changes. This
is more mean for a basic review since in the end Neil and this work
will be combined in some
Fix checkpatch warning due to line break after '(', leaving an over 80
character warning due to long macro name.
Signed-off-by: Tim Collier
---
drivers/staging/wlan-ng/hfa384x_usb.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/wlan-ng/hfa384x_usb.c
b/dri
Fix checkpatch warning for missing parameter name for function
prototype.
Signed-off-by: Tim Collier
---
drivers/staging/wlan-ng/hfa384x_usb.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wlan-ng/hfa384x_usb.c
b/drivers/staging/wlan-ng/hfa384x_usb.c
index
Fix two checkpatch issues in hfa384x_usb.c. One warning for a line
over 80 characters remains (due to a long macro name).
Tim Collier (2):
staging: wlan-ng: add missing parameter name to prototype
staging: wlan-ng: fix line-break style issue
drivers/staging/wlan-ng/hfa384x_usb.c | 5 ++---
1
At the end of atomisp_subdev_set_selection(), the function
atomisp_subdev_get_rect() is invoked to get the pointer to v4l2_rect. Since
this function may return a NULL pointer, it is firstly invoked to check
the returned pointer. If the returned pointer is not NULL, then the
function is invoked agai
Anson,
Please have a look at this change.
Shawn
On Mon, Apr 23, 2018 at 02:47:38PM +0100, Rui Miguel Silva wrote:
> Fix the mipi dphy root divider to mipi_dphy_pre_div, this would remove a
> orphan
> clock and set the correct parent.
>
> before:
> cat clk_orphan_summary
>
> -Original Message-
> From: Shawn Guo [mailto:shawn...@kernel.org]
> Sent: Thursday, May 3, 2018 9:08 AM
> To: Rui Miguel Silva ; Anson Huang
>
> Cc: mche...@kernel.org; sakari.ai...@linux.intel.com; Steve Longerbeam
> ; Philipp Zabel ; Rob
> Herring ; linux-me...@vger.kernel.org;
> de...
On Mon, Apr 23, 2018 at 02:47:39PM +0100, Rui Miguel Silva wrote:
> To guarantee that we do not get Overflow in image FIFO the outer bandwidth has
> to be faster than inputer bandwidth. For that it must be possible to set a
> faster frequency clock. So set new parent to sys_pfd3 clock for the mipi
On Mon, Apr 23, 2018 at 02:47:42PM +0100, Rui Miguel Silva wrote:
> To support camera in i.MX7 the cma heap is used to allocate frame buffers. The
> default size of CMA is 16MB which is not enough for higher resolutions (ex:
> 1600x1200).
>
> So, increase the default CMA size to 40MB.
>
> Signed-
On Mon, Apr 23, 2018 at 02:47:45PM +0100, Rui Miguel Silva wrote:
> The IOMUXC General Purpose Register has bitfield to control video bus
> multiplexer to control the CSI input between the MIPI-CSI2 and parallel
> interface. Add that register and mask.
>
> Signed-off-by: Rui Miguel Silva
> ---
>
Cc: Greg Kroah-Hartman
Cc: Arve Hjønnevåg
Cc: Todd Kjos
Cc: Martijn Coenen
Cc: Greg Hartman
Cc: de...@driverdev.osuosl.org
Cc: kernel-t...@android.com
Signed-off-by: Alistair Strachan
---
drivers/staging/android/vsoc.c | 100 -
1 file changed, 49 insertions(+)
Fix "warning: cast to pointer from integer of different size" when
printing the region shm physical address. Use the %pa conversion
specifier and pass the resource by reference.
Cc: Greg Kroah-Hartman
Cc: Arve Hjønnevåg
Cc: Todd Kjos
Cc: Martijn Coenen
Cc: Greg Hartman
Cc: de...@driverdev.osu
Map the region shm as write-combining instead of uncachable.
Cc: Greg Kroah-Hartman
Cc: Arve Hjønnevåg
Cc: Todd Kjos
Cc: Martijn Coenen
Cc: Greg Hartman
Cc: de...@driverdev.osuosl.org
Cc: kernel-t...@android.com
Signed-off-by: Alistair Strachan
---
drivers/staging/android/TODO | 1 -
driv
51 matches
Mail list logo