On Wed, Apr 25, 2018 at 04:01:40PM +0200, Sergio Paracuellos wrote:
> It's good to have SPDX identifiers in all files to make it easier to
> audit the kernel tree for correct licenses.
>
> Fix up the all of the staging ks7010 files to have a proper SPDX
> identifier, based on the license text in t
Hi Greg,
This series is actually V1 and not V2. Sorry, it's mistake from my
side.
If you want me to resend this series, please let me know.
On Wed, 25 Apr 2018 22:48:05 +0530
Ajay Singh wrote:
> This patch series contains fixes to remove the unused code. It also
> has patches to reorganize
On Wed, Apr 25, 2018 at 10:48:06PM +0530, Ajay Singh wrote:
> Replace the function call for crc7_byte() with macro CRC7_BYTE.
> crc7_byte() was called in close while(), so replaced it with macro to
> avoid extra functional call depth.
>
> Signed-off-by: Ajay Singh
> ---
> drivers/staging/wilc100
On Mon, Apr 16, 2018 at 12:37:03PM -0400, Mauro Carvalho Chehab wrote:
> When I started building media subsystem with the atomisp driver,
> I ended by adding several hacks on their Makefiles, in order to
> get rid of thousands of warnings. I felt a little guty of hiding how
> broken is this driver,
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Fix up the all of the staging ks7010 files to have a proper SPDX
identifier, based on the license text in the file itself. The SPDX
identifier is a legally binding shorthand, which can
ks_wlan_private struct has a pointer to struct ks_sdio_card in its
fields. Because of that a forward declaration in needed in ks_wlan.h
header and also it makes necessary to have ks_sdio_card public in
a ks7010_sdio.h header. Changing this pointer into a void pointer
makes no longer necessary to ha
This commit avoids a long line changing a bit message in
_ks_wlan_hw_power_save function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 7 ++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/k
This series continues with driver cleanups. Some code has been
moved to more proper files and ks7010_sdio.h header is
not needed anymore so it has been deleted.
This series also include SPDX identifier changes in '.c'
files where the style was using '/**/' comments instead
of '//' which is the on
There are some definitions for rx and tx queues in ks7010_sdio
which is not the best place to put them. Changing them into the
ks_wlan header file there is no need to explicity include ks7010_sdio.h
which makes no sense at all and can be resolved easily using
forward declarations. The functions rel
On Thu, Apr 26, 2018 at 09:17:08AM +0200, Greg KH wrote:
> On Wed, Apr 25, 2018 at 04:01:40PM +0200, Sergio Paracuellos wrote:
> > It's good to have SPDX identifiers in all files to make it easier to
> > audit the kernel tree for correct licenses.
> >
> > Fix up the all of the staging ks7010 files
Hi Greg,
On Thu, 26 Apr 2018 09:40:20 +0200
Greg KH wrote:
> On Wed, Apr 25, 2018 at 10:48:06PM +0530, Ajay Singh wrote:
> > Replace the function call for crc7_byte() with macro CRC7_BYTE.
> > crc7_byte() was called in close while(), so replaced it with
> > macro to avoid extra functional call d
On Thu, Apr 26, 2018 at 10:35:52AM +0200, Sergio Paracuellos wrote:
> On Thu, Apr 26, 2018 at 09:17:08AM +0200, Greg KH wrote:
> > On Wed, Apr 25, 2018 at 04:01:40PM +0200, Sergio Paracuellos wrote:
> > > It's good to have SPDX identifiers in all files to make it easier to
> > > audit the kernel tr
On Thu, Apr 26, 2018 at 10:55:42AM +0200, Greg KH wrote:
> On Thu, Apr 26, 2018 at 10:35:52AM +0200, Sergio Paracuellos wrote:
> > On Thu, Apr 26, 2018 at 09:17:08AM +0200, Greg KH wrote:
> > > On Wed, Apr 25, 2018 at 04:01:40PM +0200, Sergio Paracuellos wrote:
> > > > It's good to have SPDX identi
Hi Richard,
> -Original Message-
> From: Richard Cochran [mailto:richardcoch...@gmail.com]
> Sent: Thursday, April 26, 2018 10:33 AM
> To: Y.b. Lu
> Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org; Greg
> Kroah-Hartman ; dan.carpen...@oracle.com;
> Ruxandra Ioana Ciocoi Radu
This patch is to support phc_index of ethtool_ts_info.
Also make the rtc drvier depend on FSL_DPAA2_ETH because
this driver is only useful when PTP programs are getting
hardware time stamps on the PTP Ethernet packets using the
SO_TIMESTAMPING API.
Signed-off-by: Yangbo Lu
---
Changes for v2:
Hi Dan,
> -Original Message-
> From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> Sent: Wednesday, April 25, 2018 6:04 PM
> To: Y.b. Lu
> Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org; Greg
> Kroah-Hartman ; Richard Cochran
> ; Ruxandra Ioana Ciocoi Radulescu
>
> Subj
Since hardware timestmaping has been supported in driver, this
patch is to add the get_ts_info interface for ethtool to show
timestamping capability.
Signed-off-by: Yangbo Lu
---
Changes for v2:
- Added this patch.
---
drivers/staging/fsl-dpaa2/ethernet/dpaa2-eth.h |1 +
drivers/
From: Ioana Radulescu
Hardware timestamping is supported both on Rx and Tx paths.
On Rx, timestamping is enabled for all frames. On Tx, we
only instruct the hardware to timestamp the frames marked
accordingly by the stack.
Signed-off-by: Ioana Radulescu
Signed-off-by: Yangbo Lu
---
Changes for
This patch series just do minor cleanups of the driver, changing
some trivial types for its preferred, removing some comments and
cleaning some missing stuff from previous series. Minor function
refactor has been included also.
Sergio Paracuellos (10):
staging: ks7010: remove missing WPS preproc
Local variable event in ks_wlan_hw_rx function is declared
as unsigned short and can be declared as u16 which is preferred
style.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/
Local variable 'byte' in _ks_wlan_hw_power_save function is declared
as unsigned char and can be declared as u8 which is preferred. It
is being using with ks7010_sdio_readb which expects u8 already.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed
Declaration of second parameter 'event' in ks_hostif .h and .c
file is different using uint16_t and unsigned short respectively.
Just unify both using 'u16' which is preferred instead.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
drivers/staging/ks7010/ks_host
Local variable 'byte' in ks7010_rw_function is declared as unsigned
char and can be declared as u8 which is preferred. It is being used
in ks7010_sdio_readb which is already expecting an u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed, 1 inse
Event to send to init the card are always the same so change
code to be more readable putting them into an array and
enqueuing also using a for loop.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 31 +--
1 file changed, 13 insertions(+),
The following commit:
Commit '92c1552caef3 (staging: ks7010: remove WPS definition conditional code)'
removes WPS hardcoded definition and its related conditional preprocessor code.
There was some missing stuff already in this files. Remove it.
Signed-off-by: Sergio Paracuellos
---
drivers/st
Local variable 'byte' in ks7010_sdio_init_irqs is declared as
unsigned char and can be declared as u8 which is preferred.
It is being used in calls to ks7010_sdio_writeb which is already
expected an u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file cha
Header file ks_wlan.h has a lot of nonsense comments along
the different declarations included on it. Most of them are
just the same as the variable name. Just remove them all.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_wlan.h | 49
1
Parameter buffer in write_to_device function is declared as
a pointer to unsigned char and can be declared as an u8 type
which is preferred. Internally it calls to ks7010_sdio_write
which is using also u8 as parameter type. Update calls to this
function as well.
Signed-off-by: Sergio Paracuellos
Local variables 'status', 'rsize' and 'byte' are declared as
unsigned char and can be declared as u8 which is preferred.
They are being used in ks7010_sdio_readb calls which is already
expected an u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file chang
Parameter buffer in write_to_device function is declared as
a pointer to unsigned char and can be declared as an u8 type
which is preferred. Internally it calls to ks7010_sdio_write
which is using also u8 as parameter type. Update calls to this
function as well.
Signed-off-by: Sergio Paracuellos
Commit 92c1552caef3661f049c4e967550e933599e2663 removes WPS hardcoded
definition and its related conditional preprocessor code. There
was some missing stuff already in this files. Remove it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 6 --
drivers/staging/ks70
Local variable 'byte' in _ks_wlan_hw_power_save function is declared
as unsigned char and can be declared as u8 which is preferred. It
is being using with ks7010_sdio_readb which expects u8 already.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed
Local variable 'byte' in ks7010_sdio_init_irqs is declared as
unsigned char and can be declared as u8 which is preferred.
It is being used in calls to ks7010_sdio_writeb which is already
expected an u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file cha
Local variables 'status', 'rsize' and 'byte' are declared as
unsigned char and can be declared as u8 which is preferred.
They are being used in ks7010_sdio_readb calls which is already
expected an u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file chang
Local variable 'byte' in ks7010_rw_function is declared as unsigned
char and can be declared as u8 which is preferred. It is being used
in ks7010_sdio_readb which is already expecting an u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed, 1 inse
Declaration of second parameter 'event' in ks_hostif .h and .c
file is different using uint16_t and unsigned short respectively.
Just unify both using 'u16' which is preferred instead.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
drivers/staging/ks7010/ks_host
Event to send to init the card are always the same so change
code to be more readable putting them into an array and
enqueuing also using a for loop.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 31 +--
1 file changed, 13 insertions(+),
This patch series just do minor cleanups of the driver, changing
some trivial types for its preferred, removing some comments and
cleaning some missing stuff from previous series. Minor function
refactor has been included also.
v2: patch 8: add missing indexing in event vector
Sergio Paracuellos
Local variable event in ks_wlan_hw_rx function is declared
as unsigned short and can be declared as u16 which is preferred
style.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/
Header file ks_wlan.h has a lot of nonsense comments along
the different declarations included on it. Most of them are
just the same as the variable name. Just remove them all.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_wlan.h | 49
1
In the current implementation, vchi_instance is inited during the first
call of bcm2835_audio_open_connection(), and is never freed. It causes a
memory leak when the module `snd_bcm2835` is removed.
Here is how this commit fixes it:
* the VCHI context (including vchi_instance) is created once in
The method ndo_start_xmit() is defined as returning an 'netdev_tx_t',
which is a typedef for an enum type, but the implementation in this
driver returns an 'int'.
Fix this by returning 'netdev_tx_t' in this driver too
and accordingly change 'return 0;' by 'return NETDEV_TX_OK;'
Signed-off-by: Luc
I didn't really hit a real bug, but just happened to spot the bug:
we have decreased the counter at the beginning of vmbus_process_offer(),
so we mustn't decrease it again.
Fixes: 6f3d791f3006 ("Drivers: hv: vmbus: Fix rescind handling issues")
Signed-off-by: Dexuan Cui
Cc: sta...@vger.kernel.or
On Wed, Apr 25, 2018 at 11:12:47AM -0700, k...@linuxonhyperv.com wrote:
> +/*
> + * IPI implementation on Hyper-V.
> + */
> +
> +static int __send_ipi_mask(const struct cpumask *mask, int vector)
> +{
> + int cur_cpu, vcpu;
> + struct ipi_arg_non_ex **arg;
> + struct ipi_arg_non_ex *ipi
On Wed, 25 Apr 2018, k...@linuxonhyperv.com wrote:
> --- /dev/null
> +++ b/arch/x86/hyperv/hv_apic.c
> @@ -0,0 +1,98 @@
> +// SPDX-License-Identifier: GPL-2.0
Thanks for putting the license identifier in.
> +
> +/*
> + * Hyper-V specific APIC code.
> + *
> + * Copyright (C) 2018, Microsoft, Inc.
On Wed, 25 Apr 2018, k...@linuxonhyperv.com wrote:
> +static int __send_ipi_mask(const struct cpumask *mask, int vector)
> +{
> + int cur_cpu, vcpu;
> + struct ipi_arg_non_ex **arg;
> + struct ipi_arg_non_ex *ipi_arg;
> + int ret = 1;
So this indicates whether __send_ipi_mask() can
> -Original Message-
> From: k...@linuxonhyperv.com
> Sent: Wednesday, April 25, 2018 11:13 AM
> To: x...@kernel.org; gre...@linuxfoundation.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com;
> jasow...@redhat.com;
> t...@linutronix.de;
On Wed, 25 Apr 2018, k...@linuxonhyperv.com wrote:
>
> +struct ipi_arg_ex {
> + u32 vector;
> + u32 reserved;
> + struct hv_vpset vp_set;
Please align that in tabular fashion for easy of reading
u32 vector;
u32 reserved;
struct hv_vps
On Wed, 25 Apr 2018, k...@linuxonhyperv.com wrote:
>
> if (!cpumask_equal(mask, cpu_present_mask)) {
> - ipi_arg->vp_set.format = HV_GENERIC_SET_SPARCE_4K;
> + ipi_arg->vp_set.format = HV_GENERIC_SET_SPARSE_4K;
Please move this patch before the others, so you can us
On Wed, 25 Apr 2018, k...@linuxonhyperv.com wrote:
> From: "K. Y. Srinivasan"
>
> Consolidate the allocation of the hypercall input page.
Again. You can provide the new way of allocation first, then you don't have
to add code first in order to remove it later again.
Thanks,
tglx
_
Michael,
On Thu, 26 Apr 2018, Michael Kelley (EOSG) wrote:
> > -Original Message-
> > From: k...@linuxonhyperv.com
> > Sent: Wednesday, April 25, 2018 11:13 AM
> > To: x...@kernel.org; gre...@linuxfoundation.org;
> > linux-ker...@vger.kernel.org;
> > de...@linuxdriverproject.org; o...@a
> -Original Message-
> From: k...@linuxonhyperv.com
> Sent: Wednesday, April 25, 2018 11:13 AM
> To: x...@kernel.org; gre...@linuxfoundation.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com;
> jasow...@redhat.com;
> t...@linutronix.de;
On Wed, 25 Apr 2018, KY Srinivasan wrote:
>
> +struct ipi_arg_ex {
> + u32 vector;
> + u32 reserved;
> + struct hv_vpset vp_set;
> +};
Again, suggest moving to hyperv-tlfs.h. And the 5.0b version
of the TLFS has:
u32 vector;
u8 targetvtl;
Fix 'line over 80 characters' issue found by checkpatch.pl script in
mtk_set_link_ksettings().
Fix extra line before end of function.
Signed-off-by: Jefferson Capovilla
---
drivers/staging/mt7621-eth/ethtool.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/stagin
On 2018-04-25 21:17, Laura Abbott wrote:
On 04/24/2018 08:43 PM, vji...@codeaurora.org wrote:
From: Vijayanand Jitta
An issue is observed where mallocs are failing due to overcommit
failure.
The failure happens when there is high ION page pool since ION page
pool is not considered reclaimabl
Hi Srinivasan,
I love your patch! Yet something to improve:
[auto build test ERROR on v4.17-rc2]
[also build test ERROR on next-20180426]
[cannot apply to tip/x86/core]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https
Fixed coding style issues.
Signed-off-by: Efstratios Gavas
---
drivers/staging/wlan-ng/prism2sta.c | 52 +
1 file changed, 24 insertions(+), 28 deletions(-)
diff --git a/drivers/staging/wlan-ng/prism2sta.c
b/drivers/staging/wlan-ng/prism2sta.c
index fed0b8cec
> -Original Message-
> From: Thomas Gleixner
> Sent: Thursday, April 26, 2018 2:49 PM
> To: KY Srinivasan
> Cc: x...@kernel.org; gre...@linuxfoundation.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; h...@zyt
> -Original Message-
> From: Thomas Gleixner
> Sent: Thursday, April 26, 2018 3:09 PM
> To: KY Srinivasan
> Cc: x...@kernel.org; gre...@linuxfoundation.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; h...@zyt
> -Original Message-
> From: Thomas Gleixner
> Sent: Thursday, April 26, 2018 3:17 PM
> To: KY Srinivasan
> Cc: x...@kernel.org; gre...@linuxfoundation.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; h...@zyt
Hi Srinivasan,
I love your patch! Yet something to improve:
[auto build test ERROR on v4.17-rc2]
[also build test ERROR on next-20180426]
[cannot apply to tip/x86/core]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https
> -Original Message-
> From: Thomas Gleixner
> Sent: Thursday, April 26, 2018 3:24 PM
> To: KY Srinivasan
> Cc: x...@kernel.org; gre...@linuxfoundation.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; h...@zyt
> -Original Message-
> From: Michael Kelley (EOSG)
> Sent: Thursday, April 26, 2018 3:55 PM
> To: KY Srinivasan ; x...@kernel.org;
> gre...@linuxfoundation.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com;
> jasow...@redhat.com; t...@li
> -Original Message-
> From: Dan Carpenter
> Sent: Thursday, April 26, 2018 2:32 PM
> To: KY Srinivasan
> Cc: x...@kernel.org; gre...@linuxfoundation.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; t...@linut
On Fri, Apr 27, 2018 at 05:45:07AM +, Efstratios Gavas wrote:
> Fixed coding style issues.
> Signed-off-by: Efstratios Gavas
We need a blank line before the signed-off-by: line in order to properly
work.
Also, please be much more specific in your changelog text as to what you
are doing here.
65 matches
Mail list logo