On Thu, Apr 19, 2018 at 04:06:17PM +0200, Wolfram Sang wrote:
> We should get drvdata from struct device directly. Going via
> platform_device is an unneeded step back and forth.
>
> Signed-off-by: Wolfram Sang
Acked-by: Johan Hovold
___
devel mailing
On Thu, Apr 19, 2018 at 10:41:15AM +0200, Linus Walleij wrote:
> To make sure that these drivers do not leave staging before they
> are properly converted to use the new GPIO descriptor API, and the
> GPIOLIB_IRQCHIP helper library, create the TODO file with these work
> items.
>
> Cc: Johan Hovol
Am Donnerstag, 19. April 2018, 16:06:19 CEST schrieb Wolfram Sang:
> We should get drvdata from struct device directly. Going via
> platform_device is an unneeded step back and forth.
>
> Signed-off-by: Wolfram Sang
Acked-by: Marc Dietrich
> ---
>
> Build tested only. buildbot is happy. Pleas
We check "lutdpc->dpc_size" in ipipe_validate_lutdpc_params() but if
it's invalid then we would have corrupted memory already when we do
the memcpy() before calling it.
We don't ever check "gamma->tbl_size" but we should since they come from
the user.
Signed-off-by: Dan Carpenter
diff --git a/d
On Thu, 2018-04-19 at 10:41 +0200, Linus Walleij wrote:
> To make sure that these drivers do not leave staging before they
> are properly converted to use the new GPIO descriptor API,
> augment the TODO file with this work item.
Fine by me.
Acked-by: Andy Shevchenko
> Cc: Alan Cox
> Cc: Andy S
On Thu, 19 Apr 2018 10:41:21 +0200
Linus Walleij wrote:
> To make sure that this driver does not leave staging before it
> is properly converted to use the new GPIO descriptor API,
> augment the TODO file with this work item.
>
Thanks to update the TODO required to be fixed before moving out
of
Since commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS")
is CONFIG_ARCH_RENESAS a more appropriate platform check than the legacy
CONFIG_ARCH_SHMOBILE, hence use the former.
Renesas SuperH SH-Mobile SoCs are still covered by the CONFIG_CPU_SH4
check, just like before support for Ren
All drivers for Renesas ARM SoCs have gained proper ARCH_RENESAS
platform dependencies. Hence finish the conversion from ARCH_SHMOBILE
to ARCH_RENESAS for Renesas 32-bit ARM SoCs, as started by commit
9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS").
Signed-off-by: Geert Uytterhoeven
-
Change the menu title to refer to "Renesas SoCs" instead of "SuperH", as
both SuperH and ARM SoCs are supported.
Since commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS")
is ARCH_RENESAS a more appropriate platform dependency for Renesas ARM
SoCs than the legacy ARCH_SHMOBILE, hence
Hi all,
Commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS")
started the conversion from ARCH_SHMOBILE to ARCH_RENESAS for Renesas
ARM SoCs. This patch series completes the conversion, by:
1. Updating dependencies for drivers that weren't converted yet,
2. Removing the AR
The Renesas Fine Display Processor driver is used on Renesas R-Car SoCs
only. Since commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce
ARCH_RENESAS") is ARCH_RENESAS a more appropriate platform dependency
than the legacy ARCH_SHMOBILE, hence use the former.
This will allow to drop ARCH_SHMOBILE o
Emma Mobile is a Renesas ARM SoC. Since commit 9b5ba0df4ea4f940 ("ARM:
shmobile: Introduce ARCH_RENESAS") is ARCH_RENESAS a more appropriate
platform dependency than the legacy ARCH_SHMOBILE, hence use the
former.
This will allow to drop ARCH_SHMOBILE on ARM in the near future.
Signed-off-by: Ge
Since commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS")
is CONFIG_ARCH_RENESAS a more appropriate platform check than the legacy
CONFIG_ARCH_SHMOBILE, hence use the former.
Renesas SuperH SH-Mobile SoCs are still covered by the CONFIG_CPU_SH4
check.
This will allow to drop ARCH_SH
Since commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS")
is ARCH_RENESAS a more appropriate platform dependency than the legacy
ARCH_SHMOBILE, hence use the former.
This will allow to drop ARCH_SHMOBILE on ARM in the near future.
Signed-off-by: Geert Uytterhoeven
---
arch/arm/Kco
The Kconfig symbol for Renesas 64-bit ARM SoCs has always been
ARCH_RENESAS, with ARCH_SHMOBILE being selected to reuse drivers shared
with Renesas 32-bit ARM and/or Renesas SuperH SH-Mobile SoCs.
Commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS")
started the conversion from ARCH_SH
How are you doing today?
We have not heard from you yet. Are you still interested in our photo
retouching services?
We mainly do: ecommerce products photo editing, jewelry photos retouching,
beauty retouching,
wedding photo editing, and photo cutting out, clipping path
You may choose to send us
On Fri, Apr 20, 2018 at 3:28 PM, Geert Uytterhoeven
wrote:
> Hi all,
>
> Commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS")
> started the conversion from ARCH_SHMOBILE to ARCH_RENESAS for Renesas
> ARM SoCs. This patch series completes the conversion, by:
> 1. Updating de
Hi Yangbo,
Thank you for the patch! Perhaps something to improve:
[auto build test WARNING on staging/staging-testing]
[also build test WARNING on v4.17-rc1 next-20180420]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https
Hi Yangbo,
Thank you for the patch! Yet something to improve:
[auto build test ERROR on staging/staging-testing]
[also build test ERROR on v4.17-rc1 next-20180420]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com
On 04/20/2018 04:28 PM, Geert Uytterhoeven wrote:
> Since commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS")
> is ARCH_RENESAS a more appropriate platform dependency than the legacy
"ARCH_RENESAS is", no?
> ARCH_SHMOBILE, hence use the former.
>
> This will allow to drop ARCH_
On 04/20/2018 04:28 PM, Geert Uytterhoeven wrote:
> Since commit 9b5ba0df4ea4f940 ("ARM: shmobile: Introduce ARCH_RENESAS")
> is CONFIG_ARCH_RENESAS a more appropriate platform check than the legacy
> CONFIG_ARCH_SHMOBILE, hence use the former.
>
> Renesas SuperH SH-Mobile SoCs are still covered
On Thu, 19 Apr 2018 14:54:24 -0700
Long Li wrote:
> From: Long Li
>
> This is a best effort for estimating on how busy the ring buffer is for
> that channel, based on available buffer to write in percentage. It is still
> possible that at the time of actual ring buffer write, the space may not
On Fri, Apr 20, 2018 at 03:28:26PM +0200, Geert Uytterhoeven wrote:
> The first 6 patches can be applied independently by subsystem
> maintainers.
> The last two patches depend on the first 6 patches, and are thus marked
> RFC.
Would it not make sense to try to apply everything en masse rather th
For v1 of the patch see [1].
A summary of this patch:
1. Clean up of minor code style issues
2. Replace legacy GPIO ABI with modern ABI
4. Add scaling factor for angular position and angular velocity to
match the sysfs IIO ABI
5. Add documentation for device tree binding, and angle channel
6. M
This patches sorts all the includes in alphabetic order.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers/staging/iio/resolver/ad2s1200.c
i
Reorders the variable declarations to prefer a reverse Christmas tree
order to improve readability.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers
This patches removes unneeded slab.h header.
Signed-off-by: David Veenstra
---
Changes in v2:
- Introduced in this version.
drivers/staging/iio/resolver/ad2s1200.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers/staging/iio/resolver/ad2s120
Add blank lines to improve readability.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 7 +++
1 file changed, 7 insertions(+)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers/staging/iio/resolver/ad2s1200.c
index b6c3a3c8f7fe..357fe3c382b3 100644
Add missing kernel docs to the ad2s1200 driver state.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 8
1 file changed, 8 insertions(+)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
b/drivers/staging/iio/resolver/ad2s1200.c
index 357fe3c382b3..f07aa
Add variable to hold &spi->dev in ad2s1200_probe. This value is repeatedly
used in ad2s1200_probe.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1200.c | 13 -
1 file changed, 8 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1200.c
The manual states that the data is contained in the upper 12 bits
of the 16 bits read by spi. The code that extracts these 12 bits
is correct for both be and le machines, but this is not clear
from a first glance.
To improve readability the relevant expressions are replaced
with equivalent express
The sysfs iio ABI states radians per second is expected as the unit for
angular velocity, but the 12-bit angular velocity register has rps
as its unit. So a fractional scaling factor of approximately 2 * Pi is
added to the angular velocity channel.
The added comments will also be relevant for the
The iio resolver drivers in staging use angle channels. This patch
add missing documentation for this type of channel.
As was discussed in [1], radians is chosen as the unit, to match the
unit of angular velocity.
[1] https://marc.info/?l=linux-driver-devel&m=152190078308330&w=2
Signed-off-by: D
Add documentation for the added device tree bindings.
Signed-off-by: David Veenstra
---
Changes in v2:
- Introduced in this version.
.../bindings/staging/iio/resolver/ad2s1200.txt | 16
1 file changed, 16 insertions(+)
create mode 100644
Documentation/devicetree/b
The legacy, integer based gpio API is replaced with the descriptor
based API.
For compatibility, it is first tried to use the platform data to
request the gpio's. Otherwise, it looks for the "sample" and "rdvel"
gpio function.
Signed-off-by: David Veenstra
---
drivers/staging/iio/resolver/ad2s1
Move the iio driver for the ad2s1200 resolver-to-digital
converter out of staging, into mainline iio subsystems.
Signed-off-by: David Veenstra
---
Changes in v2:
- Added commit message.
- Also move device tree binding documentation out of staging.
- Disabled move detection.
.../devicetree
A fractional scaling factor of approximately 2 * Pi / (2^12 -1) is added,
to scale the 12-bits angular position to radians.
Signed-off-by: David Veenstra
---
Changes in v2:
- This patch replaces the patch that changed the
the channel for angular position to inclination
channel.
driver
Long,
> This is a best effort for estimating on how busy the ring buffer is
> for that channel, based on available buffer to write in percentage. It
> is still possible that at the time of actual ring buffer write, the
> space may not be available due to other processes may be writing at
> the ti
Long,
> If num_cpus=1, we don't have any sub channels.
>
> The host offers one sub channel for VM with 5 CPUs, after that it offers
> an additional sub channel every 4 CPUs.
>
> The primary channel is always offered.
Applied to 4.17/scsi-fixes. Thanks!
--
Martin K. Petersen Oracle Linux E
On Thu, Apr 19, 2018 at 01:40:08PM +0300, Dan Carpenter wrote:
> This driver seems nice and so far as I can see it doesn't need to be in
> staging once we get the other parts merged.
Please explain how this unit ties in with the MAC units.
Thanks,
Richard
___
On Wed, Apr 18 2018, Christian Lütke-Stetzkamp wrote:
> Remove the owner assignment form the platform driver as
> platform_driver_register() already initializes the owner.
> Found using coccinelle.
>
> Signed-off-by: Christian Lütke-Stetzkamp
Reviewed-by: NeilBrown
Thanks,
NeilBrown
> ---
>
On Wed, Apr 18 2018, Christian Lütke-Stetzkamp wrote:
> Remove the owner assignment form the platform driver as
> platform_driver_register() already initializes the owner.
> Found using coccinelle.
>
> Signed-off-by: Christian Lütke-Stetzkamp
Reviewed-by: NeilBrown
Thanks,
NeilBrown
> ---
>
On Wed, Apr 18 2018, Christian Lütke-Stetzkamp wrote:
> Remove the owner assignment form the platform driver as
> platform_driver_register() already initializes the owner.
> Found using coccinelle.
>
> Signed-off-by: Christian Lütke-Stetzkamp
Reviewed-by: NeilBrown
Thanks,
NeilBrown
> ---
>
On Wed, Apr 18 2018, Christian Lütke-Stetzkamp wrote:
> Fix checkpatch: multiple assignments should be avoided, to improve
> readability.
>
> Signed-off-by: Christian Lütke-Stetzkamp
> ---
> drivers/staging/mt7621-mmc/sd.c | 7 ---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff -
On Wed, Apr 18 2018, Christian Lütke-Stetzkamp wrote:
> The current default transfer is to use DMA or not depending on the
> size of the data. The upstream driver mtk-sd uses DMA all times,
> change the standard mode here to DMA for testing, if there are any
> performance problems with DMA for sma
On Wed, Apr 18 2018, Christian Lütke-Stetzkamp wrote:
> Here are the next cleanups for the mt7621-mmc driver. Most of them
> just remove some unused code, but there are also some other cleanups
> and fixes. This also changes the default to always using DMA for data
> transfer, if there are no perf
Good day,
I am seeking your concept with great gratitude to present you as a
representative to carry out business transactions with a reasonable share upon
your interest and cooperation to work with us in trust. If interested please
get back.
Regards
Kingsley
---
This email has been checked
Am 21.04.2018 00:22, schrieb NeilBrown:
On Wed, Apr 18 2018, Christian Lütke-Stetzkamp wrote:
Fix checkpatch: multiple assignments should be avoided, to improve
readability.
Signed-off-by: Christian Lütke-Stetzkamp
---
drivers/staging/mt7621-mmc/sd.c | 7 ---
1 file changed, 4 insertions
On Sat, Apr 21 2018, Christian Luetke wrote:
> Am 21.04.2018 00:22, schrieb NeilBrown:
>> On Wed, Apr 18 2018, Christian Lütke-Stetzkamp wrote:
>>
>>> Fix checkpatch: multiple assignments should be avoided, to improve
>>> readability.
>>>
>>> Signed-off-by: Christian Lütke-Stetzkamp
>>> ---
>>>
Here is another round of staging cleanups for this driver mostly based
on Jonathon's feedback. We're very close to a staging graduation and I
only have a few items remaining on my todo list:
- Remove wildcards from the driver name. Jonathan suggested tsl2571.
- Don't make the events/ directory av
tsl2x7x_write_interrupt_config() has an unnecessary return value check
at the end of the function. This patch changes the function to just
return the value from the call to tsl2x7x_invoke_change().
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 7 +--
1 file changed, 1
tsl2x7x_event_handler() could return an error and this could cause the
interrupt to remain masked. We shouldn't return an error in the
interrupt handler so this patch always returns IRQ_HANDLED. An error
will be logged if one occurs.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2
The summary text for the GPL is not needed since the SPDX identifier
is a legally binding shorthand that can be used instead.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 10 +-
drivers/staging/iio/light/tsl2x7x.h | 14 +-
2 files changed, 2 insertion
The integration_time* attributes are currently associated with the
IIO_LIGHT channel but should be associated with the IIO_INTENSITY
channel. Directory listing of the sysfs attributes for a TSL2772
with this patch applied:
dev
events
in_illuminance0_calibrate
in_illuminance0_calibscale_available
i
This patch renames tsl2x7x_device_id() to tsl2x7x_device_id_verif(),
removes the unnecessary pointer on the id parameter, and only calls
the verification function once.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 11 +--
1 file changed, 5 insertions(+), 6 deleti
The power and diode defines are needed for the platform data so this
patch moves the defines out of the .c file and into the header file. A
comment for the diode is also cleaned up while this code is touched.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 12
This patch removes several unnecessary comments, changes some comments
so that the use as much of the allowable 80 characters as possible, adds
the proper whitespace, removes some structure members from the kernel
docs that are no longer present, and improves the existing kernel doc
information for
This patch changes the defaults of the als_time, prox_time and
wait_time to match the defaults according to the TSL2772 datasheet.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/iio/lig
tsl2x7x_suspend() and tsl2x7x_resume() both check to see what the
current chip status is. These checks are not necessary so this patch
removes those checks.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 16 ++--
1 file changed, 2 insertions(+), 14 deletions(-)
tsl2x7x_clear_interrupts() takes a reg argument but there are only
two callers to this function and both callers pass the same value.
Since this function was introduced, interrupts are now working
properly for this driver, and several unnecessary calls to
tsl2x7x_clear_interrupts() were removed. Th
The driver mostly uses the 'prox' naming convention for most of the
proximity settings, however prx_time and tsl2x7x_prx_gain was present.
This patch renames these to prox_time and tsl2x7x_prox_gain for
consistency with everything else in the driver.
The kernel documentation for prx_gain is correc
The configuration register on the device is represented with the
prox_config member on the tsl2x7x_settings structure. According to the
TSL2772 data sheet, this register can hold: 1) the proximity drive
level, 2) ALS/Proximity long wait, and 3) the ALS gain level. This
patch renames prox_config to
The sysfs attributes in_illuminance0_target_input,
in_illuminance0_calibrate, and in_proximity0_calibrate did not have
proper range checking in place so this patch adds the correct range
checks.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/tsl2x7x.c | 25 +++--
1
As a result of various previous patches, ion_buffer_create() now
has two sets of identical statements for initializing two fields of
the buffer struct, next to each other. Remove one set.
Move the initialization of these two fields together with the
statements that initialize the other two fields
On Fri, Apr 20, 2018 at 02:01:25PM -0700, Richard Cochran wrote:
> On Thu, Apr 19, 2018 at 01:40:08PM +0300, Dan Carpenter wrote:
> > This driver seems nice and so far as I can see it doesn't need to be in
> > staging once we get the other parts merged.
>
> Please explain how this unit ties in wit
On Sat, Apr 21, 2018 at 07:41:35AM +0300, Dan Carpenter wrote:
> On Fri, Apr 20, 2018 at 02:01:25PM -0700, Richard Cochran wrote:
> > On Thu, Apr 19, 2018 at 01:40:08PM +0300, Dan Carpenter wrote:
> > > This driver seems nice and so far as I can see it doesn't need to be in
> > > staging once we ge
66 matches
Mail list logo