The mmu_private.h header is included at mmu.c, with duplicates the
already existing definitions at mmu_public.h.
Fix this by removing the erroneous header file.
Solve those issues:
drivers/staging/media/atomisp/pci/atomisp2/css2400/hive_isp_css_common/host/mmu_private.h:24:26:
warning: fun
This patch series continue with the driver cleanups. It just contains
trivial cleanups in some files of the driver. For this to be applied
properly previous sent patch series must be applied before.
Sergio Paracuellos (10):
staging: ks7010: use linux circular buffer header macros to handle tx
This commit replace current custom implementation of some circular
buffer head and tail logic in favour of the use of macros defined
in linux circ_buf.h header. Queue related inline function names
have been review also.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c |
This commit changes type for device_open_status field of ks_wlan_private
structure from int to bool. This variable is only be set to 1
on ks_wlan_net_start and set to 0 on ks_wlan_net_stop. For this
purpose it is not necessary at all to use an integer because a bool
is enough. This also renames fie
This commit refactors code for hostif_sme_sleep_set function. This
function was using a switch-case block to handle only two states
where the action to do for them is the same. Just refactor a bit
to check for return condition at first and doing the common action
after in other case.
Signed-off-by
This commit change return value of ks_wlan_do_power_save function
from int to void. This function is just returning zero and return
value is not being checked also, so it is nonsense to return an
integer.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 4 +---
1 file c
This commit removes some comments which are not necessary at all
because code is clear enough to understand its intention.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 39 +++---
1 file changed, 7 insertions(+), 32 deletions(-)
diff
This commit fix length of the definition line of init_request
function. Warning from checkpatch script for this is fixed.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_hosti
This commit removes a blank line between definition in
hostif_data_request function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_hostif.c
index ebc3fb2.
This commit groups some case statements because its behaviour is
just do nothing which is the same as the default. Clean 'break'
keyword in those which are affected.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(
This commit changes logic to handle with the status of the device
at first checking for close state to return directly instead
of just do the stuff when device is open. This improves readability
avoiding one level indentation.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hosti
This commit removes 'break' from case block because the
code is just using the 'default' break for some cases and
this one can be included also there.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/ks701
Hi
> -Original Message-
> From: Rob Herring [mailto:r...@kernel.org]
> Sent: 2018年4月10日 4:04
> To: Jun Li
> Cc: gre...@linuxfoundation.org; heikki.kroge...@linux.intel.com;
> li...@roeck-us.net; a.ha...@samsung.com; shufan_...@richtek.com; Peter
> Chen ; devicet...@vger.kernel.org;
> linux
On Mon, Apr 16, 2018 at 12:09:43AM -0400, James Simmons wrote:
> @@ -1033,6 +953,7 @@ static int cfs_cpu_dead(unsigned int cpu)
> #endif
> ret = -EINVAL;
>
> + get_online_cpus();
> if (*cpu_pattern) {
> char *cpu_pattern_dup = kstrdup(cpu_pattern, GFP_KERNEL);
>
>
On Mon, Apr 16, 2018 at 12:09:45AM -0400, James Simmons wrote:
> diff --git a/drivers/staging/lustre/lnet/libcfs/libcfs_cpu.c
> b/drivers/staging/lustre/lnet/libcfs/libcfs_cpu.c
> index 705abf2..5ea294f 100644
> --- a/drivers/staging/lustre/lnet/libcfs/libcfs_cpu.c
> +++ b/drivers/staging/lustre/l
On Mon, Apr 16, 2018 at 12:09:46AM -0400, James Simmons wrote:
> From: Amir Shehata
>
> Replace depricated MAX_NUMNODES with nr_node_ids.
>
The changelog makes it sound like this is just a style change, but it's
actually a behavior change isn't it?
regards,
dan carpenter
_
On Mon, Apr 16, 2018 at 12:09:49AM -0400, James Simmons wrote:
> @@ -114,6 +115,15 @@ struct cfs_cpt_table *
> memset(cptab->ctb_cpu2cpt, -1,
> nr_cpu_ids * sizeof(cptab->ctb_cpu2cpt[0]));
>
> + cptab->ctb_node2cpt = kvmalloc_array(nr_node_ids,
> +
On Mon, Apr 16, 2018 at 6:54 AM, Jun Li wrote:
> Hi
>> -Original Message-
>> From: Rob Herring [mailto:r...@kernel.org]
>> Sent: 2018年4月10日 4:04
>> To: Jun Li
>> Cc: gre...@linuxfoundation.org; heikki.kroge...@linux.intel.com;
>> li...@roeck-us.net; a.ha...@samsung.com; shufan_...@richtek
On Mon, Apr 16, 2018 at 12:09:50AM -0400, James Simmons wrote:
> +int cfs_cpt_distance_print(struct cfs_cpt_table *cptab, char *buf, int len)
> +{
> + char *tmp = buf;
> + int rc = -EFBIG;
> + int i;
> + int j;
> +
> + for (i = 0; i < cptab->ctb_nparts; i++) {
> + if
Use new return type vm_fault_t for fault handler
in struct vm_operations_struct. For now, this is
just documenting that the function returns a
VM_FAULT value rather than an errno. Once all
instances are converted, vm_fault_t will become
a distinct type.
Reference commit id->
1c8f422059ae5da07db7
There's no sense for a Kernel driver to have __KERNEL macros
on it.
Signed-off-by: Mauro Carvalho Chehab
---
.../css2400/css_2401_csi2p_system/host/system_local.h | 15 ---
.../css2400/hive_isp_css_common/host/system_local.h | 15 ---
.../atomisp2/css2400/hive_i
When atomisp got merged, there were so many warnings with W=1
that we simply disabled the ones that were causing troubles.
Since then, several changes got applied to atomisp, and the
number of warnings are a way smaller than it used to be.
So, let's reenable warnings there and fix the issues.
Si
The code with uses the dummy var is commented out. So,
coment out its definition/initialization.
Fix this warning:
drivers/staging/media/atomisp/i2c/atomisp-gc2235.c: In function
'gc2235_get_intg_factor':
drivers/staging/media/atomisp/i2c/atomisp-gc2235.c:249:26: warning: variable
'dummy' s
The register settings for several resolutions aren't used
currently. So, comment them out.
Fix those warnings:
In file included from drivers/staging/media/atomisp/i2c/atomisp-gc2235.c:35:0:
drivers/staging/media/atomisp/i2c/gc2235.h:340:32: warning:
'gc2235_960_640_30fps' defined but not used [-
drivers/staging/media/atomisp/i2c/atomisp-ov2680.c: In function
‘__ov2680_set_exposure’:
drivers/staging/media/atomisp/i2c/atomisp-ov2680.c:400:10: warning: variable
‘hts’ set but not used [-Wunused-but-set-variable]
u16 vts,hts;
^~~
drivers/staging/media/atomisp/i2c/atomisp-ov2680.c:
The identation for several tables there are broken.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/staging/media/atomisp/i2c/ov2680.h | 895 ++---
1 file changed, 447 insertions(+), 448 deletions(-)
diff --git a/drivers/staging/media/atomisp/i2c/ov2680.h
b/drivers/sta
There are lots of data structs defined there but aren't used
anywhere.
Comment them out. Gets rid of those warnings:
drivers/staging/media/atomisp/i2c/atomisp-mt9m114.c:1808:45: warning:
'mt9m114_entity_ops' defined but not used [-Wunused-const-variable=]
static const struct media_entity_operat
If something wrong gets there, return the error.
Get rid of this warning:
drivers/staging/media/atomisp/i2c/atomisp-gc0310.c: In function 'gc0310_init':
drivers/staging/media/atomisp/i2c/atomisp-gc0310.c:713:6: warning: variable
'ret' set but not used [-Wunused-but-set-variable]
int ret;
It seems that, originally, the logic would allow selecting between
fine and coarse integration. However, only coarse seems to be
implemented.
Get rid of this warning:
drivers/staging/media/atomisp/i2c/atomisp-mt9m114.c: In function
'mt9m114_s_exposure':
drivers/staging/media/atomisp/i2c/atom
When I started building media subsystem with the atomisp driver,
I ended by adding several hacks on their Makefiles, in order to
get rid of thousands of warnings. I felt a little guty of hiding how
broken is this driver, so I decided t remove two Makefile hacks that
affect sensors and fix the warni
The original code had ring size as a module parameter, but
then it was made a fixed value. The code to set the size of
the ring buffer binary file was lost in the transistion.
The size is needed by user mode driver to know the size of
the ring buffer.
Fixes: 37b96a4931db ("uio_hv_generic: support
Need to mask the correct sub-channel in the callback from VMBUS
isr. Otherwise, can get in to infinite interrupt storm.
Fixes: 37b96a4931db ("uio_hv_generic: support sub-channels")
Signed-off-by: Stephen Hemminger
---
drivers/uio/uio_hv_generic.c | 14 +++---
1 file changed, 7 insertion
These are fixes for the UIO Hyper-V driver found while testing
multiple channel support with DPDK.
v2
- add additional fixes for isr and mmap support
Stephen Hemminger (4):
uio_hv_generic: set size of ring buffer attribute
uio_hv_generic: make ring buffer attribute for primary channel
uio
The primary channel also needs a ring buffer attribute. This allows
application to check if kernel supports uio sub channels, and also
makes all channels use consistent API.
Signed-off-by: Stephen Hemminger
---
drivers/uio/uio_hv_generic.c | 5 +
1 file changed, 5 insertions(+)
diff --git a
The fault method of handling subchannel ring, did not work correctly
(it only worked for the first page).
Since ring buffer is physically contiguous, using the vm helper
function is simpler and handles more cases.
Fixes: 37b96a4931db ("uio_hv_generic: support sub-channels")
Signed-off-by: Stephen
Hello
Greeetings to you please did you get my previous email regarding my
investment proposal last week friday ?
MS.Zeliha ömer faruk
zeliha.omer.fa...@gmail.com
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.o
Fix most of checkpatch.pl issues unrelated with 80 columns limit
Signed-off-by: Fernando Pereira
---
drivers/staging/ks7010/ks_hostif.c | 17 +
drivers/staging/ks7010/ks_wlan_net.c | 5 ++---
drivers/staging/ks7010/michael_mic.c | 5 ++---
3 files changed, 13 insertions(+), 1
In the current implementation, vchi_instance is inited during the first
call of bcm2835_audio_open_connection(), and is never freed. It causes a
memory leak when the module `snd_bcm2835` is removed.
Here is how this commit fixes it:
* the VCHI context (including vchi_instance) is created once in
38 matches
Mail list logo