There are no null pointer checking on rd_info and td_info values which
are allocated by kzalloc. It has potential null pointer dereferencing
issues. Add return when allocation is failed.
Signed-off-by: Ji-Hun Kim
---
Change: since v1:
- Delete WARN_ON which can makes crashes on some machines.
-
On Wed, Mar 28, 2018 at 12:01:42PM -0700, Stephen Hemminger wrote:
> On Sun, 4 Mar 2018 22:24:08 -0700
> k...@exchange.microsoft.com wrote:
>
> > From: Michael Kelley
> >
> > Fix bugs in signaling the Hyper-V host when freeing space in the
> > host->guest ring buffer:
> >
> > 1. The interrupt_
On 2018/3/29 15:22, Ji-Hun Kim wrote:
There are no null pointer checking on rd_info and td_info values which
are allocated by kzalloc. It has potential null pointer dereferencing
issues. Add return when allocation is failed.
Signed-off-by: Ji-Hun Kim
---
Change: since v1:
- Delete WARN_ON w
This patchset has been introduced for the cleanup of
adis16209 driver.
This patchset cleans up miscellaneous code fragments
and improves the code readability.
After the cleanup, driver is moved from staging to
mailine IIO subsystem directory.
Changes in v6
-This patchset has some new patches int
Have indentation in field definitions to make them
clearly different from the register addresses.
Signed-off-by: Shreeya Patel
---
Changes in v5
-Change some macro names and have indentation in the field
definitions.
Changes in v6
-Have indentation in the field definitions and do not
change
Prefer reverse christmas tree ordering of declarations to
improve readability.
Signed-off-by: Shreeya Patel
---
Changes in v6
-Introduce this new patch in the series.
drivers/staging/iio/accel/adis16209.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging
Add a blank line after return statements to improve the code
readability.
Signed-off-by: Shreeya Patel
---
Changes in v6
-Introduce this new patch in the series.
drivers/staging/iio/accel/adis16209.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/iio/accel/adis16209.c
It doesn't make any difference to runtime but I've switched these two
checks to make my static checker happy.
The problem is that "buffer->data_size" is user controlled and if it's
less than "sizeo(*hdr)" then that means "offset" can be more than
"buffer->data_size". It's just cleaner to check it
Remove few unused header files since the adis core handles
the sysfs and buffer support.
Signed-off-by: Shreeya Patel
---
Changes in v6
-Introduce this new patch in the series.
drivers/staging/iio/accel/adis16209.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/iio/acc
Use GENMASK to improve readability and remove the local
variables used to store intermediate data.
Signed-off-by: Shreeya Patel
---
Changes in v6
-Introduce this new patch in the series.
drivers/staging/iio/accel/adis16209.c | 19 ---
1 file changed, 8 insertions(+), 11 delet
Move the adis16209 driver out of staging directory and merge to the
mainline IIO subsystem.
Signed-off-by: Shreeya Patel
---
Changes in v6
-Move driver adis16209 from staging to mainline IIO subsystem
after complete cleanup of it.
drivers/iio/accel/Kconfig | 12 ++
drivers/iio/a
On Wed, Mar 28, 2018 at 10:51:46PM -0700, Quytelda Kahja wrote:
> Reorder the members of 'ks_wlan_netdev_ops' to reflect the order
> of their counterparts in the kernel's 'struct net_device_ops'.
Why? This shouldn't matter at all, why make this change?
greg k-h
__
On Wed, Mar 28, 2018 at 10:51:50PM -0700, Quytelda Kahja wrote:
> The "_t" suffix is not needed for structure names in this driver,
> and is a reflection of an older typedef system that is no longer
> in place. Remove the "_t" suffix from every structure defined in this
> driver.
Again, please br
On Mon, Mar 26, 2018 at 03:27:10PM +0200, Rene Hickersberger wrote:
> Fixed a coding style issue where the comment * was not aligned.
>
> Signed-off-by: Rene Hickersberger
> ---
> drivers/staging/comedi/drivers/ni_stc.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/dr
On Wed, Mar 28, 2018 at 10:18:48PM +0100, Chris Coffey wrote:
> Include the local ethtool.h header file in mtk_eth_soc.h so
> implementation files have centralized access to it.
>
> This fixes the following sparse warning:
>
> drivers/staging/mt7621-eth/ethtool.c:213:6: warning: symbol
> 'mtk_set
On Thu, Mar 29, 2018 at 12:06:12AM +0800, Li Jun wrote:
> With that we can clear any pending events and the port is registered
> so driver can be ready to handle typec events once we request irq.
>
> Signed-off-by: Peter Chen
> Signed-off-by: Li Jun
These sign offs aren't clear.
Sign offs mean
2018-03-29 17:00 GMT+09:00 Jia-Ju Bai :
>
>
>
> On 2018/3/29 15:22, Ji-Hun Kim wrote:
>>
>> There are no null pointer checking on rd_info and td_info values which
>> are allocated by kzalloc. It has potential null pointer dereferencing
>> issues. Add return when allocation is failed.
>>
>> Signed-o
On Thu, Mar 29, 2018 at 11:14 AM, Dan Carpenter
wrote:
> It doesn't make any difference to runtime but I've switched these two
> checks to make my static checker happy.
>
> The problem is that "buffer->data_size" is user controlled and if it's
> less than "sizeo(*hdr)" then that means "offset" can
This fixes the following sparse warning:
drivers/staging/mt7621-eth/ethtool.c:213:6: warning: symbol
'mtk_set_ethtool_ops' was not declared. Should it be static?
Signed-off-by: Chris Coffey
---
Changes in v2:
- Per GregKH's feedback (thanks!), don't add unnecessary new .h file
dependencies. Th
Hi,
On Thu, Mar 29, 2018 at 12:06:09AM +0800, Li Jun wrote:
> Add fwnode handle to get the fwnode so we can get typec configs
> it contains.
>
> Suggested-by: Heikki Krogerus
> Signed-off-by: Li Jun
> ---
> drivers/staging/typec/tcpci.c | 14 +++---
> drivers/usb/typec/tcpm.c | 1
This patch series replace some macros with inline functions in
ks_hostif.h header file and replace its uses along the source
code.
Sergio Paracuellos (6):
staging: ks7010: replace IS_11B_RATE macro with inline function
staging: ks7010: replace IS_OFDM_RATE macro with inline function
staging:
This commit replaces IS_HIF_IND macro with is_11b_rate inline
function to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.h | 18 +++---
1 file changed, 11 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif.h
b/dr
This commit replaces IS_HIF_CONF macro with is_11b_rate inline
function to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
drivers/staging/ks7010/ks_hostif.h | 12 +++-
2 files changed, 8 insertions(+), 6 deletions(-)
diff --git
This commit replaces IS_OFDM_EXT_RATE macro with is_11b_rate
inline function to improve readability.
It also fix a checkpatch script warning because a line with more
than 80 spaces.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
drivers/staging/ks7010/ks_hosti
This commit replaces IS_11BG_RATE macro with is_11b_rate inline
function to improve readability.
It also fix a checkpatch script warning because a line with more
than 80 spaces.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
drivers/staging/ks7010/ks_hostif.h |
This commit replaces IS_11B_RATE macro with is_11b_rate inline
function to improve readability.
It also fix a checkpatch script warning because a line with more
than 80 spaces.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
drivers/staging/ks7010/ks_hostif.h |
This commit replaces IS_OFDM_RATE macro with is_ofdm_rate inline
function.
This also fix checkpatch warning about more than 80 spaces line.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.h | 17 -
1 file changed, 12 insertions(+), 5 deletions(-)
diff --g
Hi Li,
On 03/28/2018 06:06 PM, Li Jun wrote:
> Add bingdings supported by current typec driver, so user can pass
> all those properties via dt.
>
> Signed-off-by: Li Jun
> ---
> .../bindings/connector/usb-connector.txt | 39
> ++
> 1 file changed, 39 insertions(+)
Hi Li,
On 03/28/2018 06:06 PM, Li Jun wrote:
> In case of drp toggling, we may need set correct cc value for role control
> after attach as it may never been set.
>
> Signed-off-by: Li Jun
> ---
> drivers/usb/typec/tcpm.c | 5 +
> 1 file changed, 5 insertions(+)
>
> diff --git a/drivers/usb
On Thu, Mar 29, 2018 at 12:06:15AM +0800, Li Jun wrote:
> In case of drp toggling, we may need set correct cc value for role control
> after attach as it may never been set.
>
Isn't CC set by the lower level driver in this case ? In other words, is it ever
necessary to call back into the low leve
There are no null pointer checking on rd_info and td_info values which
are allocated by kzalloc. It has potential null pointer dereferencing
issues. Implement error handling code on device_init_rd*, device_init_td*
and vnt_start for the allocation failures.
Signed-off-by: Ji-Hun Kim
---
Changes v
On 2018/3/30 10:44, Ji-Hun Kim wrote:
@@ -1165,10 +1205,18 @@ static int vnt_start(struct ieee80211_hw *hw)
}
dev_dbg(&priv->pcid->dev, "call device init rd0 ring\n");
- device_init_rd0_ring(priv);
- device_init_rd1_ring(priv);
- device_init_td0_ring(priv);
-
On Fri, Mar 30, 2018 at 11:15:03AM +0800, Jia-Ju Bai wrote:
>
>
> On 2018/3/30 10:44, Ji-Hun Kim wrote:
> >@@ -1165,10 +1205,18 @@ static int vnt_start(struct ieee80211_hw *hw)
> > }
> > dev_dbg(&priv->pcid->dev, "call device init rd0 ring\n");
> >-device_init_rd0_ring(priv);
> >-
On Fri, Mar 30, 2018 at 11:15:03AM +0800, Jia-Ju Bai wrote:
>
>
> On 2018/3/30 10:44, Ji-Hun Kim wrote:
> >@@ -1165,10 +1205,18 @@ static int vnt_start(struct ieee80211_hw *hw)
> > }
> > dev_dbg(&priv->pcid->dev, "call device init rd0 ring\n");
> >-device_init_rd0_ring(priv);
> >-
On 2018/3/30 11:39, Ji-Hun Kim wrote:
On Fri, Mar 30, 2018 at 11:15:03AM +0800, Jia-Ju Bai wrote:
On 2018/3/30 10:44, Ji-Hun Kim wrote:
@@ -1165,10 +1205,18 @@ static int vnt_start(struct ieee80211_hw *hw)
}
dev_dbg(&priv->pcid->dev, "call device init rd0 ring\n");
- de
There are no null pointer checking on rd_info and td_info values which
are allocated by kzalloc. It has potential null pointer dereferencing
issues. Implement error handling code on device_init_rd*, device_init_td*
and vnt_start for the allocation failures.
Signed-off-by: Ji-Hun Kim
---
Changes v
There was no code for handling memory leaks of device_init_rings() and
request_irq(). It needs to free allocated memory in the device_init_rings()
, when request_irq() is failed. Add freeing sequences of irq and device
init rings.
Signed-off-by: Ji-Hun Kim
---
It's additional memory leak handling
If we just want to have the address field full of zeros during the
driver probe, is there a reason we should zero it explicitly here?
When the 'struct net_device' is first allocated using
alloc_etherdev(), the dev_addr field is explicitly set to zeros (in
the subfunction dev_addr_init() in net/core
On Thu, 2018-03-29 at 23:03 -0700, Quytelda Kahja wrote:
> If we just want to have the address field full of zeros during the
> driver probe, is there a reason we should zero it explicitly here?
> When the 'struct net_device' is first allocated using
> alloc_etherdev(), the dev_addr field is explic
39 matches
Mail list logo