Re: Re: [PATCH] staging: media: davinci_vpfe: add error handling on kmalloc failure

2018-03-19 Thread Dan Carpenter
On Mon, Mar 19, 2018 at 01:24:57PM +0900, Ji-Hun Kim wrote: > > 1294 } else if (to && !from && size) { > > 1295 rval = module_if->set(ipipe, NULL); > > 1296 if (rval) > > 1297

Re: [PATCH] staging: lustre: o2iblnd: Stop MLX5 triggering a dump_cqe

2018-03-19 Thread Dan Carpenter
I don't really understand this patch... On Fri, Mar 16, 2018 at 04:40:21PM -0700, Doug Oucharek wrote: > We have found that MLX5 will trigger a dump_cqe if we don't > invalidate the rkey on a newly alloated MR for FastReg usage. > > This fix just tags the MR as invalid on its creation if we are >

Re: [PATCH 1/2] pci: host: pci-hyperv: Replace GFP_ATOMIC with GFP_KERNEL in hv_pci_onchannelcallback

2018-03-19 Thread Dan Carpenter
On Sun, Mar 18, 2018 at 10:53:02PM +0800, Jia-Ju Bai wrote: > hv_pci_onchannelcallback() is not called in atomic context. > > The call chain ending up at hv_pci_onchannelcallback() is: > [1] hv_pci_onchannelcallback() <- hv_pci_probe() > hv_pci_probe() is only set as ".probe" in hv_driver > struc

Re: [PATCH 2/2] pci: host: pci-hyperv: Replace GFP_ATOMIC with GFP_KERNEL in new_pcichild_device

2018-03-19 Thread Dan Carpenter
Looks ok. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH 1/2] pci: host: pci-hyperv: Replace GFP_ATOMIC with GFP_KERNEL in hv_pci_onchannelcallback

2018-03-19 Thread Jia-Ju Bai
On 2018/3/19 16:38, Dan Carpenter wrote: On Sun, Mar 18, 2018 at 10:53:02PM +0800, Jia-Ju Bai wrote: hv_pci_onchannelcallback() is not called in atomic context. The call chain ending up at hv_pci_onchannelcallback() is: [1] hv_pci_onchannelcallback() <- hv_pci_probe() hv_pci_probe() is only s

[staging] 184ecc5ceb: BUG:unable_to_handle_kernel

2018-03-19 Thread kernel test robot
FYI, we noticed the following commit (built with gcc-6): commit: 184ecc5ceb379b43b29fc373f497fca88c73ad38 ("staging: lustre: allow monolithic builds") https://git.kernel.org/cgit/linux/kernel/git/gregkh/staging.git staging-testing in testcase: trinity with following parameters: runtime

Re: [PATCH 1/2] pci: host: pci-hyperv: Replace GFP_ATOMIC with GFP_KERNEL in hv_pci_onchannelcallback

2018-03-19 Thread Dan Carpenter
Smatch tracks information about every function call. When a function pointer is called it maybe looks something like this: kernel/module.c | SYSC_delete_module | (struct module)->exit | INTERNAL | -1 | | void(*)() So then we just have to know what functions are assigned to module->e

[PATCH] ncpfs: memory corruption in ncp_read_kernel()

2018-03-19 Thread Dan Carpenter
If the server is malicious then *bytes_read could be larger than the size of the "target" buffer. It would lead to memory corruption when we do the memcpy(). Reported-by: Dr Silvio Cesare of InfoSect Signed-off-by: Dan Carpenter diff --git a/drivers/staging/ncpfs/ncplib_kernel.c b/drivers/sta

[PATCH] staging: media: davinci_vpfe: fix spelling of resizer_configure_in_continious_mode

2018-03-19 Thread Colin King
From: Colin Ian King Trivial fix: rename function resizer_configure_in_continious_mode to resizer_configure_in_continuous_mode to fix spelling mistake. Signed-off-by: Colin Ian King --- drivers/staging/media/davinci_vpfe/dm365_resizer.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)

Re: [PATCH] ncpfs: memory corruption in ncp_read_kernel()

2018-03-19 Thread Greg Kroah-Hartman
On Mon, Mar 19, 2018 at 02:07:45PM +0300, Dan Carpenter wrote: > If the server is malicious then *bytes_read could be larger than the > size of the "target" buffer. It would lead to memory corruption when we > do the memcpy(). > > Reported-by: Dr Silvio Cesare of InfoSect > Signed-off-by: Dan C

[PATCH 3/5] Staging:rtl8723bs:os_dep braces not necessary

2018-03-19 Thread Paul McQuade
WARNING: braces {} are not necessary for any arm of this statement Signed-off-by: Paul McQuade --- drivers/staging/rtl8723bs/os_dep/recv_linux.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8723bs/os_dep/recv_linux.c b/drivers/staging/rtl8723bs/os

[PATCH 1/5] Staging: rtl8723bs: os_dep

2018-03-19 Thread Paul McQuade
ERROR: do not initialise statics to NULL Signed-off-by: Paul McQuade --- drivers/staging/rtl8723bs/os_dep/rtw_proc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8723bs/os_dep/rtw_proc.c b/drivers/staging/rtl8723bs/os_dep/rtw_proc.c index 9a885e626d1c..

[PATCH 4/5] Staging:rtl8723bs:os_dep blank line needed

2018-03-19 Thread Paul McQuade
WARNING: Missing a blank line after declarations Signed-off-by: Paul McQuade --- drivers/staging/rtl8723bs/os_dep/recv_linux.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/rtl8723bs/os_dep/recv_linux.c b/drivers/staging/rtl8723bs/os_dep/recv_linux.c index 117fda4fa1bf..b4

[PATCH 2/5] Staging: rtl8723bs: os_dep Spacing issue

2018-03-19 Thread Paul McQuade
ERROR: spaces required around that '<' (ctx:VxV) Signed-off-by: Paul McQuade --- drivers/staging/rtl8723bs/os_dep/rtw_proc.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/rtl8723bs/os_dep/rtw_proc.c b/drivers/staging/rtl8723bs/os_dep/rtw_pr

[PATCH 5/5] Staging:rtl8723bs:os_dep Fixed braces

2018-03-19 Thread Paul McQuade
ERROR: that open brace { should be on the previous line Signed-off-by: Paul McQuade --- drivers/staging/rtl8723bs/os_dep/recv_linux.c | 9 +++-- 1 file changed, 3 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8723bs/os_dep/recv_linux.c b/drivers/staging/rtl8723bs/os_dep/rec

Re: [PATCH 1/5] Staging: rtl8723bs: os_dep

2018-03-19 Thread Greg KH
On Mon, Mar 19, 2018 at 02:34:56PM +, Paul McQuade wrote: > ERROR: do not initialise statics to NULL You are going to have to do a bit more writing in the changelog than just dumping in random output from checkpatch.pl. I know that's where that line came from, but no one else will. And your

Re: [PATCH v2 06/21] fpga: Remove depends on HAS_DMA in case of platform dependency

2018-03-19 Thread Alan Tull
On Fri, Mar 16, 2018 at 8:51 AM, Geert Uytterhoeven wrote: Hi Geert, This essentially removes this commit commit 1c8cb409491403036919dd1c6b45013dc8835a44 Author: Sudip Mukherjee Date: Wed Aug 3 13:45:46 2016 -0700 drivers/fpga/Kconfig: fix build failure While building m32r allmodco

Re: [PATCH] staging: lustre: o2iblnd: Enable Multiple OPA Endpoints between Nodes

2018-03-19 Thread Greg Kroah-Hartman
On Thu, Mar 15, 2018 at 02:53:46PM -0700, Doug Oucharek wrote: > OPA driver optimizations are based on the MPI model where it is > expected to have multiple endpoints between two given nodes. To > enable this optimization for Lustre, we need to make it possible, > via an LND-specific tuneable, to c

Re: [PATCH] staging: lustre: o2iblnd: Fix FastReg map/unmap for MLX5

2018-03-19 Thread Greg Kroah-Hartman
On Wed, Mar 14, 2018 at 11:18:30PM -0700, Doug Oucharek wrote: > The FastReg support in ko2iblnd was not unmapping pool items > causing the items to leak. In addition, the mapping code > is not growing the pool like we do with FMR. > > This patch makes sure we are unmapping FastReg pool elements

Salut l'ami.

2018-03-19 Thread Mr.WUSO
Salut l'ami. S'il vous plaît allumer contactez-moi, il y a un problème important dont j'ai besoin pour discuter avec vous concernant mon client décédé une nationalité de votre pays qui a quitté le fonds immobilier non réclamé évalué USD 5,3 millions de dollars avant sa mort. S'il vous plaît écrivez

Re: [PATCH 5/7] staging: wilc1000: replace switch statement by simple if condition

2018-03-19 Thread Greg KH
On Wed, Mar 14, 2018 at 06:15:03PM +0530, hariprasath.ela...@gmail.com wrote: > From: HariPrasath Elango > > In this case,there is only a single switch case statement.So replacing > by a simple if condition. > > Signed-off-by: HariPrasath Elango > --- > drivers/staging/wilc1000/wilc_wfi_cfgope

Re: [PATCH v2 0/4] staging: ks7010: some cleanups and replaces

2018-03-19 Thread Greg KH
On Thu, Mar 15, 2018 at 08:09:20PM +0100, Sergio Paracuellos wrote: > The following patch series includes some cleanups of useless traces as well > as some replaces in order to use preferred macros for debugging and others. > > v2: > * Review deleted DPRINTK traces > * Minor checkpatch warning cle

Re: [PATCH 1/6] staging: ks7010: Factor out repeated code.

2018-03-19 Thread Greg KH
On Thu, Mar 15, 2018 at 11:26:59PM -0700, Quytelda Kahja wrote: > Some of the code for reading IEs is replicated multiple times in the > switch statement for get_ap_information(). Factor that code out into > read_ie(). > > Signed-off-by: Quytelda Kahja > --- > drivers/staging/ks7010/ks_hostif.c

Re: [PATCH] staging: android: ashmem: Fix possible deadlock in ashmem_ioctl

2018-03-19 Thread Joel Fernandes (Google)
On Tue, Feb 27, 2018 at 10:59 PM, Yisheng Xie wrote: > ashmem_mutex may create a chain of dependencies like: > > CPU0CPU1 > mmap syscall ioctl syscall > -> mmap_sem (acquired) -> ashmem_ioctl > -> ashmem_mmap

RE: [PATCH v2 1/3] staging: xm2mvscale: Driver support for Xilinx M2M Video Scaler

2018-03-19 Thread Rohit Athavale
Hi Hans, Thanks for taking the time to take a look at this. > This should definitely use the V4L2 API. I guess it could be added > to staging/media with a big fat TODO that this should be converted to > the V4L2 mem2mem framework. > > But it makes no sense to re-invent the V4L2 streaming API :-)

Re: [PATCH] staging: lustre: Fix unneeded byte-ordering cast

2018-03-19 Thread NeilBrown
On Sat, Mar 17 2018, Justin Skists wrote: > Fix sparse warning: > > CHECK drivers/staging//lustre/lnet/lnet/acceptor.c > drivers/staging//lustre/lnet/lnet/acceptor.c:243:30: warning: cast to > restricted __le32 > > LNET_PROTO_TCP_MAGIC, as a define, is already CPU byte-ordered when > compared

Re: [PATCH v2 1/3] staging:iio:ad2s1210: Add channel for fclkin and fexcit

2018-03-19 Thread Rodrigo Siqueira
Hi, On 03/17, Jonathan Cameron wrote: > On Tue, 13 Mar 2018 13:05:28 -0300 > Rodrigo Siqueira wrote: > > > The ad2s1210 does not contain any channel for the fclkin and fexcit. As > > a result, it uses IIO_DEVICE_ATTR to expose this information. This patch > > adds one channel for fclkin and anot

Re: [PATCH v2 1/3] staging: xm2mvscale: Driver support for Xilinx M2M Video Scaler

2018-03-19 Thread Nicolas Dufresne
Le mardi 20 mars 2018 à 00:46 +, Rohit Athavale a écrit : > Hi Hans, > > Thanks for taking the time to take a look at this. > > > This should definitely use the V4L2 API. I guess it could be added > > to staging/media with a big fat TODO that this should be converted > > to > > the V4L2 mem2m

Re: [PATCH v2 1/8] staging:iio:ade7854: Fix error handling on read/write

2018-03-19 Thread Rodrigo Siqueira
On 03/18, Jonathan Cameron wrote: > On Fri, 16 Mar 2018 19:48:33 -0300 > Rodrigo Siqueira wrote: > > > The original code does not correctly handle the error related to I2C > > read and write. This patch fixes the error handling related to all > > read/write functions for I2C. This patch is an ada

Re: [staging] 184ecc5ceb: BUG:unable_to_handle_kernel

2018-03-19 Thread NeilBrown
On Mon, Mar 19 2018, kernel test robot wrote: > FYI, we noticed the following commit (built with gcc-6): > > commit: 184ecc5ceb379b43b29fc373f497fca88c73ad38 ("staging: lustre: allow > monolithic builds") > https://git.kernel.org/cgit/linux/kernel/git/gregkh/staging.git > staging-testing > > in

ABOUT TO TRANSFER YOUR ATM NOTIFICATION

2018-03-19 Thread MOSES LINGARD
Dear Sir/Madam I remain convinced that you will be surprised by this mail, but this remains the utmost truth. I know that it is against my official duty to release confidential issue like this to an outsider.There is nothing I can do to help you beside this; I am taking this bold step because of

Re: meter ABI: (was Re: [PATCH v2 1/3] staging:iio:meter: Replaces IIO_DEV_ATTR_CH_OFF by IIO_DEVICE_ATTR)

2018-03-19 Thread John Syne
Hi Jonathan, Thank you for all your hard work. Your feedback is really helpful. I’m surprised that no one from Analog Device has offered any suggestions. Anyway, please see my comments inline below Regards, John > On Mar 18, 2018, at 5:23 AM, Jonathan Cameron wrote: > > On Sat, 17 Mar 20

[PATCH 1/6] staging: ks7010: Factor out repeated code.

2018-03-19 Thread Quytelda Kahja
Some of the code for reading IEs is replicated multiple times in the switch statement for get_ap_information(). Factor that code out into read_ie(). Signed-off-by: Quytelda Kahja --- drivers/staging/ks7010/ks_hostif.c | 48 +- 1 file changed, 22 insertions(+)

[PATCH 5/6] staging: ks7010: Fix line over 80 characters.

2018-03-19 Thread Quytelda Kahja
There is no reason for comment describing the BSSID check for loop to be spaced so far to the right. Move it above the for loop. Signed-off-by: Quytelda Kahja --- drivers/staging/ks7010/ks_hostif.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/ks7010/ks_h

[PATCH 3/6] staging: ks7010: Remove unnecessary parentheses.

2018-03-19 Thread Quytelda Kahja
Remove unnecessary parentheses highlighted by checkpatch. Signed-off-by: Quytelda Kahja --- drivers/staging/ks7010/ks_hostif.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/ks7010/ks_hostif.c b/drivers/staging/ks7010/ks_hostif.c index 948d45280d18..00b9

[PATCH 4/6] staging: ks7010: Remove unnecessary braces.

2018-03-19 Thread Quytelda Kahja
Braces aren't required for a single line if statement. Signed-off-by: Quytelda Kahja --- drivers/staging/ks7010/ks_hostif.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/ks7010/ks_hostif.c b/drivers/staging/ks7010/ks_hostif.c index 00b97e8e9b4f..2de4dbbcd

[PATCH 6/6] staging: ks7010: Factor out repeated request initialization code.

2018-03-19 Thread Quytelda Kahja
The code to initialize various different types of request structs is repeated multiple times. Factor this code out into a macro called INIT_REQUEST. Signed-off-by: Quytelda Kahja --- drivers/staging/ks7010/ks_hostif.c | 55 +++--- 1 file changed, 16 insertions(+)

[PATCH 2/6] staging: ks7010: Factor out code into helper methods.

2018-03-19 Thread Quytelda Kahja
Some cases in the switch statement in get_ap_information() are indented as much as five levels, which makes the code difficult to read because of all the wrapping. Factor them out into helper methods. Signed-off-by: Quytelda Kahja --- drivers/staging/ks7010/ks_hostif.c | 46

Re: [PATCH 5/7] staging: wilc1000: replace switch statement by simple if condition

2018-03-19 Thread
On Mon, Mar 19, 2018 at 07:45:46PM +0100, Greg KH wrote: > On Wed, Mar 14, 2018 at 06:15:03PM +0530, hariprasath.ela...@gmail.com wrote: > > From: HariPrasath Elango > > > > In this case,there is only a single switch case statement.So replacing > > by a simple if condition. > > > > Signed-off-by

Re: meter ABI: (was Re: [PATCH v2 1/3] staging:iio:meter: Replaces IIO_DEV_ATTR_CH_OFF by IIO_DEVICE_ATTR)

2018-03-19 Thread John Syne
Hi Jonathan, I broke out the {Direction}_{Type}_{Index}_{Modifier}_{Info_Mask} into separate columns to make sure I understand your instructions. Good way to check the results. Probably easier to copy and paste this table into a spreadsheet. Let me know if there is anything I got wrong. Thank

Re: [PATCH 5/6] staging: ks7010: Fix line over 80 characters.

2018-03-19 Thread Joe Perches
On Mon, 2018-03-19 at 22:58 -0700, Quytelda Kahja wrote: > There is no reason for comment describing the BSSID check for loop > to be spaced so far to the right. Move it above the for loop. [] > diff --git a/drivers/staging/ks7010/ks_hostif.c > b/drivers/staging/ks7010/ks_hostif.c [] > @@ -844,7